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About Web Analysis Studio
Hyperion® System™ 9 BI+™ Web Analysis Studio™ is an online analysis, presentation, and
reporting interface for multidimensional and relational data. This chapter introduces Web
Analysis Studio concepts and conventions.

See Chapter 7, “Navigating Documents.”

Starting Web Analysis Studio
The Sun Java Plug-in is automatically installed when Web Analysis Studio is first used.

➤ To start Web Analysis Studio:

1 In your Web browser's Address bar, enter the Web Analysis Studio URL and press Enter.

The server name is case-sensitive. For example, “WebAnalysis_Server” is case-sensitive in
this URL: http://hostname:port/WebAnalysis_Server/index.html

where hostname:port is the computer name, or Web Analysis Studio server IP address and port.
The default port is 16080 for Tomcat users.

The Logon page is displayed.

2 Enter a user name and password.

3 Click Logon.

The document or interface specified by Startup preferences is displayed. See “Startup
Preferences” on page 263.
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Web Analysis Studio Interfaces
Web Analysis Studio has four interfaces for accomplishing tasks:

● Analyze—Primary interface for analysis, presentation, and reporting; features navigation
methods used for investigating information (see Chapter 7, “Navigating Documents”)

● Desktop—Centrally collects and presents presentation icons, which function like Windows
desktop shortcuts, for access (see Chapter 2, “Web Analysis Studio Desktops”)

● Document Designer—Interface for creating custom documents; when active, its
component toolbar is displayed below the menu bar (see Chapter 16, “Creating Custom
Documents”)

● Edit Data—Interface for changing data values, and sending changes back to Hyperion®
System™ 9 BI+™ Analytic Services™; accessed from the data object shortcut menu (see
Chapter 17, “Editing Data Values”)

➤ To switch between Web Analysis Studio interfaces, use the toolbar buttons:

●

Switch to Desktop 

●

Switch to Analyze 

●

Switch to Document Designer 

Analyze Interface
Analyze interface components:

● Title bar— Features minimize, maximize, and close buttons, and a shortcut menu.

● Masthead—Crosses the application window below the title bar. It identifies the Hyperion
product and enables companies to customize and co-brand the client.

● Menu bar—Below the masthead. It centrally organizes principal commands and
subcommands.

● Toolbar—Located to the right of the menu bar; provides single-click access to principal
tasks and modules.

To show or hide the toolbar, select View > Toolbar, or press Ctrl+T.

Toolbar Button Description

Toggle View Pane

New

Open
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Toolbar Button Description

Save

Save As

Print

Undo

Redo

Home Page

Previous Document

Next Document

Cube Navigator

Desktop

Analyze

Design

● Process bar—Below the toolbar and above the content area. When you begin a complex
task with multiple steps, the process bar indicates the number of steps, and the current step.
The content area changes with each step, until the process is completed. When not in a
process, it indicates the full path to the current document's repository location. The process
bar also indicates the current module or interface.

● View pane—Extends down the left side of the interface. Buttons atop the View pane switch
View pane tabs:

❍  Browser —Presents the repository as a node tree. Only files and folders to which
you are granted access are listed. This typically consists of your own folder and group
folders to which you belong. When navigation panel items are selected, their contents
are listed in the selection panel below.

❍  Information Panel—Composed of segments summarizing the content area. Each
segment features controls and context-sensitive shortcut menus.

❍  Palette—Lists the document components in the current document, and their
component properties.
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To show or hide the View pane, select View > View Pane, or press F6.

● Content area—Largest area of the interface. It is located between the Process bar and the
Status bar, and reflects the current module, View pane panel, and document. A content tab
bar is displayed at the bottom of the Content area when multiple documents are open. The
current content tab is highlighted.

● Status bar—At the bottom of the interface, provides applet processing information.

Documents and Data Objects
Documents display data values returned from the data source in a data object. Multiple data
objects can occupy a document, and each data object's display type can differ:

● Spreadsheet

● Chart

● Pinboard

● SQL Spreadsheet

● Free-form grid

You can convert spreadsheets to charts or pinboards. SQL Spreadsheets and Free-form grids
must be created using the Document Designer. Prerequisites exist for all display types.

Topics related to documents and data objects:

● “Filter Panel” on page 20

● “Page Control Panel” on page 20

● “Shortcut Menu” on page 21

Filter Panel
The Filter panel displays dimension member selections on the Filter axis. When no member
selections are made in Filters, dimensions are represented by their highest aggregate. Filter
selections focus the intersections, the data values, and consequently the data object analysis.

➤ To show or hide the Filter panel, select View > Filters, or press F7.

Page Control Panel
The Page Control panel indicates dimension members assigned to the spreadsheet Pages axis.
Spreadsheet row and column intersections are organized by Pages axis dimensions. The Page
Control panel is displayed when dimensions are assigned to the Pages axis.
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Think of pages as the Z-axis of a three-dimensional graph. Visualize a stack of spreadsheets.
Traveling back and forth in the stack enables comparison of values on different pages.

➤ To navigate Page dimensions:

● Click Page Control scroll buttons to move in the page series.

● Select a page dimension member name from the list.

The Page Control panel can display multiple drop-down lists when working with page dimension
combinations. Multiple-page drop-down lists display all possible page combinations, whether
data exists. Single-page drop-down lists omit page combinations without data. Hyperion
recommends single page drop-down lists when working with sparse dimensions.

➤ To separate page dimensions into multiple drop-down lists, click the Page Control panel page
icon.

➤ To combine multiple-page dimensions into one drop-down list, click the Page icon.

Shortcut Menu
Data objects feature a shortcut menu that is context sensitive to headers, cells, dimensions, and
data values. It provides immediate access to advanced formatting and functional options:

Command Description Submenu

Browse Displays the Dimension Browser dialog box,
used in member selection.

 

Keep Only Deselects all other dimension member
selections for the selected Dimension,
leaving only the selected member.

 

Remove Only Removes only the member selected.  

Drill Increases or decreases the level of
dimension detail by including or excluding
members of the dimensional hierarchy in
the display.

Select from the submenu:

● Drill

● Down

● Up

● To Top

● Options

Analysis Tools Applies sorting, ranking, filtering,
calculation and conversion definitions to
the current selection.

Select from the submenu:

● Analysis Tools Manager

● Traffic Lighting

● Sort

● Retrieve Only Top/Bottom

● Restrict Data
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Command Description Submenu

● Calculation

● Show/Hide Only

● Format

● Currency Conversion (On SAP BW data
sources)

● Unit of Measure Conversion (On SAP BW
data sources)

Related Content Accesses data from other Hyperion
sources.

 

Search Searches for a dimension member in the
selected dimension.

 

Data display Sets custom data display behavior. ● Selected Member

● Selected Member First

● Default Label Mode

● Product-specific Label Mode

● Dimension Header Sort (Default,
Ascending, Descending, Level, Generation)

● Show Linked Reporting Object Indicators

● Suppress (Missing Rows, Shared
Members, Zero Rows)

Refresh data Refreshes the data from the data source.  

Export Data Exports data values. You can export to Microsoft Office, to a tab-
delimited text file, or to the operating system
clipboard in three formats:

● Query-ready

● Formatted

● Image

Print Displays the Print dialog box, used to print
the current page of the data object.

 

Formatting Displays the Formatting dialog box, used to
set header and cell formatting options.

 

Edit data Edits cell values and writes them back to
Analytic Services.

Spreadsheet Options Displays the Spreadsheet Options dialog
box used to select options. For charts,
opens Chart Properties

 

Column Sizing Sets the column width. ● Autosize

● Custom width

● Set all columns to this width
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Exiting Web Analysis Studio

➤ To exit Web Analysis Studio, select File > Exit.
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Desktop Folders
Desktop folders centrally collect and present presentation icons. Presentations are playlists of
documents. They enable documents to be grouped, organized, ordered, distributed, and
reviewed. Presentation icons are represented on the Desktop like application shortcuts on the
Windows desktop.

Accessing Multiple Desktops
You can create multiple Desktop folders. The Desktop interface displays the Desktop folder
specified by the active preference file. You cannot review Desktop folders in inaccessible
locations, however.

Although only one Desktop can be current, you can change the active preference file. Each
preferences set can specify a different Desktop folder. See “Folders Preferences” on page 263.

Topics that discuss how to access Desktops:

● “Accessing the Current Desktop” on page 26

● “Accessing Desktops” on page 26
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Accessing the Current Desktop

➤ To access the current Desktop, select Go > Desktop, or click  (Switch to Desktop), or press
F11.

Accessing Desktops
To access Desktops, you must display preferences and reset the active preference file.

➤ To access a Desktop:

1 Select File > Preferences.

The User Preferences dialog box is displayed.

2 In Active Preferences, select one option:

● Use My Preferences—Sets the current preference files to the preference files in your user
folder

● Use Shared Preferences—Sets the current preference file to the specified repository location.

3 To verify the current Desktop folder, click Folders.

Desktop folder specifies the folder location used by the Desktop.

4 Optional: To specify another repository location as the current Desktop folder, perform these actions:

a. Click the Desktop Folder Browse button (...).

b. In Open, navigate to a repository location.

c. If there is no Desktop folder at that location, click New Folder.

d. In File name, enter a folder name.

e. Click OK.

The repository location and folder name are displayed in Desktop Folder.

5 Click OK.

6 Click the Switch to Desktop button.

The selected Desktop is displayed.

Managing Desktop Presentations
Only presentations, and links or shortcuts to presentations, display on the Desktop. Other files
and folders in the Desktop folder do not display as icons.

You must grant access and locate a presentation, link, or shortcut in the Desktop folder for a
presentation icon to be displayed.
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You cannot hide a presentation in the Desktop folder from the Desktop. If you do not want a
presentation to display on the Desktop, relocate it outside the Desktop folder.

Efficient presentation distribution requires planning:

● Hyperion discourages copying presentations to multiple individual Desktops. It is difficult
to track and synchronously maintain multiple copies in large repositories.

● It is better to distribute a shortcut or link, than the original presentation. Maintaining only
one presentation protects the repository from multiple file footprints of identical
information, and enables presentations to be centrally maintained and updated.

Best practices for managing presentations:

1. Create and maintain a presentation in your user Desktop folder.

2. Create groups for each distribution pattern you require.

3. To distribute the presentation, edit Security file properties to grant access to groups.

4. Reference the original presentation by creating links or shortcuts in the group desktop.

Opening Presentations from the Desktop
The Desktop centrally collects and presents presentation icons.

➤ To open a presentation from the Desktop, perform one action:

● Right-click the presentation icon and select Open.

● Double-click the presentation icon.

You may be prompted with the Database Logon dialog box, if the selected presentation uses
database connections that you do not own. To log on to the database connection, enter the
database connection user ID and password, and click OK.

All documents in the presentation playlist are loaded in the Analyze interface. Document
names are listed in the tabs bar. The first document in the presentation is opened. Its tab is
highlighted as the current document.

Note:

When you open a presentation from the Desktop, all other currently opened documents
close.

Editing Presentations from the Desktop

➤ To edit a presentation from the Desktop, right-click the presentation icon and select Edit.

The Presentation Wizard is displayed, enabling you to edit the presentation icon, presentation
contents, and their order. See “Editing Presentations” on page 42.
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Deleting Presentation Icons from the Desktop
Deleted presentations are removed from your repository Desktop folder. This file may be a link
or a shortcut referencing a presentation at another location. Although the link or shortcut is
deleted, the referenced presentation persists. Deleting a presentation does not delete documents
referenced by the presentation.

➤ To delete a presentation from the Desktop, right-click the presentation icon and select Delete.

See “File and Folder Shortcut Menus” on page 51.

Editing Presentation File Properties from the Desktop
Presentation file properties enable you to rename the presentation, enter a file description, and
set security options.

➤ To edit a presentation's file properties, right-click the presentation icon and select Properties.

The File Properties dialog box is displayed. The General tab enables you to rename the
presentation, and enter a description. The Security tab enables you to grant or withhold access
to users and groups. See “Setting File Properties” on page 49.

Setting Desktop Wallpaper
You can load an image as the desktop wallpaper, clear an image, or indicate how the image covers
the desktop.

➤ To set the Desktop wallpaper:

1 Right-click the Desktop (not an icon) and select Wallpaper.

The Select Graphic dialog box is displayed.

2 Click Load to browse for a graphic file; click Open to select the graphic file.

3 In Style, select an option:

● Center—Centers the graphic on the Desktop

● Stretch— Stretches the graphic across the Desktop

● Tile—Repeats the graphic across the Desktop

● Top-Left—Displays the graphic in the top left corner of the Desktop

You can set the Desktop wallpaper for the current Desktop using the preferences Look and Feel
tab.
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Refreshing the Desktop
Refreshing updates the current Desktop to reflect changes.

➤ To refresh the Desktop, right-click the desktop and select Refresh.
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Documents
Documents synthesize formatting definitions with data values from a data source. A document
is the content and display formatting. After documents are saved, they become multipurpose
files for presentation, analysis, and distribution in numerous formats.

Document tasks include:

● “Opening Documents” on page 32

● “Saving Documents” on page 33

● “Closing Documents” on page 34

● “Modifying Document Properties” on page 34

Additional document procedures are described by these tasks:

● Renaming Documents—See “File and Folder Shortcut Menus” on page 51.

● Distributing Documents—See “Exporting Documents and Presentations” on page 141,
“Printing” on page 149, and “Setting File Properties” on page 49.

● Importing Document Definitions—See Chapter 19, “Accessing External Media”

Open Dialog Box
The Open dialog box provides an interface for retrieving repository files.
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➤ To access the Open dialog box, select File > Open or click .

Control Description

Location Indicates the current repository folder. A list of previously visited locations is stored as a series.
Select locations from the series, or use Back and Forward to move through the series.

Back Moves to the previous location. Assumes you navigated to another location.

Forward Moves to the next location in the series. Assumes you navigated to a previous location.

Up Moves up one folder level in the repository.

Favorites Moves to the current Favorites folder. The Favorites Folder is set for by Folders preferences.

Favorites List Lists links to available group Favorites folders. Because the Favorites button jumps to only the
current user's Favorites folder, this list is provided to navigate to alternate Favorites folders.

Home Moves to the current Home folder. The Home Folder is set by Folders preferences.

New Folder Creates a folder at the current location.

View Changes between Detail, List and Icon views.

Favorites frame Displays shortcuts to the contents of Favorites folders. Click the dark blue bar to display the contents
of that Favorites folder.

Selection frame Lists the current folder's contents. The selection frame contains the standard shortcut menu that
includes: Copy, Cut, Rename, Delete, View, and Properties.

File Name Indicates the current selection's name.

Files of Type Indicates the file type filter, used to display the current selection's content in the selection frame.

Opening Documents

➤ To open a document:

1 Select File > Open, or click , or press Ctrl+O.

The Open dialog box is displayed and lists the current folder content specified by location.

2 From Files of Type, select Web Analysis Document.

3 Navigate to the document you want to open.

4 Optional: To sort large lists of documents and presentations:

a. Right-click the selection frame and select View > Detail.

The selection frame features three columns: Name, File Type, and Last Modified.

b. Click a column header to sort the contents of the selection frame in ascending order, by
that column.
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c. Click the column header again to sort the contents of the selection frame in descending
order, by that column.

5 Select a document or documents using these options:

● To select a document from the selection frame, click the document name or icon.

● To select a series of documents from the selection frame, click a document name and press
and hold Shift while selecting another document name. The first selection, the last selection
and all documents in between are selected.

● To select multiple documents, not necessarily in a series, hold down Ctrl while clicking
document names in the selection panel.

● To deselect items, click outside the Name column or on empty white space.

● Double-click to select and dismiss the Open dialog box.

6 Click OK.

7 If prompted, in Database Login, enter a User ID and password for the database connection. Click Save User
ID and Password to store log on credentials for the database connection, and click OK.

The selected document is displayed in the content area.

Saving Documents
Saving stores information, such as the query, document properties and formatting. Saving does
not send data value updates back to the data source. See “Editing Data Values” on page 245.
You can only save documents into folders that you can access.

You can create Services buttons or hotspots that save the current document. See “Creating
Hotspots” on page 223.

➤ To save previously saved documents, perform one action:

● Select File > Save.

● Select the Save icon.

● From the Contents Tab bar, right-click the current content tab and select Save.

● Press Ctrl+S.

➤ To save a document:

1 Perform one action:

● Select File > Save As.

● Select the Save As icon.

● From the Contents Tab bar, right-click the current content tab and select Save As.

The Save As dialog box is displayed. It features a selection frame listing the current folder
content, specified by Location.

2 From Files of Type, select Web Analysis Document.

Saving Documents 33



3 Navigate to the folder in which to save the document.

4 In Filename, enter a document name.

5 Click OK.

Closing Documents

➤ To close the active document, perform one action:

● Select File > Close.

● From the Contents Tab bar, right-click the current content tab and select Close.

➤ To close all opened documents, perform one action:

● Select File > Close All.

● From the Contents Tab bar, right-click the current content tab and select Close All.

Unchanged files close. Changed files stored in the repository prompt you to save changes.
Unsaved files trigger the Save As dialog box. See “Saving Documents” on page 33.

Modifying Document Properties
Documents properties enable you to specify settings that impact display and use. You set
document properties in the File Properties dialog box Advanced tab. Document Usage options
prevent subsequent users from using these methods:

● Drill up

● Drill down

● Access shortcut menus

● Change Display Type

➤ To modify document properties:

1 Perform one action:

● Right-click the content tab for a document and select Properties.

● Right-click the document name in the View Pane Browser tab, and select Properties.

● With the document open in the Content area, select File > Properties.

2 Click the Advanced tab.

The Advanced tab shows the document properties for the current document.

3 Optional: To prevent subsequent use of methods, select the corresponding Document Usage options.

You can prevent use of: drilling up, drilling down, accessing the shortcut menu, and changing
the display type.
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4 Click OK.
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About Presentations
Presentations are playlists of documents. They enable documents to be grouped, organized,
ordered, distributed, and reviewed. Presentations are not documents copied into a set. A
presentation is a list of pointers referencing documents in the repository.

Topics that discuss presentation permissions:

● “Presentation Access and Document Permissions” on page 37

● “User and Group Permissions” on page 38

Related Topics

“File and Folder Shortcut Menus” on page 51.

“Exporting Documents and Presentations” on page 141

“Printing” on page 149

“Setting File Properties” on page 49.

Presentation Access and Document Permissions
It is possible to distribute to another user a presentation that contains documents that he or she
cannot access. Document access is independent of presentation access.

A document in a presentation is not listed to users without list permissions. A document in a
presentation cannot be opened by users without read permission.
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Document permissions that withhold access prevent all access to the document, directly or
through a presentation. Presentation permissions that withhold access do not prevent access to
a document.

User and Group Permissions
Users can access presentations assigned directly to them or presentations assigned to a group to
which they belong.

When presentations are assigned to a group, the documents in that presentation must also be
assigned to the group. Otherwise, group members can access the presentation, but they cannot
access its documents (unless they have individual user access).

To mitigate the risk of conflicting permissions, store presentations with the documents they
reference. Whenever possible, distribute documents and presentations to groups. It is easier to
set permissions for all files in a folder, and all users in a group than it is to manage permissions
for individual files and individual users.

Document and Folder References
You can add two kinds of references to presentations:

● Document—When you add documents directly to a presentation, a reference to a unique
document identifier is created in the presentation. Wherever the document is moved, the
presentation can locate and present the document.

● Folders—When you add folders to a presentation, the folder reference is directly added to
Presentation Content, but documents in the folder are dynamically referenced. Documents
added or removed from the folder are automatically added or removed from presentations
referencing that folder.

Note:

You cannot dynamically include descendant folders, or presentations in target
presentations. When adding a folder to a presentation, only documents immediately in the
selected folder are dynamically added to the target presentation.

Presentation Benefits and Considerations
Folder references simplify presentation maintenance because Web Analysis Studio synchronizes
presentation playlists with referenced folder content. You can also change folder content without
editing its presentation. You must limit write access to the folder to prevent other users from
inadvertently adding content to a folder, and subsequently your presentation.

While document references are less flexible and require more maintenance, presentation content
is fixed.
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Presentation Reference Reconciliation
When presentations are opened, Web Analysis Studio first attempts to reconcile document
references, then folder references.

If files are copied and the original file deleted, Web Analysis Studio cannot locate the unique file
identifier. In this case, Web Analysis Studio searches for files of the correct name at the same
location. When a reference cannot be found by means of identifier or location, the reference
displays as red in the Presentation Wizard.

Opening Presentations

➤ To open a presentation:

1 Perform one action:

● Select File > Open.

● Click .

The Open dialog box is displayed and lists the current folder contents, specified by location.

2 Select Web Analysis Presentation from Files of Type.

3 Navigate to the presentation you want to open.

As you navigate, the selection frame lists the files and folders indicated by Files of Type.

4 Optional: Sort large lists of documents and presentations using these options:

a. Right-click the selection frame and select View > Detail.

The selection frame features three columns Name, File Type, and Last Modified.

b. Click a column header to sort the selection frame contents in ascending order, by that
column.

c. Click the column header again to sort the selection frame contents in descending order,
by that column.

5 Select a presentation (or additional documents and presentations) using these options:

● To select a presentation from the selection frame, click the presentation name or icon.

● To select a series of document or presentations from the selection frame, click a file name
and press and hold Shift while selecting another file name. The first selection, the last
selection and all files in between are selected.

● To select multiple files, not necessarily in a series, hold down Ctrl while clicking file names
in the selection panel.

● To deselect items, click outside the Name column or on empty white space.

● Double-click to select and dismiss the Open dialog box.

6 Click OK.
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If the first document in a presentation uses a Database Connection requiring log on, you are
prompted by the Database Login dialog box.

7 If prompted by the Database Login dialog box, enter a User ID and password for the Database Connection.
Select the Save User ID and Password option to store log on credentials for the Database Connection, and
click OK.

The selected presentation (and other selections) display as content tabs below the content area.
The first document in the presentation is opened and displays as the current document.

Important Notes on opening presentations:

● In the Open dialog box, you can select documents and presentation. If you selected multiple
files to open, files are opened in the order listed in the selection frame. The order of
documents inside the presentation are observed in the context of the other files selected for
opening.

● If you open multiple presentations containing the same document, only the first instance
of the document is opened. It may appear that the document did not open, or opened in
the wrong order. Only one instance of a document can be opened (and modified).

Closing Presentations

➤ To close all opened presentations, perform one action:

● Select File > Close All.

● From the Content Tab bar, right-click the current content tab and select Close All.

Unchanged files close. Changed files that are stored in the repository prompt you to save
changes. Unsaved files trigger the Save As dialog box. See “Saving Documents” on page
33.

Creating Presentations

➤ To create a presentation:

1 Perform one:

● Select File > New > Presentation.

● Click , and select Presentation.

The Process bar displays steps for creating a presentation: Content, Order, and Image. In
the first step, you must select the presentation content from previously defined documents
in the repository. Notice that the Presentation wizard automatically displays the View Pane
Browser tab, so you can select documents and folders from the repository.

2 In the View Pane Browser tab, navigate to a location containing a document, folder, or link.

3 To add a file to the presentation playlist:
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● Select a file on the Browser tab, and click the right arrow button.

● To select a series of files in a folder, click a file name and press Shift and select another file
name. The first selection, the last selection and all files in between are selected. Click the
right arrow button.

● To select multiple documents in a folder that are not necessarily in a series, hold down
Ctrl while clicking multiple file names. The files you click are selected. Click the right arrow
button.

Your selections display in the Presentation Content list.

4 Optional: To remove content from the selected presentation content panel:

● Click the file name on the Content page and click the left arrow button.

● Right-click a file on the Content page and select Remove from the shortcut menu.

● To deselect a series of files, click a file name and press Shift and select another file name. The
first selection, the last selection and all files in between are selected. Click the left arrow
button.

● To select multiple documents that are not necessarily in a series, hold down Ctrl while clicking
multiple file names. The files you click are selected. Click the left arrow button.

5 Optional: Click Next.

6 Optional: To reorder the selected content, perform one action:

● Select a file on the Order page and click an Up or Down arrow button to reposition the file
in the playlist.

● Right-click a file and select Move Up or Move Down from the shortcut menu.

● To select a series of files, click a file name and press Shift and select another file name. The
first selection, the last selection and all files in between are selected. Click the Up or Down
arrow button to reposition the files in the playlist.

● To select multiple documents in a folder that are not necessarily in a series, hold down
Ctrl while clicking multiple file names. The files you click are selected. Click the Up or
Down arrow button to reposition the files in the playlist.

7 Optional: To select an image for the presentation icon, perform these steps:

a. Click Select Graphic.

The Open dialog box is displayed.

b. Navigate to a folder containing a JPG or GIF image file, and click to select the file.

c. Click Open.

Your image is displayed as the Desktop Button Image on the Presentation wizard. Clicking
Clear restores the default desktop button image.

8 When your selected content is in the correct order, click Finish.

The Save As dialog box is displayed that lists the current folder contents, specified by location.

9 Navigate to the folder into which you want to save your presentation and enter a name in Filename.
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10 Click OK.

The presentation is saved to the specified location, using the specified name.

Editing Presentations
Options for modifying presentations:

● You can edit a presentation by changing the content, order, and presentation icon and saving
these changes.

● You can also copy a presentation and paste it to another location, where it can be modified
without impacting the original presentation. You can not save a presentation under another
name or to another location (Save As).

See “Copying Files” on page 52.

➤ To modify a presentation:

1 Right-click a presentation file name and select Edit.

The Presentation Wizard is displayed with the View Pane Browser tab.

2 Optional: In the View Pane Browser tab, navigate to a location containing a document, folder, or link that
you would like to add to the presentation.

3 Optional: To add a file to the presentation playlist, perform one action:

● Select a file on the Browser tab, and click the right arrow button.

● To select a series of files in a folder, click a file name and press Shift and select another file
name. The first selection, the last selection and all files in between are selected. Click the
right arrow button.

● To select multiple documents in a folder that are not necessarily in a series, hold down
Ctrl while clicking multiple file names. The files you click are selected. Click the right arrow
button.

Your selections display in the Presentation Content list.

4 Optional: To remove content from the selected presentation content panel, perform one action:

● Click the file name on the Content page and click the left arrow button.

● Right-click a file on the Content page and select Remove from the shortcut menu.

● To deselect a series of files, click a file name and press Shift and select another file name. The
first selection, the last selection and all files in between are selected. Click the left arrow
button.

● To select multiple documents that are not necessarily in a series, hold down Ctrl while clicking
multiple file names. The files you click are selected. Click the left arrow button.

5 Optional: Click Next.

6 Optional: To reorder the selected content, perform these actions:
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● Select a file on the Order page and click Up or Down arrow button to reposition the file in
the playlist.

● Right-click a file and select Move Up or Move Down from the shortcut menu.

● To select a series of files, click a file name and press Shift and select another file name. The
first selection, the last selection and all files in between are selected. Click anUp or Down
arrow button to reposition the files in the playlist.

● To select multiple documents in a folder that are not necessarily in a series, hold down
Ctrl while clicking multiple file names. The files you click are selected. Click anUp or
Down arrow button to reposition the files in the playlist.

7 Optional: To select an image for the presentation icon:

a. Click Select Graphic.

The Open dialog box is displayed.

b. Navigate to a folder containing a JPG or GIF image file, and click to select the file.

c. Click Open.

Your image is displayed as the Desktop Button Image on the Presentation wizard. Clicking
Clear, restores the default desktop button image.

8 When your selected content is in the correct order, click Finish.
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Web Analysis Repository
The repository centrally stores system data in relational database tables, at a shared local area
network location. Web Analysis Studio presents the repository as a file management system in
the View panel Browser tab.

Browser Tab
The Browser tab is one of three View Pane tabs.

The Browser tab navigation panel presents the repository as a node tree. You can see only files
and folders to which you are granted access. This typically consists of your own folder and folders
of groups to which you belong. Administrators can designate additional access to individual
users and groups as needed.

You can expand, collapse, explore, and select from the repository in the course of your analysis,
presentation, and reporting. The Browser tab Selection frame presents the contents of the
currently selected Navigation frame folder.

Accessing the Browser Tab

➤ To display the View Pane Browser tab, perform one action:

● Select View > View Pane, then click .
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● Press F6, then click .

Setting the View
You can display repository contents in the Browser tab in three ways:

● Detail—Displays file names in a vertical list with additional File Type and Last Modified
information.

● Icon—Displays file icons horizontally and vertically on the panel.

● List—Displays file names in a vertical listing.

➤ To set the view, perform one action:

● Select View, and one of three menu options: Icon, List, or Detail.

● From the shortcut menu, select View, and one of three menu options: Icon, List, or
Detail.

The interface changes to reflect your selection.

➤ To refresh the interface, perform one action:

● Select View > Refresh.

● Press F5.

● From the content area shortcut menu, select Refresh.

The interface is updated with the latest repository information.

Filtering the Browser Tab
You can restrict the objects displayed in the View Pane Browser tab to reduce the number and
kinds of items displayed in the selected folder.

➤ To filter the Browser tab Selection frame:

1 Select View > Display Items of Type.

2 Select one option:

● All—displays all files, regardless of type.

● Document—displays only documents

● Presentation—displays only presentations

● Database Connection—displays only database connections.

Resizing the Browser Tab
You can resize the Navigation frame, the Selection frame and the View Pane Browser tab.
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➤ To resize the View Pane Browser tab Navigation frame and Selection frame, float the cursor over
the border between the two frames, until it changes to a double arrow cursor, then click and
drag the cursor to resize the frames vertically.

➤ To resize the View Pane Browser tab, float the cursor over the border between the View Pane
and the Content area, until it changes to a double arrow cursor, then click and drag the cursor
left or right to resize the pane horizontally.

➤ To show or hide the View Pane, perform one action:

● Select View > View Pane.

●

Click .

● Press F6.

Folders
Web Analysis Studio installs these folders by default.

The default hierarchy features three (3) main folders:

The root folder is specified by the slash character (/). It contains all other files and folders.

The Groups folder is directly below the root folder. It is intended to contain all group folders.
The Groups folder contains a default group folder named Everyone, that enables all users to be
managed collectively.

The Users folder is also directly below the root folder. It is intended to contain all user profile
folders.

While administrators can see all defined users and groups folders and files, you can see only files
and folders to which you are granted access. This typically consists of your own folder and folders
of groups to which you belong. Administrators can designate additional access to individual
users and groups as needed.

Note:

As with all file systems, though the default directories, folders, and files were designed for a
purpose there is nothing to prevent you from diverging from this original design. Consider this,
when giving users and groups access and permissions to the repository. See “Setting File
Properties” on page 49.

User and Group Folders
User folders and group folders contain this standard set of folders:

Databases—Database connections.

Desktop—Presentations to be displayed on the Desktop

Folders 47



Favorites—Most commonly sought content

Every user profile and group profile features a Favorites folder. Files in the Favorites folder are
presented for quick access in the Open dialog box, the Save dialog box, and under the Go >
Favorites menu, based on the active user specified by preferences.

Reports—Other repository files

Profiles—Preference files used to customize application look-and-feel and behavior

Files
User folders, group folders, and their subfolders organize and manage files, shortcuts, and
links. There are four kinds of files:

● Database connection —Define the terms, conditions and method for connecting to a data
source.

● Web Analysis documents —Synthesize formatting definitions and analysis tools
definitions with the data values returned from the data source.

● Presentations —Playlists of documents, enabling documents to be grouped, organized,
ordered, distributed, and reviewed.

● Preferences—Customize application look and feel, and behavior.

Although multiple preference files can be defined, only one can be current. You can also change
the active preference file to a preference file shared by users.

Shortcuts and Links
Shortcuts navigate to other repository locations. Shortcuts can link to folders, files, or links.
Shortcuts do not grant access to target files.

Broken shortcuts are the result of renamed targets, moved targets, or deleted locations. Caution
should be used when a broken shortcut is encountered, as another administrator may be
updating a dynamic target. You can restore a broken shortcut by creating an object with the
specified name at the specified location.

A unique identifier is assigned to every element in the repository. Links are references to folders,
files, shortcuts and links using these identifiers. Links present their target in the current folder,
regardless of where the target is located or how the target is renamed. Links are fixed references
to another object in the repository.

Links simplify maintenance by enabling information stored at one location to be presented in
multiple, diverse locations in the repository.

Broken links are designated by icons:
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Broken links are the result of a deleted target, and they should also be deleted when encountered.
You cannot restore a broken link. You must recreate it.

Links to broken links also display as broken links, even though they are operating correctly. This
saves you the effort of pursuing a chain of links that is inevitably broken. You must identify and
repair the broken link in the chain.

Expanding and Collapsing in the Repository

➤ To expand a folder in the Navigation frame, click the folder's plus sign (+) node.

➤ To expand a folder and display its contents in the selection frame, double-click the folder icon
or name.

➤ To collapse an open folder, click the folder's minus sign (-) node.

Selecting Folders and Files
The repository supports most conventions used by other repositories. Selecting a folder also
selects all contents of that folder. Several selection methods are supported:

➤ To select a file, click the file icon or its name.

➤ To select a series of files, click a file, press Shift and select another file.

The first selection, the last selection, and all files in between are selected.

➤ To select multiple files that are not necessarily in a series, hold down Ctrl while clicking multiple
files.

Setting File Properties
All repository files have general and advanced properties.

➤ To display file repository file properties, right-click the file name in the View Pane Browser and
select Properties.

General Properties
● Name—Artifact name

● Description—User-supplied description
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● Type—Indicates whether the artifact is a folder, file, shortcut, or link (read-only)

● Owner—File creator, a user who can change permissions by default (read-only)

● Location—Repository location of the file (read-only)

● Created—Time when the artifact was created

● Modified—Time when the artifact was last modified

Advanced Properties
Advanced file properties apply to all users and groups:

● HTML Client Override Template—JavaServer Pages (JSP) template used to convert
documents to HTML Web pages when opened in Hyperion® System™ 9 Workspace™

● HTML Export Override Template—JSP template used to convert Web Analysis documents
to HTML Web pages using File > Save As HTML; output location is specified in the Save
dialog box

● HTML Batch Export Template—JSP template used to convert Web Analysis documents to
HTML Web pages when running batch export programs

● Document Usage—Restricts subsequent users from drilling up, drilling down, accessing
shortcut menus, and changing the display type

Notes on JSP Templates

● Web Analysis Studio converts Web Analysis documents to HTML Web pages using
predefined JSP templates.

● All JSP templates must be located in your application server's Web Publishing template
subdirectory (wp_templates), and all templates must be specified by name (including the
JSP file extension).

● When no JSP template is specified, Web Analysis Studio

uses the report_publish.jsp template in \webapps\WebAnalysis\templates.

● When you publish presentations, a directory named for the presentation is created in the
application server's Web publishing output directory (wp_output), if no other directory is
specified. When you use the Batch Utility, the default output file location is the application
server's Web publishing output directory (wp_output), if no other directory is specified;
however, you can enter a parameter that specifies an alternate output location.

Related Topics

“Modifying Document Properties” on page 34

“Changing and Locking Display Types” on page 103
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File and Folder Shortcut Menus
Files and folders share a common shortcut menu. Menu items are enabled and disabled based
on user profile permissions, object type, and file state.

Topics that discuss shortcuts:

● “Opening Files” on page 51

● “Editing Files” on page 51

● “Adding Files to Favorites” on page 52

● “Adding Files to Desktop” on page 52

● “Copying Files” on page 52

● “Copying and Pasting Links” on page 53

● “Moving Files” on page 54

● “Renaming Files” on page 54

● “Deleting Files” on page 54

Opening Files
Opening functionality differs by file type and your ability to access a file.

➤ To open a file, right-click the file name and select Open.

File Type Open Command Result

Document Opens the document in the Analyze content area.

Database Connection Open a Auto-Populate Dimension document using the selected database connection. Uses
the highest aggregate members of the time and measures dimensions to populate the rows
and columns axes of a spreadsheet.

Presentation Opens all documents in the presentation playlist in the content area.

Shortcut or Link Determines the file type of the source file for the shortcut or link and responds.

Editing Files
Editing functionality differs by file type and your ability to access a file.

➤ To edit a file, right-click the file name and select Edit.

File Type Edit Command Result

Document Opens the document in Document Designer, enabling you to create a custom document.
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File Type Edit Command Result

Database Connection Opens the database connection wizard, enabling you to set data source parameters.

Presentation Opens the Presentation Wizard.

Shortcut or Link Determines the file type of the source file for the shortcut or link, and responds.

Adding Files to Favorites
Every user profile and group profile features a Favorites folder. Files in the Favorites folder are
presented for quick access in the Open dialog box, the Save dialog box, and under the Go >
Favorites menu based on the active user specified by preferences.

➤ To create a shortcut to a file in the Favorites folder, right-click the file name and select Add To
> Favorites.

Note:

Because shortcuts are location based, a shortcut added to the Favorites folder requires the original
source file to remain at its original location. Links, however, reference files through unique
identifiers that travel with the file wherever it is located. To create a link to a file in the Favorites
folder, you must use the Copy > Paste Link shortcut menu option.

Adding Files to Desktop
Every user profile and group profile can feature a Desktop folder. The Desktop folder displays
presentation icons for presentations it contains on the Desktop. While all files can be saved to
the Desktop folder, only presentations are displayed on the Desktop.

Because there is a Desktop folder for every user and group, the current Desktop is set by the
active user specified by preferences.

➤ To create a shortcut to a presentation in the Desktop folder, right-click the file name and select
Add To > Desktop.

Copying Files
When you copy files, except for links, to other locations, the files adopts the file permissions set
for that location (the folder). Therefore, you need not coordinate file permissions of copied files
with file permissions of target locations.

➤ To copy a file and paste it as another file or shortcut:

1 Right-click the file name and select Copy.

2 Navigate to the location where you want to create a copy of the original file.
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3 Right-click the View Pane Browser tab Selection frame and select one option:

● Paste—Copies the original file; file permissions are inherited from this location

● Paste Shortcut—Creates a reference to the location of the original file; file permissions are
inherited from this location

A file or shortcut is created at the this location as indicated.

Note:

Because files copied to another location adopt the file permissions set for that location, your
copy may grant unlimited access to the copied file. To control access to a copied file, consider
copying a link instead. Copying a link enables you to grant unlimited access to a link, while
maintaining restricted access to the original file.

Copying and Pasting Links
When you paste a copied file as a link, you must coordinate access to the link and access to the
original file. There is no point in creating a link to a file that no one can access, or creating a link
with universal access that overrides a file with restricted access.

When no file permissions are set, the original file (or target) and the link are assigned default
Read access.

➤ To copy a file and paste it as a link:

1 Right-click the file name and select Copy.

2 Navigate to the location to create the link.

3 Right-click the View Pane Browser tab Selection frame and Select Paste Link to paste a reference to the
original file identifier.

A link is created at this location.

4 Right-click the link and select Properties.

The File Properties dialog box displays. Notice that it has General, Security, Advanced and Target
Security tabs.

5 Click the Security tab to make it the current tab.

The Security tab for a link, determines access to the link.

6 Set user and group file permissions to the link.

7 Click the Target Security tab to make it the current tab.

The Target Security tab for a link, determines access to the original file that the link references.

8 Set user and group file permissions to the target.

9 Click OK.
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Moving Files
When you cut and paste (or move) a file, the file retains its original file permissions without
regard for the file permissions of its new location (the folder).

➤ To move a file:

1 Right-click the file name and select Cut.

2 Navigate to where you want to relocate the file.

3 Right-click the View Pane Browser tab Selection frame and select Paste, to relocate the file.

Renaming Files
With permissions, you can rename a file without accessing file properties.

➤ To rename a file, right-click the file name and select Rename.

Deleting Files
With permissions, you can delete a file from the repository.

➤ To delete a file, right-click the file name and select Delete.
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About Documents
Documents display data values returned from the data source in a data object. Multiple data
objects can occupy a document, and each data object's display type can differ:

● Spreadsheet

● Chart

● Pinboard

● SQL Spreadsheet
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● Free-form grid

Each display type has prerequisites.

● Pinboards are generated from spreadsheets and charts, and they require traffic lighting
definitions. See “Creating Pinboards” on page 185.

● Because custom documents use component combinations that differ, there is no single
process for creating custom documents. See “Creating Custom Documents” on page 211.

● SQL spreadsheets enable you to query a relational data source, and display the returned data
values on a custom document. You must understand how to compose a SQL query to create
a SQL spreadsheet. See “Creating SQL Spreadsheets” on page 193.

● Free-form grids enable you to combine data values from multiple data sources in one data
object. Free-form grids leverage custom document database connections. See “Creating
Freeform Grids” on page 203.

● You can change spreadsheets into a wide variety of charts. See “Changing and Locking
Display Types” on page 103.

● Finally, each display type has formatting options. See “Formatting Options” on page 93.

To create a document you are required to specify:

● Data source—Provides data values

● Data object—Displays these values

● Query—Gets data values from the data source and returns them to the data object.

You can set properties that customize each element.

The database connection wizard specifies the type of data source, logon credentials, database
applications, dimension formatting and drill-through properties.

Each data object can be set to a display types that features formatting options.

Queries can be explicit, requesting information on dimension members, or dynamic, requesting
information about a dimension member that satisfies a set of criteria.

Topics that discuss the three primary ways to create documents:

● “Creating Documents” on page 56

● “Creating Documents from Existing Documents” on page 60

● “Creating Auto-Populate Dimension Documents” on page 60

Creating Documents
A wizard guides you through creating Web Analysis Studio spreadsheets and charts. The wizard
requires that you know where a database connection is located, and have permission to use it.

➤ To create a document:

1 Perform one:
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● Select File > New > Document Wizard.

● Click , and select Document Wizard.

● Press Ctrl+Shift+N.

The Process bar displays steps for creating documents. Because the repository stores
document definitions and not document data, you must identify a data source, and the
parameters for connecting to it.

2 Perform one:

● In the text area, enter the path from the root directory (/) to a database connection, including
the file name.

● Click Browse, select a database connection file from the Open dialog box, and click OK.

3 Optional: Select Auto-Populate Dimensions to automatically populate and display a simple spreadsheet.

Selecting the Auto-Populate Dimension option and clicking Finish skips the remaining steps in
the process. Auto-Populate Dimension uses the highest aggregate members of the time and
measures dimensions to populate the rows and columns axes of a spreadsheet. This is the quickest
method to display a simple spreadsheet using the wizard.

4 Optional: Select Use Point of View to populate the query from a predefined point of view (POV) definition.

Selecting Use Point of View and clicking Next inserts the dimensions and members that are of
interest to you in documents. You can define multiple POV definitions, but Use Point of View
only applies the current POV set in preferences.

Selecting Auto-Populate Dimension and Use Point of View and clicking Finish skips the
remaining steps in the process and displays a simple spreadsheet using the active POV.

5 Click Next.

In Step 2: Select Row Dimension, you must select the dimensions to be used on the Rows axis.
You must have at least one Row axis dimension and one Column axis dimension.

6 Move a dimension name from Filters to Rows:

● Double-click a dimension name in Filters.

● Select a dimension name in Filters and click the right arrow button.

The dimension name is displayed in the Rows frame. If no POV definition is applied in Step
1, the highest aggregate member in this dimension is used. If a POV definition is applied,
its member selections are used.

7 Optional: To specify dimension member selections, double-click the dimension name hyperlink in Rows.

The Dimension Browser dialog box is displayed. The dimension is presented as a node tree in
the Browse frame. You must select dimension members in Browse and move them to Selections:

● To expand or contract the dimension hierarchy:

❍ Double-click dimension member names

❍ Click the plus sign (+) or minus sign (-).

● To select dimension members, click the dimension member name.
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A check mark is displayed in the check box of selected members, and the member name is
displayed in the Selections list.

● To select dimension members dynamically, right-click a dimension member name and select
an advanced member selection method.

● You can set the label mode for each dimension to the default label, an ID label, or the alias
table description set in Database Preferences dialog box, through preferences.

See “Selecting Dimension Members” on page 65.

● Click OK to dismiss the Dimension Browser dialog box and return to the Wizard.

8 After indicating all Rows axis dimensions, and defining their member selections, click Next.

9 Using the same methods used to define Rows, move a dimension name from Filters to Columns.

10 Optional: Using the same Dimension Browser methods, double-click the dimension name hyperlink in
Columns to specify member selections for the Column axis.

11 Click Next.

In Step 4: Select Page Dimensions, you can select dimensions to be used on the Page axis. While
all intersections in the document are relative to all dimension member selections, you can
organize these row and column intersections by page dimension members.

12 Optional: Using the same methods used to define Rows and Columns, move a dimension name from
Filters to Pages.

13 Optional: Using the same Dimension Browser methods, double-click the dimension name hyperlink in
Pages to specify member selections for the Page axis.

14 Click Next.

In Step 5: Customize Filters, you select dimension members to be used on the Filters axis.

All cube dimensions participate in every spreadsheet intersection, regardless of the axis to which
dimensions are assigned. The arrangement of intersections is defined by the Rows, Columns and
Pages axes. The data values displayed at each intersection are determined by the member
selections.

all intersections in the data object are relative to Filter dimension member selections. Filter
dimension member selections focus the intersections, the data values, and consequently the data
object analysis.

Cube dimensions left in the Filter axis are by default represented by the highest aggregate
dimension member defined in the data source outline. If a POV definition is applied, its member
selections are used. If you make Filter member selections, all intersections are relative to these
selections.

15 Optional: To display the Dimension Browser for Filter axis dimensions, perform one:

● Select a Filter dimension and click Customize.

● Double-click a dimension name hyperlink in Filters.

16 Optional: Using the same Dimension Browser methods, make Filter axis dimension member selections and
click OK.

17 Click Next.
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In Step 6: Set Options, you can set a variety of document options

18 Optional: In the Select Layout list, select one:

Chart—displays the result set as a chart data object.

Spreadsheet—Displays the result set as a spreadsheet data object.

Vertical Combination—Displays the result set as a chart data object and a spreadsheet data
object stacked vertically.

Horizontal Combination—Displays the result set as a chart data object and a spreadsheet data
object arranged side-by-side.

Custom—Displays a blank palette

You can change the display type of the Vertical Combination and Horizontal Combination
layouts; for example you can convert the spreadsheet to a chart type. The objects, however, are
linked and maintain a coordinated context.

In case you select a layout, the Cube Navigator dialog box is displayed.

● Select dimensions and members and click OK to generate a Web Analysis document.

19 Optional: You can set the default Label mode to display dimension member IDs, or the alias table description
set in database preferences.

This centrally sets all dimensions using the default Label mode to the same setting.

20 Optional: To suppress the display of one or more type of data, click the corresponding check box.

Missing Columns—Columns of data comprised of missing values.

Missing Rows—Rows of data comprised of missing values.

Shared Members—Dimension members that are used in multiple locations of one hierarchy.

Zero Rows—Rows of data comprised of zero (0) data values.

21 Optional: To suppress the display Linked Reporting Object Indicators, click the corresponding check box.

Linked Reporting Object Indicators are orange triangles indicating Related Content definitions
in Analytic Services. See “LROs” on page 257.

22 Optional: To augment the query with a server-based Retrieve Only Top/Bottom analysis, click the
corresponding button.

See “Retrieve Only Top/Bottom” on page 126.

23 Optional: To augment the query with a server-based Restrict Data analysis, click the corresponding button.

See “Restricting Data” on page 124.

24 Click Finish to submit the query to the data source.

The data source is queried. The result set returned is displayed as a data object on a document.
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Creating Documents from Existing Documents
When you save a document with other names or to other locations, you use the data source,
data object, and query defined by a document. This document creation option leverages existing
documents to save time and effort. Before saving the document under a different name, or to
another location, you can modify document properties and settings as needed.

➤ To create documents from existing documents:

1 Perform one:

● Select File > Open.

● Click .

The Open dialog box is displayed. It features a selection frame that lists the current folder
contents specified by Location.

2 Select Web Analysis Document from Files of Type.

3 Navigate to the document you want to copy.

4 Select the document, and click OK.

If the document uses a Database Connection requiring you to log on, the Database Login dialog
box prompts you.

5 If prompted by Database Login, enter a User ID and password for the Database Connection. Click Save User
ID and Password to store log on credentials for the Database Connection, and click OK.

The selected document is displayed in the content area.

6 Modify the document.

7 Perform one:

● Select File > Save As.

● Click .

● From the Contents Tab bar, right-click the current content tab and select Save As.

The Save As dialog box is displayed. It features a selection frame that lists the current folder
contents specified by Location.

8 Navigate to the folder to save your modified document.

9 Optional: Enter a name for the document in Filename.

10 Click OK.

The modified document is saved to the specified location, using the specified name.

Creating Auto-Populate Dimension Documents
This is the quickest method for creating a document. It specifies the database connection, and
assumes use of the highest aggregate members of the time and measures dimensions to populate
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the rows and columns axes of a spreadsheet. You can modify document properties and settings
as needed before eventually saving the document.

Note:

You can set the Look and Feel preferences to display Cube Navigator, instead of assuming use
of the highest aggregate members of the time and measures dimension.

➤ To create a Auto-Populate Dimension document:

1 Display the View Pane:

● Select View > View Pane.

● Press F6.

2 Click the View Pane Browser tab.

3 In the repository, navigate to a database connection file, and double-click the file name.

If the Database Connection requires you to log on, you are prompted by the Database Login
dialog box.

4 If prompted by the Database Login dialog box, enter a User ID and password for the Database Connection.
Select Save User ID and Password to store log on credentials for the Database Connection, and click OK.

A Auto-Populate Dimension document is displayed in the content area.

Modifying Queries
Cube Navigator is an interface used to edit queries. Cube Navigator displays the dimensions
returned by the database connection, as they are arranged on four axes:

● Rows

● Columns

● Pages

● Filters

Three kinds of dimensions are differentiated by these icons:

Icon Dimension

Dimensions

Attribute Dimensions

Attribute Calculations

Every query must have at least a dimension assigned to the Rows axis and the Columns axis, but
you can also nest multiple dimensions on one axis. You can organize the Row and Column
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dimensions by assigning dimensions to the Page axis. Dimensions not assigned to Rows,
Columns, and Pages, remain in the Filter axis.

All dimensions participate in every intersection displayed by a data object, regardless of the axis
to which they are assigned. You use Cube Navigator to arrange dimensions, to specify their level
of detail, and to specify query options.

Note:

All data objects start as spreadsheets. Charts and Pinboards are still organized by the four axes,
despite using metaphors that differ to display data.

➤ To redefine the current document's query and dimension layout:

● Click the Navigate Data Source toolbar button.

● Select View > Cube Navigator.

➤ To move a dimension between axes, drag the dimension name from its current axis to another
axis.

The cursor displays a box next to it when it is over the axis. When you release the mouse button,
the Dimension Browser dialog box displays. Use Dimension Browser to make member selections
as needed, and click OK.

➤ To make member selections without moving the dimension to another axis, double click the
dimension name.

➤ To clear all dimension member assignments and start over, click Reset All.

Topics that discuss query modification:

● “Modifying Filter Dimensions” on page 62

● “Cube Navigator Options” on page 63

● “Relational Dimension Header Sort” on page 64

● “Label Mode” on page 64

Modifying Filter Dimensions
All data object intersections are relative to filter member selections, which focus intersections
and data values, and consequently, analysis.

Filter-axis dimensions are by default represented by the highest aggregate member defined in
the data source outline. To focus analysis on members other than the highest aggregate, you can
select filter members.

Filter member selections do not rearrange dimensions or reorganize pages, but focus analysis
on intersections.
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Note:

If the WebAnalysis.properties variableFilterRestrictToSingleMember= true is set,
all users can select one member from the filter selections. In the Dim Browser, only one member
can be selected, therefore the right click menu options are limited to “Find in Tree” and "Search".
Users can select one member in the left pane; additional selections overwrite the previous
selection.

Cube Navigator Options
The bottom of the Cube Navigator dialog box enables you to specify server-based options in the
query:

Option Description

Default Label Mode Sets all dimensions using the default label mode to:

● Descriptions—Current alias table specified by database preferences.

● IDs—Unique ID label.

● Both—When using Hyperion® System™ 9 Financial Management™,
you can specify ID and Description simultaneously.

Use Point of View Enables and disables the active POV definition defined on the current
database connection.

Retrieve Only Top/Bottom Displays the Retrieve Only Top/Bottom dialog box, used to limit and rank
the query result set.

Restrict Data Displays the Restrict Data dialog box, used to restrict the query result set
based on criteria.

Show Linked Reporting Object Indicators Shows/Hides the orange triangle symbols that indicate Related Content
definitions in Analytic Services.

Suppress Omits components, as selected, from the query result set:

● Missing Columns—Columns of data comprised of missing values.

● Missing Rows—Rows of data comprised of missing values.

● Shared Members—Dimension members that are used in multiple
locations of one hierarchy.

● Zero Rows—Rows of data comprised of zero data values.

Display Entity Currency When using an Financial Management data source with defined Entity
dimension currency information, you can enable the Display Entity
Currency option, to append the Entity dimension members with their
currency value. This can be set before querying using Cube Navigator
options, after querying using the Data Display shortcut menu, and for all
subsequently created documents using OLAP Server preferences. See
“Financial Management” on page 168.

Use User Point of View Selecting it adds a member selection to the Dim Browser for every
dimension in the ReportDataSrc. The selected members in the User POV
are utilized in the spreadsheet.
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Relational Dimension Header Sort
You can also order the result set returned by the SQL query in a relational database connection.
You can opt for Ascending, Descending, Selection Order and Default. Default is the natural
order in which dimension members are returned, based on the data source outline. Selection
Order is the order in which members were selected in Dimension Browser.

You must be aware that unlike OLAP servers, relational cubes are compiled and defined by Web
Analysis Studio. The current label mode, alias tables, and selection orders from Dimension
Browser are manually coordinated. Sort by alias may perform comparatively slow, as the default
query result set is sorted by ID, and sorting by alias requires a complete client-side re-sort.

In addition, the source of the relational dimension header sort impacts performance. Defining
a relational dimension header sort using Cube Navigator sorts all dimensions as part of the query
result set being displayed.

You alternatively, can sort a relational dimension using the data object shortcut menu: Data
Display > Dimension Header Sort. This method requires you to right-click a dimension header.

Lastly, you can apply dimension header sort definitions to relational generation defined in the
Generation Editor. These definitions only impact the sort ordering displayed by the Dimension
Browser however. Using the Order By Mode list, you can also specify to order members by ID
or Alias.

Label Mode
You can set the default label mode to ID or Description in Cube Navigator. This setting impacts
only those dimensions set to display the Default label mode in Dimension Browser.

The Description label comes from the alias table setting, saved per database connection and per
active user as a database user preference.

You can set the default label mode before querying using Cube Navigator options or the last step
in the wizard, and after querying using the data object shortcut menu. You can specify which
description label to use in dimensions, using Dimension Browser and the data object shortcut
menu.

➤ To set the default label mode for the current database connection:

1 Click Options in the lower left corner of the Cube Navigator dialog box.

2 Select Default Label Mode from the menu.

3 Select the IDs or Descriptions option.

Note:

Financial Management users have the additional label mode option of Both.

See“Setting the Label Mode” on page 96.
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Selecting Dimension Members
Dimension Browser, an interface for selecting members and refining database queries, is used
with the document wizard, Cube Navigator dialog box, Information panel, or on its own.

The Dimension Browser presents dimensions as a node tree in the Browse frame. You must
select dimension members from Browse and move them to Selections.

Members can be selected individually, by familial relationships, by data-source-specific options,
or from predefined selection lists.

➤ To access the Dimension Browser:

● Right-click a dimension member label on a data object, and select Browse.

● In the View Pane Information Panel tab, right-click a dimension label and select Browse.

● Click the Navigate Data Source toolbar button, and double-click a dimension name.

● Click the Navigate Data Source toolbar button, and drag a dimension between axes.
Relocating a dimension, prompts you to select members.

➤ To expand or collapse the dimension hierarchy:

● Double-click dimension member names

● Click the plus sign (+) or minus sign (-) nodes.

➤ To select a dimension member, click the member name in the Browse frame.

A check mark is displayed in the check boxes of selected members, and the member name is
displayed in the Selections list. You cannot select the database connection name at the top of the
node tree.

➤ To select dimension members dynamically, right-click a dimension member name and select
an advanced member selection method from the list.

See “Advanced Member Selection” on page 66.

➤ To remove members from the selection list:

● Select the member name in the Selection list and click Remove.

● Click the dimension member name in the Browse list again.

➤ To remove all members from the selection list, click Remove All.

➤ To set the label mode for the dimension, click a Dimension Labels option:

● Use Default—Preferences default label mode.

● Descriptions—Current alias table specified by database preferences.

● IDs—Unique ID label.
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● Both—When using Financial Management, you can specify ID and Description
simultaneously.

The label displayed by the Description label mode is drawn from the alias table specified by the
active user’s database preferences. You can set the alias table for each Active Preferences user ID
or group ID.

You can specify label mode in dimensions, using Dimension Browser and the data object shortcut
menu.

You can set a default label mode before querying the data source using Cube Navigator options
or after querying using the data object shortcut menu.

See “Alias Tables” on page 267.

Advanced Member Selection
In dimensions with large member sets, you can easily define selections using the Dimension
Browser shortcut menu. Right-clicking dimension member names enables selection by familial
relationship and data source-specific options:

Icon Shortcut Menu Command Selects:

Also Select Children Currently selected member and its children (one level below)

Also Select Descendants Currently selected member and its descendants

Select Parent Direct parent of the selected member

Also Select Ancestors Currently selected member and its ancestors

Also Select Siblings Currently selected member and members on one level with identical parent
ancestor

Select Dim Bottom All dimension members on the lowest level of the hierarchy

Select Dim Top Highest ancestor

Also Select Level Currently selected dimension member and all dimension members on one level

Also Select Generation Currently selected dimension member and all dimension members in one
generation

Also Select Previous A number of previous members at one dimension level

Also Select Subset An Analytic Services member subset

 Substitution Variables Sets a substitution variable as the dimension selection

Select Attribute A selection from a list of attribute dimensions
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Icon Shortcut Menu Command Selects:

 User Defined Fields Financial Management—One of three pre-defined attribute values

. Select members featuring these attribute values and compose compound
selection statements with AND and OR operators

 Dynamic Time Series Analytic Services Dynamic Time Series selection (for example: History To Date,
Quarter To Date)

 Search Locates dimension members in large dimensions with search criteria, and adds
found members to the Selection list

 Find In Tree Locates dimension members in large dimensions

Expands the dimension hierarchy, but does not add found members to the
Selection list

Advanced Member Selection by Data Source

Data Source Advanced Member Selection Method

Analytic Services ● Also Select Children

● Also Select Descendants

● Select Parent

● Also Select Ancestors

● Also Select Siblings

● Select Dim Bottom

● Select Dim Top

● Also Select Level

● Also Select Generation

● Also Select Previous

● Select Subset

● Substitution Variables

● Select Attribute

● Dynamic Time Series

● Search

● Find in Tree

SAP BW ● All Members

● Select Dim Top

● Select Dim Bottom

● Also Select Descendants

● Select Parent

● Also Select Ancestors

● Also Select Children

● Also Select Siblings
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Data Source Advanced Member Selection Method

● Also Select Level

● Select At Level

● Also Select Previous

● Also Select Next

● Dynamic Time Series

● Select Top/Bottom

● Filter on Member Properties

● Find in Tree

See “SAP BW” on page 171.

Financial Management ● All Members

● Select Dim Top

● Select Dim Bottom

● Also Select Descendants

● Member List

● Also Select Children

● User Defined Field

● Search

● Find in Tree

See “Financial Management” on page 168.

JDBC Relational Data Sources ● Also Select Children

● Also Select Descendants

● Select Parent

● Also Select Ancestors

● Also Select Siblings

● Select Dim Bottom

● Select Dim Top

● Also Select Generation

● Find in Tree

Consider the implications of the relational hierarchy in advanced member selections on
relational data sources. When the highest ancestor is selected, a default dimension member may
be used instead of the aggregation. The relational hierarchy may also equate Also Select Children
and Also Select Descendants for example.

Advanced member selection methods depend on your data source implementation.

Searching for Members
Analytic Services users can locate members in large dimensions using search criteria. These
searches can be conducted inside the Dimension Browser dialog box when composing a query,
or from the data object shortcut menu when analyzing a document.
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➤ To search for Analytic Services dimension members in Dimension Browser:

1 Right-click a dimension member in the Dimension Browser, and select Search.

2 Enter search criteria in the corresponding text boxes, and click OK.

Search Criteria Control Description

Member  The text string for the search function.

Mode ID Searches by member name.

 Description Searches by member alias (description).

 Both Financial Management data source enables you to search by ID and Description,
using this option.

 Expand Tree When the Expand Tree option is selected, not only is the found member added to
the Selections list, but the Browse node tree is expanded to display the found
member in the dimension hierarchy. Only the first instance of the search criteria is
selected.

When the Expand Tree option is not selected, found members are added to the
Selections list, without changing the Browse node tree.

Range  Specifies the search of the dimension (All Top Members), or down the hierarchy
from the selected member.

Option Whole Searches for the whole member name or alias.

 Substring Searches for the first, last, or middle part of the member, in the order entered in
the member text box.

 Beginning Searches for the start of the member string.

 Ending Searches for the end of the member string.

➤ To search for Analytic Services dimension members in a document data object:

1 Right-click a dimension member header and select Search.

2 Enter search criteria in the corresponding text boxes, and click OK.

Note:

Search performance is directly related to the size and complexity of the dimension hierarchy.

Searching For SAP BW Characteristic Values
SAP BW users can locate characteristic values in large dimension hierarchies using search criteria.
These searches can be conducted only inside the Dimension Browser dialog box when composing
a query.

Searching For SAP BW Characteristic Values 69



➤ To locate SAP BW dimension members in Dimension Browser:

1 Right-click a dimension member, and select Search.

2 Enter search criteria in the corresponding text boxes.

Search Criteria Control Description

Mode ID Searches by member technical name.

 Description Searches by member alias (description).

Search Criteria  A list enables selection from these operands:

● Equal To

● >=

● <=

● >

● <

● Between

● Contains Pattern

  Enter the text string for the search function in the text area.

Supports the wildcard characters * and +.

Execute  Runs the search function.

Filtered Members  Displays the search result set.

 Add Adds the currently selected member from the Filtered Members list to the Selected
Members list.

 Remove Removed the currently selected member from the Selected Members list back to
the Filtered Members list.

Selected Members  Displays potential member selections made from the search result set.

 Add All Adds all Filtered Members to the Selected Members list.

 Remove All Removes all Selected Members back to the Filtered Members list.

OK  Adds the Search Selected Members list to the Dimension Browser Selections list.

3 Click Execute to run the search function using the criterion specified in the Mode and Search Criteria groups.

The search result set is displayed in the Filtered Members group.

4 Select members from Filtered Members, and click Add to add them to Selected Members.

Only the members added to the Selected Members list are added to the Dimension Browser
Selections list when you click OK.

5 Click OK.
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Locating Dimension Members
In large or complex dimension hierarchies, you can locate known dimension members to select
neighboring members. This is a useful alternative to composing a search string for unknown
members.

➤ To find a known dimension member, right-click a dimension member in the Dimension Browser
Selections list, and select Find In Tree.

In the Browse frame, the dimension hierarchy expands and the first instance of the selected
member is highlighted. You can now select other members based on their relationship to the
selected member.

Selecting Intervals

➤ To select an interval:

1 In Analyze, open Dimension Browser.

2 In Dimension Browser, right-click a characteristic and highlight Select Interval Between.

3 In the dialog box that is displayed, enter the interval To and From values.

For example, for a calendar year characteristic, you could enter 1990 to 1993 as the interval to
analyze.

Previewing Member Selections
You can preview the dimension members returned by advanced member selections, before you
quit the Dimension Browser dialog box.

➤ To preview advanced member selections for the current dimension:

1 In Analyze, open Dimension Browser.

2 In Dimension Browser, click Preview Selections.

The data source is queried using the current Selections list. The result set is displayed in the
Preview Selections dialog box.

3 Click Close to return to the Dimension Browser.

Selecting Members Using Analytic Services Subsets
Analytic Services users can define rules that select dimension member subsets by rules composed
of data source constructs:

● UDAs—Members with a specified user-defined attribute (UDA)

● Generation—Members belonging to a specified generation of the dimension hierarchy
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● Level—Members belonging to a specified level of the dimensional hierarchy

● Expression—Members matching a pattern of wildcard characters

● Attribute dimensions—Members with a specified database-defined attribute

● Conditional logic—Members satisfying advanced subset member selection criteria

You can search all selected member descendants using a maximum of 50 subset conditions.
Subset criteria are saved by individual document. Because the filter panel cannot accommodate
lengthy selection lists, subset member selections made in Filters are summarized with a
description.

Topics that discuss Analytic Services subset selections:

● “Defining Member Subset Selections” on page 72

● “Wildcard Characters” on page 73

● “Expressions” on page 73

● “UDAs” on page 73

Defining Member Subset Selections

➤ To define a member subset selection:

1 Right-click a dimension member in the Dimension Browser, and select Select Subset.

The Subset dialog box is displayed. At the top, it indicates dimension members against which
the rule is applied. Use the Individual Selection Rule control to compose a rule by selecting
components from drop-down lists.

2 Select a subset type: UDA, Generation, Level, Expression, or Attribute.

3 Select an operand for the subset rule: is (=) or is not (not equal).

4 Select a value for the subset rule from the last drop-down list.

5 Click Add to augment the Total Subset Definition.

You must add the individual rule to the Total Subset Definition for it to be used. You can define
compound and conditional rules by adding multiple rules to the definition, and using Advanced
options to connect them:

Advanced Subset Option Sub menu Description

Add  Add the current rule to the Total Subset Definition.

Update  Replace the selected rule with the current rule.

Validate  Verifies the parenthetical syntax of the Total Subset Definition.

Remove  Remove the current rule from the Total Subset Definition.

Remove All  Remove all rules from the Total Subset Definition.
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Advanced Subset Option Sub menu Description

Connect And Inserts the AND operand at the end of the currently selected rule. The
AND operand is used by default when multiple rules are added to the
Definition.

 Or Inserts the OR operand at the end of the currently selected rule.

Move Move Up Moves up the currently selected rule in the Total Subset Definition.

 Move Down Move the currently selected rule down in the Total Subset Definition.

Parenthesis Add ( Inserts an open parenthesis at the beginning of the currently selected
rule.

 Add ) Inserts a close parenthesis at the end of the currently selected rule, but
before an operand.

 Remove ( Deletes the open parenthesis from the beginning of the currently
selected rule.

 Remove ) Deletes the close parenthesis from the end of the currently selected rule.

 Remove All () Removes all parentheses from the Total Subset Definition.

Substitution Variable  Presents the Substitution Variable dialog box, enabling you to select a
pre-defined substitution variable for the subset rule value.

6 Optional: To compose a compound subset definition, repeat steps 3 through 6, and click Add to augment
the Total Subset Definition.

7 Click OK to finish your subset selection and return to Dimension Browser.

Wildcard Characters
Supported expression wildcard characters include the question mark (?) and the asterisk (*).
The asterisk can be used only once in an expression and only at the end of a text string.

Expressions
Subset queries defined by expressions are not dependent upon label mode, and return all strings
satisfying the expressions regardless of the alias table. The onus is on the user to distinguish
whether the source of the value is the ID, the Description, or from an alias table, and to refine
the query if needed.

UDAs
Analytic Services users can create user-defined attributes (UDAs) for dimension member
subsets. A UDA is a word or phrase about the dimension member that is associated with it as a
characteristic.
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Selecting Financial Management User Defined Fields
Financial Management users can select members with specified attribute criterion. A user
defined field is used to define compound selection rules for attributes of a specified value.

➤ To define a user defined field selection:

1 Right-click a dimension member in the Dimension Browser, and select User Defined Field.

The User Defined Field Selection dialog box is displayed. The controls at the top prompt the
user to compose a rule by selecting a user defined field and setting it to a value.

2 Select a field: UserDefined1, UserDefined2, or UserDefined3.

The equal sign is the sole operand for the rule.

3 Enter a value for the user defined field.

4 Click Add to augment the Selection Criteria.

To be used, the individual rule must be added to the Selection Criteria. Define compound and
conditional rules by adding multiple rules to the frame, and use Advanced options to connect
them.

Advanced Option Sub menu Description

Add  Add the current rule to the Total Subset Definition.

Update  Replace the selected rule with the current rule.

Remove  Remove the current rule from the Total Subset Definition.

Remove All  Remove all rules from the Total Subset Definition.

Connect And Inserts the AND operand at the end of the currently selected rule. The AND operand
is used by default when multiple rules are added to the Definition.

 Or Inserts the OR operand at the end of the currently selected rule.

Move Move Up Moves the currently selected rule up in the Total Subset Definition.

 Move Down Move the currently selected rule down in the Total Subset Definition.

Parenthesis Add ( Inserts an open parenthesis at the beginning of the currently selected rule.

 Add ) Inserts a close parenthesis at the end of the currently selected rule, but before an
operand.

 Remove ( Deletes the open parenthesis from the beginning of the currently selected rule.

 Remove ) Deletes the close parenthesis from the end of the currently selected rule.

5 Optional: To compose compound subset definitions, repeat steps 3 through 5, and click Add to augment
the Selection Criteria.

6 Click OK to finish your user defined field selection and return to Dimension Browser.
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Filtering by SAP BW Member Properties
SAP uses the term member properties to indicate member attributes. You can select SAP BW
members and filter them by their member properties. This requires you to first make a
conventional member selection, or advanced member selection, and further define a filtering
definition on the selection.

➤ To select SAP BW members by their member properties:

1 In Dimension Browser, make a member selection or advanced member selection.

Your member selection is displayed in the Selection frame.

2 Right-click a member selection in the Selection frame and select Filter on Member Properties.

The Member Properties dialog box is displayed. The controls at the top prompt the user to
compose a rule by selecting a member property, operand and value.

3 From the list, select a member property for the selection dimension.

4 Select an operand from the operand list.

5 Enter a value for the member property.

6 Click Add, to add the rule to the filter statement.

You must add the individual rule to the filter definition for it to be used. You can define
compound and conditional rules by adding multiple rules to the frame, and use Advanced
options to connect them:

Advanced Option Sub menu Description

Add  Add the current rule to the filtering definition.

Update  Replace the selected rule with the current rule.

Remove  Remove the current rule from the Total Subset Definition.

Remove All  Remove all rules from the Total Subset Definition.

Parenthesis Add ( Inserts an open parenthesis at the beginning of the currently selected rule.

 Add ) Inserts a close parenthesis at the end of the currently selected rule, but before an
operand.

 Remove ( Deletes the open parenthesis from the beginning of the currently selected rule.

 Remove ) Deletes the close parenthesis from the end of the currently selected rule.

Connect And Inserts the AND operand at the end of the currently selected rule. The AND operand
is used by default when multiple rules are added to the Definition.

 Or Inserts the OR operand at the end of the currently selected rule.

Move Move Up Moves up the currently selected rule in the Total Subset Definition.

 Move Down Move the currently selected rule down in the Total Subset Definition.
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7 Optional: To compose compound definition, repeat steps 3 through 6, and click Add to augment the
definition.

8 Click OK to finish your filter definition and return to Dimension Browser.

SAP BW Select Top/Bottom
SAP BW enables you to limit the size and rank the query result set on the data source server.

➤ To limit and rank SAP BW members as part of the query:

1 In Dimension Browser, make a member selection or advanced member selection.

Your member selection is displayed in the Selection frame.

2 Right-click a member selection in the Selection frame and select Select Top/Bottom.

The Top/Bottom dialog box is displayed. The controls prompt you to indicate top or bottom,
define criteria, and select a dimension member for ranking.

3 Select Top or Bottom.

You cannot select both, as when using Analytic Services.

4 From the Using Function group, select Percent, Sum, or Count.

You can select only one method for determining rank.

5 Enter a value for the method.

The Percent text area should be a value between one and a hundred. The Sum text area requires
you to enter a threshold. All member values summed to and including the threshold are returned.
The Count text area requires only an integer indicating how m top or bottom members to return.

6 In Order By, select another cube dimension.

Because all dimensions participate in every intersection, you are required to identify the
intersection by which the selected dimension is ranked.

7 Optional: Click Selection to display the dimension browser for the Order By dimension.

The Dimension Browser dialog box is displayed. You can select a dimension member from the
dimension by which to rank the selected dimension, and click OK.

8 Click OK to finish your Top/Bottom definition and return to Dimension Browser.

9 Click OK.

Selecting SAP BW Period to Date
When Period to Date data is configured on the SAP BW server, you can access data as
consolidated by a specified date.
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➤ To select dimension members using SAP BW Period to Date:

1 In Dimension Browser, make a member selection or advanced member selection.

Your member selection is displayed in the Selection frame.

2 Right-click a member selection in the Selection frame and select SAP BW Period to Date.

The SAP BW Period to Date dialog box is displayed. The control prompts you to select a period
definition from the list.

3 Select a period definition and click OK.

Providing SAP BW Variables
When SAP BW Variables are configured on BEx Query Cube InfoProviders, you are prompted
to provide the replacement value for the SAP BW Variable before submitting the query.

Prompting occurs when you click Finish when completing the Document Creation wizard, or
when you click OK after modifying a query using the Data Layout interface.

➤ To provide SAP BW Variable values when prompted:

1 In Database Variables ServerName, read the record for each variable.

It is important to know the variable type, a characteristic value or a hierarchy node.

2 Click the Edit cell for a variable record.

The Dimension Browser dialog box is displayed. If the record is a characteristic value, you must
select one explicit value at the lowest level of the dimension hierarchy. If the variable is a hierarchy
node, you can select a value in the dimensional hierarchy.

3 Select a characteristic value for the variable type, and click OK.

4 Repeat steps 2 and 3 until all variables are assigned values for the query.

5 Click OK.

The query is submitted using the specified variable values.

Selecting Financial Management Member Lists
Member Lists are predefined Financial Management variables for frequently changing
information.

➤ To use a Financial Management Member List in a Dimension Browser member selection:

1 Right-click a dimension member in the Dimension Browser, and select Member List.

The Choose Member List dialog box is displayed.

2 Select a predefined member list from Choose Member List.

3 Click OK.
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Selecting Substitution Variables
Substitution variables are predefined Analytic Services variables for frequently changing
information.

Substitution variables simplify document maintenance by enabling fluctuating values to be
adjusted centrally (in Analytic Services), and enabling documents to reference the changing value
dynamically.

➤ To use a substitution variable in Dimension Browser member selection:

1 Right-click a dimension member in the Dimension Browser, and select Substitution Variable.

The Substitution Variable dialog box is displayed.

2 Select a substitution variable from the list of Analytic Services substitution variables.

3 Click OK.

Multiple Substitution Variables
Multiple substitution variables can be used using Subset Member Selections.

Tips on Syntax
Substitution variables have their own rules and syntax requirements:

● The substituted value should be a dimension or a member name, and member values should
come from the corresponding dimension.

● Do not use the ampersand (&) as the first character of a member name.

Analysis Tools and Substitution Variables
When member selections defined by substitution variables are used in analysis tool definitions,
the system resolves the substitution variable to its current value. This ensures accurate
aggregations, comparisons, and calculations regardless of the substitution variable definition.

Creating and Selecting Personal Variables
Personal variables simplify complex member selections. After being defined, you can leverage
personal variables when you are presented with the corresponding dimension and database
connection. Personal variables are containers for an ad hoc collections of otherwise unrelated
dimension members.

Defining a personal variable does not include the personal variable in a query. You must select
the personal variable from the Dimension Browser when defining the query.

78 Creating Documents



➤ To create a personal variable:

1 Select File > Preferences.

The User Preferences dialog box is displayed, with the active user or group displayed in the Active
Preferences list.

2 Click the Databases tab to make it current.

3 Select a database connection name, and click Edit.

The Database Preferences dialog box is displayed.

4 Click Connect.

The Personal Variable and Point of View tabs are enabled.

5 Click Personal Variable.

The Personal Variable tab lists all currently defined personal variables for the database
connection.

6 Click Add.

The Personal Variable dialog box is displayed.

7 Enter a name for the personal variable in Name.

8 Select a dimension from the data source from the Dimension list.

The Dimension Browser for the selected dimension is displayed.

9 Select the dimension members to be included in the personal variable.

All conventional Dimension Browser methods and options are supported.

10 Click OK.

The Personal Variable tab is displayed and the personal variable definition is listed. Whenever
the database connection and dimension is used, the personal variable definition is displayed as
a selection option in the Dimension Browser Browse panel.

➤ To use a personal variable in a query, select the personal variable definition from the Dimension
Browser Browse panel.

Creating and Applying Points of View
POV database preferences enable you to insert dimensions and members that are of interest to
you into the documents of others. POV definitions must be defined and activated by database
connection.

When a POV is activated, the Use Point of View option in Cube Navigator and the wizard are
enabled. All subsequently created and loaded documents use the specified POV until it is
deactivated. You can also deactivate use of POV by deselecting the Cube Navigator Use Point
of View option as needed.

POV definitions consist of axes and dimension member selections. The definition is used when
documents are created with the activated POV.
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When you apply a POV definition to a document, only the dimension member selections are
applied. This prevents points of view from automatically arranging non-functioning layouts
(such as moving all dimensions to one axis).

If all POV member selections are custom filters, you may not see obvious changes to your
document. You can check to see which POV is applied on the View Pane Information Panel tab,
Point of View segment.

Using a POV definition is a three part process. First, you must create a POV definition. Next,
you must activate the POV definition. Lastly, you must set a document to use the activated POV
definition, or create a document that uses it.

➤ To create a POV and activate it:

1 Select File > Preferences.

The User Preferences dialog box is displayed, with the active user or group displayed in the Active
Preferences list.

2 Click Databases.

3 Select a database connection name, and click Edit.

The Database Preferences dialog box is displayed.

4 Click Connect.

The Personal Variable and Point of View tabs are enabled.

5 Click Point of View.

The Point of View tab lists all currently defined POV definitions for the database connection.

6 Click Add.

The Point of View dialog box is displayed.

7 Enter a name for the POV in Name.

Use the Cube Navigator interface to locate dimensions from this data source on axes and make
member selections.

8 Define the POV layout, selections, and analysis tools as you would for a query.

9 Click OK.

The Point of View tab is displayed and the definition is listed.

10 To activate this POV definition, select the POV name and click Activate.

11 Click OK.

Whenever the database connection is used, you can apply the activated POV definition in lieu
of defining its member selections.

➤ To apply an activated POV definition to an open document:

1 Display Cube Navigator:

● Click the Navigate toolbar button.
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● Select View > Cube Navigator.

Cube Navigator is displayed for the current document.

2 From the Option button list, select Use Point of View.

3 Click OK.

The activated point of definition is applied to the current document. You must refresh the
content area to display POV selections.

4 To refresh the document, perform one:

● Right-click the content tab for the current document and select Refresh.

● Select View > Refresh.

● Press F5.

● Right-click the data object and select Refresh Data.

Activated POV selections are applied to the current document.

User POV
User POV enables users to select members in Filters, Pages, Rows, and Columns (Data layout
and/or member selection controls) and apply them to multiple Web Analysis documents.

This is exposed through the current POV functionality, where User POV is the name of another
POV that is created and utilized in Web Analysis documents. The User POV exist for all database
connections and can be set at user level only.

➤ To set a User POV:

1 Right click a spreadsheet and select Save Selection to save the dimension member selections to the User
POV.

This feature is available in Web Analysis Studio and Workspace.

2 In Web Analysis User Preferences > OLAP Server, select Save Filters only for User POV.

All Subscription controls have the “Save Selection as a User POV” option. A selection is saved
as a filter to the User POV.

If a Subscription control points to multiple ReportDataSrcs, all database connections have
their User points of view set for the dimensions of the active control.

➤ To enable a User POV, in Data Layout, select Use User POV

Enabling this item adds a member selection option to the Dim Browser for every dimension in
the ReportDataSrc. Selected member(s) in the User POV are utilized in the spreadsheet query.

Defining Dynamic Time Series Selections
You can select Dynamic Time Series (DTS) definitions for query selection statements.
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DTS definitions must be created in Analytic Services before you can make DTS selections. You
select the DTS definition and a corresponding Time dimension member that defines a time
period.

You can select DTS substitution variables.

Substitution variables are predefined placeholders for information that changes frequently. Each
substitution variable is identified by a variable name and has a temporary value defining its data
type. When the substitution variable is used, the temporary value is replaced by a current value.
For substitution variables to be used, they must be stored at the database level in Analytic Services.

➤ To define a DTS selection:

1 Right-click a Time dimension member in the Dimension Browser, and select Dynamic Time Series.

Available DTS definitions are displayed in a drop-down list.

2 Select a DTS definition.

The Dynamic Time Series dialog box is displayed.

3 Perform one:

● Select the Substitution Variable tab and select a substitution variable from the list.

● Select the Member tab and select a dimension member representing the specified date in the
"X-to-date" definition.

4 Click OK.

Defining Previous Member Selections
Selecting Also Select Previous selects a specified number of previous members at one dimension
level.

➤ To define a previous member selection:

1 In the Dimension Browser, right-click a dimension member, and select Also Select Previous.

The Also Select Previous dialog box is displayed.

2 Specify the number of previous members to retrieve, using the list.

3 Click OK.

The Dimension Browser is redisplayed. The member that you right-clicked is displayed in the
Selections list with the Also Select Previous icon.

Selecting Attributes
Analytic Services can store dimension member names, locations, relationships, and
characteristics of members.
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Example: The product dimension may indicate that in Women's Apparel, Shirts and Blouses,
there is a cotton T-shirt product. An attribute indicates whether each cotton T-shirt is red, cyan,
lime, or pink.

Example: The Market dimension may indicate that there is a franchise store in Biloxi, Mississippi.
An attribute indicates that the store is 2,500 square feet.

Attributes are stored in the same manner as dimension members. Attribute dimensions are
displayed beside the conventional dimensions that they modify in Cube Navigator. It is
important to note that attribute dimensions are labeled and function differently though.

To include attribute dimensions in the query, you must select the attribute dimension itself.

To select conventional dimension members using attributes, you must select the conventional
dimension, and use the Select Attribute advanced member selection method.

➤ To select dimension members by their attributes:

1 Right-click a dimension member in the Dimension Browser, and select Select Attribute.

2 Select an attribute dimension from the Select Attribute sub menu.

The Select Attribute dialog box is displayed for the selected attribute dimension.

3 Select a dimension member attribute from the Select Attribute frame.

4 Click OK.

Turning Off Key Figure Attributes

➤ To turn off a key figure attribute:

1 Right-click the attribute on the Analyze interface.

2 Select Data Display > Suppress Currency and Units

Note:

This feature can be applied for all other characteristics too.

Creating Calculated and Restricted Key Figures

➤ To create or edit key figures:

1 Select Analysis Tools > Calculated Key Figures

2 In Calculated Key Figures, select New or a key figure.

3 If creating a key figure, replace Untitled with a unique name.

4 Select a Function and related information.
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Note:

Information requested differs depending on the function selected.

Function Measure Cube Hierarchy

Avg x x

Var x x

Max x x

Median x x

Min x x

Sum x x

Count  x

Note:

In the Selections box, you can only add members from the same hierarchy of a dimension

5 In Cube Hierarchy, double-click an entry to move it to Selections.

Caution!

Only one hierarchy can be used. If you attempt to select another hierarchy, Hyperion® System™
9 BI+™ Web Analysis™ asks if you want to remove all selections made on the other hierarchy.

6 Click OK to close Calculated Key Figures

7 In Key Figures Browser, select a key figure to move it to Selections and click OK.
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7
Navigating Documents

In This Chapter
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Navigating Data Objects and Data Sources
Web Analysis documents contain a variety of non-static data objects:

● Spreadsheets

● Charts

● Pinboards

● SQL Spreadsheets

● Freeform Grids

You can rearrange, expand, change and concentrate dimension intersections; these are called
navigation methods because they enable travel through dimensional hierarchies.

Navigation methods vary for data objects and data sources:

Table 1 Web Analysis Studio Supported Data Sources

Type Data Source

OLAP Analytic Services

IBM DB2 OLAP Server

SAP BW

Hyperion Financial Management

Hyperion® System™ 9 Planning™

Relational IBM DB2 Enterprise Server Edition

Microsoft SQL Server

Oracle

Teradata

Other JDBC RDBMS
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OLAP data sources support all navigation methods described in this chapter. Other Hyperion
data sources and relational data sources support fewer navigation methods.

Navigation Methods
Web Analysis Studio navigation methods include:

Navigation Description Method

Swapping and Moving Dimensions Swap—Switches the placement of two
dimensions.

Move—Relocates a dimension on
document axes.

Swap—Drag a dimension onto another
dimension.

Move—Drag a dimension from one
position to another position.

Paging Maintains the dimensions on the row
and column axes, while changing their
intersection with dimensions that
differ on the Page axis.

Click or scroll the Page Control panel.

Keep Only Deselects all other dimension member
selections for the selected Dimension,
leaving only the selected member.

Right-click a dimension member
header, and select Keep Only from the
shortcut menu.

Remove Only Deselects the selected member,
removing it from the query result set.

Right-click a dimension member
header, and select Remove Only from
the shortcut menu.

Drilling Increases or decreases the level of
dimension detail by including or
excluding members of the
dimensional hierarchy in the display.

Double-click dimension member
headers. You can customize the
drilling behavior.

Drill Linking Navigates to other documents or
executables.

Clicking linked cells and passing the
selected cell and the dimension
context to another document or data
object.

Dragging Uses the Information panel to
rearrange the data object in the
content area.

Drag objects on the Information panel.

Undo and Redo Undo reverses the last executed
command, and returns the display to
its previous state.

Redo reverses the negation of the last
command.

Select Edit > Undo. You can select to
undo the last ten executed
commands.

Select Edit > Redo. You can select to
redo the last ten executed commands.

Custom Controls You can define document navigation
using controls in custom documents.

Drag a component onto a custom
document, and associate a data
source or behavior with it. See
“Creating Subscription Controls” on
page 226.

It is important to differentiate these navigation methods:
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● Drilling—Conventional drilling navigates to related dimension members.

● Linking (also called drill-linking)—Drill linking passes the selected member to other
documents.

● Linked Reporting Objects (LROs)—LROs open executables to display cell-notes, Windows
executables, or Web page URLs.

Swapping and Moving Dimensions
You can rearrange intersections by swapping and moving dimensions:

● Swapping switches two dimensions, replacing one with the other.

● Moving relocates a dimension.

Swapping and moving are nearly identical in their use of interface drag methods. They differ in
where the dimension is dropped. To swap, drop the dimension on another dimension label. To
move, drop the dimension between dimension labels.

➤ To swap dimensions:

1 Click and hold a dimension member.

2 Drag the dimension member on to another dimension member.

The two dimensions exchange places.

➤ To move a dimension:

1 Click and hold a dimension member.

2 Drag the dimension member to a point between other dimension members and release the mouse button
when a bold rule is displayed.

The dimension is relocated to where the rule displayed.

Document creators can lock the ability to swap and move dimensions using Properties.

Paging
Paging maintains the dimensions on the row and column axes, while changing their intersection
with dimensions that differ on the Page axis.

You can jump or scroll through pages of intersections using the Page Control panel.

The Page Control panel organizes Page axis intersections so that each page is relevant to a Page
dimension member.
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➤ To navigate the Page dimension, perform one action:

● Click the Page Control scroll buttons to move in the page series.

● Enter a page number for the page series and press Enter.

● From the list, select a page dimension member.

Pages
The Page axis is another axis for organizing dimensions. It is sometimes helpful to think of it as
the Z axis of a three-dimensional graph.

Visualize a stack of spreadsheets. Traveling back and forth in the stack enables comparison of
values on different pages.

If spreadsheets in the stack must be relevant to Page axis dimensions, each page must represent
a Page axis dimension member or dimension member combination.

Multiple and Single Drop-Down Lists
The Page Control panel can display multiple page drop-down lists when you work with page
dimension combinations. Multiple-page drop-down lists display all possible page combinations,
whether data exists. Single-page drop-down lists omit page combinations that do not contain
data. Hyperion recommends using one page drop-down list when working with sparsely
populated dimensions.

➤ To separate Page dimensions into multiple drop-down lists, click the Page Control panel Page
icon.

➤ To combine multiple page dimensions into one drop-down list, click the Page icon.

Keep Only
Keep Only deselects all other dimension member selections for the selected Dimension, leaving
only the selected member.

➤ To deselect all but one dimension member, right-click the dimension member header, and select
Keep Only from the shortcut menu.

Remove Only
Remove Only deselects a dimension member, removing it from the query result set.
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➤ To remove one dimension member from the query result set, right-click a dimension member
header, and select Remove Only from the shortcut menu.

Drilling
Drilling increases or decreases the level of document detail by changing the display of dimension
members. Because drilling is customizable, the term drilling can mean almost hierarchical
navigation prompted by double-clicking a dimension label.

You can customize drilling using three options:

● Drilling options specify the drilling result set.

● Expand on Drill specifies whether the drilling result set replaces or augments the currently
displayed dimension members.

● The Selected Member data display option specifies whether the drilled member is included
in the drilling result set.

Drilling Options
Web Analysis Studio features these default drilling behaviors:

● Drill Down–Iincludes member's children .

● Drill Up—Includes member's parents.

● Drill to Top–Includes highest ancestor

You can customize drilling by setting drilling options. Drilling options are set for the current
document through the data object shortcut menu (Drill > Drill Options). Drilling options can
also be set for all subsequently created documents through Drilling preferences.

Drilling Option Description

Drill to Next Level Includes children of drilled member.

Drill to Descendants Includes all descendants of drilled member.

Drill to Dim Bottom Includes lowest level descendants of drilled member.

Drill to Siblings Includes members at one level who share a parent with the drilled member

Drill to Same Level Includes all members on drilled member's level.

Note: Hyperion defines levels as hierarchical layers counted from the lowest descendant
(Level 0); other data sources define levels differently. Asymmetric hierarchies may also
yield unexpected results

Drill to Same Generation Includes all members on drilled member's generation

Note: Hyperion defines generations as hierarchical layers counted down from the highest
ancestor (Generation 0); other data sources define generations differently

Drilling options are data-source specific. Drilling options that are not supported by the data
source default to Drill to Next Level.
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Expand on Drill
The Expand on Drill drilling option sets the drilling return set to augment or replace currently
displayed dimension members. You can set Expand on Drill for the current document through
the data object shortcut menu (Drill > Drill Options). Expand on Drill can also be set for all
subsequently created documents through Drilling preferences.

When Expand on Drill is selected the drilling return set is added to currently displayed dimension
members. When Expand on drill is disabled the drilling return set replaces currently displayed
dimension members.

Selected Member Data Display Option
The Selected Member data display option specifies that the query result set should include the
member from which advanced member selections are defined.

For example: If you specify Also Select Children on the Year dimension member and Selected
Member is enabled, Year and all of its children are returned by the query. When Selected Member
is disabled, only the children of year are returned.

This Selected Member functionality also impacts the drilling result set, by including or excluding
the drilled member in the drilling result set.

Additionally, you can enable the Selected Member First data display option, to ensure that the
drilled member is listed above the drilling result set.

Drilling Variations
These data display and drilling option combinations result in drilling return sets that differ. If
you are aware of this dynamic you are better prepared to receive the intended drilling return set.

Drilling Variation Description

Drilling down with Expand Drilling enabled and Data
Display > Selected Members disabled

Augments current member selections with the drilled return
set and removes the drilled member.

Drilling down with Expand Drilling enabled and Data
Display > Selected Members enabled

Augments current member selections with the drilled return
set and includes the drilled member.

Drilling down with Expand Drilling disabled and Data
Display > Selected Members disabled

Replaces the current member selections with the drilled
return set and removes the drilled member.

Drilling down with Expand Drilling disabled and Data
Display > Selected Members enabled

Replaces the current member selections with the drilled
return set and includes the drilled member.

Drill Linking
Drill linking enables you to navigate to other documents by double-clicking cells with replaced
links.
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It is important to distinguish drilling from drill linking. Drilling navigates along the lines of the
dimensional hierarchy. Linking passes the current member selection to other documents and
executables.

Linking differs from LROs in that linking passes the current member selection. LROs are linked
to cell notes, file attachments, and URLs.

➤ To access the Drill Link Options dialog box, right-click and select Drill > Drill Link Options.

Drill Linking Option Description

Link From Indicates the dimensions, attributes, and data on which links can be set.

Link To Indicates the destination document of the link.

Add Displays the Open dialog box to select the link destination.

Remove Removes the link and restores conventional drill navigation.

Bottom Executes linking only at the lowest dimension level.

Pass Pages Passes the Page context to the link destination.

Pass Filters Passes the Filter context to the link destination.

Defining Drill Links

➤ To define a drill link:

1 Right-click the data object and select Drill > Drill Link Options.

The Drill Link Options dialog box is displayed.

2 Click the ellipses (...) Set Link (in the Add column) for the dimension on which to place the drill link.

The Select a Document dialog box is displayed. This dialog box works like the Open dialog box.

3 Click the document to be displayed.

4 Click OK.

The Drill Link Options dialog box becomes the current dialog box again.

5 Select options in the Bottom, Pages, and Filters columns as needed.

The Bottom option indicates that the drill link is executed only at the lowest level of the specified
dimension. The Pages option passes the Page axis context to the document. The Filter option
passes the Filter axis context to the document.

6 Click OK.

Dragging
You can drag or move dimension member labels between Information panel axis segments:
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Icon Axis Segment

Columns

Rows

Pages

Filters

➤ To move a dimension using the Information panel:

1 Select the View Panel Information Panel tab.

2 Click an axis segment icon to expand the segment.

3 Click and hold dimension member.

4 Drag the dimension member between axes or other dimension members and release the mouse button.

The dimension is relocated.

Note:

The requirement to have at least one row dimension and one column dimension, may prevent
you from dragging dimensions that leave an axis empty. In this case, use Cube Navigator to
rearrange the dimension layout.

Undo and Redo
An index containing the last 10 executed commands is cached on each client. The Undo
command reverses the most recent command. The Redo command repeats the last command.

➤ To undo the last command, perform one action:

● Select Edit > Undo.

●

Click .

➤ To reinstate the last command,

● Select Edit > Redo.

●

Click .

➤ To undo or redo one of the previous 10 commands, perform these actions:

1 Select the undo or redo list from the corresponding toolbar button.

2 Select a command from the index.

All commands through that point in the index are undone or redone, as selected.
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Formatting Documents

In This Chapter

Formatting Options... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .93

Other Kinds of Formatting ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .94

Formatting Order of Precedence... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .94

Data Display Options ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .95

Formatting Dialog Box ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .98

Cell Formatting ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 102

Sizing Columns ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 102

Changing and Locking Display Types ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 103

Spreadsheet Options ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 104

Charts and Chart Types... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 105

Chart Properties .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 106

Selecting Color .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 113

Font Properties .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 113

Selecting Graphics ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 114

Formatting Options
Documents display data values returned from the data source in a data object. Multiple data
objects can occupy a document, and each data object's display type can differ:

● Spreadsheet

● Chart

● Pinboard

● SQL Spreadsheet

● Free-form grid

Each display type has formatting options. This chapter describes the formatting options for
spreadsheets and charts.

Related Topics

“Creating Pinboards” on page 185.

“Creating SQL Spreadsheets” on page 193.
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“Creating Freeform Grids” on page 203.

Other Kinds of Formatting
● Display Type—Converts spreadsheet data objects to charts or pinboards.

● Data Display options—Sets document behavior through the data object shortcut menu (or
preferences, for subsequently created documents).

● Formatting options—Formats dimension headers and cell ranges. You can restrict
formatting by member selection or cell value. Formatting options include currency
formatting and positive and negative numeric formatting. See “Formatting Dialog Box” on
page 98. Formatting options include:

❍ Measures formatting

❍ Default formatting preferences

❍ Ad hoc formatting

❍ Data formatting analysis tool

❍ Cell Formatting

See “Formatting Data” on page 101.

● Column sizing—Sizes columns individually, uniformly, or to their default column width
using the shortcut menu. See “Sizing Columns” on page 102.

The scope of formatting depends on its source. To review all formatting definitions applied to
a document, you must consult preferences, the Analysis Tools Manager, the Information Panel,
and various document, data object, dimension and cell property settings.

Formatting Order of Precedence
Formatting is applied an order of precedence:

1. Measures formatting—Applied globally to dimensions on database connections. Settings
are saved with the database connection. See “Creating OLAP and Hyperion Database
Connections” on page 158.

2. Default formatting preferences—Applied globally to column and row headers, and data
values. Settings are saved in preference files. See “Default Formatting Preferences” on page
265.

3. Formatting—Applied ad hoc from the data object shortcut menu on dimension members.
It is stored with the document definition and applied as a preliminary Analysis Tool
definition. See “Formatting Dialog Box” on page 98.

4. Data formatting analysis tool—Applied after Data Formatting Analysis Tool definitions are
created and applied. It is stored with the document and applied from the Analysis Tools
Manager. See “Data Formatting” on page 128.

5. Cell formatting—Applied ad hoc to cell ranges, and is stored with the document. See
“Formatting Data” on page 101.
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Preferences and formatting options:

There are some identical formatting options and preferences. Preferences are global settings
applied to documents. Preferences, however, can be overridden by database connection
formatting and document-based formatting.

Order of formatting precedence:

1. Formatting options saved with documents

2. Formatting options saved with the database connection

3. Formatting options specified by the User Preferences dialog box

Data Display Options
Each display type has data display options specifying document behavior:

● Label mode—Analytic Services and Financial Management enable administrators to define
multiple alias tables. Web Analysis Studio enables you to specify which alias table to use.
Alias table selection is saved as a database connection property. See “Setting the Label Mode”
on page 96.

● Dimension header sort—Order column and row headers in a query result set using
Dimension Header Sort definitions. Dimension Header Sort options are determined by the
data source. See “Sorting Dimension Headers” on page 97.

● Suppression—Suppresses rows with missing data, rows with zeroes, and in the case of
Analytic Services, rows with shared members. Suppression can be set from the Cube
Navigator dialog box, Data Display shortcut menu or OLAP Server preferences.

Data Display Option Description

Selected Member Displays the explicit member selection made in the query. This
member selection can be previewed in the Information panel, or
Dimension Browser. Selected Member provides a method for
displaying this information in data objects.

Selected Member First When Selected Member is active, enables you to position the explicit
member selection made in the query definition first (from left to right,
or top to bottom).

Default Label Mode Toggles between label modes:

❍ Descriptions

❍ IDs

❍ Both (Financial Management option)

Dimension-Specific Label Mode Toggles between label mode options:

❍ Use Default

❍ Descriptions

❍ IDs

❍ Both (Financial Management option)
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Data Display Option Description

Display Entity Currency When using Financial Management data sources with defined Entity
dimension currency information, you can enable the Display Entity
Currency option to append Entity dimension members with currency
value. This can be set before querying using Cube Navigator options,
after querying using the Data Display shortcut menu, and for all
subsequently created documents using OLAP Server preferences.
See “Financial Management” on page 168.

Dimension Header Sort Orders the selected dimension per the order option:

❍ Default

❍ Ascending

❍ Descending

❍ Level (OLAP specific)

❍ Generation (OLAP specific)

❍ Selection Order (Relational specific)

The Default option is the order in which dimension members are
naturally ordered by data source outlines. Using this option may offer
improved performance.

For a complete description, See “Sorting Dimension Headers” on
page 97.

Show Linked Reporting Object Indicators Shows or hides small cell triangles indicating the presence of linked
documenting objects. Triangles persist for related content.

Suppress Omits data, as specified, from the query result set:

❍ Missing Rows

❍ Shared Members

❍ Zero Rows

Setting the Label Mode
Alias tables are database tables storing alternate description labels for dimension members.

Analytic Services and Financial Management enable administrators to define multiple alias
tables. Web Analysis Studio enables you to specify which alias table to use. The alias table
selection is saved as a database connection property. See “Alias Tables” on page 267.

You can specify to display the member ID or its description label from the alias table.

● The ID number is a column of unique values distinguishing members from all other
members.

● Description displays the alias table description. Web Analysis Studio uses the Description
label when no label mode is specified.

Financial Management users have an additional label mode option. They can select the Both
option to display the ID label and description.
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You can set the default label mode before querying using Cube Navigator options or the last step
in the document creation wizard, and after querying using the data object shortcut menu. You
can specify which description label to use in dimensions, using Dimension Browser and the data
object shortcut menu.

The Description label comes from the alias table setting, saved per database connection and per
active user as a database user preference.

➤ To set the default label mode for the current database connection:

1 Right-click dimension header.

2 Right-click and select Data Display.

3 Select Default Label Mode from the drop-down list.

4 Select IDs or Descriptions.

➤ To set the label mode for a dimension:

1 Right-click a dimension header.

2 Right-click and select Data Display.

3 Select the dimension-specific Label Mode from the drop-down list.

4 Select Use Default, IDs or Descriptions.

Default label mode coordinates the label mode of the selected dimension with all other
dimensions displaying the default label mode. Default label mode can be set for all dimensions
in a query through Cube Navigator, and per dimension by Dimension Browser or the Data
Display shortcut menu.

Sorting Dimension Headers
You can order column and row headers in a query result set using Dimension Header Sort
definitions. Dimension Header Sort options are determined by the data source.

For Example, Analytic Services enables you to order columns and rows in default, ascending,
descending, level or generation order. The default order is the natural order in which dimension
members are returned, based on the data source outline.

➤ To indicate a Dimension Header Sort definition:

1 Right-click a dimension member header and select Data Display > Dimension Header Sort.

The Dimension Header Sort submenu is displayed.

2 Select Default, Ascending, Descending, Level or Generation.
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Relational Dimension Header Sort
You can order the result set returned by relational SQL queries. You can opt for Ascending,
Descending, Selection Order and Default. Default is the order members are returned based on
the data source outline. Selection Order is the member selection order in Dimension Browser.

Unlike OLAP servers, relational cubes are compiled by Web Analysis Studio, and the label mode,
alias tables, and selection order are manually coordinated. Sort by alias may perform
comparatively slow, as the default query result set is sorted by ID. Sorting by alias requires a
complete client-side re-sort.

The source of the relational dimension header sort impacts performance. Defining a relational
dimension header sort using Cube Navigator, prompts Web Analysis Studio to sort all
dimensions as part of the current query result set.

Alternatively, sorting a relational dimension using the data object shortcut menu (Data Display
> Dimension Header Sort) requires you to select dimension headers.

Lastly, you can apply dimension header sort definitions to relational generations defined in the
Generation Editor. These definitions only impact the Dimension Browser sort order however.
Using the Order By Mode drop-down list, you can also specify orders by ID or Alias.

Formatting Dialog Box
Selecting Formatting from the data object shortcut menu displays the Formatting dialog box. It
indicates the members to which these formats are applied:

● Header font properties by member.

● Data value font properties by member.

● Edit the dimension members selected for formatting.

● Restore default formatting preferences.

Control Description

Selections Displays all dimension member selection definitions.

Remove All Deletes all dimension member selection definitions from the Selections panel.

Remove Deletes the selected dimension member selection definition from the Selections
panel.

Edit Displays the Edit Formatting Selections dialog box, enabling you to define member
selection definitions.

Header Font Displays the Font Properties dialog box.

Data Font Displays the Font Properties dialog box.

Format Data Displays the Format Data dialog box, used to specify text and numeric formatting.

Conditional Formatting Enables conditional formatting of dimension member selections based on the criteria
defined in the operand drop-down list and value text box.
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Control Description

Operand drop-down list Specifies the conditional formatting operand: >, >=, =, <=, <, or <>.

Value Text box Specified the conditional formatting value.

Restore Defaults Restores the settings specified by the Default Formatting preferences.

Topics that discuss formatting:

● “Creating Formatting Definitions” on page 99

● “Editing Formatting Selection Statements” on page 100

● “Formatting Data” on page 101

Creating Formatting Definitions

➤ To create formatting definitions:

1 Right-click a column or row dimension header.

2 Select Formatting.

The Formatting dialog box is displayed.

If the default dimension member selection in the Selections panel is satisfactory, proceed to Step
8.

3 To edit the dimension member selection, click Edit.

The Edit Selections dialog box is displayed.

4 To display the Dimensions panel, click Advanced.

5 To select a dimension, click its check box.

If you select one dimension from the Dimensions panel, the corresponding dimension members
are displayed in the Combinations panel.

If you select multiple dimensions from the Dimensions panel, the Combinations panel displays
dimension member aggregations.

6 To specify dimension members, click check boxes in the Combinations panel.

Selections display in the Selections panel. Click Remove to delete the current selection, or
Remove All to delete all member selections and start over. See “Editing Formatting Selection
Statements” on page 100.

7 When dimension member selections are defined, click OK.

The Edit Selections dialog box is dismissed, and the Formatting dialog box is displayed. The
Selections panel displays the dimension member selection.

8 To specify a formatting definition, perform one action:

● To specify header cell font properties for the dimension member selection, click the
Header group Font button.
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● To specify data cell font properties for the dimension member selection, click the Data group
Font button.

● To display the Format Data dialog box, used to specify leading and trailing text and numeric
formatting, click Format Data. See “Formatting Data” on page 101.

● To enable conditional formatting, select Conditional Formatting and enter a value and select
an operand from the corresponding controls. You can further refine formatting definitions
using conditional formatting. Conditional formatting requires dimension member selection
values to satisfy additional criteria before formatting is applied.

9 When you are finished specifying formatting definition properties for the dimension member selection, click
the Formatting dialog box OK button.

The formatting definition is listed in the Analysis Tools Manager for future reference and the
definition is applied to the document.

Editing Formatting Selection Statements
The Edit Selections dialog box enables you to edit the dimension member selections to which
formatting options are applied.

➤ To access the Edit Selections dialog box:

1 Right-click a column or row dimension header.

2 Select Formatting.

The Formatting dialog box is displayed.

3 To edit the dimension member selection, click Edit.

The Edit Selection dialog box is displayed. It features dynamic panels that you can show or hide.
If necessary, click the Advanced button to display the Dimension panel.

Control Description

Dimension Panel Enables you to select from the dimensions in play on the right-clicked axis. See the note
on dimensions in play below.

Combinations Panel Displays aggregate dimension member combinations, and enables you to select them for
formatting.

Selections Panel Displays the dimension member selections to be formatted.

Advanced/Basic Button Shows or hides the Dimension panel that enables you to select aggregate dimension
member combinations.

Remove Removes the current dimension member selection from the Selections panel.

Remove All Removes all dimension member selections from the Selections panel.

Initiate formatting by right-clicking a column or row dimension header, and selecting
Formatting or Analysis Tools > Format. The right-click target axis determines the initial selection
options in the Edit Selections dialog box:
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● Clicking a row header enables selection of row axis dimensions and the current page
dimension.

● Clicking a column header enables selection of only column axis dimensions.

The formatting method used determines whether a default selection is provided:

● If you select Analysis Tools > Format from the data object shortcut menu, you do not find
default selections in the Formatting dialog box Selections panel.

● If you select Formatting from the data object shortcut menu, you find the right-clicked axis
header in the Formatting dialog box Selections panel.

You can select only the current page dimension, and only from the row header shortcut menu.
To select current page and column dimension combinations, you must move the column
dimension to the rows axis. Conversely, moving row and current page dimension combinations
to the columns axis may cancel the formatting.

Formatting Data
You define format definitions in the Format Data dialog box:

Formatting Options Description

Leading and Trailing Formatting  

Currency Symbol Inserts currency formatting symbols into the Positive Prefix and Negative Prefix
text boxes: Dollar ($), Cents (¢), Pound (£), Euro(E), Deutschmark (DM), Franc
(F), and Yen (¥).

Positive Prefix Specifies the character to precede positive numeric values.

Positive Suffix Specifies the character to follow positive numeric values.

Negative Prefix Specifies the character to precede negative numeric values. Caution: The minus
sign (-) is the default prefix. Deleting the default prefix without replacing it displays
negative values as positive.

Negative Suffix Specifies the character to follow negative numeric values.

Numeric Formatting  

Grouped Thousands Displays numeric digits as grouped by thousands.

Minimum Decimals Indicates the minimum number of decimal places displayed.

Maximum Decimals Indicates the maximum number of decimal places displayed.

Scale Enables abbreviated values by tens, hundreds, thousands, ten-thousands,
hundred-thousands, millions, and billions.

Use Negative Color Indicates that negative numbers are signified by a selected color.

Select Negative Color Enables you to select the color representing negative values.

Samples  
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Formatting Options Description

Update Samples Updates the samples panel based on the most recent formatting selections.

Cell Formatting
The Cell Formatting dialog box enables you to format cell ranges ad hoc.

● Format data value font properties for cell ranges.

● Set text and numeric formatting for cell ranges.

● Restore default formatting preferences.

To define cell formatting, right-click a spreadsheet cell and select Cell Formatting:

Controls Description

Selections Displays the cell dimension member selection statement.

Font Displays the Font Properties dialog box.

Format Data Displays the Format Data dialog box, used to specify text and numeric formatting.

Restore Defaults Restores the settings specified by the Default Formatting preferences.

Sizing Columns
Columns can be individually sized, uniformly sized, or reset to their default column width.

The Freeze Headers formatting option must be enabled in the preferences or the Spreadsheet
Options dialog box before you can size columns. The Freeze Headers option holds column
dimension headers in place as cells scroll independently. After headers are fixed, they can be
resized without inadvertent scrolling behavior.

Sizing Individual Columns

➤ To size a column:

● Position your mouse over the border between two column headers. When the cursor changes
to the double-arrow cursor, drag the column border to adjust the column width.

● Right-click a column header and select Column Sizing > Custom Width from the shortcut
menu. When the Column Width dialog box is displayed, enter the desired column width in
pixels. The default is 75 pixels.
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Sizing All Columns to a Common Width

➤ To size all columns uniformly:

1 To size one column:

● Position your mouse over the border between two column headers. When the cursor changes
to the double-arrow cursor, drag the column border to adjust the column width.

● Right-click a column header and select Column Sizing > Set Column Width from the
shortcut menu. When the Column Width dialog box is displayed, enter the desired column
width in pixels.

2 When you are satisfied the selected column size, right-click that column and select Column Sizing > Set All
Columns To This Width.

The remaining columns are automatically resized to the selected column's width.

Autosizing Column Width

➤ To size all column widths so that headers display without truncation, select Column Sizing >
Autosize from the header shortcut menu.

Note:

You must save the document before closing it to preserve the column widths.

Changing and Locking Display Types

➤ To change the current display type, select the Display menu, and select a display type or chart
type from the submenu.

➤ To prevent others from changing the current display type:

1 Right-click the current content tab and select Properties.

The File Properties dialog box is displayed.

2 Select the Advanced tab.

3 In Document Usage, select  Change Display Type.

4 Click OK.

See “Modifying Document Properties” on page 34.
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Spreadsheet Options
All spreadsheet formatting options are set using the Spreadsheet Options dialog box, accessed
from the spreadsheet data object shortcut menu. You can set these options for all spreadsheets
subsequently created using Spreadsheet preferences.

Spreadsheet Option Description

Display  

Gridlines Sets the spreadsheet to display table gridlines.

Transparent Makes the cell background transparent to display a spreadsheet background
image.

Row Banding Sets spreadsheet rows to display alternating banding.

Column Banding Sets spreadsheet columns to display alternating banding.

Background Color Opens the Select Color dialog box, to set the background color.

Background Image Opens the Select Background Image dialog box.

Band Color Opens the Select Color dialog box, to set the color of row banding.

Column Band Color Opens the Select Color dialog box, to set the color of column banding.

Headers  

Custom Row Height Sets a fixed height for spreadsheet rows in point size (from 20-200).

Freeze Headers Holds column dimension headers in place as cells scroll independently. Note:
Freeze Headers must be enabled for Column Sizing.

Row Titles Displays column headers for nested rows.

Row Header Alignment drop-down list Aligns row headers left, center, or right or indents them based on generation.

Indent Amount Indicates the number of pixels to indent row headers for each level from the
top of the dimension hierarchy.

Row Group Alignment drop-down list Aligns rows as a group center, top, or bottom in a cell.

Header Font Displays the Font Properties dialog box, enabling the selection of header
fonts and font formatting.

Header Background Color Opens the Select Color dialog box, where you can set the header background
color.

Sample Header Displays the current header formatting.

Data  

Align Text Sets the alignment of textual data values: left, center, and right.

Align Values Sets the alignment of numeric data values: left, center, and right.
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Spreadsheet Option Description

Cell Font Displays the Font Properties dialog box enabling the selection of data value
fonts and font formatting.

Note: Font sizes are limited to a maximum of 100 points.

Cell Background Color Opens the Select Color dialog box where you can set the cell background
color; does not override banding.

Sample Cell Displays the current data values formatting.

Charts and Chart Types
Charts are graphic representations of spreadsheet data. Their visual nature expedites quick
analysis, color coding, and cues that aid comparisons.

Charts, depending on the chart type, can display one to four dimensions. Pie charts only display
one dimension; quadrant charts offer more complex displays.

Charts can be rendered using a variety of chart types:

Chart Type Compares

Bar Similar elements, represented as vertical bars.

Line Items over time.

Spline Displays the document as a spline chart.

Pie Contributions.

Area Items over time.

Curve Area Items over time, represented as a curved area.

Horizontal Bar Similar elements.

Marks Items over time.

Pareto Trends in data.

Box Displays the document as a box plot chart.

Quadrant Two members from one dimension over time.

Bubble Displays the document as a Bubble chart.

Only the first 50 dimension members can be accommodated on chart axes.

Pie Charts
Special features of pie charts:
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● Wedge separation

● Pie rotation

Drag pie wedges along the radius of the pie. Click and drag to rotate the pie chart.

Only 19 multiple pie charts can be displayed simultaneously on the data object.

Quadrant Charts
In Quadrant charts, one dimension must be placed on the row axis and two dimensions must
be placed on the column axis. Other dimension-axes arrangements result in error messages.

Bubble Charts
Bubble charts require three dimensions. Only one dimension can be placed on the column axis.
One or two dimensions can be placed on the row axis. There must be two columns in the
dimension positioned on the columns axis. These columns may be the result of selecting two
dimension members, or of including a calculated column with a dimension member. The values
in the first two columns provide the X and Y values required to plot the chart.

A third column provides the Z value used to determine the bubble size. If no third column is
available, a constant of 100 is used to determine the bubble size.

Chart Properties
Use the data object shortcut menu to access Chart Properties, described in these topics:

● “General Chart Properties” on page 106—options for effects, object borders, chart
backgrounds, and legends.

● “Titles Chart Properties” on page 107—options for chart titles.

● “Axes Chart Properties” on page 108—options for axes, number formatting, gridlines, scale,
and labels.

● “Series Effects Chart Properties” on page 109—options for chart behavior and border
formatting.

● “Series Chart Properties” on page 109—options for chart object properties.

● “Pie Chart Properties” on page 111—options for pie charts.

● “Bubble Chart Properties” on page 111—options for bubble charts.

General Chart Properties

Control Description

Layout
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Control Description

Chart Type Enables you to set the Chart Type: Bar, Line, Spline, Pie, Area, Curve Area, Horizontal Bar,
Marks, Pareto, Multi, Box, Quadrant, and Bubble.

Stacked Enables you to arrange chart objects: Side-by-Side, Stacked, and Stacked 100%.

Left Plot Area Margin Enables you to specify a left margin for the plot area.

Right Plot Area Margin Enables you to specify a right margin for the plot area.

Effects

3D Represents chart objects in three-dimensional space.

Anti-alias Fonts Enables and disables the use of anti-alias fonts. Although anti-alias fonts are clearer, they
sometimes differ from the original font style.

Cluster (Z-axis) Arranges chart objects along the Z axis in three-dimensional space.

Show Z-axis Labels Displays labels along the Z axis (front to back). This feature is only available when the chart
is clustered, and for Bar, Horizontal Bar, Pareto and Multichart chart types. Long Z-axis labels
may be cut off by chart margins.

Background

Background Color Displays the Select Color dialog box where you can set the chart background color.

Plot Area Color Displays the Select Color dialog box where you can set the plotter background color.

Background Image Displays the Select Graphic dialog box where you can set the chart background image.

Legend

Show Legend Displays a chart legend.

Position Locates the Legend to the Top, Left, Bottom, or Right of the chart.

Color Displays the Select Color dialog box to set the legend background color.

Font Displays the Font Properties dialog box to select font and their formatting.

Titles Chart Properties

Control Description

Header Title Sets the text string for the header title.

Footer Title Sets the text string for the footer title.

Left Title Sets the text string for the left title.

Right Title Sets the text string for the right title.

Font Displays the Font Properties dialog box to select font and their formatting.

Chart Properties 107



Axes Chart Properties

Control Description

Axis Indicates the current axis:

● X-axis - Sets the Axes tab to display x-axis parameters.

● Y-axis - Sets the Axes tab to display y-axis parameters.

● Secondary Y-axis - Set the Axes tab to display secondary y-axis parameters. See also
Series Tab, Assign to Secondary Y-axis.

Show Axis Displays the current axis.

Scale

Auto-calculate Enables the current axis to be calculated automatically based on data values.

Start at Minimum Value Indicates whether to start numeric labels with the minimum value.

Minimum Sets the minimum value on the current axis.

Maximum Sets the maximum value on the current axis.

Step Sets the number of increments to scale on the current axis.

Scale Enables you to indicate the multiple by which to scale the current axis: None, Tens,
Hundreds, Thousands, Ten Thousands, Hundred Thousands, Millions, or Billions.

Gridlines

Show Gridlines Displays gridlines on the current axis.

Style Represents gridlines using one style: Solid Line, Dash, Dot, and Dash Dot.

Weight Sets the width of gridlines in pixels (from 1-8).

Color Displays the Select Color dialog box where you can select a gridline color.

Number Format

Decimal Places: Enables you to sets the number of decimal places used to represent data values (0-10).

Format: Enables you to sets the numeric format for data values: Numeric, Currency, Percent.

Currency Symbol: Inserts currency formatting symbols: Dollar ($), Cents (¢), Pound (£), Euro(E), Deutschmark
(DM), Franc (F), and Yen (¥).

Labels

Stagger Alternates labels on two lines to accommodate larger labels.

Angle Enables you to indicates the angle at which labels extend from the current axis: 0-360
degrees.

Font Displays the Font Properties dialog box to select fonts and their formatting.
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Series Effects Chart Properties
Series Effects chart properties impact all chart object series in general. Series chart properties are
applied only to specific series.

Control Description

Charting

Enable Scrolling Allows you to specify the number of chart object groups to display, and to scroll left
to right to display additional groups. Note: Scrolling is not supported on Quadrant,
Box, Pie, and Bubble chart types.

Number of Groups Displayed Specifies the number of chart object groups to display.

Chart All Dimensions Delineates nested dimensions for chart type requirements and displays each
combination set as a series.

Chart type requirements differ for dimension member position and number. When
dimension members exceed a requirement, surplus dimensions are relocated to the
page axis so that the designated chart type can be displayed. Enabling Chart All
Dimensions prompts Web Analysis Studio to delineate nested dimensions and display
each combination set as a series.

Borders

Show Borders Represents chart objects with a border or outline.

Style Represents the chart object border using one style: Solid Line, Dash, Dot, and Dash
Dot.

Width Sets the width of chart object border in pixels (from 1-8).

Color Displays the Select Color dialog box where you can set the border color.

Series Chart Properties

Control Description

Series Indicates the current dimension member chart object series.

Style

Show Series Displays the current series.

Type Sets the chart type for the series when multiple chart types are enabled: Bar, Line, Area,
Spline and Curve Area.

Shape Sets the series chart object to one shape: Bar, Cylinder, Diamond Bar, or Triangle Bar.

Color Displays the Fill Properties dialog box where you can set chart object color, pattern fill,
or gradient.

Assign to Secondary Y-axis Displays the current series on the secondary y-axis.
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Control Description

Markers

Style Sets the series to one marker: None, Square, Circle, Triangle-Up, Diamond, Cross,
Triangle-Down, or Multiple Chart Type.

Image Marker Displays the Select Graphic dialog box enabling graphics to be used as chart markers.
Note: You cannot use animated GIFs as marker images.

Size Sets the size of the series marker in pixels (1-20).

Point Values

Show Values Displays data values with the series.

Font Displays the Font Properties dialog box where you can select font and their formatting.

Angle: Indicates the angle at which value labels extend from the current series: 0-360 degrees.

Lines

Style Represents the chart object border using one style: Solid Line, Dash, Dot, and Dash
Dot.

Width Sets the width of chart object border in pixels (from 0-8).

Apply selections to all. Sets all series to the parameters of the current series.

Filling Chart Objects
Like the Select Color dialog box, the Fill Properties dialog box enables you to select colors for a
series of chart objects. In addition, it differentiates chart objects with a pattern or gradient fill.

➤ To fill chart objects with a pattern fill:

1 Select Chart Properties from the chart shortcut menu.

2 Click the Series tab, and Color in the Style group.

The Fill Properties dialog box is displayed.

3 Click the Pattern Fill option and select a pattern.

You can combine two colors in the selected pattern.

4 Click Color 1 or Color 2 to select a color from the Select Color dialog box.

➤ To fill chart objects with a gradient fill:

1 Select Chart Properties from the chart shortcut menu.

2 Click the Series tab, and Color in the Style group.

The Fill Properties dialog box is displayed.

3 Click Gradient Fill, and select the direction of the gradient.
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You can combine two colors in the gradient.

4 Click Color 1 or Color 2 to select a color from the Select Color dialog box.

Line Widths of Zero (0)
Line charts accommodate a line width of zero, enabling a line chart to appear as a marks chart.
This applies only to two-dimensional line, quadrant, multichart, spline, area, and curve area
chart types.

Pie Chart Properties

Control Description

Values

Values Indicates the current pie slice.

Color Displays the Select Color dialog box to set color, pattern fill or gradient scale for the current
slice.

Labels

Show Values Displays data values with pie slices.

Position Indicates where to display labels: Inside Slices or Outside Slices.

Font Displays the Font Properties dialog box where you can select font and their formatting.

Show Multiple Pies Sets Page Dimensions to be displayed as multiple pie charts in one document.

Bubble Chart Properties
Bubble charts require three dimensions. Only one dimension can be placed on the column axis.
Up to two dimensions can be placed on the row axis. There must be two columns in the
dimension positioned on the columns axis. These columns may be the result of selecting two
dimension members, or the result of including a calculated column with a dimension member.
The values in the first two columns provide the X and Y values required to plot the chart.

A third column provides the Z value used to determine the bubble size. If no third column is
available, a constant of 100 is used to determine the bubble size.

Control Description

Effects

Marker Style: Sets the bubble chart to be displayed using these options: none, square, circle, Triangle
Up, Diamond, Cross, Triangle Down, or Multi.

Maximum Size: Sets the maximum bubble object size in points.
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Control Description

Show Points Displays plot points.

Point Color Sets the color of the center point.

Values

X-member Values: Indicates the dimension member used to plot x-axis values.

Y-member Values: Indicates the dimension member used to plot y-axis values.

Z values:

Constant Sets the constant used to plot the size of bubble chart objects when no third column
is available, so that object sizes match.

Z-member Values: Indicates the third column used to plot the size of bubble chart objects.

Scaling

Minimum Scaling: Sets the minimum bubble size when the bubble object size has reached the Maximum
Size limit.

Maximum Scaling: Sets the maximum bubble size when the bubble object size has reached the Maximum
Size limit.

Scale On: Sets the bubble chart to determine scale using area or diameter.

Borders

Show Borders Displays or hides the bubble borders.

Use Traffic Lights for Colors Sets the bubble object border to use colors specified in the traffic lighting definition;
only one dimension, with a traffic lighting definition, can be positioned on the rows axis

Color Displays the Select Color dialog box.

Border Width: Sets the border width in pixels.

Chart Preview
Clicking Preview displays an abstract of current chart parameters.
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Selecting Color
The Select Color dialog box enables you to set object, font, and component colors.

Control Description

Swatches Tab

Recent Displays recently selected colors.

RGB Float Over Values Displays the Red-Green-Blue color values when mouse is floated over a color.

HSB Tab

Hue Sets the percentage of hue in the current color.

Saturation Sets the percentage of saturation in the current color.

Brilliance Sets the percentage of brilliance in the current color.

Red Displays the red value of the current color.

Green Displays the green value of the current color.

Blue Displays the blue value of the current color.

RGB Tab

Red Displays the red value of the current color.

Green Displays the green value of the current color.

Blue Displays the blue value of the current color.

Preview Displays the application of the current color.

Font Properties
The Font Properties dialog box enables font selection and formatting.
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Control Description

Font Sets the font family.

Size Sets the font point size. Note: Fonts are limited to 100 points in size.

Font Style

Bold Displays the bold font.

Italic Displays the italic font.

Color Displays the Select Color dialog box, to enable font color selection.

Sample Text Displays the current font selection.

Selecting Graphics
The Select Graphic dialog box enables you to select the GIF or JPEG files used in Web Analysis
Studio.

Control Description

Center Centers the selected graphic in the panel.

Stretch Expands the selected graphic to fill the panel.

Tile Repeats the selected graphic to fill the panel.

Load Displays the Open dialog box, to select the GIF or JPEG graphic file.

Clear Deletes the previously selected image.
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Analysis Tools
Web Analysis Studio enables you to leverage server-based analytical formatting tools and data
source-specific tools from the client. Analysis Tools expedite comparisons, visually organize
data, and promote structures and conclusions.

Analysis Tools are data source-specific, and all Analysis Tools are not available in all data objects.

Analysis Tools are centrally organized and applied by the Analysis Tools Manager, accessed using
the data object shortcut menu. The Analysis Tools Manager features an Ordered By panel
showing the number and order of Analysis Tools definitions activated on the current data object.
Toolbar buttons enable you to generate Analysis Tools definitions.

Analysis Tool Used To:

Traffic Lighting Color-code dimension member values based on fixed limits or a comparison of values.

Traffic Lighting visually associates member values whether they are sorted or ranked.

Sorting Order the query result set.

Calculations Create calculated rows and columns.

Data Formatting Format data values based on member or value criteria.
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Analysis Tool Used To:

Show/Hide Only Filter data by color, value and member.

Related Content Create Related Content links to:

● LROs - cell notes, URLs, and file attachments stored at Analytic Services
intersections

● Hyperion® System™ 9 BI+™ Analytic Integration Services™ drill-through content

● Financial Management cell text and line item details stored at Financial
Management intersections

● Hyperion Documents content displayed as HTML or PDF

● Hyperion® System™ 9 Application Builder J2EE™ content

Restrict Data Restrict the query result set based on criteria.

Retrieve Only Top/Bottom Limit and rank the query result set.

Currency Conversion SAP BW—Converts data value currencies ad hoc during analysis, and to save those
conversion definitions as analysis tools.

Unit of Measure Conversion SAP BW—Converts the data value unit of measure ad hoc during analysis, and to save
those conversion definitions as analysis tools.

Edit Selected Definition Opens the Analysis Tool for the specified definition, enabling you to edit the definition.

Remove Selected Definition Deletes the selected Analysis Tool definition.

Remove All Deletes all defined Analysis Tools definitions.

Related Content
Related Content definitions can be managed from the Related Content dialog box and Analysis
Tools Manager. Edits, including remove and remove all, made in the Related Content dialog
box, change the content of the related content definition but do not impact the existence of the
definition. You can activate, deactivate, reorder, and remove related content in the Analysis
Tools Manager, but you cannot edit related content definitions.

Ordering Analysis Tools
The order in which Analysis Tools definitions are applied affects data object behavior. You can
edit the order in which Analysis Tools are applied by selecting Analysis Tools definitions and
moving them in the Ordered By panel.

Default Analysis Tools
The Analysis Tools Manager displays default formatting, measures formatting, and spreadsheet
option definitions at the top of the Ordered by list panel. These definitions, originating from
preferences, database connection properties, and data object properties, are applied before
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subsequent Analysis Tools definitions. They can be edited, but they cannot be removed or
disabled.

Activating and Deactivating Analysis Tools
You can activate and deactivate Analysis Tools definitions without removing them from the
Analysis Tools Manager. This enables various Analysis Tools combinations to be used.

➤ To deactivate Analysis Tools definitions, select the corresponding Active option in Ordered
By.

Editing Definitions

➤ To edit an Analysis Tools definition:

1 Right-click a dimension member header and select Analysis Tools > Analysis Tools Manager.

The Analysis Tools Manager is displayed.

2 Select a definition and click Edit.

The corresponding Analysis Tool dialog box is displayed.

3 Make selections and define parameters as needed.

4 Click OK.

The Analysis Tools Manager is displayed.

5 Click Close.

Show/Hide Only
The Show/Hide Only analysis tool includes or excludes members by member name, traffic
lighting color, or data value criteria. It is an effective means of focusing analysis by values.

The Information panel Show/Hide Only segment displays Show/Hide Only definitions that
restrict or display information on the current document.

Topics that discuss the Show/Hide Only analysis tool:

● “Asymmetrical Analysis” on page 118

● “Multiple Show/Hide Only Definitions” on page 118

● “Differences in Show/Hide Only Definitions” on page 118

● “Creating Show/Hide Only Definitions” on page 119
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Asymmetrical Analysis
Asymmetric documents feature nested dimensions that differ (by at least one member) across
an axis. Web Analysis Studio accommodates asymmetrical analysis by enabling you to hide
specified rows, columns, and chart objects.

Multiple Show/Hide Only Definitions
Multiple Show/Hide Only definitions are applied in order, enabling simultaneous control by
member, color, and values.

Differences in Show/Hide Only Definitions
Show/Hide Only definitions are applied differently for each methodology used:

● Show/Hide Only Calculations shows or hides all calculated members.

● Show/Hide Only Members shows or hides dimension members of the dimension header
right-clicked in the document.

● Show/Hide Only Values shows or hides dimension members on the axis opposite the
dimension header right-clicked in the document.

● Show/Hide Only Colors shows or hides dimension members on the axis opposite the
dimension header right-clicked in the document.

Show/Hide Only definitions are created in the Show/Hide Only dialog box:

Control Description

Select Method Show - Displays only items satisfying the Show/Hide Only definition criteria.

Hide - Hides only items satisfying the Show/Hide Only definition criteria.

Where

Calculations Shows or Hides all calculated members.

Member Bases the Show/Hide Only definition on specified dimension members of the current axis.

Values Tests whether members of the opposite axis contain values satisfying criteria of the current
axis.

All Values Tests whether all members of the opposite axis contain values satisfying criteria of the
current axis.

Colors Tests whether members of the opposite axis contain colors satisfying criteria of the current
axis.

All Colors Tests whether all members of the opposite axis contain colors satisfying criteria of the
current axis.

Set Condition
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Control Description

Operator drop-down list Select an operator for your criteria: Greater than (>), Greater Than or Equal To (>=), Equal
to (=), Less Than or Equal To (<=), Less Than (<), Not Equal To (<>).

Value Text box Enables you to enter the value for Show/Hide Only Values conditions.

Color Opens the Select Color dialog box to set the condition color.

Members Lists available dimension members and attributes to which the Show/Hide Only definition
is applied.

Advanced Aggregates or separates dimension member combinations.

Apply Applies the definition to the document.

Creating Show/Hide Only Definitions

➤ To create a Show/Hide Only definition:

1 Right-click a dimension member header and select Analysis Tools > Show/Hide Only.

The Show/Hide Only dialog box is displayed.

2 From Select Method, select Show or Hide.

3 Define one option:

● To show or hide only calculated members, click the Where group Calculations option.

● To show or hide specified members, click the Where group Members option and select
dimension members from Members.

● To show or hide only dimension members if dimension member value satisfies a condition,
perform these actions:

a. Click the Where group Values option.

b. Select dimension members from Members.

c. Use the operator list and the value area to define a condition.

● To show or hide only dimension members when all dimension member values satisfy a
condition, perform these actions:

a. Click the Where group All Values option.

b. Select dimension members from Members.

c. Use the operator list and the value area to define a condition.

● To show or hide only dimension members if dimension member value satisfies a traffic
lighting color condition, perform these actions:

a. Click the Where group  Colors option.

b. Select dimension members from Members.

c. From the operator list, select Equal To (=) or Not Equal To (<>).
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d. Click Color. The Select Color dialog box is displayed. Select one defined traffic lighting
range color. The color displays in the large square. Click OK. The button displays the
selected color.

● To show or hide only dimension members if all dimension member values satisfy a traffic
lighting color condition, perform these actions:

a. Click the Where group All Colors option.

b. Select dimension members from Members.

c. From the operator list, select Equal To (=) or Not Equal To (<>).

d. Click Color. The Select Color dialog box is displayed. Select one defined traffic lighting
range color. The color displays in the large square. Click OK. The button displays the
selected color.

Note:

Show/Hide Only Members is applied to the named dimension member, and Show/Hide
Only Values and Show/Hide Only Colors is applied to the opposite axis, using the values
in the selected axis.

Color options are only enabled when the data object features an active traffic lighting
definition. An Advanced option specifies conditions for dimension member
combinations. Apply enables you to apply the definition to the current data object,
without exiting the dialog box. Drag the dialog box title bar to see the data object
underneath.

4 Click OK.

The current definition is added to the Analysis Tools Manager.

5 Click Close.

Traffic Lighting
The Traffic Lighting analysis tool color-codes data cells based on dimension member values.
You can base color-coding on a comparison of two dimension members or by fixed limits on
one dimension member. Colors graphically associate member values, whether they are sorted
or ranked. Traffic Lighting definitions are maintained as the document is pivoted and changed.

The Information panel Traffic Lighting segment displays the Traffic Lighting definitions that
color-code the current data object.

Traffic Lighting definitions are created in the Traffic Lighting dialog box:

Control Description

Apply Traffic Lighting To: Specifies the dimension to which traffic lighting is applied.

Comparing It To: Specifies the dimension to which the preceding dimension is compared.
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Control Description

Assign Limits Specifies the interval, set point, and color parameters that compose the traffic lighting
definition.

% Differences Indicates that the color-coding is based on the percent difference of the compared
members. When disabled, color-coding is based on the value difference of the
compared members.

Enable Financial Intelligence Enables Hyperion data sources to treat expenses and liabilities as negative values.
Works in cooperation with the % differences option to reflect variance and variance
percent calculations for the traffic lighting dialog box.

Advanced Aggregates or separates dimension member combinations.

Apply Applies the definition to the document.

Topics that discuss traffic lighting:

● “Financial Intelligence Variations” on page 121

● “Assign Limits Shortcut Menu” on page 121

● “Creating Traffic Lighting Definitions” on page 122

● “Setting Traffic Lighting Opacity” on page 123

Financial Intelligence Variations
The % Differences and Enable Financial Intelligence options cooperate to provide four
calculations for the Traffic Lighting dialog box.

● When neither option is selected, the Traffic Lighting dialog box compares selected members
using a conventional subtraction calculation.

● When only the % Differences option is selected, the Traffic Lighting dialog box compares
the selected members using a conventional percent difference calculation.

● When the Enable Financial Intelligence option is selected, the Traffic Lighting dialog
compares the selected members using an advanced variance calculation that recognizes
expenses and liability dimensions as negative values.

● When both options are selected, the Traffic Lighting dialog compares the selected members
using an advanced variance percent calculation that recognizes expenses and liability
dimensions as negative values.

Understanding the calculations and the nature of your dimension metadata helps you to better
compare dimensions.

Assign Limits Shortcut Menu
The Assign Limits color band and the Set Point arrows feature context-sensitive shortcut menus:
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Control Description

Assign Limits Shortcut Menu

Add Set point Inserts a set point within the range.

Set Color Opens the Select Color dialog box where you can set the range color.

Set Opacity Opens the Opacity dialog box, enabling you to determine the percentage of transparency for
the selected range color.

Set Point Shortcut Menu

Color Above Set point Sets the set point color to that of values greater than the set-point.

Color Below Set point Sets the set point color to that of values less than the set-point.

Delete Set point Opens the Confirm Deletion message box where you can confirm intentional deletion of the
set point.

Note:

Setting traffic lighting colors to colors used by Spreadsheet Options may obscure the color-
coding of dimension members.

Creating Traffic Lighting Definitions

➤ To create a traffic lighting definition:

1 Right-click a dimension member header and select Analysis Tools > Traffic Light.

The Traffic Lighting dialog box is displayed.

2 Select the dimension member to which traffic lighting is applied, from Apply Traffic Lighting To.

3 From Comparing It To, select the dimension member to which the preceding dimension member is compared.

● Compare to a fixed limit by disabling the % Differences option in the Assign Limits group
box, or by selecting Fixed Value from Comparing It To.

● Select the Advanced option to separate dimension members into combinations. Click it
again to select from aggregated dimension members.

The Assign Limits option contains three default set points and colors.

4 Right-click ranges to:

● Insert another set point.

● Redefine the range color.

● Set range opacity or transparency.

5 Right-click a set point arrow to:

● Include the set point in the range above.

● Include the set point in the range below.
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● Delete the set point.

6 Click the set point text box to enter or edit set point threshold values.

7 Click Apply.

8 Click OK.

Setting Traffic Lighting Opacity
The Opacity dialog box enables you to define transparent traffic lighting ranges and set points,
and to control the percentage of transparency for these ranges and set points.

This is especially valuable when you want background images to show through spreadsheets
with color comparisons and traffic lighting definitions.

➤ To specify transparency for a traffic lighting range or set point:

1 In the Traffic Lighting dialog box, right-click an Assign Limits range or set point and select Set Opacity.

2 The Opacity dialog box is displayed.

3 Drag the slider bar to the desire percentage of transparency.

4 If you want to apply this percentage of transparency to all other ranges and set points, click Apply to All
Colors.

5 Click OK.

Sorting
The Sorting analysis tool orders specified dimensions of the query result set in ascending or
descending alphanumeric order. Sorting definitions are dynamic and are applied as the
document is drilled, pivoted, and changed.

The Information panel Sorting segment displays all client-based sorting definitions.

Multiple sorting definitions are applied in the order presented by the Analysis Tools Manager.
Sorting definitions applied to axes with equal values may subsequently be rearranged by sorting
definitions applied to axes with diverse values. The document display is the result of the
cumulative application of all active sorting, client-side and server-side, even though it may
appear that only the last sorting definition is applied.

Sorting Dialog Box
Sorting definitions are created in the Sorting dialog box.

Control Description

Sort On Specifies the dimension member to which the sorting definition is applied.

Order
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Control Description

Ascending Selects ascending alphanumeric order for the result set display.

Descending Selects descending alphanumeric order for the result set display.

Apply Apply the definition to the document.

Creating Sorting Definitions

➤ To create a sorting definition:

1 Right-click a dimension member header and select Analysis Tools > Sort.

The Sorting dialog box is displayed.

2 Select the dimension member to which sorting is applied, from Sort On.

3 Select Ascending or Descending.

4 Click Apply.

5 Click OK.

Restricting Data
The Restrict Data analysis tool provides another means of narrowing the return set, by requiring
data values to be relevant to rules and operands. Data can be restricted by a comparison between
columns or using fixed limits on one column.

The Information panel Restrict Data segment is displayed Analytic Services Restrict Data
definitions for the current document.

Restrict Data is executed by Analytic Services. This can protect the network server from
transmitting, and the client from processing, large result sets.

Although you can apply Restrict Data to the result set of a processed query (using the Analysis
Tools shortcut menu), you can also define Restrict Data criteria before submitting a query. The
last step in the Document Creation wizard enables you to create Restrict Data definitions.

Topics that discuss restricting data:

● “Restrict Data Controls” on page 125

● “Creating Restrict Data Definitions” on page 125
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Restrict Data Controls

Control Description

Select Column Displays the Select Column dialog box, enabling you to select a column from the current
document.

Operator drop-down list Select an operator for your criteria: Greater than (>), Greater Than or Equal To (>=), Equal
to (=), Less Than or Equal To (<=), Less Than (<), Not Equal To (<>).

Operand drop-down list Specifies one of three operands for restricting data:

● A value Of - Restricts Data to a value or range of values.

● The Data Value of Column - Displays a secondary Select Column button, enabling you
to compare two columns.

● A Missing Value - Enables restriction of missing values.

Value Text box Enables you to enter the value for Restrict Data conditions.

Note:

Only use one member per dimension in filters when restrict data and /or retrieve top/bottom is
applied. When multiple members are selected per dimension, the application aggregates the
results. Because restrict data and retrieve top/bottom are parts of the Analytic Services query,
the aggregation occurs after the query is returned and may result in unexpected result sets.

Creating Restrict Data Definitions

➤ To create a Restrict Data definition:

1 Perform one:

● Right-click a dimension member header and select Analysis Tools > Restrict Data.

● Right-click a dimension member header and select Analysis Tools. When the Analysis Tools
Manager is displayed, select New Restrict Data.

● Select Restrict Data from Cube Navigator Options.

● In the last step of the Document Creation wizard, click Restrict Data.

The Restrict Data dialog box is displayed.

2 Click Select Column.

The Restriction Columns dialog box is displayed.

3 Select the Column to which the Restrict Data definition is applied, and click OK.

Focus is returned to the Restrict Data dialog box.

4 Select an operator from Operator.

5 Select an operand from the Operand menu: A Value Of, The Data Value of Column, or A Missing Value.

6 Enter a data value in Value, as needed.
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7 Click Add.

The restriction criteria is listed in the Restriction Definition frame. You can use the Advanced
button to create compound definitions with additional criteria.

8 Optional: Click Advanced to add criteria, update the definition, remove one or all definitions, connect
individual definitions with an AND or OR, or move a criteria.

Advanced Option Sub menu Description

Add  Add the current rule to the Total Subset Definition.

Update  Replace the selected rule with the current rule.

Validate  Verifies the parenthetical syntax of the Total Subset Definition.

Remove  Remove the current rule from the Total Subset Definition.

Remove All  Remove all rules from the Total Subset Definition.

Connect And Inserts the AND operand at the end of the currently selected rule. The AND operand
is used by default when multiple rules are added to the Definition.

 Or Inserts the OR operand at the end of the currently selected rule.

Move Move Up Moves up the currently selected rule in the Total Subset Definition.

 Move Down Move the currently selected rule down in the Total Subset Definition.

9 Click OK.

Retrieve Only Top/Bottom
The Retrieve Only Top/Bottom analysis tool leverages Analytic Services server-based sorting and
ranking to control the size and order of an OLAP query result set. This can protect the network
server from transmitting, and the client from processing, large result sets. The Retrieve Only
Top/Bottom analysis tool is central to top/bottom analysis.

Although you can apply Retrieve Only Top/Bottom to the result set of a processed query (using
the Analysis Tools shortcut menu), you can also define Retrieve Only Top/Bottom criteria before
submitting a query. Click the Cube Navigator Options button and select the Retrieve Only Top/
Bottom menu item, to define a Retrieve Only Top/Bottom definition before sending a query.
The last step of the Document Creation wizard also enables you to create Retrieve Only Top/
Bottom definitions.

The Information panel Retrieve Only Top/Bottom segment is displayed all Analytic Services
Retrieve Only Top/Bottom definitions for the current document.

Behavior of multiple row dimension member selection
Retrieve Only Top/Bottom Analysis Tool restricts the use of multiple row dimension member
selections, because Top/Bottom applies only to one dimension. When you add a dimension to
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a row and retrieve the top two members of a column, the Top/Bottom Analysis Tool displays
the top two members for each member of the first dimension instead of the top two members
of the selected column.

Analysis Tools and Multiple Filter Axis Dimension Members
Multiple filter dimension member selections impact Retrieve Only Top/Bottom.

Multiple filter axis dimension members are aggregated before being sent in a query. Because the
client-based aggregation does not exist in the data source server, the query is processed in terms
of the data values on the server. The discrepancy between client aggregations and server-based
sorting and ranking results in irregular result sets.

Nominate only single filter dimension member selections when using Retrieve Only Top/Bottom
and Restrict Data analysis tools.

Control Description

Select Column Specifies the columns to which the Retrieve Only Top/Bottom definition is applied.

Show Limits the result set to these criteria:

Top Selects the number of highest data values indicated by the corresponding value text box.

Bottom Selects the number of lowest data values indicated by the corresponding value text box.

Sorting

Ascending Displays the result set in ascending alphanumeric order.

Descending Displays the result set in descending alphanumeric order.

Clear Deletes all Retrieve Only Top/Bottom definitions.

Creating Retrieve Only Top/Bottom Definitions

➤ To create a Retrieve Only Top/Bottom definition:

1 Perform one:

● Right-click a dimension member header and select Analysis Tools > Retrieve Only Top/
Bottom.

● Right-click a dimension member header and select Analysis Tools. When the Analysis Tools
Manager is displayed, select New Retrieve Only Top/Bottom.

● Select Retrieve Only Top/Bottom from Cube Navigator Options.

● In the last step of the Document Creation wizard, click Retrieve Only Top/Bottom.

The Retrieve Only Top/Bottom dialog box is displayed.

2 Select the column to which the Retrieve Only Top/Bottom definition is applied from Select Column.
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3 Limit the result set by selecting Top or Bottom and indicating the number of members in Value.

4 Sort the result set by selecting Ascending or Descending.

5 Optional: To remove all selections from the current definition and start over, select Clear.

6 Click OK.

Data Formatting
Data Formatting options automatically format headers and data values by dimension member
and criteria. While formatting options are fixed, the formatting scope varies depending on the
formatting source. See “Formatting Order of Precedence” on page 94.

➤ To create a Data Formatting definition, right-click a dimension member header and select
Analysis Tools > Format.

➤ To edit Data Formatting definitions, right-click a dimension member header, select Analysis
Tools > Analysis Tools Manager, and double-click the desired data formatting definition.

Formatting Dialog Box
The Formatting dialog box indicates the dimension member selection to which the formatting
definition is applied.

You can perform these tasks from this dialog box:

● Format header font properties for a dimension member selection.

● Format data value font properties for a dimension member selection.

● Edit the dimension member selection.

● Restore the settings specified by the Default Formatting preferences.

Controls Description

Selections Displays all dimension member selection definitions.

Remove All Deletes all dimension member selection definitions from the Selections panel.

Remove Deletes the selected dimension member selection definition from the Selections
panel.

Edit Displays the Edit Formatting Selections dialog box, enabling you to define member
selection definitions.

Header

Font Displays the Font Properties dialog box.

Data
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Controls Description

Font Displays the Font Properties dialog box.

Format Data Displays the Format Data dialog box, used to specify text and numeric formatting.

Conditional Formatting Enables conditional formatting of dimension member selections based on the criteria
defined in the operand drop-down list, and value text box.

Operand drop-down list Specifies the conditional formatting operand.

Value Text box Specified the conditional formatting value.

Restore Defaults Restores the settings specified by the Default Formatting preferences.

Creating Data Formatting Definitions

➤ To create a data formatting definition:

1 Right-click a column or row dimension header, and select Analysis Tools > Format.

The Formatting dialog box is displayed.

If the default dimension member selection in Selections is satisfactory, proceed to Step 7.

2 Click Edit to edit the dimension member selection.

The Edit Formatting Selections dialog box is displayed.

3 Click Advanced to display the Dimensions panel.

4 Select dimension members.

If you select one dimension from the Dimensions panel, the corresponding dimension members
display in the Combinations panel.

If you select multiple dimensions from the Dimensions panel, the Combinations panel displays
dimension member aggregations.

5 In Combinations, select the dimension member or dimension member combination to be formatted.

Selections display in the Selections panel. Click Remove to delete the current selection, or
Remove All to delete all member selections and start over.

6 When dimension member selections are defined, click OK.

The Formatting dialog box is displayed. The Selections panel displays the dimension member
selection.

7 To specify a formatting definition:

● Click the Header group Font button to specify header cell font properties for the dimension
member selection.

● Click the Data group Font button to specify data cell font properties for the dimension
member selection.
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● Click Format Data to display the Format Data dialog box, used to specify leading and trailing
text, and numeric formatting.

● Click Conditional Formatting to enabling conditional formatting, and enter a value and select
an operand from the controls below. You can further refine formatting definitions using
conditional formatting. Conditional formatting requires dimension member selection
values to satisfy additional criteria before formatting is applied.

8 When you are finished specifying formatting definition properties for the dimension member selection, click
OK.

The formatting definition is listed in the Analysis Tools Manager for future reference and the
definition is applied to the document.

Creating Calculations
You can create client-side calculated members, and edit, delete, and analyze these calculations.

The order of calculation definitions in the Analysis Tools Manager establishes a precedent for
subsequent compound calculations. You can change the order of calculation definitions, by
selecting the definition and clicking the up and down arrow buttons.

The complete list of calculations includes:

Average
● Function Performed—Sum of all arguments divided by the number of arguments.

● Number of Arguments—Two or more members or calculations.

● Options—Whether missing values should be set to 0 in the calculation and included in the
number of arguments.

Example—If Actual is 100 and Budget is 200, the Average of Actual and Budget is 150.

Cumulative
● Function Performed—Provides a running total.

● Number of Arguments—One member or calculation.

● Options—Whether missing values should be set to 0 in the calculation.

Example—Consider a spreadsheet with Actual as a column and Colas, Root Beer, and Cream
Soda as rows. If the Actual values for these products were 100, 200, and 300, the Cumulative
column would be 100, 300, 600.

Difference from Average
● Function Performed—Subtracts each argument's average value from each occurrence of

the argument.
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● Number of Arguments—One member or calculation.

● Options—Whether missing values should be set to 0 for the purposes of the calculation.

Example—Consider a spreadsheet with Actual as a column and Colas, Root Beer, and Cream
Soda as rows. If the Actual values for these products were 100, 200, and 300, the average would
be 200. So the Difference from Average column would be -100, 0, 100.

Divide
● Function Performed—Arithmetic division

● Number of Arguments—Two members or calculation

● Options—Whether missing values should be set to zero in the calculation

Linear Regression
● Function Performed—Straight-line linear regression. Looks at all occurrences of the

specified argument, and uses a linear regression algorithm to calculate a 'straight line'
through the occurrences.

● Number of Arguments—One member or calculation.

● Options—Whether missing values should be set to 0 in the calculation.

Example—Consider a spreadsheet with Actual as a column and Jan, Feb, Mar as rows. If the
Actual values for these time periods were 100, 300, and 600, the Linear Regression column would
be 83, 333, 58. Notice that there is now a constant difference between each value (250). All points
in the sequence are adjusted. A chart of these numbers would produce a straight line that goes
through the original data points.

Maximum
● Function Performed—Given two or more arguments, Maximum returns the name of the

member or calculation that has the maximum value.

● Number of Arguments—Two or more members or calculations.

● Options—Whether missing values should be set to 0 in the calculation.

Example—Consider a spreadsheet with East and West as columns and Jan, Feb, Mar as rows. If
the East values were 100, 300, and 600 and the West values were 200, 200, 300, the Maximum
column would be West, East, East.

Maximum Value
● Function Performed—Given two or more arguments, Maximum Value returns the value

of the member or calculation that has the maximum value.

● Number of Arguments—Two or more members or calculations.
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● Options—Whether missing values should be set to 0 in the calculation.

Example—Consider a spreadsheet with East and West as columns and Jan, Feb, Mar as rows. If
the East values were 100, 300, and 600 and the West values were 200, 200, 300, the Maximum
Value column would be 200, 300, 600.

Minimum
● Function Performed—Given two or more arguments, Minimum returns the name of the

member or calculation that has the minimum value.

● Number of Arguments—Two or more members or calculations

● Options—Whether missing values should be set to 0 in the calculation.

Example—Consider a spreadsheet with East and West as columns and Jan, Feb, Mar as rows. If
the East values were 100, 300, and 600 and the West values were 200, 200, 300, the Minimum
column would be East, West, West.

Minimum Value
● Function Performed—Given two or more arguments, Minimum Value returns the value

of the member or calculation that has the minimum value.

● Number of Arguments—Two or more members or calculations

● Options—Whether missing values should be set to 0 in the calculation.

Example—Consider a spreadsheet with East and West as columns and Jan, Feb, Mar as rows. If
the East values were 100, 300, and 600 and the West values were 200, 200, 300, the Minimum
Value column would be 100, 200, 300.

Multiply
● Function Performed—Arithmetic multiplication.

● Number of Arguments—Two members or calculations, or one member or calculation and
a constant.

● Options—You can specify a constant as an argument if you want to work with one rather
than two members or calculations. You can also choose whether missing values should be
set to 0 in the calculation.

Percent
● Function Performed—Percentage calculation.

● Number of Arguments—Two members or calculations, or one member or calculation and
a constant.
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● Options—You can specify a constant as an argument if you want to work with one rather
than two members or calculations. You can also choose whether missing values should be
set to 0 in the calculation.

Example—Consider a spreadsheet with Actual and Budget as columns and Jan, Feb, Mar as
rows. If the Actual values were 100, 300, and 600 and the Budget values were 200, 200, 400, the
Percentage column (Actual % Budget) would be 50, 150, 150.

Percent Difference from Average
● Function Performed—Performs the same actions as Difference from Average but displays

each result as a percentage of average.

● Number of Arguments—One member or calculation.

● Options—Whether missing values should be set to 0 in the calculation.

Example—Consider a spreadsheet with Actual as a column and Colas, Root Beer, and Cream
Soda as rows. If the Actual values for these products were 100, 200, and 300, the average would
be 200. So the Difference from Average (%) column would be -50, 0, 50.

Percent of Difference
● Function Performed—Percentage difference calculation.

● Number of Arguments—Two members or calculations, or one member or calculation and
a constant.

● Options—You can specify a Constant as an argument if you want to compare a member
with a fixed value. You can also choose whether missing values should be set to 0 in the
calculation.

Example—Consider a spreadsheet with Actual and Budget as columns and Jan, Feb, Mar as
rows. If the Actual values were 100, 300, and 600 and the Budget values were 200, 200, 400, the
Percentage difference column (Actual % diff Budget) would be calculated as ((Actual -Budget) /
Budget)*100 and shown as -50, 50, 50.

Percent of Member
● Function Performed—Evaluates a dimension member argument as a percentage of another

dimension member argument. The second argument is defined by the dimension member
intersected on an opposite axis.

● Number of Arguments—Two or more members or calculations, or one member or
calculation and a constant.

● Options—You can choose whether missing values should be set to 0 in the calculation.

● Procedure—Select a Percent of Member calculation from the Function list, select a
dimension member argument, and select a dimension member from the opposite axis using
the Opposite Member drop-down list.
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Percent of Total
● Function Performed—Percentage of total.

● Number of Arguments—One member or calculation.

● Options—None.

Example—Consider a spreadsheet with Actual as a column and Jan, Feb, Mar as rows. If the
Actual values were 100, 300, and 600, the Percentage of Total column would be shown as 10, 30,
and 60.

Rank Ascending
● Function Performed—Ranking.

● Number of Arguments—One member or calculation.

● Options—Ascending or descending (the default). If ascending is chosen, the smallest value
is given a ranking of 1. If descending is chosen, the largest value is given a ranking of 1.

Example—Consider a spreadsheet with Actual as a column and Jan, Feb, Mar as rows. If the
Actual values were 100, 300, and 600, the Rank column would be shown as 3, 2, 1.

Rank Descending
● Function Performed—Ranking.

● Number of Arguments—One member or calculation.

● Options—Ascending or descending (the default). If ascending is chosen, the smallest value
is given a ranking of 1. If descending is chosen, the largest value is given a ranking of 1.

Subtract
● Function Performed—Arithmetic subtraction.

● Number of Arguments—Two or more members or calculations, or one member or
calculation and a constant.

● Options—You can choose whether missing values should be set to 0 in the calculation.

Sum
● Function Performed—Arithmetic addition.

● Number of Arguments— Two or more members or calculations, or one member or
calculation and a constant.

● Options—Whether missing values should be set to 0 in the calculation.

134 Managing Analysis Tools



Trend
● Function Performed—Trend based on straight-line Linear Regression; that is, the slope of

the 'straight line' that a Linear Regression calculation would plot between the points in the
original data series.

● Number of Arguments—Two or more members or calculation.

● Options—Whether missing values should be set to 0 in the calculation

Variance
● Function Performed—Arithmetic subtraction that uses Financial Intelligence account

metadata to interpret Financial Management expense and liability items as negative values.

● Number of Arguments—Two or more members or calculations, or one member or
calculation and a constant.

● Options—You can choose whether missing values should be set to 0 in the calculation.

Variance Percent
● Function Performed—Percentage difference calculation that uses Financial Intelligence

account metadata to interpret Financial Management expense and liability items as negative
values.

● Number of Arguments—Two members or calculations, or one member or calculation and
a constant.

● Options—You can specify a Constant as an argument if you want to compare a member
with a fixed value. You can also choose whether missing values should be set to 0 in the
calculation.

Complex Calculations
Hyperion recommends breaking complex calculations into smaller components that you
combine to create a compound calculation.

Example: To create a calculation for (A + B) / (C x 2), where A, B, and C are members, divide
the formula into steps:

● Create Total for A + B, and name it Step 1.

● Create multiplication for C x 2, and call it Step 2.

● Create a third calculation to divide Step 1 by Step 2 to get the result.

● You can use Show Only Members to hide Step 1 and Step 2 so that they do not display in
your view. If you want to switch between seeing only members or only calculations, or both,
you can use the Hide option in the shortcut menu on your document.
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➤ To create a calculation:

1 Right-click a dimension member header and select Analysis Tools > Calculation.

The Calculation Definition dialog box is displayed. It provides seven labeled groups:

● Name

● Function

● Select Position

● Select Members

● Arguments

● Missing Values

● Formula

2 Enter a name for the Calculation definition in Name.

3 Select the calculation type from Function.

The calculations type is displayed in the Function text box.

4 Position the calculation by selecting one option in Select Position:

● Front/Top

● Back/Bottom

● Insert Before

● Insert After

If you selected Insert Before or Insert After, select an insertion point from the corresponding
list. The calculated row or column is inserted before or after the specified dimension header.

5 Specify the arguments for the calculation by:

● Click a dimension member label and click the arrow button (>) to replace an undefined
argument (?) with the member.

● Enter a value in the Constant text box and click the arrow button (>) to replace an undefined
argument (?) with a value.

● Select Advanced to display dimension member combinations. Click to select a dimension
member combination label and click the arrow button (>) to replace an undefined argument
(?).

● Select All Members to quickly select all available dimension members.

● Select Ignore Calculations to exclude calculated members from the equation when All
Members is enabled.

● Select an argument and click the remove argument button (<) to remove an argument.

The calculation definition is displayed in Formula.

6 Optional: To indicate how the Calculations Analysis Tool should handle missing values, select one Missing
Values option:

● Include—Calculates missing values as they are stored.
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● Exclude—Removes arguments populated by missing values from the calculation.

● Treat as Number—Populates the argument with the value indicated. Default is zero (0).

The Opposite Member list in the arguments frame is enabled only for the Percent of Member
Calculation. This control evaluates a dimension member argument as a percentage of
another dimension member argument. The second argument is defined by the dimension
member intersected on an opposite axis.

7 Optional: To use Opposite Member:

● Select a Percent of Member calculation from the Function list.

● Select a dimension member argument.

● Select a dimension member from the opposite axis using the Opposite Member list.

8 When the calculation is defined, Click Apply and OK.

Modifying Calculations

➤ To modify a calculation:

1 Right-click a dimension member header and select Analysis Tools > Analysis Tools Manager.

The Analysis Tools Manager is displayed.

2 Click a calculation definition.

3 Click Edit.

The Calculation Definition dialog box is displayed the arguments for the selected calculation
definition.

4 Optional: To change the calculation definition name, enter a name in Name.

5 Optional: To move the calculation position, select another option.

6 Optional: If you selected Insert Before or Insert After, select an insertion point from the corresponding list.

The calculated row or column is inserted before or after the specified dimension header.

7 Optional: To change the calculation type, select a calculation type from Function.

Changing the calculation type requires that the user to redefine all arguments. For instructions,
See To create a calculation:.

8 Optional: To change the arguments for the calculation, perform one:

● Click an argument, click a dimension member label, and click the arrow button.

● Click an argument, enter a value in the Constant text box, and click the arrow button.

● Select Advanced to display dimension member combinations. Click an argument, click a
dimension member combination label, and click the arrow button.

The calculation definition is displayed in the Formula group box.

9 When the calculation is redefined, click Apply and OK.

10 Click Close.
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Analytic Services Attribute Calculations
Web Analysis Studio leverages server-based Analytic Services attribute calculations in the client.
Server-based calculations are performed by the server before returning the OLAP query result
set. This minimizes the result set and network traffic.

To use attribute calculations, you must use Cube Navigator to select the attribute calculations
dimensions to participate in the query. You must use Dimension Browser to select the server-
based calculations to be returned by the query result set.

Note:

You can reproduce attribute calculations in Web Analysis Studio, but the onus is on you to
define these calculations, and the client to process the result set.

Consider the use of attribute members in these calculations:

● You can select, aggregate and document on data sharing common attributes.

● You can select attributes by their data types: text, numeric, Boolean, and data type.

● You can group numeric data types into statistical ranges.

● You can use sum, count, min, max, and average functions on the attribute calculations
dimension automatically generated by Analytic Services.

● You can use numerical attribute values from calculation scripts and member formulas in
calculations.

● You can create crosstabs of attribute data for one dimension, and analyze the dimension in
terms of each attribute.

Creating SAP BW Currency Conversion Definitions
SAP BW converts data value currencies ad hoc during analysis, and saves conversion definitions
as analysis tools. You can activate and deactivate currency conversion definitions without
removing them from the Analysis Tools Manager, enabling currency combinations that differ.

➤ To create a currency conversion definition:

1 Right-click a dimension member header and select Analysis Tools > Currency Conversion.

The SAP Currency Conversion dialog box is displayed. Because exchange rates fluctuate, you
must indicate the exchange rates and supported currencies for a date. You can use the arrow
controls to the left and right of the current month and year, to scroll to another date.

2 Scroll to the month and year of a date, and click the cell for the date.

The selected date is highlighted.

3 In the Select Currency To list, select the currency to which you would like a currency converted.

Your options may be limited to the currencies supported by the date of your exchange rate.
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4 In the Select Currency Rate list, select the exchange rate used to convert currency.

5 In the Select Currency From list, select the currency that you would like to convert.

Your options may be limited to the currencies supported by the date of your exchange rate.

6 Click OK.

All data values using the last currency selection are converted to the specified currency, using
the specified exchange rate. Repeat this process to convert all data values to one currency.

Creating SAP BW Unit of Measure Conversion Definitions
SAP BW converts data value unit of measure ad hoc during analysis, and saves conversion
definitions as analysis tools. You can activate and deactivate unit of measure conversion
definitions without removing them from the Analysis Tools Manager, enabling unit of measure
combinations that differ.

Note:

To use the Unit of Measure Conversion analysis tool, the 0MATERIAL characteristic must be
selected as a data object column, row, or page dimension.

➤ To convert all units of a measure to another unit of measure:

1 Right-click a dimension member header and select Analysis Tools > Unit of Measure Conversion.

The SAP Unit Conversion dialog box is displayed.

2 From the Unit From list, select a unit of measure that you would like to convert.

3 From the Unit To list, select the unit of measure into which you would like your previous selection converted.

The drop-down list displays known conversion rates from your SAP BW 0MAT_UNIT table.
You must define a logical conversion for the analysis tool to work.

4 Optional: To define a custom unit of measure conversion using these steps:

a. From the Unit To list, select Custom Unit.

b. In Select Custom to Rate, enter a unit name in Unit Name.

c. Enter a custom conversion factor in Conversion Factor.

5 Click OK.

All data values using the specified unit of measure are converted using the standard or custom
conversion rate. Repeat this process to convert all data values to one unit of measure.
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Smart View
Hyperion® System™ 9 Smart View for Office™for Office provides a common Microsoft Office
interface for these Hyperion products:

● Analytic Services

● Financial Management

● Planning

● Hyperion® System™ 9 BI+™ Financial Reporting™

● Hyperion® System™ 9 BI+™ Interactive Reporting™

● Hyperion® System™ 9 BI+™ Production Reporting™

● Web Analysis

The centralized interface enables simultaneous use of multiple Hyperion products, and improves
integration with Microsoft Office (2000, 2002, and 2003). The Smart View implementation
provides this functionality:

● Exports the current page of the current data object to Excel, Word, or PowerPoint

● Exposes Financial Management and Analytic Services functions in Excel, Word, and
PowerPoint content

● Notifies you when to upgrade to later releases of Smart View.

Smart View enables these export options:
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● You can export the current page of the current data object to Word, PowerPoint or Excel
as an image. After insertion, you can requery the corresponding Web application to refresh
the image.

You can export documents to Microsoft Excel as query-ready HTML, or formatted HTML:

● When you export content as query-ready HTML, the current page of the current data object
is converted to HTML and Hyperion-specific formatting is removed. This enables Smart
View to requery the data source independent of the Web application.

● When you export content as Formatted HTML, the current page of the current data object
is converted to HTML with the Hyperion formatting definitions and calculated members.
This formatting content prevents Smart View from directly querying the data source, but
enables Hyperion content to be leveraged by Office applications.

Not all export options are supported by all data sources and Web applications.

Web Applications
Export Image to Microsoft
Word, and PowerPoint

Export Formatted HTML to
Excel

Export Query-ready
HTML to Excel

Analytic Services Yes Yes Yes

Financial Management Yes Yes Yes

Planning Yes Yes Yes

*

Financial Reporting Yes Yes Yes

Interactive Reporting N/A N/A N/A

Production Reporting N/A Yes N/A

Web Analysis Yes Yes Yes

*To export Planning data sources in query ready format, you must use the Analytic Services provider.

Because Excel worksheets prevent users from entering data into read-only cells, some Excel
functions such as AutoSum, F9, and some formatting functions are disabled in Smart View. Also
note that Microsoft Excel, Word and PowerPoint must be installed on the computer running
the Hyperion® System™ 9 BI+™ client.

Exporting Web Analysis Documents to Microsoft Office

➤ To export a page of a data object from the current Web Analysis document to Microsoft Excel,
Word, or PowerPoint:

1 Right-click a data object and select Export.

2 Select one option:

● Query-Ready > to Microsoft Excel.

● Format > to Microsoft Excel.

142 Exporting Documents and Presentations



● Image > to Microsoft Excel 2003, or to Microsoft PowerPoint 2003, or to Microsoft Word
2003.

Although the image is static, you can requery the Web application as needed.

Data is exported to the Microsoft Office application and displayed in a worksheet.

When exporting to Excel, using one of the three methods that populates cells of data (Query
Ready, Formatted, Unformatted), Web Analysis evaluates the number of rows and columns in
the data and if they are larger than the number of rows and or/columns in Excel, an error message
is displayed and the Web Analysis document is not exported.

Exporting to the Clipboard
Web Analysis Studio can export a page of a data object from an Web Analysis document to the
operating system clipboard.

➤ To export a page of a data object to the clipboard:

1 Right-click a data object and select Export Data.

2 Select one:

● To export a page of a data object as query-ready HTML, select Query-Ready > To Clipboard
from the submenu.

Note that query-ready HTML is stripped of Web Analysis Studio-specific content. This
enables Smart View to reconnect directly to the data source and query it independently of
Web Analysis Studio.

● To export a page of a data object as formatted data, select Formatted > To Clipboard.

Note that formatted data is converted to HTML with all Web Analysis Studio formatting
definitions and calculated members. This enables Smart View to leverage Web Analysis
Studio functionality in supported Microsoft Office applications. The data source however
cannot update or recognize formatted data generated by Web Analysis Studio.

You cannot export a static image of the data object to the Clipboard.

Export Data Unformatted
Data in a spreadsheet, chart, or pinboard can now be exported unformatted to Excel, Clipboard
or to a file. To access this, right click a report object and select Export > Unformatted.

When exporting data to Excel using the Unformatted option (Export Data > Unformatted >
To Microsoft Excel), filter dimensions with members selected are included in the Excel output.
For example, if a Web Analysis document against Analytic Services Sample Basic has the Scenario
dimension in the filter, and the member Budget is selected, the Budget member appears in the
Excel output above the column headers.
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Note:

This feature does not apply to the Query-Ready or Formatted export types.

Exporting to Tab Delimited Text Files
Web Analysis Studio can export a page of a data object of a Web Analysis document to a simple
text file delimited with tabs.

➤ To export the current data object to the clipboard or to a file:

1 Right-click a data object and select Export Data.

2 Select one:

● To export the current page of the current data object as query-ready HTML, select Query-
Ready > To File from the submenu.

Note that query-ready HTML is stripped of Web Analysis Studio-specific content. This
enables Smart View to reconnect directly to the data source and query it independently of
Web Analysis Studio.

● To export the current page of the current data object as formatted data, select Formatted >
To File from the submenu.

Note that formatted data is converted to HTML with all Web Analysis Studio formatting
definitions and calculated members. This enables Smart View to leverage Web Analysis
Studio functionality in supported Microsoft Office applications. The data source however
cannot update or recognize formatted data generated by Web Analysis Studio.

● To export the current page of the current data object as a static image, select Image > To
File from the submenu.

Note that while the image is static, you can use Smart View to re-query Web Analysis Studio
and update the image as needed.

The Save dialog box is displayed.

3 Navigate to the folder to save the file.

4 Enter a name for the document in Filename, and click OK.

Note:

Query-ready HTML and Formatted Data formats are saved with HTML suffixes, and exported
images are saved as JPG files.

Exporting Documents and Presentations
You can export documents and presentations to local computers and mapped drives. Exported
documents are appended with the ARD file name extension. Exported presentations are appended
with the APT file name extension. To export Web Analysis Studio content to Hyperion® System™
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9 Shared Services™, See “Exporting XML Document and Presentation Definitions to Shared
Services” on page 146.

Exporting the Current Document

➤ To export the current document, select File > Export > Current Document. In the Save dialog
box, indicate the network location to which the file is to be saved and click OK.

Exporting Documents and Presentations

➤ To export a document or presentation:

1 Perform one:

● Select File > Export > Documents.

● Select File > Export > Presentations.

The Open dialog box is displayed. It features a selection frame that lists the current folder
contents, specified by Location.

2 If not specified, select Web Analysis Document or Web Analysis Presentation from Files of Type.

3 Navigate to the document or presentation you want to open:

● In Location, type the path to the repository folder whose contents you want displayed, and
press Enter.

● In Location, click the drop-down arrow and select from the location series.

● When you navigate to another folder, you can click Back to return to the previous folder.

● Similarly, you can click Forward to display the next folder.

● Click Up to display the contents of the parent folder in the selection frame.

● Click Favorites to jump to the Favorites folder of the current user.

● Click the Favorites list to jump to the Favorites folder of groups.

● Click Home to jump to and display the contents of the current Home folder in the selection
frame.

As you navigate, the selection frame lists the files and folders indicated by Files of Type.

4 Select a document or presentation:

● To select one document from the selection frame, click the document name or icon.

● To select a series of documents from the selection frame, click a document name and press
and hold Shift while selecting another document name. The first selection, the last selection
and all documents in between are selected.

● To select multiple documents, not necessarily in a series, hold down Ctrl while clicking
document names in the selection panel.

● To deselect items, click outside the Name column or on empty white space.
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● Double-click to select and dismiss the Open dialog box.

5 Click OK.

The Save dialog box is displayed. It features a selection frame that lists the contents of the current
folder, specified by Look in. Note that Files of Type is set to Web Analysis Document Definition
(*apt, *ard, *arg).

6 Navigate to the network location where files are to be saved:

● Click Up to display the contents of the parent folder in the selection frame.

● Click Home to jump to and display the contents of the current Home folder (set in
preferences) in the selection frame.

● Click Look in to list mapped drives and network folder locations. Click a location name to
display its contents in the selection frame.

● Click the Create New Folder icon to create a folder at the current location.

7 Click to select a folder location in the selection frame.

8 Optional: Specify a name for the exported file in File name.

9 Click Save.

The files selected in the Open dialog box are converted to Web Analysis document definitions
and stored at the location specified by the Save dialog box.

Note:

The ARD and APT file suffixes are dropped when you export to a folder that has a period (.) in
it. To guard against this issue, do not use periods in folder names.

Exporting XML Document and Presentation Definitions to Shared
Services

To share Web Analysis Studio content with other Web Analysis Studio environments, you can
export Web Analysis document and presentation definitions to a configured Shared Services
server.

➤ To export Web Analysis Studio content to Shared Services:

1 Select File > Export > to Shared Services.

If your administrator has not established global Shared Services connectivity, you may be
prompted with the Shared Services dialog box. The Shared Services dialog box requires you to
provide a server name, port, user ID and password for connecting to Shared Services.

The Export to Shared Services dialog box is displayed.

2 In Repository, select the document or presentation to be exported.
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To expand or collapse the node tree double click a node, or click the plus sign (+) or minus sign
(-). To select, click the document or presentation name. Folder icons differ for presentations.
Documents are indicated by the page icon.

3 In Shared Services, perform one:

● Select a subfolder into which to copy Web Analysis Studio content.

● Create a subfolder for Web Analysis Studio content by right-clicking the document or
presentation folder and selecting New > Folder. Enter a folder name in the New Document
Folder dialog box, and click OK.

Each BI+ configuration registered with Shared Services is indicated by a root folder in the
Shared Services node tree. When you expand the root folder, a Default project folder is
displayed.

Project folders are required under the root folder. Project folders can be used to distinguish
departments or environments that differ. When you expand a Project folder, default
documents and presentations folders are displayed.

The documents and presentation folders under the project folder are also required. They
categorize the kind of content stored on Shared Services. You cannot export Web Analysis
document content into the Presentation folder or presentation content into a Reports folder.
The Export button is disabled when incompatible content and folders are selected.

Additionally, you are required to create subfolders for individual documents and
presentations in the documents and presentations folders.

The Export button is not enabled until you select files from the repository frame and a
compatible folder from the Shared Services frame. Remember, you may be required to create
projects and folders for exporting Web Analysis Studio content.

Note:

Slash (/) and backslash (\) characters are replaced with an underscore (_) during import and
export to prevent exception errors in Shared Services.

4 Click Export.

The selection from the repository frame is copied to the Shared Services frame. Click the
subfolder plus sign (+) to display subfolder content.

5 Click Close to return to the Analyze interface.

Saving As HTML

➤ To convert a document to HTML:

1 Select File > Save As HTML.

The Save As HTML menu is displayed.

2 Select one:

● Current Document
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● Presentation

The Save as HTML dialog box is displayed.

3 Specify a file name and a location for saving the output file, and click Save.

E-mailing Document Links
You can e-mail hyperlinks to the URL of the current document.

➤ To send a document link of the current document by e-mail:

1 Select File > E-mail As Link.

The E-mail As Link submenu is displayed.

2 Select one:

● Workspace—Presents the current document in the Workspace.

● Web Analysis Studio—Presents the current document in Web Analysis Studio.

The E-mail dialog box is displayed.

3 Enter the e-mail address of recipients under Add and Remove.

4 Click Add.

The E-mail address is displayed in the Recipients’ E-mail Address box.

5 Enter your e-mail address in Sender’s E-mail Address.

6 Replace the default subject string in Subject.

The Body group box is displayed the document link URL of the current document.

7 Click OK.
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Printing
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Printing Options
There are three printing options:

● Print Screen—Prints the content area.

● Print Selected Object—Prints the specified OLAP pages of the current data object.

● Print All Objects—Prints all data object in a Web Analysis document.

Print Screen prints the current display quickly and easily. Because documents can contain
multiple data objects, Print Screen does not specify OLAP pages. If you want to include OLAP
pages or object-specific document summaries, you should select Print Selected Object.

Print All Objects enables printing of all report objects on the current Web Analysis document.
The output format is similar to the format of Print Selected Object. Page members can be printed
for all report objects for which page members are defined.

Output options:

● Print the content area to the default printer.

● Print the content area to a PDF output file.

● Print the content area to a JPG output file.

● Print the current data object to the default printer.

● Print the current data object to a PDF output file.

● Print all objects to the default printer.

● Print all objects to the PDF output file.

● Print Preview

The Print dialog box features:
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● Page tab—Specifies the print output, layout orientation, how to break the output over
multiple pages, and whether a document summary page is included.

● Header/Footer tab—Defines custom headers and footers for print output.

An option at the bottom of these tabs enables you to save print specifications with the document
definition the next time the document is saved. Selecting "Allow print settings to be saved with
document" indicates that print specifications should be saved with the document. Otherwise
print specifications persist only as long as the document is open during the current session.

Print Dialog Page Tab
The Page tab specifies print output, layout orientation, how to break the output over multiple
pages, and whether a document summary page is included:

Control Description

Print To

Printer Directs print output to the default printer.

PDF Saves print output as a PDF file.

JPEG Saves print output as a JPG file.

Orientation

Portrait Prints the document with a portrait orientation.

Landscape Prints the document with a landscape orientation.

Scale

__ page(s) wide __ page(s) tall. Fit to page printing. Enables you to determine how document
content is broken down into print job pages.

Summary Page

Include a document page Automatically inserts a print summary into the printer output when
checked.

OLAP Pages

Page Selection Panel In Print Current Document context, specifies the OLAP page axis
dimensions to print.

Allow print settings to be saved with document Saves print specifications when the document is saved.

Print Preview Displays the Print Preview panel.

See also Print Dialog Headers/Footers Tab.
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Print Dialog Headers/Footers Tab
The Headers/Footers tab defines custom headers and footers for print output.

Control Description

Table Headers

Include row and column headers on all pages. Automatically inserts row and column headers on all pages when
checked.

Headers

Font Opens the Font Properties dialog box, enabling you to set font
properties for the current text selection.

Insert Adds a dynamic text label to the header at the location in the string
specified by the cursor. See “Dynamic Text Labels” on page 151.

Clear Deletes the content of the Header text box.

Header Text box Adds a header text string.

Footers

Font Set font properties for the current text selection.

Insert Adds a dynamic text label to the footer at the location in the string
specified by the cursor. See “Dynamic Text Labels” on page 151.

Clear Deletes the content of the Footer text box.

Footer text box Adds a header text string.

Allow print settings to be saved with document Enables you to save print specifications when the document is
saved.

Print Preview Displays the Print Preview panel.

See also Print Dialog Page Tab.

Dynamic Text Labels
You can add dynamic text labels to headers and footers, using the Insert button on the Print
Dialog Headers/Footers Tab. Dynamic text labels update themselves as strings are changed in
the repository.

Dynamic Text Tag Default Tag Inserts:

Database Note <<dbnote>> Database note in the label.

Cell Reference <cell 0,0>> Cell reference string in the label.

Page <<page>> Page dimension name in the label.
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Dynamic Text Tag Default Tag Inserts:

Filter <<filter 0>> Filter member name in the label.

Document Description <<rd>> Document description string in the label.

Document Name <<rn>> Document name string in the label.

Date/Time <<date,MM-dd-yyyy>> Date/time string in the label.

Connection Name <<cn>> Database connection name string in the label.

Username <<username>> User name string in the label.

UserID <<userid>> User ID string in the label.

Note:

Because custom documents can contain multiple data objects, dynamic text labels reference the
current data object (the spreadsheet, chart, pinboard, or SQL spreadsheet with the yellow
border).

Creating Dynamic Text Labels

➤ To create dynamic text labels, click the text string where the label is to be added, and select the
dynamic text label from Insert.

After dynamic text labels are placed in the text box, you can edit the tag to display additional
information.

Fixed References
Because dynamic text labels change as focus is shifted in composite documents, you may want
to fix the dynamic reference. Tags can be associated with specified data sources using these
modifications:

Dynamic Text Tag Default Tag Fixed Reference

Connection Name <<cn>> <<cn DataSourceName1>>

Cell Reference <<cell 0,0>> <<cell DataSourceName1,0,0>>

Filter <<filter>> <<filter DataSourceName1,0>>

Pages <<page>> <<page DataSourceName1>>

Database Note <<dbnote>> <<dbnote DataSourceName1>>

Note:

It is not possible to specify a fixed references for a page dimension member.
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Time Format Syntax
Time Format strings specify the format of the dynamic date/time label. The count of the ASCII
letter pattern determines the format used.

ASCIISymbol Meaning Type Example

G Era Text AD

y Year Number 2002

M Month in Year Text & Number July & 07

d Day in Month Number 10

h Hour in am/pm (1-12) Number 12

H Hour in Day (0-23) Number 0

m Minute in Hour Number 30

s Second in Minute Number 55

S Millisecond Number 978

E Day in Week Text Tuesday

D Day in Year Number 189

F Day of Week in Month Number 2 (meaning 2nd Wed in July)

w Week in Year Number 27

W Week in Month Number 2

a am/pm marker Text PM

k Hour in Day (1-24) Number 24

K Hour in am/pm (0-11) Number 0

z Time Zone Text Pacific Standard Time

' (apostrophe) Escape for Text Delimiter  

' ' (single quote) Single Quote Literal '

When four or more Text type letters are used, the full form is provided.

When three or more Text & Number type letters are used, text is provided. When only one or
two letters are provided for this type, the number is provided.

Numbers use the minimum number of digits. Year can be truncated to two digits. Shorter
numbers are zero-padded.

All other characters are used as quoted text strings.
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Examples
"yyyy.MM.dd G 'at' hh:mm:ss z" returns 1996.07.10 AD at 15:08:56 PDT

"EEE, MMM d, 'yy" returns Wed, July 10, '96

"h:mm a" returns 12:08 PM

"yyyyy.MMMMM.dd GGG hh:mm aaa" returns 1996.July.10 AD 12:08 PM

Printing

➤ To print:

1 Perform one:

● Select Print from a data object shortcut menu.

● Click .

● Select File > Print.

● Press Ctrl+P.

The Print dialog box is displayed.

2 Select one from Context:

● Print Screen—prints the content area.

● Print Selected Object—prints the current data object of the current document.

● Print All Objects—prints all data object in a Web Analysis document.

Context determines the scope of the print job. Numerous print options are available on the
Page and Headers/Footers tabs.

3 On the Page tab, select one from Print To:

● Printer—Sends the print job to the default printer.

● PDF File—Sends the print job to a PDF output file.

● JPG File—Sends the print job to a JPG output file (Screen only).

Select other print options on the Print Dialog Page Tab and Print Dialog Headers/Footers
Tab.

4 Click Print.

Depending on your Print To list selection, a dialog box is displayed:

● Operating System Print window—To select a network printer.

● Operating System Save dialog box—To select a network location.

5 Click OK.
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Print Preview

➤ To preview the print job before printing:

1 Select one:

● Print from a data object shortcut menu.

● Click .

● File > Print.

The Print dialog box is displayed.

2 Click Print Preview.

The Print Preview dialog box is displayed.

3 Optional: To magnify or minimize the print preview, select Zoom list and select a size ratio option (25%,
50%, 75%, or 100%).

4 Click OK to return to the Print dialog box.
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Database Connections
Database servers typically use a server name, application name, and database name in the
creation of unique identifiers. The nature of these identifiers makes database references less
portable. Web Analysis Studio uses user-friendly database aliases instead of long identifiers. Not
only are database connection names easier to remember and more economical to employ, they
enable the database to be maintained on multiple servers.

In short, database connections are portable files that define the terms, conditions and method
for connecting to a data source.

System requirements vary for RDBMS (see the Hyperion System 9 BI+ Installation Guides), and
you must compose a database connection string and provide log on credentials to navigate your
relational hierarchy. You can also connect to level 2 or level 4 JDBC RDBMS using other
relational data objects (SQL Spreadsheet, freeform grid, relational drill-through and Analytic
Integration Services drill-through).
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The View Pane Information Panel tab displays the database connection used by the current data
object. The Information panel features two database connection segments:

● The Database segment displays the database connection name for the current data object.

● The Database User Name segment displays the user ID by which access to the database
connection is granted.

Database Connections
Database connections are stored as repository files and adhere to most file management
conventions. You can only see the database connections to which you are granted access. Various
permissions are needed to read, write, edit, and change database connection properties.

Database Connection Access and Document Permissions
It is possible to distribute a document or presentation to a user that requires database connections
he or she cannot access. Document access is independent of database connection access.

Database connection permissions withholding access prevent access to only one database
connection file. You are free to compose another database connection to this data source, or to
compose a database connection to an alternate data source. You can leverage the document
definition independently of a database connection.

See “Setting File Properties” on page 49.

User and Group Permissions
You can access database connections assigned directly to you or database connections assigned
to a group to which you belong.

When documents are assigned to a group, the database connections that the document uses
must also be assigned to the group. Otherwise, group members can access the document, but
they cannot access its data values (unless they have individual user access).

To mitigate the risk of conflicting permissions, store documents with the database connections
they reference. Whenever possible, distribute documents and database connections to groups.
It is easier to set permissions for all files in a folder, and all users in a group than it is to manage
permissions for individual files and individual users.

Creating OLAP and Hyperion Database Connections
The database connection wizard guides you through the creation of OLAP and Hyperion
database connections. You must know the name of your server, application, and database, and
have log on credentials.
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➤ To create a document using the document creation wizard:

1 Perform one:

● Select File > New > Database Connection.

● Click , and select Database Connection.

2 From Database Connection, select a database connection:

● Analytic Services

● Financial Management

There is an SAP BW and Relational option. See “SAP BW Features Available in Web Analysis
Studio” on page 173 and “Creating Relational Database Connections” on page 180.

The Process bar displays steps for creating a database connection: Server, Database,
Formatting, and Drill-through. On the Server page, you must enter the server name of your
data source server, and the log on credentials used to access it.

3 In the Database Server text area, enter the name of the data source server.

4 In the Logon Information group, enter a user ID and password for accessing the data source server.

The current user ID and password are entered by default, in case the data source server uses
credentials that match.

5 Optional: If you want to save the credentials , select Save User ID and Password.

6 Click Next.

Clicking Next queries the data source for application and database information. The content
area displays the Database page.

7 From the list of Available Databases on the right, select a database.

Databases are listed by application. When you select the database, the application and database
name are loaded into the text area on the left.

Note that Next and Finish are enabled at the lower right of the content area. The last two steps
of the database connection wizard are optional. If you do not want to specify Measures
Formatting or Relational Drill-through connectivity, click Finish.

8 Select one:

● Click Next, to specify Measures Formatting or Relational Drill-through connectivity.

● Click Finish, to skip these optional steps. If you click Finish, skip to step 12.

Clicking Next queries the specified database for dimension information. The content area
displays the Formatting page.

9 Optional: To specify measures formatting for the database connection, select a dimension from Formatted
Dimension.

10 Optional: Specify a measures formatting definition, by selecting from these options:

Creating OLAP and Hyperion Database Connections 159



Formatting Option Description

Formatted Dimension Specifies the dimension to which the formatted member belongs.

Advanced Member Selection Specifies the single member or single advanced member selection to which the
formatting definition is applied.

Leading and Trailing Formatting  

Currency Symbol Inserts the currency formatting symbols into the Positive Prefix and Negative Prefix
text boxes: Dollar ($), Cents (¢), Pound (£), Euro(E), Deutschmark (DM), Franc
(F), and Yen (¥).

Positive Prefix Enters character to precede positive numeric values.

Positive Suffix Enters character to follow positive numeric values.

Negative Prefix Enters character to precede negative numeric values. Warning: The minus sign
(-) is the default prefix. Deleting the default prefix without replacing it causes
negative values to display positively.

Negative Suffix Enters character to follow negative numeric values.

Numeric Formatting  

Grouped Thousands Displays numeric digits as grouped by thousands.

Maximum Decimals Indicates the maximum number of decimal places to display.

Minimum Decimals Indicates the minimum number of decimal places to display.

Replace Missing With Replaces missing values with a text string or zero as indicated by the option.

Font  

Header Font Displays the Font Properties dialog box, for specifying Font family, point size,
style, and color for the dimension header label.

Data Font Displays the Font Properties dialog box, for specifying Font family, point size,
style, and color for the cell data values.

Note that Next and Finish are enabled at the lower right of the content area. The last step of the
database connection wizard is optional. If you do not want to specify Relational Drill-through
connectivity, click Finish.

11 Select one:

● Click Next, to specify Relational Drill-through connectivity.

● Click Finish, to skip this optional step.

If you click Next, the content area displays the Drill Through page. See “Creating Relational
Drill-Through” on page 163.

After clicking Finish, the Save As dialog box is displayed. It prompts you to navigate to the
repository location where you would like the database connection file saved.

12 Navigate to the folder into which you want to save your database connection file:
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● Click Up to display the contents of the parent folder in the selection frame.

● Click Home to jump to and display the contents of the current Home folder (set in
preferences) in the selection frame.

● In Location, type the path to the repository folder whose contents you want displayed, and
press Enter.

● In Location, click the drop-down arrow and select another location from the repository
drop-down list.

● When you navigate to another folder, you can click Previous to return to the last folder
displayed in the selection frame.

● Similarly, you can click Next to display the next folder in the location series.

As you navigate, the selection frame lists the files and folders indicated by Files of Type.

13 Optional: When you reach the location where you want to save the file, enter a name for the database
connection in Filename.

14 Click OK.

Your database connection file is saved to the specified repository location.

Database Connection Properties
Database connection properties are set when the database connection is defined. You define
database connections using the database connection wizard. Database connection properties
include:

● Servername

● Log on credentials

● Application and database names

● Measures formatting

● Relational drill-through connectivity

It is important to differentiate properties.

● Database Connection properties—Define the terms, conditions, and method for connecting
to a data source. They are set using the database connection wizard.

● File Properties—Determine identification and access to the database connection. They are
set using the File Properties dialog box.

● Data Object Properties—Specify which database connection is used by the data object.

● Preferences—Specify database connection options that are set for each user (such as log on
credentials, alias table, POV definitions, and personal variables).

See also “Measures Formatting” on page 162, “Creating OLAP and Hyperion Database
Connections” on page 158, “Integrating OLAP and Relational Data” on page 162, and “Creating
Relational Drill-Through” on page 163.
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Note:

If you edit the Server Name, Application Name, or Database Name parameter values, you cannot
load documents created using parameter values that differ. A better practice is to create a database
connection with the desired parameter values.

Measures Formatting
Measures formatting enables you to globally format one dimension used by an OLAP database
connection. This global formatting includes leading and trailing characters, numeric formatting
of numeric dimension values, and header and data formatting.

Measures formatting options differ from those of data formatting and default formatting
preferences. See “Formatting Order of Precedence” on page 94.

You can define measures formatting using an explicit member selection or advanced member
selection. Using advanced member selection makes the measures formatting dynamic. As
members are added deleted and changed in the database, the formatting maintains itself and
does not become obsolete.

See “Creating OLAP and Hyperion Database Connections” on page 158.

Integrating OLAP and Relational Data
You can construct liaisons between OLAP and relational data sources, typically called relational
drill-through. After relational drill-through is configured, you can drill from the dimension
bottom (level 0) of the OLAP database to specified relational data.

Relational drill-through is a client-based integration solution comparable to the server-based
Analytic Integration Services drill-through.

The Relational Drill-Through dialog box is a graphical user interface for creating SQL relational
database queries. You can use complex SQL syntax to specify table joins, and select and order
by clauses.

Note:

To support a broad array of JDBC relational data sources, relational drill-through does not
support queries by levels, generations, or previously selected members.

Relational drill-through is configured as a database connection property of an OLAP database
connection. You can set database connection properties through the database connection
wizard:

● Select File > New > Database Connection > Analytic Services or Financial Management.

●

Click , and select Database Connection > Analytic Services or Financial Management.
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● In the View Pane Browser tab, right-click an OLAP database connection in the Selection
frame and select Edit. The database connection wizard for the selected database connection
is displayed. Relational drill-through is set by the last step in the wizard process.

Defining Relational Drill-through
Upon accessing the Modify Relational Drill-through Connection dialog box, you complete these
tasks in the creation of relational drill-through navigation:

1. Define a JDBC RDBMS connection, using the Configure JDBC Driver dialog box.

2. Test the connection.

3. Indicate the relational database table name.

4. Update the Columns list.

5. Map relational columns to dimensions in the OLAP database.

6. Indicate whether to pass filter dimensions or page dimensions and a row limit (if ).

7. Click Apply.

For instructions for creating relational drill-through navigation, See “Creating Relational Drill-
Through” on page 163.

Controlling Query Result Set Size
Query governors vary for relational access methods.

Custom document SQL spreadsheets and relational drill-through methods set query governors
in the course of creating the SQL query or relational drill-through definition.

When drilling from OLAP to relational data, passing only the drilled OLAP dimension member
to the relational data source may result in a large query result set. To focus and diminish the
query result set, you can pass page and filter dimensions specified in the OLAP document.

Other relational access methods rely on the Webanalysis.properties file to limit the query
result set.

Creating Relational Drill-Through
Users with privileges can create relational drill-through connections using the Database
Connection wizard. You must know the name of the relational database table that you intend
to access before beginning.

➤ To create a relational drill-through definition on an OLAP database connection:

1 Perform one:

● Select File > New > Database Connection > Analytic Services or Financial Management.

● Click , and select Database Connection > Analytic Services or Financial Management.
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● In the View Pane Browser tab, right-click an OLAP database connection in the Selection
frame and select Edit. The database connection wizard for the selected database connection
is displayed.

The first two options create a database connection. The last option enables you to define
relational drill-through on an OLAP database connection.

The Process bar displays the steps for creating a database connection: Server, Database,
Formatting, and Drill-through.

This procedure describes the creation of a relational drill-through definition on an OLAP
or Hyperion database connection. See also “Creating OLAP and Hyperion Database
Connections” on page 158.

2 On the Server, Database, and Formatting page, click Next until the Drill-through page is displayed.

Do not click Finish, or the wizard close without defining a drill-through connection.

3 On the Drill-through page, select Define Relational Drill-through Connection.

The Configure JDBC Driver dialog box is displayed. To successfully create a JDBC RDBMS
connection, you must know the kind of relational data source you are accessing, the parameters
needed to connect to it, and have a user name and password that supports connectivity.

4 Select one from Driver Type.

● IBM DB2

● Microsoft SQL Server

● Oracle

● Teradata

● Other

Your JDBC driver selection populates the Database Connection String text area with a
relational database connection string. If you selected Other, you must define your own JDBC
connection string.

5 In Database Connection String, supply values for variables.

Depending on the driver type, there are variables for host name, database name, port, and DSN.
You must replace the brackets and the variable.

6 Enter a JDBC user name in Username.

7 Enter a password for the user name in Password.

8 Click Test Connection to verify connectivity.

If the connection fails, repeat steps 6 through 10 until you can establish successful relational
database connectivity. Make sure you remove the brackets from string variables.

9 After you connect, close the message and click OK.

The Modify Relational Drill-through Connection dialog box is displayed. With this dialog box,
you can redefine a JDBC RDBMS connection, test the connection, identify a relational table,
specify a column, and finally map the column to an OLAP dimension.

10 Enter a relational database table name in From.
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11 Click Update Columns.

Column names for the specified table are displayed in the Column Name list at the bottom of
the dialog box.

12 Designate the OLAP dimensions from which you connect to these table columns. To do this, you must
understand the relationship between OLAP and relational data:

a. Click a cell in the Related Dimension column opposite a relational column name to which
you would like to connect OLAP data.

The clicked cell presents a drop-down list with the dimension list of the OLAP database
connection.

b. Click to select an OLAP dimension.

Repeat the process of mapping relational database columns and OLAP dimensions until
your mappings are complete.

13 Optional:

● Click Pass Pages to maintain the current OLAP pages as you drill into relational data.

● Click Pass Filters to maintain the current OLAP filters as you drill into relational data.

● Set row limits for the query result set in the "Max rows to return" text box. This protects
server and network resources from being consumed unintentionally by very large query
result sets.

● Specify SQL Select, Where, and Order By clauses to narrow the relational query result set.

14 Click OK.

15 Click Finish.

Your relational drill-through definition is saved as a database connection property.

Analytic Services Database Connections
These Analytic Services features are extended through Web Analysis Studio:

Restrict Data
The Restrict Data Analysis Tool enables you to narrow the return set by requiring data values
to be relevant to rules and operands. Data can be filtered by comparison to another column or
by fixed limits on one column.

See “Restricting Data” on page 124.

Retrieve Only Top/Bottom
The Retrieve Only Top/Bottom Analysis Tool leverages Analytic Services sorting and ranking to
control the size and order of an OLAP query result set. This protects the network server from
transmitting, and the client from processing, large result sets.
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See “Retrieve Only Top/Bottom” on page 126.

Edit Data
Users with permissions can edit data values and write edits back to the Analytic Services database.
After edits are applied, you can recalculate the database and measure the impact of changed
values.

See “Editing Data Values” on page 245

Suppress Missing Rows, Zeros, and Shared Members
Web Analysis Studio leverages Analytic Services to suppress missing rows, zeroes and shared
members from the query result set. This prevents irrelevant information from being returned,
reduces network traffic and increases query speed.

Label Mode and Alias Tables
Label mode enables you to select whether a dimension member is listed by ID number,
description, or both. Label mode options are database-specific, and can be set for database
connections, documents, and dimensions.

Although the label mode indicates whether the description or ID number is used, it is Analytic
Services alias table definitions that provide the displayed value.

See “Alias Tables” on page 267.

Analytic Services Drill Settings
Web Analysis Studio uses Analytic Services features to provide customizable drilling navigation
in three ways:

● The nature of the hierarchical navigation

● Whether the current dimension members are replaced or augmented

● Whether the drilled dimension member is replaced or augmented

See “Drilling Variations” on page 90.

LROs
Analytic Services LROs enable user to annotate data values by associating external media with
a cell. LRO types include:

● Text documents

● File Attachments

● URLs
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See “Related Content Definitions” on page 255.

Relational Drill-through
Web Analysis Studio enables you to drill through to related relational data from the lowest level
of the Analytic Services outline, by defining a link on Analytic Services database connections.
You can pass pages, filters, and row limits to focus and control the relational query result set.

See “Defining Relational Drill-through” on page 163.

Analytic Integration Services Drill-through
Analytic Integration Services enables you to organize, format, and present relational data as an
OLAP cube in Analytic Services. Web Analysis Studio you to access Analytic Integration Services
document data through Analytic Services LROs by drilling on cells marked for Analytic
Integration Services drill-through.

See “Analytic Integration Services Drill-Through” on page 253.

Analytic Services Advanced Member Selection
In dimensions with large member sets, you can easily define selections with the Dimension
Browser shortcut menu. Right-clicking dimension member names enables selection by familial
relationship and database-specific selection options.

See “Advanced Member Selection” on page 66.

Attribute Dimensions and Attribute Calculations
Analytic Services can store dimension member names, locations, and relationships, and
characteristics about members. Analytic Services does not store attribute dimensions as part of
the OLAP cube, but instead dynamically calculates them upon request. Attribute dimensions
are displayed in dimension hierarchies and used in calculations in the same manner as dimension
members, despite being stored differently.

Analytic Services Metadata Security and Web Analysis
Document Design
If metadata security is established, when you create Web Analysis documents against Analytic
Services cube, adhere to these guidelines:

If report member selections contain dimensions that are specified in a METAREAD filter, use
dynamic member selections (for example, Children of East) and use only members that users
can access. Users accessing a Web Analysis document that contains members that they cannot
access receive an “Unknown Member” error.
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For example, If METAREAD filter applies to the Market dimension and @Children(East) is
specified, when users try to open the Web Analysis document with the METAREAD filter,
Unknown Member is displayed, because the user cannot access West, South, and Central.

Note:

Users cannot access the West, South, and Central members and their children.

Financial Management
These Financial Management features are extended through the Web Analysis Studio graphical
user interface:

● Org by Period

● Financial Management-specific Advanced Member Selection

● Financial Management Cell Text - Related Content

● Financial Management Line Item Detail - Related Content

● Financial Management Advanced Member Selection Methods

● Financial Management User Defined Fields

● Display Entity Currency

Financial Management Related Content
The Related Content dialog box indicates links to previously configured related content and
applications.

When Linked Reporting Object Indicators are enabled, blue triangles are displayed in the
spreadsheet cells containing links to related content. Right-clicking these cells and selecting
Related Content, displays the Related Content dialog box.

These Financial Management features are accessed as related content:

Cell Text
Web Analysis Studio users can launch Cell Text notes stored in the Financial Management data
source. The text string is read-only.

Line Item Detail
Web Analysis Studio users can launch Line Item Detail spreadsheets stored in the Financial
Management data source. Line Item Detail information is displayed in a read-only relational
spreadsheet.
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Recalculating Financial Management
Changes to Cell Text and Line Item Detail items are not displayed in Web Analysis Studio until
Financial Management is recalculated and the changes registered.

Org By Period
Financial Management Organization by Period functionality allows an organization’s latest
consolidation structure to coexist with past structures in one application.

Dimension member hierarchies can be consolidated differently during different periods.
Organizational structures can change for m reasons, including acquisitions, disposals, mergers,
and reorganizations.

Web Analysis Studio users can access Org by Period functionality when Org by Period is
configured and set on the Financial Management server.

When querying Financial Management database connections configured with Org by Period,
the Cube Navigator Options button displays an Org by Period menu item. The Org by Period
dialog box offers you an interface for enabling Org by Period and selecting three corresponding
dimension members.

See "Managing Metadata" in the Hyperion System 9 Financial Management Administrator's
Guide.

Financial Management Advanced Member Selection
In dimensions with large member sets, you can easily define selections with the Dimension
Browser shortcut menu. Right-clicking dimension member names enables selection by familial
relationship and database-specific selection options. See “Advanced Member Selection” on page
66.

Financial Management offers a smaller set of advanced member selection methods than its
Analytic Services counterpart. Typical Financial Management-specific advanced selection
methods include:

Method Description

All Members Selects all dimension members. This member selection method is specific to
Financial Management.

Select Dim Top Selects the highest ancestor.

Select Dim Bottom Selects the lowest descendants.

Also Select Descendants Selects the currently selected member and its descendants.

Member List Displays the Member List dialog box, for selecting predefined lists of dimension
members. This member selection method is specific to Financial Management.
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Method Description

User Defined Fields 1, 2, and 3 Displays the User Defined Field dialog box, enabling you to select dimension
members with User Defined Field values.

Search Displays the Search dialog box, used to locate dimension members.

User Defined Fields
User Defined Fields are typically defined only for Account, Scenario, Entity, and custom
dimensions, and they are limited to 20 characters.

You can compose compound selection statements using values that differ for a User Defined
Field (for example, User Defined Field 1= West AND User Defined Field 1= East.).

You cannot define a User Defined Field with an empty string as a value.

Display Entity Currency
Financial Management stores currency metrics in the Value dimension, and as an attribute of
the Entity dimension. This enables you to query the data source using a selected currency value,
or a default currency value.

When using an Financial Management data source with defined Entity dimension currency
information, you can enable the Display Entity Currency option, to append the Entity dimension
members with your default currency value. This can be set before querying using Cube Navigator
options, after querying using the Data Display shortcut menu, and for all subsequently created
documents using OLAP Server preferences.

Financial Management Conventions
Financial Management supports 12 dimensions in outlines. Four are custom and eight are
predefined: Period, View, Entity, Account, ICP, Scenario, Value, and Year.

No Drill To Top
If you query Financial Management, you cannot drill to top as you can when querying Analytic
Services. Financial Management tracks parent-child relationships differently than Analytic
Services. The Financial Management hierarchy enables multiple consolidations, which enables
the existence of multiple parents for child.

No Edit Data
You cannot write data back to the Financial Management data source, as you can in Analytic
Services.
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Adding and Deleting Dimension Members
You must click the Reload button before dimensions with added or deleted members can be
displayed.

New Financial Management Databases
Current sessions of Web Analysis Studio cannot interact with Financial Management data
sources added during the course of the session. Only those data sources operating when the Web
Analysis Studio session is established can communicate with Web Analysis Studio. To connect
to new Financial Management databases, log off and log on again.

Deleted Financial Management Users
After you establish a Web Analysis Studio session with Financial Management, your access is
not revoked under the sessions ends (that is, until you log out). This applies even when your
user ID is deleted server-side.

SAP BW

SAP BW Pre-requisites
To access SAP BW data sources you must first install SAP JCo driver on the Web Analysis Studio
server. After installation, you must provide these SAP Logon parameters to create an SAP BW
database connection:

● Host name or IP address of the SAP BW server

● Router string

● User name and password

● Client number

● System number

● Language

SAP BW Conventions
SAP BW conventions differ from other data sources. For example, Level 0 is the highest ancestor
in SAP, as opposed to the lowest descendant in Analytic Services. SAP Member Properties are
analogous to Analytic Services attribute dimensions.

BI+ supports these SAP InfoProviders:

● InfoCubes

● ODS Objects
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● InfoSets

● BEx Query Cubes

● Multiproviders

SAP BW Advanced Member Selection
In dimensions with large member sets, define selections with the Dimension Browser shortcut
menu. Right-clicking dimension member names enables selection by familial relationship and
database-specific selection options. See “Advanced Member Selection” on page 66.

Option Selects

All Members All dimension members. This member selection method is specific to Financial
Management.

Select Dim Top The highest ancestor, or in multiple hierarchies all top level ancestors.

Select Dim Bottom All lowest level descendants.

Also Select Descendants The currently selected member and its descendants.

Select Parent The direct parent of the currently selected member.

Also Select Ancestors The currently selected member and its ancestors.

Also Select Children The currently selected member and its children (one level below).

Also Select Siblings The currently selected member and members on one level with a shared parent
ancestor.

Also Select Level The currently selected dimension member and all dimension members on one level.

Select At Level All members at a specified level of the dimension hierarchy. You can specify the level
by name or number.

Also Select Previous A variable number of previous members from the right-clicked member's level. Uses
the MDX LAG command to indicate the number of previous members to return.

Also Select Next A variable number of next members from the right-clicked member's level. Uses the
MDX LEAD command to indicate the number of subsequent members to return.

Date Time Series Time dimension members based on time definition criteria. SAP BW does not return
aggregated values for DTS selections, and returns only the members that satisfy the
criteria.

Select Top/Bottom A variable number of dimension members based on their rank by another specified
dimension member.

You can select the top values or the bottom values. Rank can be calculated by
percentage, sum, or count. Sum uses a threshold value to select dimension members
up to and including the value that exceeds the threshold.

Result sets may differ from dimension browser preview, due to the influence of custom
filter selections on the query.
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Option Selects

Filter on Member Properties Displays the Member Properties dialog box, for selecting a subset of members by their
SAP BW member property values.

Find in Tree Locates dimension members in large dimensions. Find In Tree expands the dimension
hierarchy, but does not add found members to the Selection list.

SAP BW Features Available in Web Analysis Studio
Web Analysis Studio extends these SAP BW features:

● SAP BW Variables

● SAP BW Period To Date

● SAP BW Top Bottom

● SAP BW Member Properties

● Searching for SAP BW Characteristic Values

● SAP BW Currency Conversion

● SAP BW Unit of Measure Conversion

Creating SAP BW Database Connections
Before beginning, you must know the host name of your server or IP address, router string, client
number, system number, language, catalogue, and cube, and have log on credentials.

➤ To create a document using the document creation wizard:

1 Perform one:

● Select File > New > Database Connection > SAP BW

● Click , and select Database Connection > SAP BW.

The Process bar is displayed the steps for creating an SAP BW database connection:
Server, and Database. The content area displays the Server page.

2 In SAP BW Server, enter the host name or IP address of the server.

3 In Router String, enter the SAP BW server router string.

4 Enter a user ID, password, client number, system number, and language.

The current user ID and password are entered, in case known server credentials are used.

5 Optional: To save these credentials, select Save User ID and Password.

6 Click Next.

Clicking Next queries the data source for catalogue and cube information. The content area
displays the Database page.
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7 From Available Databases, select a cube.

Cubes are listed by catalogue. When you select the cube, the catalogue and cube name are loaded
into the text area on the left.

To search for an InfoProvider:

a. Under Enter search criteria, enter the criteria by which to search.

b. Under Search by label, select whether to search for the InfoProvider based on the technical
name, the description, or both.

c. Click Search.

d. Based on the search criteria entered, Web Analysis displays the technical name of the
InfoProvider, the description of the InfoProvider, or both under Available Databases.

8 Select Finish.

SQL Server Analysis Services

SSAS Prerequisites
To access SSAS, you must first install the SSAS client. For example, 2000 (version 8) from Pivot
Table Services install or 2005 (version 5) from OLE DB 9 installer. The other pre-requisites are:

● Install and configure BI+

● User authorization for Web Analysis

● Access to Microsoft SQL Server Analytic Services as a data source

● Access to the SSAS database and/or your own database

SSAS Advanced Member Selections

Option Selects

Also select Children The currently selected member and its children (one level below).

Also select Level The currently selected dimension member and all dimension members on one level.

Also select Previous A variable number of previous members from the right-clicked member's level. Uses the MDX
LAG command to indicate the number of previous members to return.

Select Dim Bottom All lowest level descendants.

Date Time Series Time dimension members based on time definition criteria. SSAS does not return aggregated
values for DTS selections, and returns only the members that satisfy the criteria.

Select Top/Bottom A variable number of dimension members based on their rank by another specified dimension
member. You can select the top values or the bottom values. Rank can be calculated by
percentage, sum, or count. Sum uses a threshold value to select dimension members up to
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Option Selects

and including the value that exceeds the threshold. Results may differ from dimension browser
preview, due to the influence of custom filter selections on the query.

SSAS features available in Web Analysis Studio
The SSAS features available in Web Analysis Studio are:

● Suppress Missing data or zero

● Select ID/member vs Description/Alias per dimension

● Multiple Hierarchies

● Ragged Hierarchies

● Linked Cubes

● Large Dimensions (1-Million+ Members)

● Cell-Level & Dimension-Level Security

● Data Mining & Mining Dimensions

● Connection Pooling

● MSAS 2005 Aggregates

● Local Cube support

● Server-side Top/Bottom and Hierarchical Sort

SQL Server Analysis Services Connectivity
To connect to Microsoft SQL Server Analysis Services, a Database Connection is needed. If a
database connection exist, proceed to Step 2.

1. If no database connection exist:

● In Web Analysis Studio, select File > New > Database Connection > SSAS.

● For SSAS Server, User ID, and Password enter the required information and click Next

● Select a cube and click Finish.

● Enter a database connection name in the Save dialog box.

2. To create a document, select File > New > Document Wizard.

3. Click Browse and select an SSAS database connection.

4. Select Auto Populate Dimensions and click Next

5. From Filters add one or more dimensions toRows.

6. Double-click a dimension in Rows and select members.
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Note:

You can right click a member to use dynamic member selections.

7. From Filters add one or more dimensions to Columns

8. Double-click a dimension in columns and select members

9. Click Next to select Page members or click Finish to complete.

Relational Access
There are five methods for accessing relational data from the Web Analysis Studio client:

SQL Spreadsheet
SQL Spreadsheets represent relational data sources as spreadsheet, using standard SQL syntax
queries. See Chapter 14, “Creating SQL Spreadsheets.”

Freeform Grid
Freeform grids enable you to combine data values from multiple data sources in one data object.
See Chapter 15, “Creating Freeform Grids.”

Relational Drill-through
Web Analysis Studio users can construct liaisons between OLAP data and relational data sources.
This navigation from OLAP to relational data is called "relational drill-through." After
configuration, you can drill from the bottom of OLAP dimensions (level 0) to relational data.

Web Analysis Studio stores relational drill-through definitions as database connection
properties of an Analytic Services database connections. The query result set is presented in the
format of the SQL Spreadsheet described above. See “Integrating OLAP and Relational Data”
on page 162.

Relational Database Connection
Relational database connections specify a relational database type and login credentials and
relational tables, and define the properties of the database connection and cube. Web Analysis
Studio clients query the specified relational data source, aggregate the result set, and express data
in the format of an OLAP cube.

Analytic Integration Services Drill-through
Analytic Integration Services Drill-through is a server-based form of relational drill-through.
Like conventional relational drill-through, you can construct liaisons between OLAP and
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relational data sources. Unlike conventional relational drill-through, you can drill to the
relational document from intersection in the Web Analysis document.

Your Analytic Services Administrator must establish Analytic Integration Services drill-through
documents. The relational query is stored as Intersection metadata, and flagged with an LRO
indicator. When you double-click flagged cells, the OLAP document navigates to the specified
relational document.

See “Analytic Integration Services Drill-Through” on page 253.

Controlling Query Result Set Size
Query governors vary for relational access methods.

SQL spreadsheets and relational drill-through methods enable you to declare query governors
while creating SQL queries or relational drill-through definitions.

When you drill from OLAP to relational data, passing only the drilled OLAP dimension member
to the relational data source may result in a large query result set. To focus and diminish the
query result set, you can pass OLAP page and filter dimensions.

Other relational access methods rely on the WebAnalysis.properties file to limit the query
result set.

Relational Database Connections
Before beginning, you must know the kind of supported JDBC RDBMS to which you are
connecting, the name of your server and database, and have log on credentials. You also must
know the organization and content of relational tables, to select and map column and table
selections to a fact table.

Connection Page
The first relational database connection wizard panel, Connection, requires you to configure a
JDBC driver by specifying a supported relational database, editing the database connection
string, and providing database login credentials.

Text box or Control Description

Driver Type Selects one of the supported relational databases:

● IBM DB2 7.2 Personal Edition

● IBM DB2 7.2 fp7 and 8.1 fp2 Workgroup and Enterprise Edition

● Microsoft SQL Server 2000 sp3

● Oracle 8.1.7 and 9.2.1

● Teradata 4.1

JDBC Driver Displays the Java Database Connectivity Driver.
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Text box or Control Description

Database Connection String Provides a sample database connection string syntax. Edit the string until it specifies
the RDBMS computer name and database name.

Username Indicate a user name for the relational database. Important! You cannot create
relational database connections without a user name and password.

Password Indicate a password for the user name. Important! You cannot create relational
database connections without a user name and password.

Test Connection Click to test the relational connection before proceeding.

Important notes on JDBC drivers:

The JDBC driver connects the application server hosting Web Analysis Studio and the relational
database, not the client computer. You must ensure that the application server is able to connect.

Web Analysis Studio currently supplies all drivers that Hyperion supports.

IBM DB2 is release specific. Hyperion provides the JDBC driver for IBM DB2 7. The
DB2java.zip client drivers must match the DB2java.zip archive on the IBM DB2 database
server. Caution: Be extremely careful when copying files from the RDBMS server to the Web
Analysis Studio installation directory! There are extreme consequences if you overwrite the
application server local DB2 files used to access configuration information.

The Teradata 4.1 Connection string features four bracketed JDBC connection string parameters.
Brackets and parameter names must be replaced with values.

Parameters Description

{host-name} Server domain name

{port} TCP/IP port number

{DSN} Data source name

{database name} A database name

Note:

JDBC driver archives must be explicitly referenced by file name within the classpath of the
Webapp application server.

Select Fact Table Page
The second relational database connection wizard panel, Select Fact Table, provides filters for
locating a fact table by schema and finally table name.

Text box or Control Select

Schema Filter A schema type from the corresponding drop-down list.
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Text box or Control Select

Table Type Filter A table filter from the corresponding drop-down list.

Retrieve Table List This button retrieves the list of relational tables.

Relational Cube Editor
The third relational database connection wizard panel, Relational Cube Editor, diagrams the
relational cube as a node tree.

Default Node Shortcut Menu Right-click node and select menu command to:

Relational Cube   

 Rename Cube Specifies the relational database connection name.

Dimensions   

 Add Dimension Creates a dimension.

Defined Dimension   

 Add Generation Specifies a relational column as a dimension generation.

 Rename Dimension Specifies a name for the dimension.

 Delete Dimension Removes the dimension from the node hierarchy.

 Preview Displays a node tree of the selected dimension hierarchy.

Defined Generation   

 Edit Generation Changes properties for that generation.

 Rename Generation Specifies a name for that generation.

 Delete Generation Removes that generation from the node hierarchy.

 Move Up Moves that generation up in the node hierarchy.

 Move Down Moves that generation down in the node hierarchy.

 Preview Displays a node tree of the selected dimension hierarchy.

Measures   

 Edit Measures Specifies columns as measures.

 Rename Specifies another name for the measures dimension.

 Preview Displays a node tree of the selected dimension hierarchy.

Defined Measure   
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Default Node Shortcut Menu Right-click node and select menu command to:

 Rename Member Specifies a name for the measure.

 Delete Measure Removes the measure from the node hierarchy.

 Preview Displays a node tree of the selected dimension hierarchy.

 Order By Mode Indicates the label used to determine Dimension Header Sorting.
Options include ID and Alias.

 Dimension Header Sort Indicates the order that relational members are displayed by the
Dimension Browser dialog box. Subsequent users must use this
dialog box to select members from the relational data source.
Options include:

● Default (Natural ordering based on outline)

● Ascending

● Descending

Properties  Displays the properties of the currently selected node.

Important notes on relational table properties:

To protect open documents and to expedite network traffic, there is only one cached JDBC
connection per user per relational database connection. Therefore, relational database
connection edits are not implemented until you log off Web Analysis Studio and log back on.

Creating Relational Database Connections

➤ To create a relational database connection:

1 Perform one:

● Select File > New > Database Connection > Relational.

● Click , and select Database Connection > Relational.

The Process bar displays the steps for creating relational database connections:
Connection, Select Fact Table, and Define Cube. To successfully create a JDBC RDBMS
connection, you must know the kind of relational data source you are accessing, the
parameters needed to connect to it, and have a user name and password that supports
connectivity.

2 Select one from Driver Type:

● IBM DB2

● Microsoft SQL Server

● Oracle

● Teradata

● Other
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Your JDBC driver selection populates the Database Connection String text area with a
relational database connection string. If you selected Other, you must define your own JDBC
connection string.

3 Replace Database Connection String variables with values.

Depending on the driver type, there are variables for host name, database name, port, and DSN.
You must replace the brackets and the variable.

4 Enter a JDBC user name in Username.

5 Enter a password in Password.

6 Click Test Connection.

If the connection fails, repeat steps 6 through 10 until you can establish successful relational
database connectivity. Make sure you remove brackets from string variables.

7 After connecting, close the Test Connection message and click Next.

Step 2: Select Fact Table you must select a relational fact table from a list. Schema filters and
table type filters are available to narrow long lists of tables.

Note:

Before you can use a schema filter, it must be mapped to the RDBMS database user name used
to log on to the database. This user name is specified on the previous wizard page, Configure
JDBC Drivers.

8 Select a schema from Schema Filter.

9 Select a table type from Table Type Filter.

10 Click Retrieve Table List to query the relational database for tables meeting filter requirements, and display
the result set.

To select the fact table, you must understand the relational database. If necessary, ask the
relational database administrator to identify the fact table. The fact table must contain at least
one column of numeric data that can be used as a measures dimension.

11 Select a table to be used as the fact table from the table result set, and click Next.

Step 3 Relational Cube Editor diagrams the relational cube as a node tree in the same manner
that the Dimension Browser presents OLAP cubes. Click to select a node. Double-click to expand
and collapse nodes. Right-click to edit dimensions and measures.

12 Right-click Measures and select Edit Measures.

The Measure Editor dialog box enables you to define relational columns as measures by moving
them from the Available Columns list to the Measures Members list. You can also rename the
measures dimension, specify the default dimension, add measures to the cube, and specify
aggregation methods for measures dimensions.

13 Select a column with a numeric data type from Available Columns, and click the right arrow (>) to move
the column to Measure Members.

Note that the selected measure is designated as the default measure dimensions.
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14 Optional: When Measure Members contains multiple measures, you can specify the measure used as the
default measure by clicking an option in Default.

15 Optional: To change the measure name, double-click Member Name, and type a name. Member names
must be unique to each other and the name of the measures dimension for SQL parsing to be successful.

16 Optional: To indicate another member aggregation method, click Aggregation Type and select from these
aggregation methods. When no aggregation type is specified Sum is used by default:

● Sum

● Count

● Min

● Max

● Avg

17 When all fact table columns used as measures are specified, click OK.

The Relational Cube Editor is displayed. Note that the Measures node can be expanded to display
the measures dimension.

18 Right-click Dimensions and select Add Dimension.

The New Dimension Name dialog box is displayed.

19 Enter a dimension name to define, and click OK.

The Generation Editor dialog box is displayed. It enables you to create a generation for the
dimension, to name the generation, to indicate the ID and alias tables used for return values,
and to relate the dimension back to the fact table.

20 Enter a dimension generation name in Generation Name.

Note that Select Member ID and Description Columns displays the fact table by default.

21 To narrow the list of tables, select a filter from Table Type.

22 Select a table from Table.

23 Indicate the ID aliases column in the top Column list.

24 Indicate the Descriptions aliases column in the bottom Column list.

By identifying common table columns, you relate the defined dimension generation to the fact
table. Typically, several sets of common columns are used to identify a circuit to the fact table.

Ask the relational database administrator for a description of relational tables and their columns
to discern common table columns.

Start by identifying tables sharing columns with the dimension generation table. Find tables
sharing columns with the fact table. Determine if tables that share columns with the dimension
generation also share columns with the fact table. If they do, your relationship is mapped. If not,
you must continue comparing columns until you can map a bridge between the dimension
generation and the fact table.

Note that Define Fact Table Mappings displays the dimension and the fact table by default.
Unless they share a common column, you must select a Table Type filter, a table, and a column
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that matches the dimension generation. If they do share a common column, you need only
indicate that column in the Column drop-down list.

When a table and column are selected, a line is added to Define Fact Table Mappings below
until the dimension generation and fact table relationship is mapped.

Keep these considerations in mind as you make your selections.

● Question marks (?) indicate unspecified columns.

● Left and right Column lists must display common columns.

● Each Define Fact Table Mappings line should display column sets that differ from the line
above.

● To improve performance, specify as few column sets as is possible.

25 In Define Fact Table Mappings, select a table from Table that has a column that matchesColumn.

The specified table and column display on a line below.

26 Select a Column at right that matches the Column at left.

27 Repeat steps 25 and 26 until a relationship between the dimension generation and the fact table is mapped,
and click OK.

The Relational Cube Editor is the current dialog box again. Note that the Dimension, generation
and Measures nodes can be expanded, by clicking the plus sign (+), to display the relational cube
structure.

28 Optional: To add generations to one dimension, right-click the dimension name and select Add
Generation. The Generation Editor is displayed again. Repeat steps 20-27.

29 Optional: To reorder the generations in the dimension hierarchy, right-click a generation name and select
Move Up or Move Down.

The generation node moves in the specified direction in the dimension hierarchy.

30 Optional: To add dimensions to one relational cube, right-click Dimensions and select Add Dimension.
Repeat steps 18-29.

31 When all measures, dimensions, and generations are defined and ordered, click Finish.

The Save As dialog box is displayed. It prompts you to navigate to the repository location where
the database connection is saved.

32 Navigate to the folder into which you want to save your database connection file:

● Click Up to display the contents of the parent folder in the selection frame.

● Click Home to jump to and display the contents of the current Home folder (set in
preferences) in the selection frame.

● In Location, type the path to the repository folder whose contents you want displayed, and
press Enter.

● In Location, click the drop-down arrow and select another location from the repository.

● When you navigate to another folder, you can click Previous to return to the last folder.

● Similarly, you can click Next to display the next folder in the location series.
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As you navigate, the selection frame lists the files and folders indicated by Files of Type.

33 When you reach the location where you want to save the file, enter a name for the database connection in
Filename, and click OK.

Your relational database connection file is saved to the specified repository location. You can
use it to create documents, just as you would OLAP database connection.

Editing Database Connections
You edit database connections to select other data sources or change formatting preferences.

➤ To edit database connections:

1 In Web Analysis Studio, navigate the repository to locate the database connection file.

2 Select the database connection file, then right click and select Edit to display the Database Connection
wizard.

3 Change items as desired.

You can select different servers and databases.

4 Click Finish to save the changes and close the Database Connection wizard.

Changing Database Connections for Report Objects

➤ To change the database connection that a report object (that is, spreadsheet, chart, or pinboard)
uses:

1 Open a Web Analysis document; if it contains multiple report objects, select a report object to edit by clicking
on it.

2 Click  to display the View Pane.

3 Right click  (database node) in the View Pane and select Change Database.

The Open dialog box is displayed.

4 Select a database connection and click OK to change the database connection for the report object.
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Creating Pinboards
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Pinboards
Pinboards are custom graphic representations of multiple dimensions. Pinboard dimensions
are represented by a graphic, pin icons on the graphic, and the color (or state) of the pins.
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Pinboards Prerequisites
Because pins dynamically change image or color based on traffic lighting cues, you must establish
traffic light definitions for the corresponding spreadsheet before designing the pinboard.

Creating a Pinboard Series
A pinboard series enables drilling from one pinboard to another. You create the first pinboard
in the series and use the Pinboard Designer shortcut menu to designate subsequent pinboards.
The subsequent pinboards are generated using the children of the previous pinboard's pins. If
the current pinboard represents the dimension bottom, no subsequent pinboard can be created
in this series. See “Creating a Pinboard Series” on page 188.

Creating Pins
You can use the default pins provided with Web Analysis Studio or create your own pins using
the Pin Designer. Pins can change an image or color based on traffic lighting. See “Creating Pins”
on page 188.

Traffic Lighting Control Panel
Only the pinboard display type displays a traffic lighting control panel when multiple traffic
lighting definitions exist in the document. The traffic lighting control panel enables you to scroll
through the series of traffic lighting definitions.

Select Traffic Lighting Dimension Dialog Box
The Select Traffic Lighting Dimension dialog box prompts you to create a pinboard from another
display type without traffic lighting. After selecting the dimension to which a traffic lighting
definition is applied, the Traffic Lighting dialog box is displayed to finish the definition.

Pinboard Designer
The Pinboard Designer interface includes:

● Pinboard panel— positions pin graphics relative to the background.

● Image Source group—Specifies the background.

● Member Selections group—Specifies dimension members used as pins.

● Null Pins group—Indicates how to display members with null values.

● Select Pin Images group—Specifies the kind of pin to display for each traffic lighting color.
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Creating a Pinboard

➤ To create a pinboard:

1 Open spreadsheet with a traffic lighting definition.

2 Select Display > Pinboard.

Note:

If a pinboard is defined for the document, it is displayed as a result of your selection. When no
pinboard is defined, the Pinboard Designer is displayed. To edit a Pinboard, right-click the data
object and select Edit Pinboard.

Pinboard Designer is displayed, automatically displaying column dimension members as pins
and traffic lighting ranges as pin colors in the Select Pin Images group.

3 In the Image Source group, click Set Background.

The Open dialog is displayed.

4 Navigate to a GIF or JPEG file to use as the background. Select the file name, and click OK.

The selected image is displayed in the Pinboard Designer panel.

5 Optional: To set the image to fill the Pinboard panel, select Stretch to Fit.

6 Optional: To change the dimension member selections, perform one:

● Click the Member Selections list to select other traffic lighted column dimension members.

● Click Add Members to display the Dimension Browser, and change dimension member
selections.

● Click Add Calculations to create pins from calculated members.

● Right-click a pin and select Delete Pin, to remove pins without redefining the member
selection statement.

7 Optional: To specify to hide pins with null values, select Hide Null Pin.

8 Optional: You can also select a special color for pins with null values, by clicking Select Null Pin Color.

The Select Null Pin Color dialog box is displayed, enabling you to select a color, and click OK.
See “Selecting Color” on page 113. The selected color is displayed in the box beside the button,
after selection.

The specified dimension members are rendered with default pins on the Pinboard panel. The
Select Pin Images group reflects the traffic lighting range colors. You can also specify pin images
that differ for each traffic lighting range, or a different part of the current pin image to reflect
the traffic lighting range color.

See “Creating Image Pins” on page 190, or “Creating Color Pins” on page 191.

9 Drag pin images on the Pinboard background to position them.

10 Click Pinboard Designer OK to display the finished pinboard.
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Modifying Pinboards
You must have the correct permissions to change pinboards.

➤ To edit a pinboard, select Edit Pinboard from the data object shortcut menu and modify options.

Creating a Pinboard Series

➤ To create a pinboard series:

1 Create the starting pinboard and its pins.

The starting pinboard must feature pins with descendants.

2 Right-click a pin on the Pinboard Designer and select the Next Pinboard menu command.

Pinboard Designer displays a subsequent pinboard using the children of the previous pinboard
pins.

3 Set the background image, and pin images. Position these pins.

4 Repeat until all pinboards in the series are specified.

This table describes the Pinboard Designer shortcut menu commands that help to define
Pinboard series:

Command Description

Next Pinboard Go to the next pinboard in the series. If no next pinboard exists, create one using the children of
the previous pinboard pins.

Previous Pinboard Go to the previous pinboard in the series.

Starting Pinboard Go to the first pinboard created.

Delete Pinboard Delete the current pinboard.

Delete Pin Delete the current pin.

Creating Pins
Pin options:

●

A default pin, , is provided by Web Analysis Studio.

●

An Image Pin, , displays pin images that differ per an associated traffic lighting definition.

●

A Color Pin, , changes its active color per the traffic lighting definition.
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Selecting Pins
The Select Pin Images dialog box presents pin graphics available for use in the current pinboard.
You can add pins, edit pins (using Pin Designer), or delete pins from the list. The default pin
cannot be deleted.

➤ To select a pin for a traffic lighting range:

1 Click a Pin from Pinboard Designer Select Pin Images.

The Select Pin Images dialog box is displayed.

2 Select a pin from the list and click OK.

The selected pin is displayed next to the traffic light range it represents.

Creating Pins

➤ To add a pin image and set it to a traffic lighting range:

1 Click a Pin from Pinboard Designer Select Pin Images.

The Select Pin Images dialog box is displayed.

2 Click Add.

The Pin Designer dialog box is displayed.

3 In Pin Image, click Load.

The Open dialog is displayed.

4 Navigate to a GIF or JPEG file to use as the pin image. Select the file name, and click OK.

The selected image is displayed in the Pin Designer panel.

Before a pin can be added to the selection list, the "point of the pin" and its active color must be
defined. This is accomplished using the Pin Designer shortcut menu:

5 Optional: To set the point of the pin, right-click the pin image where you think the point should be, and select
Hotspot.

The grid to the left demonstrates how the pin is positioned relative to this point.

6 Optional: To set the Active Color, right-click a prominent color in the pin image, and select Active Color.

The Active Color panel reflects this selection. You should only elect an Active color when you
are going to use one pin image for every traffic lighting range. This enables the selected color to
adopt the color of the traffic lighting range.

7 Click OK.

The pin is displayed in the Select Pin Images dialog box.

8 Select the pin from the list and click OK.

The pin is displayed next to the traffic light range it represents.
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Editing Pins
To redefine pin location point or active color, you can edit pins.

➤ To edit a pin, access the Select Pin Images dialog box, select the pin and click Edit.

See “Creating Pins” on page 189.

Deleting Pins

➤ To delete a pin, access the Select Pin Images dialog box, select the pin and click Delete.

Creating Image Pins
Image pins display pin images that differ per an associated traffic lighting definition. You create
Image pins by indicating the pin image to use for corresponding traffic lighting ranges.

Pins on the Pinboard panel may not accurately reflect all pin images and traffic lighting ranges
until the Pinboard is finished and displayed as a document.

If you select duplicate images for traffic lighting conditions, you must set the pin Active Color
property to differentiate traffic lighting conditions. See “Creating Color Pins” on page 191.

➤ To create an image pin:

1 Click a Pin from the Pinboard Designer Select Pin Images.

The Select Pin Images dialog box is displayed.

2 Click Add.

3 The Pin Designer dialog box is displayed.

4 In Pin Image, click Load.

The Open dialog is displayed.

5 Navigate to a GIF or JPEG file to use as the pin image. Select the file name, and click OK.

The selected image is displayed in the Pin Designer panel.

Before a pin can be added to the selection list, the "point of the pin" and its active color must be
defined. This is accomplished using the Pin Designer shortcut menu:

6 Optional: To set the point of the pin, right-click the pin image where you think the point should be, and select
Hotspot.

The grid to the left demonstrates how the pin is positioned relative to this point.

7 Click OK.

The pin is displayed in the Select Pin Images dialog box.

8 Select the pin from the list, and click OK.
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The pin is displayed next to the traffic light range it represents.

9 Repeat steps 1 through 8 for each traffic lighting range.

The traffic lighting definition displays the corresponding pin for each traffic lighting range, when
the Pinboard is in Analyze mode.

Creating Color Pins
Color pins change their active color per the traffic lighting definition. You create Color pins by
indicating the pin image to use for corresponding traffic lighting conditions, and indicating the
Active Color.

Pins on the Pinboard panel may not accurately reflect all pin images and traffic lighting
conditions until the Pinboard is finished and displayed as a document.

Pins on the Pinboard Panel may not accurately reflect all pin images and traffic lighting ranges
until the Pinboard is finished and displayed as a document.

➤ To create a color pin:

1 Click a Pin from Pinboard Designer Select Pin Images.

The Select Pin Images dialog box is displayed.

2 Click Add.

3 The Pin Designer dialog box is displayed.

4 In Pin Image, click Load.

The Open dialog is displayed.

5 Navigate to a GIF or JPEG file to use as the pin image. Select the file name, and click OK.

The selected image is displayed in the Pin Designer panel.

Before a pin can be added to the selection list, the "point of the pin" and its active color must be
defined. This is accomplished using the Pin Designer shortcut menu:

6 Optional: To set the point of the pin, right-click the pin image where you think the point should be, and select
Hotspot.

The grid to the left demonstrates how the pin is positioned relative to this point.

7 To set the Active Color, right-click a prominent color in the pin image, and select Active Color.

The Active Color panel reflects this selection. By electing an Active color, you indicate that this
color is replaced by the traffic lighting range color.

8 Click OK.

The pin is displayed in the Select Pin Images dialog box.

9 Select the pin from the list, and click OK.

The pin is displayed next to the traffic light range it represents.

10 Click another Pin from Pinboard Designer Select Pin Images.

Creating Color Pins 191



The Select Pin Images dialog box is displayed.

11 Select a matching pin image, and click OK.

The pin is displayed next to another traffic light range. The Active Color of this pin is replaced
by the color of the range.

12 Repeat steps 10 and 11 for all traffic lighting ranges, and click OK.
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Creating SQL Spreadsheets
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SQL Spreadsheets
SQL Spreadsheet data objects enable you to query a relational data source, and display the
returned data values on a custom document.

Prerequisites for SQL Spreadsheets:

● SQL Spreadsheets can only be created on a custom document.

● You must understand how to compose a SQL query to create a SQL spreadsheet.

● You must be able to connect to a relational data source using supported JDBC drivers.

To create a SQL Spreadsheet you are required to specify:

● Data source that provides data values

● SQL spreadsheet data object that displays these values

● Query that gets data values from the data source and returns them to the data object.

The process of creating SQL spreadsheets assumes that you know your JDBC driver, database
application, and logon credentials. The process also assumes that you can compose the SQL
query for the SQL spreadsheet data object, or be able to use a SQL Query Builder to create a
query.

There are four alternatives for accessing relational data in Web Analysis Studio:

● You can create a relational database connection to be used by regular spreadsheets, charts,
and pinboards. See “Creating Relational Database Connections” on page 180.

● Free-form grids enable you to combine data values from multiple data sources in one data
object. Free-form grids leverage custom document database connections. See “Creating
Freeform Grids” on page 203.
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● You can create a relational drill-through connection from an OLAP database connection to
a relational data source. See “Creating Relational Drill-Through” on page 163.

● You can leverage pre-defined Analytic Integration Services drill-through documents using
the Related Content dialog box. See “Analytic Integration Services Drill-Through” on page
253.

Note:

To troubleshoot SQL queries, copy the SQL statement from the Enter SQL Query dialog
box and run it in an RDBMS SQL tool. Compare the result sets.

Creating SQL Spreadsheets

➤ To create a SQL spreadsheet:

1 Start Web Analysis Studio.

2 Perform one:

● Select File > New > Document.

● Click .

● Click , and select Document.

● In the View Pane Browser tab, right-click a document and select Edit.

● Press Ctrl+N.

The Document Designer is displayed.

3 Drag the SQL Spreadsheet icon from the component toolbar to a document panel.

The Enter SQL Query dialog box is displayed.

4 Select a supported JDBC driver type from the JDBC Driver drop-down list.

You can select from Microsoft SQL Server, IBM DB2, Oracle, JDBC-ODBC Bridge, and Other.

When the selection is made, a driver name populates the corresponding Driver text box. If Other
is selected, you must enter a driver name definition.

When the selection is made, a sample database connection string syntax populates the
corresponding JDBC Connection String text box. When Other is selected, you must enter a JDBC
database connection string.

5 Edit the sample database connection string syntax so that it specifies your RDBMS computer name and
database name.

6 Enter a user name and password for the relational data source in the corresponding text boxes, or select
Username/Password to enter your current logon credentials.

7 Optional: Define query governor parameters for row limits and fetch size.

The default settings limit the result set to 250 rows, being fetched 100.
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8 Define a SQL query, using one of these methods:

● Enter a SQL query, using standard SQL syntax, in the panel at the bottom of the dialog box.

● Click Query Builder to display the SQL Query Builder Wizard.

See “SQL Query Builder Wizard” on page 198.

9 Click OK.

The query is sent to the relational data source and a SQL spreadsheet is displayed on the
document panel.

Creating SQL Spreadsheets with SQL Query Builder Wizard
The SQL Spreadsheet component offers advanced features for creating dynamic SQL queries
and subsequently dynamic relational spreadsheets. You can quickly and conveniently compose
SQL queries using the SQL Query Builder Wizard.

➤ To create a SQL spreadsheet:

1 Start Web Analysis Studio.

2 Perform one:

● Select File > New > Document.

● Click .

● Click , and select Document.

● In the View Pane Browser tab, right-click a document and select Edit.

● Press Ctrl+N.

The Document Designer is displayed.

3 Drag the SQL Spreadsheet icon from the component toolbar to a document panel.

The Enter SQL Query dialog box is displayed.

4 Select a supported JDBC driver type from the JDBC Driver list.

You can select from Microsoft SQL Server, IBM DB2, Oracle, JDBC-ODBC Bridge, and Other.

When the selection is made, a driver name populates the corresponding Driver text box. If Other
is selected, you must enter a driver name definition.

When the selection is made, a sample database connection string syntax populates the
corresponding JDBC Connection String text box. When Other is selected, you must enter a JDBC
database connection string.

5 Edit the sample database connection string syntax so that it specifies your RDBMS computer name and
database name.

6 Enter a user name and password for the relational data source in the corresponding text boxes, or select
Username/Password to enter your current logon credentials.
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7 Optional: Define query governor parameters for row limits and fetch size.

The default settings limit the result set to 250 rows, being fetched 100.

You could define a SQL query by entering standard SQL syntax, in the panel at the bottom of
the dialog box, but use the SQL Query Builder as described in these steps.

8 Click Query Builder to display the SQL Query Builder Wizard.

The SQL Query Builder dialog box features tabs corresponding to aspects of your relational data
source:

● Tables—specifies the relational table(s) to query.

● Columns—specifies the columns to be returned by the query.

● Filters—narrows the focus of the SQL query by specifying filter criterion for Where clauses.

● Groups—organizes relational data on the server before it is returned.

● Sorting—orders relational data in ascending or descending order per column.

● Mappings—relates relational columns in the SQL query result set to multidimensional
dimensions from an OLAP data source.

9 Click Tables, and select one or more tables.

To select a table, click the table name in Available Tables, and click one of the arrow buttons.
The selection moves to Selected Tables. You can also move selected tables up and down in order.

10 Click Columns, and select one or more columns.

To select a column, click the column name in Available Columns, and click one of the arrow
buttons in the center of the tab. The selection moves to Selected Columns.

11 Optional: To change a column name, or apply a function call to the column, click Add Column Advanced,
the middle button on the Columns tab before moving the column to the Selected Columns frame.

Add Columns Advanced on the Columns tab displays the Select Column Advanced dialog box,
enabling you to apply function calls to a selected column (on the Columns tab) or manually
enter a RDBMS supported function call. You can select from these functions: None, Average,
Count, Maximum, Minimum, or Sum.

If you would like to change the column name in the SQL spreadsheet display, enter an alternate
name in Displayed As.

12 Optional: To define Where clauses for the SQL query, click Filters.

The Filters tab enables you to define complex Where clauses by selecting parameters from drop-
down lists. Select parameters from four columns: Operator, Column, Comparator, and Value.

To define a Where clause:

a. Click Add to add a row to the Filters frame.

b. Click the Column cell in the row and select a column name from the list.

c. To filter the selected column, click the Comparator cell. You can select from these options:

● Enter a constant.

● Right-click and select the value of another column member.
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● Enter a dynamic text label, a variable that is dynamically replaced with a value at
runtime. See “Dynamic Text Labels” on page 200.

d. Click the Value cell and select a filter value. This limits the return set to those rows that
satisfy filter criteria.

You can compose compound statements by adding additional rows, selecting operands
from the Operator column and parentheses from the (and) lists.

Note that Select Distinct changes the selection statement to a SELECT DISTINCT
statement.

13 Optional: To define a dynamic SQL spreadsheet, enter dynamic text labels for values on Filters.

You can enter Dynamic Text Labels that reference data, metadata, fixed references and time
format syntaxes. See, “Dynamic Text Labels” on page 200.

14 Optional: To define a GROUP BY clause for the SQL query, click Groups.

15 Optional: To define a SORT clause for the SQL query, click Sorting.

16 Optional: To map columns in your relational data sources to similar OLAP dimensions, click Mappings.

You can associate columns in your relational data sources with similar dimensions in an OLAP
data source, by mapping columns to OLAP dimensions. These mappings, used when drill linking
from an OLAP source to a SQL data object, enable the OLAP query to pass its Where clauses to
corresponding relational columns.

17 Click OK to query the relational data source and display a SQL spreadsheet.

Enter SQL Query Dialog Box
The Enter SQL Query dialog box enables you to define a relational SQL query that supports the
SQL Spreadsheet custom document component. The Enter SQL Query dialog box prompts you
to specify a supported JDBC driver, JDBC connection string, log on credentials, and a SQL query.
You can compose the SQL query using standard SQL syntax in the panel at the bottom of the
dialog box, or you can use a SQL Query Builder Wizard. You can also define row limits and fetch
limit parameters for the SQL query.

Control Description

JDBC Driver Configuration Enables you to select a supported JDBC driver from a drop-down list:

● IBM DB2

● Microsoft SQL Server

● Oracle

● Teradata

● JDBC-ODBC Bridge—leverages a Microsoft Windows ODBC driver as a JDBC
connection. To use this option, you must manually configure the JDBC Connection
String using "JDBC:ODBC:<DSN>" (where DSN is the ODBC connection name).

● Other—Specifies alternative JDBC driver parameters.
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Control Description

JDBC Connection String A sample database connection string syntax is provided in this text box. You must edit
the string so that it specifies your RDBMS computer name and database name. In the
case of Other, you must enter a database connection string syntax.

JDBC Username Indicate a user name for the relational database. You cannot create a relational database
connection without specifying a password.

JDBC Password Indicate a password for the user name. Important! Web Analysis Studio requires this
text box to be populated. You cannot create a relational database connection without
specifying a user name and password.

JDBC Row Limit Enables you to enter an optional query governor limiting the result set to a number of
rows.

JDBC Fetch Size Enables you to enter an optional query governor limiting the number of rows returned at
time. In other words, transactions limited to the fetch size are conducted until the overall
row limit is reached.

SQL Query Panel Enables you to enter a SQL query manually.

Query Builder Displays the SQL Query Builder Wizard, enabling you to make selections from tabs that
are subsequently parsed into a SQL query.

SQL Query Builder Wizard
The SQL Query Builder wizard specifies the elements used in a SQL syntax query. This is helpful
if you are familiar with your relational data source, but do not know SQL syntax.

SQL Query Builder Tab Procedure and Controls Description

Tables   

 Select tables in the Available Tables panel
and move them to the Selected Tables
panel using Add and Remove in the
middle.

To reorder the table selections, select a
table in the Selected Table panel and click
the up and down arrow buttons.

Prompts you to select tables from the
relational data source, prescribed on the
Enter SQL Query dialog box, for use in a SQL
query.

Columns   

 Select columns in the Available Columns
panel and move them to the Selected
Columns panel using Add and Remove in
the middle.

To reorder the Column selections, select a
column in the Selected Column panel and
click the up and down arrow buttons.

Prompts you to select columns from the
relational tables for use in a SQL query.

 Select Column Advanced Displays the Select Column Advanced dialog
box, enabling you to select a function call,
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SQL Query Builder Tab Procedure and Controls Description

compose an expression, or enter an
alternative column label.

Filters   

 Click Add to enter a Where clause. Click
each column cell and make a selection
from the drop-down list.

Prompts you to define filter selections for the
Where clause on the SQL query. To focus and
diminish the query result set, you can define
dimension criteria (filters).

 Dynamic Text Labels You can also employ the powerful dynamic
text labels used by the Print function and the
Custom Document Label component in your
SQL expressions.

 Select Distinct Sets up the query to return only distinct rows;
eliminates duplicate rows.

Groups   

 Select columns in the Available Group By
Columns panel and move them to the
Selected Group By Columns panel using
Add and Remove in the middle.

To reorder the column selections, select a
column in the Selected Group By Column
panel and click the up and down arrow
buttons.

Prompts you to define GROUP BY selections
for the SQL query. Groupings sort rows based
on column members but do not order the
rows.

Sorting   

 Select columns in the Available Sort
Columns panel and move them to the
Selected Sort Columns panel using Add
Sort Ascending and Add Sort
Descending in the middle.

To reorder the Column selections, select a
column in the Selected Sort Column panel
and click the up and down arrow buttons.

Prompts you to define sorting criteria for the
SQL query result set in Ascending or
Descending order.

Sorting results are influenced by the order of
tables, columns, and filters on their
corresponding tabs.

Mappings   

 Enter the OLAP dimension name to the right
of the relational column supporting drill
linking.

Prompts you to define (or map) drill links to
or from relational columns to OLAP
dimensions in other documents.

Select Column Advanced Dialog Box
The Select Column Advanced dialog box specifies a function call, composes an expression, or
enters an alternative column label in a SQL Spreadsheet query. You can access the Select Column
Advanced dialog box only from the Columns tab of the SQL Query Builder Wizard.
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Control Description

Function Enables you to enter a function call related to the column selected on the Column tab of the SQL
Query Builder wizard.

● None

● Average

● Count

● Maximum

● Minimum

● Sum

Expression Enables you to manually enter a RDBMS supported function call for the column selected on the Column
tab of the SQL Query Builder wizard.

Displayed As Enters an alternative column label in the SQL Spreadsheet query for the column selected on the
Column tab of the SQL Query Builder wizard.

Dynamic Text Labels
Dynamic text labels are variables that are dynamically replaced with values at runtime. Dynamic
text labels display the latest information without being manually updated

You can use Dynamic Text Labels in these ways:

● To create dynamically updated labels on custom documents, add dynamic text labels to
custom document label objects using the shortcut menu. See “Creating Dynamic Text
Labels” on page 231.

● To create dynamically updated headers and footers for your JPG output, PDF output and
hardcopy printing, use dynamic text labels in the Print dialog box Headers/Footers tab. See
“Print Dialog Headers/Footers Tab” on page 151.

● To create dynamic SQL statements, include dynamic text labels in your SQL filter clauses
as values.

Dynamic Text Tag Default Tag Description

Cell Reference <cell 0,0>> Inserts a cell reference string in the label object.

Filter <<filter 0>> Inserts the filter member name in the label object.

After dynamic text labels are entered, you can edit the tag to display additional information.

Dynamic Text Labels for SQL Spreadsheets
Dynamic Text Labels are used primarily in custom report label objects and in the Headers/
Footers tab.

Two dynamic text labels are supported with SQL Spreadsheets: filter and Cell of the print dialog
box. Because SQL spreadsheet objects cannot be selected on Web Analysis documents as on
standard OLAP spreadsheets, charts, and pinboard, filter and cell functions must use fixed
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references to their data source. For example, the filter function must contain
ReportSQLDataSrc, which is selected when a SQL subscription control is defined:

<<filter ReportSQLDataSrc1, 0>

A reference without a data-source specification (for example, <<filter 0>>) does not function
with SQL spreadsheets.

Cell Functions
Cell functions insert cell reference strings in label objects. The fixed reference format for the
function is:

<<cell SQLDataSourceName1, row, column>>

Where

row is the numerical row reference on the spreadsheet and column is the numerical column
reference on the spreadsheet

Filter Functions
Filter functions insert filter member names in label objects. The fixed reference format for the
function is:

<<filter SQLDataSourceName1,n>>

Where

n is the filter number in the order that is displayed in the SQL WHERE clause:

SELECT MONTH, PRODUCT, CITY, SALES, COGS FROM DETAILS WHERE PRODUCT =

'100-10' AND MONTH = 'Aug'

<<filter ReportSQLDataSrc1, 0>> returns 100–10

<<filter ReportSQLDataSrc1, 1>> returns Aug

Creating a SQL Subscription Control

➤ To create a SQL subscription control for a SQL Spreadsheet:

1 Start Web Analysis Studio.

You must open a document containing a SQL Spreadsheet or create a SQL spreadsheet after
entering Document Designer.

2 Select File > New > Document.

The Document Designer is displayed.

3 Drag the SQL Subscription Object icon from the component toolbar to a document panel.

4 Select the SQL spreadsheet data source for the subscription object.
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The Select Column dialog box is displayed, prompting the user to select a column from the
relational data source. The members of this column populate the drop-down list of the control.

Select the asterisk character (*) to return all column members.

5 Select the relational data source column, and click OK.

The SQL Subscription Control is displayed on the document panel. The control functionality
takes effect when you return to Analyze mode.
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Creating Freeform Grids
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Freeform Grids
Freeform grids present OLAP, relational, and manually entered data on one data object, and
enable you to leverage these data sources in integrated dynamic calculations.

Freeform grids are comprised of only rows and columns. There is no visual representation of
page dimensions participating in cell intersections. You can still use OLAP database connections
with dimension members assigned to the Page axis, but you cannot navigate through these page
dimensions unless you create additional subscription controls. In short, only the first page of a
multidimensional cube is displayed.

Freeform Grid prerequisites:

● Freeform Grids can only be created on a custom document.

● You must understand how to compose a SQL query to access relational data sources.

● You must be able to connect to a relational data source using supported JDBC drivers.

There are four alternatives for accessing relational data in Web Analysis Studio:

● You can create a relational database connection to be used by regular spreadsheets, charts,
and pinboards. See “Creating Relational Database Connections” on page 180.

● SQL Spreadsheet data objects enable you to query a relational data source, and display the
returned data values on a custom document. See “Creating SQL Spreadsheets” on page
194.

● You can create a relational drill-through connection from an OLAP database connection to
a relational data source. See “Creating Relational Drill-Through” on page 163.

● You can leverage pre-defined Analytic Integration Services drill-through connections using
the Related Content dialog box. See “Analytic Integration Services Drill-Through” on page
253.
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To create freeform grids you are required to specify:

● The data sources providing data values

● The Freeform Grid data object that displays these values

● The queries retrieving data values.

The process of creating freeform grids assumes that you know your data sources and logon
credentials. Freeform grid querying methods are not unique; you can use the database
connections established for other data objects.

Creating Freeform Grids

➤ To create a freeform grid:

1 Start Web Analysis Studio.

2 Perform one:

● Select File > New > Document.

● Click .

● Click , and select Document.

● In the View Pane Browser tab, right-click a document and select Edit.

● Press Ctrl+N.

The Document Designer is displayed.

3 Drag the Freeform Grid icon from the component toolbar to a document panel.

An empty freeform grid and the Set Grid Size dialog box are displayed. Note that the grid can
consists of only row and column axes.

4 Enter the number of rows in Number of Rows.

5 Enter the number of columns in Number of Columns.

6 Click OK.

The grid is reset to the indicated number of rows and columns.

7 Optional: To move the freeform grid object, click and drag the component with the Move cursor to another
location on the document panel.

The conventional cursor is transformed into the Move cursor when it is floated over a selected
component. Be careful not to drag over a blue selection handle, as this resizes the component
instead of moving it.

8 Optional: To resize the freeform grid object, click and drag the blue selection handles on the sides and
corners of the selected grid component.

9 Optional: To anchor the freeform grid object to document panel borders, right-click the component and select
Anchor, and an anchor option: Top, Bottom, Left, Right, Slack, None.

204 Creating Freeform Grids



The Anchor property orients selected components to an edge of the panel containing them.
Using Slack, you can realign objects to occupy empty space. It is best to design documents in
terms of container panels and orient components relative to these panels. Components that are
placed with an absolute alignment in the context of the main document panel, maintain their
position even as other components fluctuate. This may cause the overlapping and shifting of
components.

10 When the custom document is laid out correctly, click Analyze.

The remaining customization is done in the Analyze interface.

Data sources are anchored at cells in a freeform grid. This is done by selecting a cell and
composing a query.

11 To specify an OLAP or Hyperion data source, perform these tasks:

a. Right-click a cell and select Add Data Source.

The Select Data Source dialog box is displayed.

b. You can select a database connection, or select <Add Data Source> to define a database
connection, and click OK.

i. If you selected <Add Data Source>, the Open dialog box is displayed. Select a
database connection, and click OK. The Cube Navigator dialog box is displayed, so
that you can create a query for the selected cell. Assign dimensions to axes, make
members selections, and click OK.

Note that you cannot page dimension member selections assigned to the Pages axis,
unless you create a subscription control using a matching data source and page
dimensions.

ii. If you selected a database connection, the cell is populated based on the selected
database connection.

12 To specify a relational data source:

a. Right-click a cell and select Add SQL Query.

The Enter SQL Query dialog box is displayed.

b. Enter the JDBC connection information, log on credentials, query governor parameters
and SQL statement, and click OK. See “Creating SQL Spreadsheets” on page 194.

The query is submitted to the corresponding data source, and the result set origin is
displayed at the origin of the selection set.

13 To manually enter data values in the freeform grid, click a cell and enter text.

See “Formatting Freeform Grids” on page 206 and “Creating Formulas for Freeform Grids” on
page 207.
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Formatting Freeform Grids
You cannot format freeform grids. They inherit formatting definitions from the database
connections that they use. You can, however, show and hide numerous aspects of the freeform
grid data object:

➤ To show or hide a freeform grid component, right-click the freeform grid and select one:

● Show/Hide Formula Bar.

● Show/Hide Headers

● Show/Hide Horizontal Gridlines

● Show/Hide Vertical Gridlines

➤ To insert a row or column in a freeform grid, right-click the freeform grid and select Insert Row
or Insert Column.

➤ To remove a row in a freeform grid, right-click the freeform grid and select Remove Row or
Remove Column.

➤ To resize row height or column width:

1 In Analyze mode, float the cursor between two header cells until the cursor changes to the Resize cursor.

2 Drag column borders left or right, and drag row borders up and down.

3 When the column or row is sized correctly, release your mouse.

➤ To hide a column or a row, size the header down to 0 pixels.

Note:

Conversely, if you encounter missing columns or rows, you should assume that the header is
sized down to 0 pixels to hide the content of that column or row.

➤ To insert multiple rows and columns in a freeform grid:

1 Click  to return to Document Designer.

2 Right-click the grid and select Properties.

The Set Grid Size dialog box is displayed.

3 Enter a number of rows and columns, and click OK.

The grid is reset to the indicated number of rows and columns.

4 Click  to return to Analyze mode.
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Creating Formulas for Freeform Grids
Freeform grids leverage diverse data sources in integrated dynamic calculations. Cell references
use syntax that matches those supported by Microsoft Excel, where the column letter and the
row number indicate the cell address.

Example: =SUM(B8:C8) adds the data values from the cell on the eighth row of the B column
to the eighth row of the C column.

Note:

Formula cell addresses are absolute. They do not dynamically change themselves to
accommodate the displacement caused by adding or removing rows or columns. As a result, you
should not compose freeform grid formulas until you are finished with all other grid formatting.

You can enter these functions in cells or the Formula bar.

● OPERATOR_ADD=+

● OPERATOR_SUBSTRACT=-

● OPERATOR_DIVIDE=/

● OPERATOR_MULTIPLY=*

● OPERATOR_POWER=^

● OPERATOR_EQUAL==

● OPERATOR_DIFFERENT=<>

● OPERATOR_GREATER_OR_EQUAL=>=

● OPERATOR_LESS_OR_EQUAL=<=

● OPERATOR_GREATER=>

● OPERATOR_LESS=<

● CONDITION_IF=IF

● CONDITION_THEN=THEN

● CONDITION_ELSE=ELSE

● FUNCTION_LN=LN

● FUNCTION_LOG=LOG10

● FUNCTION_EXP=EXP

● FUNCTION_SQRT=ROOT

● FUNCTION_COS=COS

● FUNCTION_SIN=SIN

● FUNCTION_TAN=TAN

● FUNCTION_ACOS=ACOS

● FUNCTION_ASIN=ASIN
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● FUNCTION_ATAN=ATAN

● FUNCTION_COSH=COSH

● FUNCTION_SINH=SINH

● FUNCTION_TANH=TANH

● FUNCTION_INTEGER=INT

● FUNCTION_ABS=ABS

● FUNCTION_NOT=NOT

● JEKS_FUNCTION_SUM=SUM

● JEKS_FUNCTION_RAND=RAND

● JEKS_FUNCTION_MODULO=MOD

● JEKS_FUNCTION_FACT=FACT

● JEKS_FUNCTION_IF=IF

● JEKS_FUNCTION_AND=AND

● JEKS_FUNCTION_OR=OR

● JEKS_FUNCTION_TRUE=TRUE

● JEKS_FUNCTION_FALSE=FALSE

● JEKS_FUNCTION_DATE=DATE

● JEKS_FUNCTION_DATEVALUE=DATEVALUE

● JEKS_FUNCTION_NOW=NOW

● JEKS_FUNCTION_TIME=TIME

● JEKS_FUNCTION_TIMEVALUE=TIMEVALUE

● JEKS_FUNCTION_YEAR=YEAR

● JEKS_FUNCTION_MONTH=MONTH

● JEKS_FUNCTION_DAY=DAY

● JEKS_FUNCTION_WEEKDAY=WEEKDAY

● JEKS_FUNCTION_HOUR=HOUR

● JEKS_FUNCTION_MINUTE=MINUTE

● JEKS_FUNCTION_SECOND=SECOND

● JEKS_FUNCTION_CHAR=CHAR

● JEKS_FUNCTION_FIND=FIND

● JEKS_FUNCTION_CODE=CODE

These conditional operators are also supported:

● IF

● THEN

● ELSE
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Controlling Freeform Grid Content with Data Objects
Due to the variety of data sources available, freeform grids do not offer the navigation methods
and Analysis Tools available to other data objects. Instead of navigating directly on the freeform
grid, you may use another data object that shares the data source to control grid content.

Because the freeform grid shows only the first Page dimension, you can use other custom
document components (such as subscription controls) to navigate through Page axis dimension
members.

To control freeform grid content using another data object, you must perform these steps:

1. Create a custom document with a freeform grid.

2. Switch to Analyze mode, right-click and add a data source to the grid.

3. Return to Document Designer, and add another data object to the custom document.

4. The second data object must use the data source used by the freeform grid.

5. Switch to Analyze mode again.

At this point, you have a custom document with a freeform grid and another data object, both
of which use a common database connection. You can now apply client-side formatting and
analysis tools definitions to the data object. Because the freeform grid's database connection and
query match those used by the data object, it reflects all changes to the data object. When you
are done formatting the content, you have three options:

● You can leave the data object on the document, as a control.

● You can delete the data object. The grid maintains its state based on the database connection
and query, but you cannot revise the grid.

● You can hide the data object by sizing it down, or obscuring it behind another component
(send to back). Later, if you revise the grid, you can use the data object control again.

Note:

Formula cell addresses are absolute. They do not dynamically change themselves to
accommodate the displacement caused by navigation from a second data object sharing one
database connection. Changing the content of a freeform grid, may render formulas
obsolete.

➤ To control freeform grid content using another data object:

1 Start Web Analysis Studio.

2 Perform one:

● Select File > New > Document.

● Click .

● Click , and select Document.

● In the View Pane Browser tab, right-click a document and select Edit.
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● Press Ctrl+N.

The Document Designer is displayed.

3 Drag the Freeform Grid icon from the component toolbar to a document panel.

An empty freeform grid and the Set Grid Size dialog box are displayed. Note that the grid can
consists of only row and column axes.

4 Enter the number of rows and columns in the corresponding text area, and click OK.

The grid is reset to the indicated number of rows and columns. Note that the freeform grid is
selected, and displays blue selection handles.

5 Click .

Data sources are anchored at cells in a freeform grid. This is done by selecting a cell and
composing a query.

6 To specify an OLAP or Hyperion data source, right-click a cell and select Add Data Source.

The Select Data Source dialog box is displayed. You can select a database connection, or select
<Add Data Source> to select another database connection. When you are done the query is
submitted and the result set is displayed in the freeform grid. It is important to note the name
of the data source displayed at the result set origin.

7 Click .

8 Drag the Spreadsheet icon from the component toolbar to the document panel.

The Data Object Properties dialog box is displayed.

9 Select the data source used by the freeform grid for this data object, and click OK.

This is the data source displayed at the result set origin on the freeform grid.

10 Click .

Your custom document contains a freeform grid and another data object, both of which use a
common database connection. You can now apply client-side formatting and analysis tools
definitions to the data object. Because the freeform grid's database connection and query matches
those used by the data object, it reflects all changes to the data object.
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Comparing Web Analysis Studio and Workspace
Web Analysis Studio is a Java applet that enables you to create, analyze, present, and report
multidimensional content. The studio offers the complete Web Analysis feature set to designers
creating content (including dashboards).

Workspace is a DHTML based, zero-footprint client that provides a user interface for viewing
and interacting with content created by authoring studios and enables users to create queries
against relational and multidimensional data sources. It is engineered for information
consumers who do not require advanced design and content-creation capabilities.

Differences between the Two Clients
● The scrolling feature on charts is not available in Workspace.

● Because Java fonts and HTML fonts are not one-to-one equivalent, font styles and sizes may
differ.

● Label Text and Text Area static placement may not be observed and it is recommended that
you use the anchoring feature as much as possible.

● Workspace does not render these designer components:

❍ Tab selection controls
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❍ Slider selection controls

❍ Splitter panels

Note:

Splitter panel render in HTML as a two pane panel, however splitter bar and One-Touch
Expandable functionality not render in HTML.

● These Service Buttons do not function in the Workspace:

❍ Assign Edit Data

❍ Close Report

❍ Cube Navigator

❍ Desktop

❍ File Open

❍ Home

❍ Launch Executable

❍ Logout

❍ Print

❍ Save As

❍ Send to Clipboard

❍ Send to Excel

❍ Toggle Info Panel

❍ Toggle Masthead

❍ Toggle Menu

❍ Toggle Status Bar

❍ Toggle Toolbar

❍ User Preferences

Font List Differences Between Web Analysis Studio and
Workspace
Font availability dependencies in Web Analysis Studio and Workspace:

● Web Analysis Studio—Font list is generated from client machine installed fonts

● Workspace—Font list is generated from Web Analysis server machine installed fonts

Note:

If a document is created in Web Analysis Studio that uses a font that is installed only on the
client machine and is not installed on the Web Analysis server, Workspace users cannot see that
font.
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Document Designer
The Document Designer creates custom documents. When in Document Designer, the process
bar displays the Design label, and a component toolbar is displayed below the menu bar.
Document Designer access is controlled cumulatively by user and group roles.

Accessing Document Designer
You can create custom documents from scratch, the current document, or from document that
you can access.

➤ To initiate Document Designer:

● Select File > New > Document.

●

In Analyze, click , and select Document.

●

In Analyze, click .

● Press Ctrl+N.

● Press F12.

➤ To initiate Document Designer for the current document in Analyze, click Switch to Document
Designer.

➤ To open document in Document Designer, perform these actions:

1 Select View > View Pane, or press F6.

The View Pane is displayed.

2 Click the Repository tab.

3 Navigate to the document to edit in Document Designer.

4 Right-click the document name, and select Edit.

The document is opened in Document Designer, and assigned default object properties. For a
description of default object properties, See “Formatting Components” on page 218.

Setting Document Designer Options
Before designing custom documents, set these options:

➤ To show or hide the Document Designer point grid on the master panel, select View > Grid
Toggle.

➤ To set the color for the Document Designer grid points on the master panel:

1 Select View > Grid Color.
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The Select Color dialog box is displayed.

2 Select a color from the Swatches tab, and click OK.

For a complete description of color options, See “Selecting Color” on page 113.

➤ To set a background image for the Document Designer master panel:

1 Select View > Load Image.

The Select Graphic dialog box is displayed. You can select a color to fill the panel, or a graphic
background for the panel (using Load). The Style group box controls image placement inside
the master panel. Clear resets the panel to the default grey background.

2 Select one Style option:

● Center—Centers the image horizontally on the master panel.

● Stretch—stretches the image to the height and width of the master panel.

● Tile—repeats the image across the master panel until the area is covered.

● Top-Left—Anchors the image in the top left corner of the master panel.

3 Click Load.

The Open dialog box is displayed.

4 Navigate to a network location and select a JPG or GIF file.

5 Click Open.

The image is displayed on the master panel as specified by the Style option.

Design for HTML
When creating custom Web Analysis documents, you can restrict objects and functionality that
do not appear in the Workspace rendering of Web Analysis documents. Incompatible controls
such as Tab Control and Slider Bar, and some Service Buttons, are disabled and not available to
add to a Web Analysis document.

➤ To create Web Analysis documents for Workspace HTML rendering:

1 From the main menu, select Edit > Design for HTML.

2 Select Design for HTML option and click OK.

Note:

Incompatible Workspace objects are not enabled (“Comparing Web Analysis Studio and
Workspace” on page 211 for a list of incompatible objects).

3 If objects are overlayed (For Example, a Text Label placed on top of a Spreadsheet), the overlaying objects
that do not render in HTML and are highlighted with a red border.
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Note:

If incompatible controls are added when this mode is de-selected, “Design for HTML mode” is
enabled and the control is highlighted with a red border

Accessing the Palette Tab
The Palette tab is one of three View Pane tabs.

It lists custom document components as a node tree. You can expand, collapse, and explore the
node tree to identify components by name, understand how they are nested, and display
component properties.

➤ To display a node tree of custom document components, select View > View Pane (or press F6),

and click .

Custom Document Components
Web Analysis Studio provides an inventory of coding-free components for custom documents.
Twenty-one components can be added to custom documents multiple times, and customized
using various options. This provides numerous creative opportunities for custom document
designers:

Containers
The Panel Object and Split Panel Object control space and layers on custom documents. Design
documents using container panels and orient components inside these panels.

Content Panels
There are four additional panels that provide specialized content:

● Label Object—contains static or dynamic text for titles, labels, or captions.

● Text Area Object—uses dynamic text to annotate documents.

● Image Objects—contain graphics for backgrounds, pictures, illustrations, and graphic
controls.

● HTML Browser Object—displays static HTML.

These panels function without additional coding. The label object supports the dynamic text
labels used in Printing headers and footers, and SQL spreadsheets.

Four Data Objects
Data objects representing four display types are next on the component toolbar:
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● Chart—displays the query result set as a chart.

● Spreadsheet—displays the query result set as a spreadsheet.

● Freeform Grid—displays content from multiple data sources in one spreadsheet.

● Pinboard—displays the query result set as a pinboard.

The SQL Spreadsheet data object is in the last segment of the component toolbar. See also
Chapter 15, “Creating Freeform Grids.”

Subscription Controls
A variety of controls enable you to navigate dimensional hierarchies, browse documents, and
execute commands:

● Combo Box Subscription—displays a member drop-down list.

● Radio Button Group Subscription—enables you to select one dimension member option
from a series.

● Check Box Group Subscription—enables you to select multiple dimension members.

● Tab Group Subscription—enables you to select one dimension member tab from a series.

● Multi-level Combo Box Subscription—enables you to select from interdependent drop-
down lists, whose members change based on previous selections.

● Slider Subscription—enables you to select one dimension member from a series.

● Selection Button Subscription—displays a control that applies dimension member
selections to data objects using a matching data source.

● Alias Controller Object—enables you to toggle the data object between alias table labels.

● Services Button Object—executes a command. Also used to create hotspots.

All subscription buttons can control data objects that share a common database connection
query.

SQL Spreadsheet and SQL Subscription
Two components present and control SQL query result sets:

● SQL Spreadsheet Objects—displays a SQL query from a relational data source.

● SQL Subscription Objects—displays a relational subscription button.

See Chapter 14, “Creating SQL Spreadsheets.”

Creating Container Panels
Design custom documents using container panels. As they are added to panels, components are
anchored to one panel edge. Using Slack alignment, you can realign objects to occupy all empty
space.
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Components placed with absolute alignment in the main document panel maintain their
position as other components fluctuate. This may cause overlapping and shifting components.
To prevent this, subdivide custom document space using panels, and anchor these panels to the
master panel. Subsequently added components in container panels maintain their arrangement.

Adding Custom Document Components

➤ To add custom document components to a document, drag them from the component toolbar
to a document panel.

Undo and Redo
The Undo command reverses the effect of the previous command, returning the display to its
prior state. The Redo command reverses Undo, and reinstates the command executed before
Undo. Document Designer records the last ten design actions in a series, and enables you to
select multiple commands to undo or redo.

➤ To undo or redo multiple commands, select them from the Undo and Redo drop-down lists.

Selecting Components

➤ To make a component current, click it. The current component is outlined in blue.

Selecting Multiple Components

➤ To select multiple components:

● Hold Ctrl while clicking the components.

● Click and drag a box around multiple components.

Sizing Components

➤ To size a selected component, drag the blue selection handles on the corners and edges of the
selection outline.
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Moving Components

➤ To move selected component, drag the component with the Move cursor, , to another
location.

The conventional cursor is transformed into the Move cursor when it is floated over a selected
component. Be careful not to drag over a blue selection handle, as this resizes the component
instead of moving it.

Cutting, Copying, Pasting, and Deleting Components

➤ To edit custom documents, right-click a selected custom document component, and select Edit
> Cut, Copy, Paste, or Delete from the shortcut menu.

You can also select a component by clicking it and using these hot keys:

● Undo—Ctrl+Z

● Redo—Ctrl+Y

● Cut—Ctrl+X

● Copy—Ctrl+C

● Paste—Ctrl+V

● Delete—Press Delete.

Formatting Components
Components feature a shortcut menu, the primary means of formatting and editing. All menus
are identical with the exception of component-specific Custom Settings commands:

Command Submenu Description

Bring to Front  Brings the selected object to the top and front when objects are layered.

Send to Back  Sends the selected object to the bottom and back when objects are layered.

Edit   

 Cut Removes the selected object to the clipboard.

 Copy Saves the selected object to the clipboard.

 Paste Pastes content from the clipboard into the selected object.

 Delete Deletes the selected component.

Opaque  Makes the selected object opaque when selected, or transparent when
deselected.
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Command Submenu Description

Border   

 Etched Sets object borders to an etched style.

 Line Sets object borders to a solid line.

 Lowered Bevel Sets object borders to a lowered bevel style.

 Raised Bevel Sets object borders to a raised bevel style.

 None Removes object borders.

 Set Border Color Sets line border color.

 Set Border Size Sets the (interior) component line border width in pixels. Zero (0) means no
border.

Anchor   

 Top Affixes objects to the top edge of the panel.

 Bottom Affixes objects to the bottom edge of the panel.

 Left Affixes objects to the left edge of the panel.

 Right Affixes objects to the right edge of the panel.

 Slack Sizes the component to fill unused space.

 None Positions the component, using the underlying pixel grid.

Align   

 Top Edges Aligns the top edge of all selected components. Moves all selected
components vertically to the current position of the top edge of the top object.

 Vertical Centers Aligns the center point of all selected components. Center in this case is the
vertical center (left and right edges of components). Moves all selected
components vertically to a median determined using the top edge of the top
component and the bottom edge of the bottom component.

 Bottom Edges Aligns the bottom edges of all selected components. Moves all selected
components vertically to the current position of the bottom edge of the
bottom object.

 Left Edges Aligns the left edge of all selected components. Moves selected components
horizontally to the current position of the left edge of the left object.

 Horizontal Centers Aligns the center point of all selected components. Center in this case is the
horizontal center (top and bottom edges of components). Moves all selected
components horizontally to a median determined using the left edge of the
left component and the right edge of the right component.

 Right Edges Aligns the right edge of all selected components. Moves all selected
components horizontally to the current position of the right edge of the right
object.
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Command Submenu Description

Distribute   

 Top Edges Evenly spaces the top edge of three or more components vertically.

 Vertical Centers Evenly spaces the center point of three or more components. Center in this
case is the vertical center (left and right edges of components). Moves all
selected components vertically to a median determined using the top edge
of the top component and the bottom edge of the bottom component.

 Bottom Edges Evenly spaces the bottom edge of three or more components vertically.

 Left Edges Evenly spaces the left edge of three or more components horizontally.

 Horizontal Centers Evenly spaces the center point of three or more components. Center in this
case is the horizontal center (top and bottom edges of components). Moves
all selected components horizontally to a median determined using the left
edge of the left component and the right edge of the right component.

 Right Edges Evenly spaces the right edge of three or more components horizontally.

Custom Settings  Displays additional component-specific commands. Options are described
in component profiles.

Font Properties  Displays the Font Properties dialog box to format caption fonts.

Properties  Displays the component-specific property dialog box, or a series of dialog
boxes.

Default Object Properties
Default properties are assigned to documents imported into Document Designer:

Property Default Implications

Opaque Enabled The object obscures other objects behind it.

Border Etched All objects feature a default border.

Anchor Slack Change the alignment property, if you intend to resize the data object.

Data Object Properties Data Source Be aware that all objects using one data source are coordinated. Navigation
in object affects all objects using one data source.

 Display Type To change display type, select Properties from the shortcut menu.

Setting the Background
To create a uniform background for the custom document, you must create a panel object, and
anchor the panel to fill all slack space. You can set the background to a color or arrangement of
images. Every custom document begins with a master panel. See “Setting Document Designer
Options” on page 213.
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➤ To set a background image for a panel:

1 Right-click a panel, and select Properties.

The Select Graphic dialog box is displayed. You can select a background color, or a graphic
background for the panel (using Load). The Style group box controls image placement. Clear
resets the panel to the default grey background.

2 Select one Style option:

● Center—Centers the image horizontally on the master panel.

● Stretch—Stretches the image to the height and width of the master panel.

● Tile—Repeats the image across the master panel until the area is covered.

● Top-Left—Anchors the image in the top left corner of the master panel.

3 Click Load.

The Open dialog box is displayed.

4 Navigate to a network location containing graphic JPG or GIF files, and select a file.

5 Click Open.

The image is displayed on the master panel as specified by the Style option.

Aligning Components
Components are positioned relative to the panel containing them. Document designers edit
relative component positioning and spacing using alignment controls.

➤ To align components, right-click the component and select a shortcut menu option.

Anchor Options
The Anchor property orients selected components to an edge of the panel containing them.
Using Slack alignment, you can realign objects to occupy empty space.

Design documents using container panels and orient components inside these panels.
Components placed with absolute alignment in the main document panel maintain their
position as other components fluctuate. This may cause overlapping and shifting components.

Relative Alignment
Anchored components can also be positioned relative to other components. For example,
selection buttons anchored to the left edge of the panel may nevertheless be unevenly spaced.

Align and Distribute controls position components and space components relative to edges or
center points.
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Spacing Options
Spacing components using the Distribution feature does account for object size or space between
objects, only for space between edges or center points.

Spacing between object sizes that differ may vary, even when an edge of three or more
components is evenly spaced.

Alignment Options

Shortcut Command Description

Anchor  

Top Affixes objects to the top edge of the panel.

Bottom Affixes objects to the bottom edge of the panel.

Left Affixes objects to the left edge of the panel.

Right Affixes objects to the right edge of the panel.

Slack Sizes the component to fill unused space.

None Positions the component, using the underlying pixel grid.

Align  

 Top Edges Aligns the top edge of all selected components. Moves all selected components vertically
to the current position of the top edge of the top object.

 Vertical Centers Aligns the center point of all selected components. Center in this case is the vertical center,
evenly spaced from the left and right edges of components. Moves all selected components
vertically to a median determined using the center of the top component and the center of
the bottom component.

 Bottom Edges Aligns the bottom edge of all selected components. Moves all selected components vertically
to the current position of the bottom edge of the bottom object.

 Left Edges Aligns the left edge of all selected components. Moves all selected components horizontally
to the current position of the left edge of the left object.

 Horizontal Centers Aligns the center point of all selected components. Center in this case is the horizontal center,
evenly spaced from the top and bottom edges of components. Moves all selected
components horizontally to a median determined using the center of the left component and
the center of the farthest right component.

 Right Edges Aligns the right edge of all selected components. Moves all selected components horizontally
to the current position of the right edge of the farthest right object.

Distribute  

 Top Edges Evenly spaces the top edge of three or more components vertically.

 Vertical Centers Evenly spaces the center point of three or more components. Center in this case is the vertical
center, evenly spaced from the left and right edges of components. Moves all selected
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Shortcut Command Description

components vertically to a median determined using the center of the top component and
the center of the bottom component.

 Bottom Edges Evenly spaces the bottom edge of three or more components vertically.

 Left Edges Evenly spaces the left edge of three or more components horizontally.

 Horizontal Centers Evenly spaces the center point of three or more components. Center in this case is the
horizontal center, evenly spaced from the top and bottom edges of components. Moves all
selected components horizontally to a median determined using the center of the farthest
left component and the center of the farthest right component.

 Right Edges Evenly spaces the right edge of three or more components horizontally.

Creating Hotspots

➤ To create a hotspot:

1 Drag a Services button from the component toolbar to the document panel.

The Service Properties dialog box is displayed.

2 Select a service type from the Select Service Type list.

The Service button features a gray color and border and an opaque text label by default.

3 If you do not want a text label, delete the default label text.

4 To indicate a border color, click the Color button.

The Select Color dialog box is displayed, enabling the selection of a color for the button and the
border.

5 Click OK to return to the Service Properties dialog box.

The button and the border displays the selected color. If you want transparent hotspots with
colored borders, you must finish creating the service button, and disable the opaque property
on the service button shortcut menu.

6 Click OK.

The Service button can be sized and located, for component.

Note:

Use the Bring to Front shortcut menu command to locate hotspots on other objects.
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Creating Split Panels

➤ To create a split panel (a panel with a movable splitter bar):

1 In Document Designer, drag a Split Panel object from the component toolbar onto the content area.

The Split Panel Properties dialog box is displayed.

2 Select a horizontal or vertical splitter bar from the Orientation radio button group.

3 Optional: In the Sizing group, select One-Touch Expandable to add controls to the splitter bar.

The Splitter bar is the slider that divides the split panel. When the One-Touch Expandable option
is selected, two arrow controls move the splitter bar in opposing directions with one click.

4 Optional: In the Background Images group, click Left/Right or Top/Bottom, to display the Select Graphic
dialog box for that half of the Split Panel.

You can set a color for the specified half of the split panel, or load a background image in it. See
“Selecting Graphics” on page 114.

5 Click OK.

Nesting Split Panels
By dragging a Split Panel object onto another Split Panel object, you can nest split panels inside
one another. This enables you to use horizontal and vertical splitter bars simultaneously.

Retrieving Focus From Slack Space Split Panels
Focus must be removed from the split panel before the slider bar can be adjusted. When the split
panel alignment is set to Slack Space, the split panel controls the document, and you cannot
click outside the split panel. In this case, click the Splitter bar until the Split panel is deselected.

Linking Components by Query
To create a document you are required to specify:

● Data source—Provides data values

● Data object—Displays these values

● Query—Gets data values from the data source and returns them to the data object.

To set properties customizing these elements:

● Database Connection Properties indicate the type of data source, logon credentials, database
applications, dimension formatting and drill-through properties.

● Each data object can be set to a display types that features formatting options.

● Queries can be explicit, requesting information on dimension members, or dynamic,
requesting information about dimension member that satisfies a set of criteria.
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In Document Designer, the query definition is referred to as the data source.

Common Data Sources
Components using one data source are coordinated. Component navigation requires all
components using one data source to follow common lines of navigation.

To link dimension in data objects in one document, use Custom Settings. See “Linking Selected
Dimensions” on page 225.

Unlinking Components
If you do not want coordinated components, assign another data source to an object. Identical
data sources with names that differ are treated separately.

Linking Selected Dimensions
Use Custom Settings to link dimensions in data objects in one document.

Dimensional linking enables data objects sharing dimensions to remain coordinated regardless
of data source. Links are unidirectional; navigation on a data object triggers coordinated
navigation on other data objects linked to it. Data objects without defined links do not mutually
trigger navigation.

➤ To locate data object custom settings, enter Document Designer and right click a data object.

Data Object Custom Settings Description

Add/Show Data Source Link Places the data objects in the current document into Data Source Link mode.

Remove Data Source Link Deletes all data source links in the selected data object.

➤ To link selected dimensions of data objects in one document:

1 Enter Document Designer.

2 Right-click the data object from which links are to be driven.

Links are unidirectional. Bidimensional and multidimensional links must be created by
repeating this procedure on each data object. Components using one data source are also
coordinated, but these links are not dimension-specific.

3 Select Custom Settings > Add/Show Data Source Link.

The data object borders are red, green or black.

● Red borders—Indicate the data objects share a data source.

● Green borders—Indicate the data objects available for dimensional linking.

● Black borders—Indicate the data objects with previously defined links.
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Black-bordered objects cannot be used to define links. You must remove the link definitions
before defining link definitions.

Red-bordered objects share a data source. All dimensions are coordinated.

4 Click a green-bordered object.

The Select Dimensions dialog box is displayed.

5 Click a check box to select a dimension.

You can select multiple dimensions.

6 Click OK.

You are returned to Document Designer. You must return to Analyze before demonstrating
linking behavior.

Creating Subscription Controls
You can create five controls using one procedure:

● Combo Box Subscription

● Radio Button Group Subscription

● Check Box Group Subscription

● Tab Group Subscription

● Slider Subscription

There are alternative procedures for customizing:

● Multi-level Combo Box Subscription

● Selection Button Subscription

● SQL Subscription Objects

There is also a procedure for making subscription controls dependent on other subscription
controls.

Subscription Control Dialog Sequence
After creating a control, an automated dialog sequence helps you set properties:

● The Select Data Source prompts you to relate the control to a data source (query).

● The Select Dimension dialog box prompts you to select a dimension from the query.

● The Select Member dialog box prompts you to specify members and formatting options.
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Creating Subscription Controls

➤ To create subscription controls:

1 Drag a Subscription control object from the component toolbar to the content area of the custom document.

The Select Data Source dialog box is displayed.

2 Click to select a data source.

The Make Dependent option makes the subscription controls dependent on other controls
sharing this data source. See “Creating Dependent Subscription Controls” on page 229.

3 Click OK.

The Select Dimension dialog box is displayed.

4 Select a dimension name, and click OK.

The Select Member dialog box is displayed.

5 Click Add.

The Dimension Browser for the selected dimension is displayed.

6 Make member selections, and click OK.

Selected members display in the Select Member dialog box. You can also select font properties,
color properties, and rename the dimension member labels. The first dimension member in the
panel is used as the button label, so it is often helpful to rename the member to a more descriptive
label.

These optional subscription control procedures are also available:

● Ordering Dimension Member Controls

● Indenting Dimension Member Controls

● Changing Data Sources

● Creating Dynamic Dimension Member Controls

● Creating Dependent Subscription Controls

7 Click OK.

The dimension member control is displayed on the custom document.
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Ordering Dimension Member Controls

➤ To reorder member controls, select a member name and use the arrow buttons to move the
member in the index order. The order of members is reflected in the custom document when
you Click OK.

Indenting Dimension Member Controls
When creating check box and radio button group subscription controls, you can indent
dimension member controls a number of pixels based on each members level from the top of
the dimension hierarchy.

➤ To indent dimension member controls, open Select Members and select Indent Members.

Saving Subscription Control Selections to User POVs
User POVs enable users to select members in Filters, Pages, Rows, and Columns (Data Layout
and/or member selection controls) and apply them to multiple Web Analysis documents.

All Subscription controls have “Save Selection as User POV” option. When a selection is made
on the control, it is automatically saved to the User POV as a filter. If the Subscription control
points to multiple ReportDataSrcs, all of the underlying Database Connections have their
User points of view set for the dimension that the control applies to.

In order for a Web Analysis document to utilize the User POV selection, the option “Use User
POV” must be enabled in the Data Layout > Options dialog.

Enabling a Subscription Control to “Activate from Service
Button”
This feature allows for Subscription Control member selections to be made, and performs a data
retrieval by clicking the Service Button. Users can make multiple Subscription Control selections
without retrieving data for each selection. Subscription Control’s Properties / Select Members
dialog has a option to “Activate From Service Button”. A Service Button for “Apply
Subscriptions” must be added to the Web Analysis document to perform data retrieval after
making Subscription Control selections.

Changing Data Sources

➤ To change the data source for a dimension member control, click Relink.

The Select Data Source dialog box is displayed.
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Creating Dynamic Dimension Member Controls
You can define dimension member controls using an explicit selection or advanced member
selection, and use advanced member selections to populate the control. Using advanced member
selection to populate a control makes the control dynamic. As members are added deleted and
changed in the database, the control maintains itself and does not become obsolete.

For example, you can create a Product dimension member control. You can make a children of
Product dimension member control, and you can make a control that displays the Children of
Product, whatever they are.

➤ To create a dynamic dimension member control, select Dynamic in Member. Dynamic dimension
members must utilize an advanced member selection.

Creating Dependent Subscription Controls
You can make subscription controls dependent on other controls sharing a data source. This
enables you to create a chain of dependent subscription controls, where dimension member
selections in a subscription control prompt the display of the selection’s children in dependent
controls. Multiple dependent controls can be created to reflect the depth of the dimension
hierarchy.

Because check box subscription controls enable multiple member selection, they cannot be used
by dependent subscription controls. You are warned when you attempt to delete a subscription
control with dependent controls, as dependent controls do not function without the primary
subscription control.

➤ To create a dependent subscription control for a subscription control:

1 Drag a subscription control object from the Custom Document component toolbar to a document panel.

The Select Data Source dialog box is displayed.

2 Select Make Dependent.

Primary subscription controls are displayed.

3 Click to select a subscription control and click OK.

The dependent subscription control is displayed on the custom document. It is populated with
the children of the primary subscription control when selections are made.

Creating Selection Buttons
The Selection Button object creates a control button coordinated with other objects in the
document using a common data source. Selection button properties differ from other
subscription controls.
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➤ To create a selection button:

1 Drag the Selection Button object from the component toolbar to the content area of the custom document.

The Select Data Source dialog box is displayed.

2 Click to select a data source.

The selection button is coordinated with the data objects sharing one data source.

The Make Dependent option makes the control dependent on other controls sharing this data
source. See “Creating Dependent Subscription Controls” on page 229.

3 Click OK.

The Select Dimension dialog box is displayed.

4 Select a dimension name, and click OK.

The Select Member dialog box is displayed.

5 Click Add.

The Dimension Browser for the selected dimension is displayed.

6 Make member selections, and click OK.

The selected members display in the Select Member dialog box. You can select font properties,
color properties, and rename the dimension member labels. The first dimension member in the
panel is used as the button label, so it is often helpful to rename the member to a more descriptive
label.

You can define dimension member controls using an explicit selection or advanced member
selection. In addition, you can use advanced member selections to populate the control. Using
advanced member selection to populate a control makes the control dynamic. As members are
added deleted and changed in the database, the control maintains itself and does not become
obsolete.

These optional subscription control procedures are also available:

● Ordering Dimension Member Controls

● Creating Extended Mode Controls

● Renaming Dimension Member Buttons

7 Click OK.
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Ordering Dimension Member Controls

➤ To reorder member controls, select a member name and use the arrow buttons to move the
member on the index panel. The order of members is reflected in the custom document, when
you click OK.

Creating Extended Mode Controls
The Extended Mode option enables you to make live member selections, when you review the
custom document. Clicking the selection button in Analyze presents another Select Member
dialog box that contains options for defined member selections. You can select and display
members ad hoc.

➤ To create an extended mode dimension member control, select Extended Mode.

Renaming Dimension Member Buttons
You can rename member text labels on custom controls (combo box, radio button group, check
box, tab series, slider bar, and selection button) in the course of setting the data source (query),
selecting a dimension from the query, and specifying members.

➤ To rename member text labels, click Rename Button on the Select Member dialog box. When
the Enter Member's Display Name dialog box is displayed, enter a text label and click OK.

Creating Dynamic Text Labels

➤ To create dynamic text labels:

1 In Document Designer, drag a label object from the component toolbar onto the content area of the custom
document.

The Insert Text dialog box is displayed.

2 Right-click Caption and select a dynamic text label from the shortcut menu.

3 Click OK.

Dynamic Text Labels
Dynamic text labels are variables that are dynamically replaced with values at runtime. Dynamic
text labels display the latest information without being manually updated

You can use Dynamic Text Labels to create these dynamically updated components:

● Labels—Add dynamic text labels to label objects using the shortcut menu. See “Label Object”
on page 236.
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● Headers and footers—For your JPG, PDF and hardcopy output, use dynamic text labels in
the Print dialog box Headers/Footers tab. See “Print Dialog Headers/Footers Tab” on page
151.

● SQL statements—Include dynamic text labels in your SQL filter clauses as values. See “SQL
Spreadsheets” on page 193.

Dynamic Text Tag Default Tag Inserts this item in the label object:

Database Note <<dbnote>> A database note

Cell Reference <cell 0,0>> A cell reference string

Page <<page>> A page dimension name

Filter <<filter 0>> A filter member name

Document Description <<rd>> A document description string

Document Name <<rn>> A document name string

Date/Time <<date,MM-dd-yyyy>> A date/time string

Connection Name <<cn>> A database connection name string

Username <<username>> A user name string

UserID <<userid>> A User ID string

After dynamic text labels are placed in the Insert Text dialog box, you can edit tags to display
additional information.

For information on Dynamic Text Labels for SQL Spreadsheet, See “Dynamic Text Labels for
SQL Spreadsheets” on page 200.

Fixed References
Because dynamic text labels change as focus is shifted in composite documents, you may want
to fix dynamic references. Tags can be associated with specified data sources using these
modifications:

Dynamic Text Tag Default Tag Fixed Reference

Connection Name <<cn>> <<cn DataSourceName1>>

Cell Reference <<cell 0,0>> <<cell DataSourceName1,0,0>>

Filter <<filter>> <<filter DataSourceName1,0>>

Pages <<page>> <<page DataSourceName1>>

Database Note <<dbnote>> <<dbnote DataSourceName1>>
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Note:

It is not possible to specify a fixed references for a page dimension member.

Time Format Syntax
Time Format strings specify the format of the dynamic date/time label. The number and order
of ASCII characters determines the format used:

ASCII Symbol Meaning Type Example

G Era Text AD

y Year Number 2002

M Month in Year Text & Number July & 07

d Day in Month Number 10

h Hour in am/pm (1-12) Number 12

H Hour in Day (0-23) Number 0

m Minute in Hour Number 30

s Second in Minute Number 55

S Millisecond Number 978

E Day in Week Text Tuesday

D Day in Year Number 189

F Day of Week in Month Number 2 (meaning 2nd Wed in July)

w Week in Year Number 27

W Week in Month Number 2

a am/pm marker Text PM

k Hour in Day (1-24) Number 24

K Hour in am/pm (0-11) Number 0

z Time Zone Text Pacific Standard Time

' (apostrophe) Escape for Text Delimiter  

' ‘(single quote) Single Quote Literal '

When four or more characters are used, a completely spelled value is returned.

When three or more Text & Number types letters are used, text is provided. When only one or
two letters are provided for this type, the number is provided.
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Numbers use the minimum number of digits. Year can be truncated to two digits. Shorter
numbers are zero-padded.

All other characters are used as quoted text strings.

Examples
"yyyy.MM.dd G 'at' hh:mm:ss z" returns 1996.07.10 AD at 15:08:56 PDT

"EEE, MMM d, 'yy" returns Wed, July 10, '96

"h:mm a" returns 12:08 PM

"yyyyy.MMMMM.dd GGG hh:mm aaa" returns 1996.July.10 AD 12:08 PM

Custom Document Components
This section describes each custom document component:

● Panel Object

● Split Panel Object

● Label Object

● Text Area Object

● Image Objects

● HTML Browser Object

● Combo Box Subscription

● Radio Button Group Subscription

● Check Box Group Subscription

● Tab Group Subscription

● Slider Subscription

● Selection Button Subscription

● Multi-level Combo Box Subscription

● Alias Controller Object

● Services Button Object

● SQL Spreadsheet Objects

● SQL Subscription Objects

Panel Object
The Panel object creates an empty container for dividing space in the document.
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Panel object properties are set using the Select Graphic dialog box. See “Adding Custom
Document Components” on page 217.

Using Panels for Object Placement
To fit Web Analysis documents to any screen resolution and to help with object-placement
differences between Web Analysis Studio and Workspace, use a panel or split panel object. On
the panels, the report designer sets the anchor to Top, Bottom, Left, Right, or Slack:

● Top or Bottom—Anchors the object to the top or bottom of the panel respectively. Thus,
the object expands its width to the panel size; however, the height does not change.

● Left or Right—Anchors the object to the left or right of the panel respectively. Thus, the
object expands its height to the panel size; however, the width does not change.

● Slack —Consumes all available space in the panel. Thus, it expands its height and width to
the panel size.

Split Panel Object
The Split Panel object creates two coordinated panels separated by a splitter bar. See “Creating
Split Panels” on page 224

Control Description

Orientation  

Horizontal Sets the Splitter bar to a horizontal orientation that coordinates a top and bottom
panel.

Vertical Sets the Splitter bar to a vertical orientation that coordinates a left and right panel.

Properties  

One-touch Expandable Enables the Splitter bar to jump to the opposite panel with one click.

Set Current Sizes As Preferred Enables you to position the Splitter bar using the pixel grid. The Split Panel definition
is updated when you click OK, and this setting is refreshed each time the dialog is
displayed.

Background Images  

Left Displays the Select Graphic dialog box to set the background image of the left panel
when the Splitter bar is vertical.

Right Displays the Select Graphic dialog box to set the background image of the right panel
when the Splitter bar is vertical.
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Control Description

Top Displays the Select Graphic dialog box to set the background image of the top panel
when the Splitter bar is horizontal.

Bottom Displays the Select Graphic dialog box to set the background image of the bottom
panel when the Splitter bar is horizontal.

Label Object
The Label object creates static or dynamic text for use as a title, label, or caption. You can enter
label text in the Label Caption dialog box. See “Adding Custom Document Components” on
page 217 or “Creating Dynamic Text Labels” on page 231.

Text Area Object
The Text Area object creates a dynamic text box used for annotating documents.

You are prompted to populate the text object with a default text string with the Enter Default
Text dialog box.

Image Objects
The Image object creates a graphic. This enables you to create backgrounds, pictures,
illustrations, and graphic controls.

Image object properties are set using the Select Graphic dialog box. Graphic controls are created
in conjunction with the Services Button object. See “Creating Hotspots” on page 223 or “Services
Button Object” on page 239.

HTML Browser Object
The HTML Browser object creates a pane for displaying static HTML. The HTML is not
interactive. Selecting Properties from the component shortcut menu displays the HTML Object
Properties dialog box, used to specify a URL.
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Combo Box Subscription
The Combo Box Subscription object creates a drop-down list coordinated with other objects
using a data source. See “Creating Subscription Controls” on page 226.

Radio Button Group Subscription
The Radio Button Group Subscription object creates a radio button group (option button group)
that is coordinated with other objects using a common data source. See “Creating Subscription
Controls” on page 226.

Check Box Group Subscription
The Check Box object creates check boxes coordinated with other objects using a common data
source. See “Creating Subscription Controls” on page 226.

Tab Group Subscription
The Tab Group Subscription object creates a tab series coordinated with other objects using a
common data source.

The shortcut menu for Tab Group Subscription objects contains a special Custom Settings
command. Tab Groups are typically positioned on one side of a coordinated rectangular data
object, visually suggesting that the tab emerges from that side of the rectangle. The Orientation
options indicate the side of the data object on which the tabs are positioned:

● Top

● Bottom

● Left

● Right

Note:

The tab group area must be resized to display correctly.

See “Creating Subscription Controls” on page 226.
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Slider Subscription
The Slider Subscription creates a bar control coordinated with other objects using a common
data source. The shortcut menu for Slider Subscription objects contains a special Custom
Settings command:

Custom Setting Description

Orientation The alignment of the slider subscription in relation to the document.

Horizontal  

Vertical  

Show Ticks Shows or hides the member points on the slider bar track.

Show Track Shows or hides the slider bar track.

Show Labels Show or hides the member labels on the slider bar track.

Snap to Ticks Requires the slider to snap to tick points on the slider bar track.

See “Creating Subscription Controls” on page 226.

Selection Button Subscription
The Selection Button object creates a control button (command button) coordinated with
objects using a common data source.

The Select Member dialog box Extended Mode option enables you to make live member
selections when reviewing the custom document. Clicking the selection button in Analyze
presents another Select Member dialog box, containing check boxes for defined member
selections. You can select and display these members ad hoc. See “Creating Dependent
Subscription Controls” on page 229.

Multi-level Combo Box Subscription
The Multi-Level Combo Box Subscription object creates multiple coordinated drop-down lists
representing the dimensional hierarchy. They are also coordinated with other objects using a
common data source.

The combo boxes cascade. Selections made in a previous combo box populate subsequent dialog
boxes with hierarchical descendents. Use the Custom Setting shortcut menu command to
indicate the number of levels to cascade from the initial dimension member selection.

Multi-Level Combo Box Subscription objects feature a special Custom Settings shortcut menu
command:

238 Creating Custom Documents



Custom Settings Description

Orientation Arranges the cascading multiple combo boxes horizontally or vertically.

Note: The component area must be resized to display correctly. Also consider that asymmetric
hierarchies require a component area providing for the greatest number of combo boxes.

Horizontal  

Vertical  

Set Depth Displays the Enter Maximum Depth dialog box, used to indicate the number of levels from the
member the multi-level combo box should cascade (the number of subsequent combo boxes).

Alias Controller Object
The Alias Controller object enables custom document you to specify the alias table to use when
the label mode is set to Descriptions (for the coordinated data object). The Alias Controller and
the data object (Chart, Spreadsheet, or Pinboard) must be configured to share a common data
source.

Use the Select Data Source dialog box to select a data source for the Alias Controller object. You
can access the Select Data Source dialog box by dragging an Alias Controller object into the
Document panel, or by selecting Properties from the Alias Controller object shortcut menu.

Services Button Object
The Services Button object creates a button that callsWeb Analysis Studio services. Services are
application actions or behaviors. The Select Service dialog box sets Services Button object
properties.

Select Service Control Services Button Action

Logout Initiates logging off or existing fromWeb Analysis Studio

Previous Tab Navigates to the previous tab series option

Home Displays the Web Analysis Studio Home page

File Open Opens the Open dialog box

Print Opens the Print dialog box

Open Document Opens a specified document without use of the Open dialog box

Edit Data Puts the current document in edit data mode

Dimension Browser Displays the dimension browser for a selected dimension of a related data
object

Close Document Closes the specified document
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Select Service Control Services Button Action

Save Saves the current document

Toggle Toolbar Shows or hides the toolbar for the current document

Toggle Information Panel Shows or hides the View Pane Information Panel for the data object

Toggle Menu Shows or hides the current document's menu bar

Send to Clipboard Exports the current page of the current data object of the current document to
the operating system clipboard

Member Search Displays the Search dialog box, used to locate members in large dimension
hierarchies

See “Searching for Members” on page 68

Change Display Type Changes the data object display type

Display Type drop-down list Specifies the display type, which is applied by the Change Display Type service
button

Next Tab Navigates to the next tab series option

Desktop Displays the Web Analysis Studio Desktop

User Preferences Opens the User Preferences dialog box

Reload Document Reloads the current document

Analytic Services Calculation Script Triggers the specified calculation script of an Analytic Services data source

The calculation script consolidates the OLAP cube, reflecting changes
implemented through edit data mode or an update

Open Presentation Opens a specified presentation

Assign Edit Data Initiates edit data mode for a specified data object

Launch Executable Opens a specified application executable

Cube Navigator Opens the Cube Navigator dialog box for the current data object

Save As Opens the Save dialog box

Toggle Masthead Shows or hides the masthead for the current document

Toggle Status Bar Shows or hides the Status bar for the current document

Send to Excel Exports the current page of the current data object of the current document to
Microsoft Excel

Apply Subscriptions Performs a data retrieval when subscription controls that have “Activate From
Service Button” are enabled

Launch External Browser Launches a browser session for the specified URL

This URL enables passing of an SSO token, similar to related content URLs,
using the token syntax $SSO_TOKEN$
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Select Service Control Services Button Action

Valid in both Workspace and Web Analysis Studio

Services Button Properties Description

Enter Text Label Applies a static text caption to the Services button

Font Opens the Font Properties dialog box for formatting the caption font

Color Opens the Select Color dialog box for selecting button and border color

Select Graphic Opens the Select Graphic dialog box for setting the Services button background image

Clear Graphic Deletes the Services button background image

Hotspots
A hotspot is an area that is linked to a Web Analysis Studio service. It is an invisible button that
performs a predefined action. You can create a hotspot by making services buttons transparent.
The invisible service button can be located over a graphic image, giving the appearance that an
area of the image triggers the service.

Designers control the level of transparency. The hotspot can be completely invisible, display a
border, or display a border and a text label. Completely opaque Service buttons are considered
buttons, not hotspots. see “Creating Hotspots” on page 223.

Services Button Custom Settings
Services buttons feature a Custom Settings shortcut menu command:

Services Button Custom Setting Description

Location

Leading Positions icon before the text label

Trailing Positions icon after the text label

Horizontal Text Alignment

Left Positions the text label to the left side of the Services button

Center Horizontally centers the text label on the Services button

Right Positions the text label to the right side of the Services button

Vertical Text Alignment

Top Positions the text label to the top of the Services button

Center Vertically centers the text label on the Services button
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Services Button Custom Setting Description

Bottom Positions the text label to the bottom of the Services button

SQL Spreadsheet Objects
SQL Spreadsheet objects represent relational data sources as a spreadsheet, using standard SQL
syntax queries. A SQL Subscription object enables you to create coordinated controls for the
SQL spreadsheet. See “SQL Spreadsheets” on page 193.

SQL Subscription Objects
The SQL Subscription control enables you to select relational column definitions from a drop-
down list. The control is coordinated with a SQL Spreadsheet object using a matching relational
data source (SQL query). The shortcut menu for SQL Subscription objects contains a Custom
Settings command that indicates the type of subscription control used to present dimension
member selections:

● Combo box

● Radio button group

● Slider

● Tab group

See “Creating a SQL Subscription Control” on page 201.

Minimizing Document Load Times
Here are some general design recommendations for improving Web Analysis document load
times. Please note that these recommendations do not represent limitations of the product, but
general guidelines to allow a document to load faster. All references to a “query” are referring
to one Report Data Source in a document.

● No more than four (4) queries per document.

● No more than 100,000 of cells returned on a query.

● No more than four (4) OLAP selection/subscription controls that have “dynamic” enabled
per Web Analysis document and should only contain a maximum of 5000 members for
each.

● No more than 1000 pages on a query.

❍ No more than twenty (20) Traffic Lighting definitions with a maximum of seven (7)
levels per query.

❍ No more than twenty (20) Show/Hide definitions per query.

❍ No more than twenty (20) Calculations per query.

❍ No more than twenty (20) Data Formatting definitions per query.
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❍ Only one (1) Retrieve Top/Bottom per query.

❍ No more than twenty (20) Restrict Data conditions per query.

● No more than 1/2 MB of total size of graphics on a Web Analysis document. This includes
graphics used on pinboards.

● When LROs or Analytic Integration Services Drill Through report are not necessary, disable
the Show Linked Reporting Object Indicators to improve performance.

● When using advanced member selections to apply database formatting on a database
connection, limit the use on small outlines no more than 10,000 members.
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Editing Data Values

In This Chapter

Edit Data... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 245

Editing Data Values ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 245

Copying, Cutting, and Pasting To and From Microsoft Excel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 246

Tips for Edit Data Mode ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 246

Edit Data
Users with permissions can edit cell values and write edits back to Analytic Services. You can
initiate Edit Data mode only from the spreadsheet display type.

➤ To initiate Edit Data mode, right-click a cell and select Edit Data.

The Edit Data Bar is displayed at the bottom of the content area and features these controls:

Button Control Description

Close and Disable Edit Data mode Closes Edit Data mode.

Send/Commit changes to database server Applies edits to the database.

Calculate database Prompts the database server to recalculate the database.

Refresh Data Reload the last saved data values.

Editing Data Values

➤ To edit data values:

1 Right-click a cell and select Edit Data.

The Edit Data Bar is displayed.

2 Double-click a cell to edit its data value.
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The cell border becomes gray, and cell formatting is disabled.

3 Enter a data value and click outside the cell.

4 Click Send/Commit changes to the database server.

Only authorized users can successfully write changes to the database. The Confirmation dialog
box is displayed if write-back is successful.

5 Optional: To recalculate the database, click Calculate database.

6 To exit Edit Data mode, click Close and Disable Edit Data mode.

Copying, Cutting, and Pasting To and From Microsoft Excel
When in Edit Data, you can cut, copy and paste a range of cells from a Microsoft Excel spreadsheet
into the Web Analysis Studio spreadsheet. These edits can be posted to Analytic Services. You
can also cut, copy, and paste between values in Web Analysis Studio.

You can use these keyboard shortcuts:

● Copy—Select a range of cells and press Ctrl+C

● Cut—Select a range of cells and press Ctrl+X

● Paste—Select a range of cells and press Ctrl+V

Tips for Edit Data Mode
● You cannot edit calculated members, because these values do not reside in the database.

● You cannot edit attribute dimensions, because these values do not reside in the database.

● Dimensions composed of implied shares (or user-defined hierarchies) aggregate differently
than conventional dimension hierarchies. Therefore, the implied share may overwrite data
edits made to the Parent of an implied share as the model is pivoted.

Example: Actual and Budget are implied shares of the Parent, Scenario. Scenario, however, is a
categorical label, not an aggregation of Actual and Budget measures.
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Portlets
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Portlets
Portlets are reusable Web components that display relevant information to portal users.
Examples for portlets are Email, Weather, Discussion forum, and News.

Subscription Controls Functional in Portlets
In Web Analysis portlets, all navigation are performed through the Subscription Controls.

The Subscription Controls working principle is based on JavaScript functions. Using namespace
encoding provided by the portlet tag library, you can create separate JavaScript functions for
multiple instances of the same portlet on a portal page. In VIEW mode, the Web Analysis portlet
represents the Web Analysis document selected by administrator in EDIT mode, which contains
all data source and design objects as well as Subscription Controls. No right-click functions are
available.

Designer Components Not Supported in Portlets
The HTML Web Client does not render these designer components:

● Tab selection controls

● Slider delection controls

● Splitter panels

● Some service buttons

❍ Assign Edit Data

❍ Cube Navigator
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❍ Send to Excel

❍ Send to Clipboard

❍ Toggle Toolbar

❍ Toggle Status Bar

❍ Toggle Menu

❍ Logout

❍ Dimension Browser

❍ User Preferences

❍ Launch Executable

❍ Print

❍ Close Report

Launch Out to Workspace
“Launch Out to Workspace” enables launching a section of the screen in a Workspace window
with fully interactive menus.

Note:

Modifications to the launched instance are not applied back to the portlet instance.

Points of View, Personal Variables, and Subscription Controls
Member-selection related points of view and personal variables are passed to the launch out
instance, so that the same exact Web Analysis document (dimension layout, member selection,
data) is displayed. If points of view or personal variables are used for member selection in the
portlet (probably also in the source Web Analysis document overall), they should be selected.

Subscription controls reflect the member selections from the portlet. This is consistent with drill
linking one Web Analysis document to another (that is, if the target Web Analysis document
has subscription controls, member selections from the source Web Analysis document that are
passed are appended to the subscription controls in the target Web Analysis document).
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Accessing External Media
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Importing Documents and Presentations
You can import previously exported documents and presentations from local computers and
mapped drives. Exported documents are appended with the ARD file name extension. Exported
presentations are appended with the APT file name extension.

See, “Exporting Documents and Presentations” on page 144 and “Importing XML Document
and Presentation Definitions from Shared Services” on page 251.

➤ To import a document or presentation:

1 Select File > Import > From Local File.

The Import wizard is displayed. The Import wizard has two steps: Choose Files and Map
Resources.

2 Perform one:

● Enter the fully qualified path from your client to a file you would like to import in Select a
file to Import.

● Click the ellipses (...) button to Browse to the file using the Open dialog box.

3 Perform one:

● Enter the path from the root directory to the repository location to save the imported file.

● Click the ellipses (...) button to Browse to the repository location using the Open dialog box.

4 Optional: Select one:

● Click Create entire to recreate the database connections and documents used by the file,
from xml definitions in the file.
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● Click Map to existing files to use database connections and documents currently in the
repository, instead of generating duplicates.

If no selection is made, Map to existing is used by default.

In Step 2, you must map database connections, and for presentations, you must map
document playlists back to repository documents.

5 Optional: To locate a database connection for an unmapped document, perform these tasks:

a. Click a document row with a <Missing> status.

Three command buttons are enabled at the bottom of the dialog box.

b. Click Locate.

The Open dialog box is displayed, with the Files of type set to database connections.

c. Navigate to a database connection, select it, and click OK.

The Open dialog box is dismissed. The Step 2 frame displays the document database
connection status as OK.

6 Optional: To create a database connection for an unmapped document:

a. Click a document row with a <Missing> status.

Three command buttons are enabled at the bottom of the dialog box.

b. Click Create New.

The Database Editor dialog box is displayed with the Server tab current.

c. Enter a server name in Database Server.

Web Analysis Studio enters the cached user ID and password information in the Login
Information group.

d. Optional: Replace User ID and Password credentials.

e. Click Connect.

The Database tab is enabled.

f. Click the Database tab to make it current.

The Database tab features Application and Database areas and a Available Database
selection frame listing the databases on the connected data source.

g. In Available Database, select a database application.

The selection populates the corresponding area.

h. Optional: To define measures formatting criterion, click Formatting. See “Creating OLAP
and Hyperion Database Connections” on page 158.

i. Optional: To define a relational drill-through connection to a relational data source, click
the Relational Drill-through tab. See “Creating Relational Drill-Through” on page 163.

j. Click OK.

The Database Editor dialog box is dismissed. The Step 2 frame displays the document
database connection status as OK.
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7 Optional: To restore the original database connection exported with the document:

a. Click a document row with a <Missing> status.

Three command buttons are enabled at the bottom of the dialog box.

b. Click Restore.

c. The Save As dialog box prompts you for a location to which database connections and
document definitions are saved. Navigate to a repository location, enter a file name, and
click OK.

The Step 2 frame displays the document database connection status as <Creating>. The
connection is not created until you map all document rows.

8 Repeat steps 5, 6, and 7 until all documents are mapped to a database connection.

9 Click Finish.

10 When database connections are mapped for all imported documents in the selected repository folder, click
Close.

Importing XML Document and Presentation Definitions from
Shared Services

You can import Web Analysis Studio content from a configured Shared Services server.

➤ To import Web Analysis Studio content from Shared Services:

1 Select File > Import > from Shared Services.

The Import from Shared Services dialog box is displayed.

2 In Shared Services, select Web Analysis content from the node tree.

Each BI+ configuration registered with Shared Services is indicated by a root folder in the Shared
Services node tree. When you expand the root folder, a Default project folder is displayed.

Project folders are required under the root folder. Project folders can be used to distinguish
departments or to differentiate environments. When you expand a Project folder, default
Documents and Presentations folders are displayed.

The Documents and Presentation folders under the project folder are also required. They
categorize the kind of content stored on Shared Services. Only document content can be stored
in Documents subfolders and only presentation content can be stored in Presentation subfolders.

When you expand Documents and Presentations folders, subfolders are displayed. Subfolders
contain and group individual documents and presentations in the Documents and Presentations
folders.

3 In Repository, select a repository folder into which to copy the selected document or presentation:

To expand or collapse the node tree double click a node, or click the plus sign (+) or minus sign
(-). To select, click the repository folder name.
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Note:

Slash (/) and backslash (\) characters are replaced with an underscore (_) during import and
export to prevent exception errors in Shared Services.

4 If you want Web Analysis Studio to automatically create database connections for all imported documents,
or documents for all imported presentations, select Auto Create All Imported Resources.

5 Click Import.

Web Analysis Studio parses the exported XML document or presentation definition into a
definition stored in the repository.

If you selected Auto Create All Imported Resources, Web Analysis Studio regenerates documents
and database connections from your XML definitions. The auto create process assumes you have
access and permissions to the original data sources used by the database connection definition.

If you are not certain that you can access the original data sources used by the database
connection definition, do no select Auto Create All Imported Resources. You are prompted to
map documents to data sources you can access, instead.

If you do not want to load the repository with redundant document definitions, do no select
Auto Create All Imported Resources.

When a document or database connection cannot be found, the Import from Shared Services
dialog box lists individual imported documents, and the status of their database connections.
Documents with <Missing> status must be mapped to a database connection, or have a database
connection created for them. For presentations, the document playlist must be mapped to
documents in the repository or have documents regenerated from XML definitions.

6 Optional: To locate a database connection for an unmapped document:

a. Click a document row with a <Missing> status.

Three command buttons are enabled at the bottom of the dialog box.

b. Click Locate.

The Open dialog box is displayed, with Files of type set to database connections.

c. Navigate to a database connection, select it, and click OK.

The Open dialog box is dismissed. The Import from Shared Services dialog box displays
the document database connection status as OK.

7 Optional: To create a database connection for an unmapped document:

a. Click a document row with a <Missing> status.

Three command buttons are enabled at the bottom of the dialog box.

b. Click Create New.

The Database Editor dialog box is displayed with the Server tab current.

c. Enter a server name in Database Server.

Web Analysis Studio enters the cached user ID and password information in the Login
Information group box.

d. Optional: Replace User ID and Password credentials.
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e. Click Connect.

The Database tab is enabled.

f. Click the Database tab to make it current.

The Database tab features Application and Database text areas and a Available Database
selection frame listing the databases on the connected data source.

g. In Available Database, select a database application.

The selection populates the corresponding text areas.

h. Optional: To define measures formatting criterion, click the Formatting tab. See “Creating
OLAP and Hyperion Database Connections” on page 158.

i. Optional: To define a relational drill-through connection to a relational data source, click
the Relational Drill-through tab. See “Creating Relational Drill-Through” on page 163.

j. Click OK.

The Database Editor dialog box is dismissed. The Import from Shared Services dialog box
displays the document database connection status as OK.

8 Optional: To restore the original database connection exported with the document:

a. Click a document row with a <Missing> status.

Three command buttons are enabled at the bottom of the dialog box.

b. Click Restore.

c. The Save As dialog box prompts you for a location to which database connections and
document definitions are saved. Navigate to a repository location, enter a file name, and
click OK.

The Step 2 frame displays the document database connection status as <Creating>. The
connection is not created until you map all document rows.

9 Repeat steps 6, 7, and 8 until all documents are mapped to a database connection.

10 Click OK.

11 When database connections are mapped for all imported documents in the selected repository folder, click
Close.

Analytic Integration Services Drill-Through
Analytic Integration Services drill-through is a server-based form of relational drill-through. As
with conventional relational drill-through, you can construct liaisons between OLAP data and
relational data sources. With Analytic Integration Services drill-through, you can also drill to
the relational document from an intersection in the Web Analysis Studio document.

Your Analytic Services Administrator must establish Analytic Integration Services drill-through
documents. The relational query is stored as intersection-specific metadata and flagged as a
linked documenting object. When you double-click flagged cells, the OLAP document navigates
to the specified relational document.
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Web Analysis Studio enables read access to Analytic Integration Services through the Related
Content dialog box.

Linked documenting object indicators, blue triangles, indicate related content such as drill-
through documents. Each Analytic Integration Services drill-through document is unique to the
drilled intersection.

➤ To access an Analytic Integration Services document, double-click cells displaying linked
documenting object indicators, and select the drill-through document from the Related
Content dialog box.

Accessing Related Content
You can use Web Analysis Studio to create and retrieve related content definitions. Related
content can include, but is not limited to:

● LROs - cell notes, URLs, and file attachments stored at Analytic Services intersections

● Analytic Integration Services drill-through content

● Financial Management cell text and line item details stored at Financial Management
intersections

● Hyperion Documents content displayed as HTML or PDF

● Application Builder J2EE content

Web Analysis Studio passes the context of the current document to Application Builder J2EE
and other Web Analysis documents. This enables the related content target to reflect the current
POV.

When passing context to Hyperion Documents, only dimensions in the current Hyperion
Documents POV are imported.

After they are defined, Related Content definitions can be managed from the Related Content
dialog box and Analysis Tools Manager. Edits, including remove and remove all, made in the
Related Content dialog box change the content of the related content definition but do not
impact the existence of the definition. You can activate, deactivate, reorder, and remove related
content definitions in the Analysis Tools Manager, but you cannot edit definitions in that dialog
box.

➤ To access related content definitions:

1 Perform one:

● Double-click a cell displaying an LRO indicator.

● Right-click a cell displaying an LRO indicator and select Related Content from the shortcut
menu.

The Related Content dialog box is displayed.

2 To display the corresponding content, double-click a related content definition, or click Launch.

If necessary, select one client option from the shortcut menu, or the Launch drop-down list.
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Related Content Definitions
You can apply related content definitions to these cell ranges:

● All cells in a row by dimension member

● All cells in a column by dimension member

● Cells specified by a selection statement

● Specified cell intersections

When the Related Content dialog box is displayed, it lists all related content definitions for that
intersection. Related content definitions defined for cell intersections are differentiated by
italicized text.

Related Content Dialog Box
The Related Content dialog box lists previously configured related content links. Related
Content links are defined using the Add Related Content dialog box.

The Add Related Content dialog box saves document, dimension, or cell information to
registered Hyperion applications. Hyperion applications must be registered by administrators
using Shared Services or the Webanalysis.properties file.

For system integrity, only externally authenticated users can create related content definitions.
When no integrated Hyperion applications are registered with BI+, the Available panel is empty.

Control Used To:

Add Text Note Create a text note linked documenting object. Cell Intersections only.

Add URL Define an URL linked documenting object. Cell Intersections only.

Add File Specify the location of a Microsoft Windows file attachment (LRO). Cell Intersections only.

Add Related Content Pass context to other registered Hyperion applications.

Launch Display the linked documenting object or related content application specified by the
definition.

Edit Create the selected definition.

Delete Delete the selected related content definition.

Delete All Delete all related content definitions for the current selection.

Creating Related Content Definitions
Creating related content definitions is a two-part process, as described in these topics:

1. “Specifying Related Content Dimension Members” on page 256

2. “Defining Related Content” on page 256
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Specifying Related Content Dimension Members

➤ To apply a related content definition to a cell, right-click the cell and select Related Content.

➤ To apply a related content definition to all cells in a row or column by dimension member, right-
click the dimension member row or column header.

➤ To apply a related content definition to a selection statement:

1 Right-click the dimension member row or column header.

2 Select Related Content.

The Related Content dialog box is displayed.

3 To edit the dimension member selection displayed in Apply to, click Edit.

The Edit Selections dialog box is displayed.

4 To display Dimensions, click Advanced.

5 Click a check box to select dimension members.

If you select one dimension from the Dimensions panel, the corresponding dimension members
are displayed in the Combinations panel.

If you select multiple dimensions from the Dimensions panel, Combinations displays dimension
member aggregations.

6 To specify the dimension member, click check boxes in Combinations.

Selections display in Selections. Click Remove to delete the current selection, or Remove All to
delete all member selections and start over.

7 When dimension member selections are defined, click OK.

The Edit Selections dialog box is dismissed, and the Related Content dialog box is displayed.
The Apply To panel displays the dimension member selection. You can now create a related
content definition, using the next procedure.

Defining Related Content

➤ To create a related content definition:

1 Right-click the cell or dimension member header in which the related content is to be embedded.

2 Select Related Content.

The Related Content dialog box is displayed.

3 Click the Add Related Content icon.

The Add Related Content dialog box is displayed. In the Available panel, Hyperion applications
are listed as nodes. Each node can be expanded to list available application content.

4 To locate application content, perform one:
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● Double-click a node name to expand the node.

● Click a node plus sign (+) to expand the node.

Notice that applications such as Web Analysis Studio enable you to specify the client with
which the content displays.

5 Click to select the application content.

6 To move the selection to Selected Related Content, click Add.

If the “Show Properties When Adding Content” option , at the bottom of the Add Related
Content dialog box, is selected the Related Content Properties dialog box is displayed.

7 Optional: To set Related Content Properties for Selected Related Content, perform one:

● Select a related content definition and click Properties.

● Right-click a related content definition and select Properties.

The Related Content Properties dialog box is displayed.

You can optionally set properties:

● To change the related content definition name, enter a name in Label.

● To indicate how related content is displayed, select options in Client Options. Hyperion
documents related content can be displayed in HTML or PDF.

● To edit the URL of the related content definition, edit the URL of the corresponding tab.

8 Click OK to close the Related Content Properties dialog box.

9 Click OK to close the Add Related Content dialog box.

The related content definition is displayed in the Related Content dialog box.

10 Click Close.

The document displays the LRO indicator(s).

LROs
LROs embed cell notes, URLs, and file attachments in document cells. LROs are connections to
external media stored in Analytic Services.

LROs are available to Analytic Services users who enabled the Analytic Services Grid API feature.

An LRO indicator triangle indicates the presence of a drillable LRO. LROs are embedded in, and
move with, multidimensional intersections.

You can display or hide Linked Documenting Object indicators using the Data Display shortcut
menu.

Linked Documenting Objects can only be applied to cell intersections, unlike other related
content definitions (which can be applied to cells, rows, columns, or selection statements).
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Creating LROs

Note:

You must first configure and enable the Analytic Services Grid API, before you can create LROs.

➤ To create an LRO:

1 Right-click the cell in which the LRO is to be embedded.

2 Select Related Content

The Related Content dialog box is displayed.

3 Click one of the first three icons to define a cell note, URL or file attachment.

4 Perform one or more of these actions:

● Enter cell note information.

● Enter a URL and a description in the corresponding text areas.

● Enter a file attachment description, click Browse, navigate to the file attachment, and click
Open.

5 Click OK.

6 Click OK.

The document displays the LRO indicator.

Accessing LROs

➤ To access an LRO:

1 Perform one:

● Double-click a cell displaying an LRO indicator.

● Right-click a cell displaying an LRO indicator and select Related Content from the shortcut
menu.

The Related Content dialog box is displayed.

2 To display the corresponding content, double-click a related content definition, or click Launch.
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Working with Preference Files
You can customize the Web Analysis display and set behavior for documents by setting
preferences.

➤ To display the User Preferences dialog box, select File > Preferences.

Preferences are stored in the repository as a preference file. Although multiple preference files
can be defined, only one can be current, or active. Multiple users can share a common active
preference file, also called shared preferences.

User preference files for a user are located in a user’s Profiles folder and are named “Analyzer
Preferences”; for example, Users/username/Profiles/Analyzer Preferences. When
user preferences are modified, all changes are saved to this file.

An administrator can create a shared preference file that other users can select as their active
preferences.

Note:

Shared preference files can be created and edited only in Web Analysis Studio.
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At the top of the User Preferences dialog box, the Active Preferences controls specify the current
preference file. Changing active preferences does not impact currently opened documents in the
content area. Preferences are only applied to subsequently opened and created documents.

Note:

Some preferences may take effect only when documents are reloaded.

Topics that discuss preference files:

● “Setting Active Preferences” on page 260

● “Creating Preference Files” on page 261

● “Editing Shared Preference Files” on page 261

● “Managing Shared Preference Files” on page 261

Setting Active Preferences

➤ To set active preferences, perform one:

● To use the preference file in your Users/username/Profiles directory, click Use My
Preferences.

● To use another preference file, click Use Shared Preferences, and click Browse to navigate
to the preference file.

Preferences and Formatting Options
There are some identical formatting options and preferences. Preferences are global settings
applied to documents. Preferences, however, can be overridden by database connection
formatting and document-based formatting.

Order of Formatting Precedence

1. Formatting options saved with documents

2. Formatting options saved with the database connection

3. Formatting options specified in the User Preferences dialog box

See “Formatting Order of Precedence” on page 94.

Spreadsheet preferences and chart preferences are identical to spreadsheet options and chart
properties. They are only applied to subsequently created documents, however. See “Spreadsheet
Options” on page 104 and “Charts and Chart Types” on page 105.
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Creating Preference Files
Administrators can create preference files that users can select as shared preferences in Web
Analysis Studio and Workspace. The default folder for shared preferences is Users/
{Profiles}.

➤ To create a preference file that can be shared by users:

1 Select File > New > Preferences.

The Save As dialog box is displayed.

2 Navigate to a repository folder and enter a file name.

3 Click OK to display User Preferences.

4 Edit user preferences, and click OK to save changes.

Editing Shared Preference Files

➤ To change preferences settings in a shared preference file:

1 In Web Analysis Studio, navigate the repository to locate a shared preference file and select it.

2 Right-click the preference file and select Edit to open User Preferences.

3 Change user preferences, and click OK to save the changes and close User Preferences.

Managing Shared Preference Files
Preference files can be shared with among users to utilize as their active preferences.

➤ To enable user access to shared preference files:

1 In Workspace, navigate to a preference file, right-click it, and select Properties.

2 In Properties, under General Properties, click Edit Permissions.

3 Assign users, groups, or roles to the file (in the same manner as you would permissions to repository objects).

Finding Preferences
Preferences are organized onto nine (9) tabs. Click a tab to make it current.

Panel Preferences

General Home Page and Startup

Folders Reports folder, Databases Folder, Desktop Folder, and Favorites Folder

Look and Feel Use of Cube Navigator in documents, Desktop Wallpaper, and Interface Elements
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Panel Preferences

Drilling Drilling Methods, Linking, Append or Replace Member Selections (Expand on Drill)

Spreadsheet Spreadsheet Options

Chart Chart Properties

Default Formatting Leading and Trailing Formatting, Replace Missing With, and Numeric Formatting

OLAP Server Suppression, Show Linked Document Object Indicators, Financial Management Entity Currency
(Financial Intelligence)

Databases Database Alias Table, Default Log on, POV Definitions, Personal Variable Definitions

General Preferences
General preferences are divided into three groups:

● Home Page Preferences

● Startup Preferences

Home Page Preferences
The toolbar and the Go menu offer single-click access to a Web Analysis Studio Home page. The
home page should be a frequently used repository location.

You can specify the Desktop or a document as the Web Analysis Studio Home page. The specified
document is displayed when you click the Home toolbar button.

➤ To set the Web Analysis Studio Home page using preferences:

1 Select File > Preferences.

The User Preferences dialog box is displayed. Note that you are setting the Home page for active
preferences. If it is a shared preference, you are setting the Home page for all users sharing this
preference file.

2 Click to make General the current tab.

3 In Home Page, perform one:

● Click Use Desktop to set the Desktop Folder, as specified by Folder preferences, as the Home
Page.

● Click Use Current Document to set the current document as the Home Page.

● Click the ellipses (...) button to select a repository location from the Open dialog box as the
Home Page.

● Enter a repository location in the text area to be used as the Home Page.

4 Click OK.
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➤ To go to the Web Analysis Studio Home Page in Analyze:

●
Click .

● Select Go > Home.

● Press Alt+Home.

Startup Preferences
Startup preferences enable you to specify the document or document group to be displayed at
startup:

● The Analyze mode interface (None)

● The Open dialog box

● The Web Analysis Studio Home Page

● A presentation

● A document

➤ To set startup preferences:

1 Select File > Preferences.

The User Preferences dialog box is displayed. Note that you are setting the startup option for
active preferences. If it is a shared preference, you are setting the startup option for all users
sharing this preference file.

2 Click to make General the current tab.

3 In Startup, select one:

● None

● Start in Open Dialog

● Home Page

● Document

4 Optional: If you select Document, you must also specify which document to use:

● Click the ellipses (...) button to select a repository location from the Open dialog box as the
Startup document.

● Enter a repository location in the text area to be used as the Startup Document.

You can specify a document or a presentation as the startup document.

5 Click OK.

Folders Preferences
Folders preferences display the repository locations currently set as these folders for the active
user or group:
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● Reports folder

● Databases folder

● Desktop folder

● Favorites folder

You can only reset the folder locations for the active user.

Note:

As with all file systems, though the default directories, folders, and files were designed for a
purpose there is nothing to prevent you from diverging from this original design. See “User and
Group Folders” on page 47.

➤ To reset Folder preferences:

1 Select File > Preferences.

The User Preferences dialog box is displayed. Note that you are setting folders for active
preferences. If it is a shared preference, you are setting folders for all users sharing this preference
file.

2 Click to make Folders the current tab.

3 Perform one:

● In a text area, enter a repository location to be used for the corresponding folder.

● Alternatively, click the ellipses (...) button and select a repository location from the Open
dialog box, to be used for the corresponding folder.

4 Click OK.

Look and Feel Preferences
Look and Feel preferences are organized into three groups:

Look and Feel Preferences Description

New Documents Specifies Web Analysis Studio behavior for opening a database connection.

When disabled (default), opening a database connection through the Open Menu,
Open toolbar button or View Pane shortcut menu, results in a Auto-Populate Dimension
document. Auto-Populate Dimension documents assume use of the highest aggregate
members of the time and measures dimensions to populate the rows and columns
axes of a spreadsheet.

When enabled, the use of a spreadsheet is still assumed, but you must assign
dimensions to axes with Cube Navigator as part of creating a document.

Desktop Sets the Desktop wallpaper graphic, using the Select Graphic dialog box.

Display Sets interface elements to be displayed by default:

● Content tabs
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Look and Feel Preferences Description

● Main menu (menu bar)

● Toolbar

● Masthead

● Filter panel

● View pane

● Status bar

● Multi-page drop-down

Drilling Preferences
Drilling preferences are organized into these three groups:

Drilling Preferences Description

Method Sets drilling navigation through the dimension hierarchy to one of these menu options:

● Next Level - Returns the next lowest level.

● Descendants - Returns all descendants.

● Dimension Bottom - Returns the lowest level (level O).

● Siblings - Returns members on one level that share a parent.

● Same Level - Returns members on one level

● Same Generation - Returns members equidistant from the highest ancestor.

Linking Sets drilling navigation to Pass Page dimension and/or Pass Filter dimension context during
drill-through operations to other documents:

● Pass Pages - sets drill linking to pass the page dimension member context.

● Pass Filters - sets drill linking to pass the filter dimension member context.

Expand On Drill Augments the drilled member with the drilling result set. See “Drilling” on page 89.

Default Formatting Preferences
Formatting options format headers and data based on dimension member selections.

While the formatting options are fixed, the scope of the formatting varies depending on the
source of the formatting. See Chapter 8, “Formatting Documents.”

Formatting Options Description

Leading and Trailing Formatting  

Currency Symbol Inserts currency formatting symbols into the Positive Prefix and Negative Prefix text
boxes: Dollar ($), Cents (¢), Pound (£), Euro(E), Deutschmark (DM), Franc (F), and
Yen (¥).
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Formatting Options Description

Positive Prefix Enters character to precede positive numeric values.

Positive Suffix Enters character to follow positive numeric values.

Negative Prefix Enters character to precede negative numeric values. Warning: The minus sign (-)
is the default prefix. Deleting the default prefix without replacing it causes negative
values to display positively.

Negative Suffix Enters character to follow negative numeric values.

Numeric Formatting  

Grouped Thousands Displays numeric digits as grouped by thousands.

Minimum Decimals Indicates the minimum number of decimal places to display.

Maximum Decimals Indicates the maximum number of decimal places to display.

Scale Enables abbreviated values by tens, hundreds, thousands, ten-thousands,
hundred-thousands, millions, and billions.

Use Negative Color Indicates that negative numbers are signified by a selected color.

Select Negative Color Enables you to select the color representing negative values.

Samples  

Update Samples Updates the samples panel based on the most recent formatting selections.

Replace Missing With Replaces missing values with a text string or zero.

● Zero

● Text

OLAP Server Preferences
OLAP server preferences set features of the OLAP server from Web Analysis Studio.

OLAP Server Preferences Description

Suppress Omits components, as selected, from the query result set:

● Missing Rows

● Shared Members

● Zero Rows

Show Linked Reporting Object Indicators Enables and disables the display of LRO icons (triangles).

Display Entity Currency When using a Financial Management data source with defined Entity
dimension currency information, you can enable the Display Entity
Currency option, to append the Entity dimension members with your
currency value. This can be set before querying using Cube Navigator
options, after querying using the Data Display shortcut menu, and for all
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OLAP Server Preferences Description

subsequently created documents using OLAP Server preferences. See
“Financial Management” on page 168.

Save Filters only for User POV User POV enables users to select members in Filters, Pages, Rows, and
Columns (Data Layout and/or member selection controls) and applies
them to multiple Web Analysis documents.

All Subscription controls have Save Selection as a User POV option. A
selection is saved as a filter to the User POV.

Analytic Services imposes a maximum limit of 256 columns. Web Analysis Studio sets a column
limit of 50,000 data cells for a query. There is also a query governor that enables you to set limits
on the number of cells returned by a query; the default is also 50,000 data cells.

Database Preferences
Databases preferences provide an inventory of database servers and database connections
available to the current user by listing the database connection name, description, alias table,
and repository location for available database connections.

To review the database preferences for a database connection, you must select the database
connection name from the list and click Edit. The Database Preferences dialog box is displayed.
It has three tabs:

● General

● Point of View

● Personal Variable

You must click Connect to connect to the data source and retrieve the values for these settings.
If you are unable to connect, you may browse to another database connection file.

See also “Creating and Applying Points of View” on page 79 and “Creating and Selecting Personal
Variables” on page 78.

Alias Tables
Alias tables are database tables that store aliases, or alternate description labels, for dimensions
or members. Only Analytic Services enables you to define multiple alias tables. Web Analysis
Studio enables you to specify which alias table to use. The alias table selection is saved as a
Database user preference.

Label mode enables you to select whether a dimension member is listed by ID number,
description, or both. Label mode options are data source-specific, and can be set for database
connections, documents, and dimensions.

Although the label mode indicates whether the description or ID number is used, it is the database
alias table that provides the displayed value.

You can set the alias table before opening a document using Database preferences.
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You can set a default label mode before querying the data source using Cube Navigator options,
and after querying using Data Display options on the Main Display panel shortcut menu.

You can specify which description label to use in dimensions, using Dimension Browser and
using Data Display options on the data object shortcut menu.

Setting Alias Tables and Default Logon Method

➤ To specify a default alias table for a database connection:

1 Select File > Preferences.

The User Preferences dialog box is displayed. Note that you are setting the default alias table for
active preferences. If it is a shared preference, you are setting the default alias table for all users
sharing this preference file.

2 Click to make Databases the current tab.

3 Optional: To edit database preferences for a database connection, select the database connection from the
list and click Edit.

4 Optional: To add a database connection to the list, click Add.

The Database Preferences dialog box is displayed. It has three tabs: General, Point of View, and
Personal Variables. Note that the Point of View and Personal Variable tabs are disabled until a
database connection is identified.

5 Optional: To identify a database connection file, perform one:

● Click the Browse button and navigate to an database connection file in the repository. Select
the file and click the Open dialog box OK.

● Enter the repository location and file name for a database connection file in the text area.

If you cannot access database connections, See Chapter 12, “Managing Database
Connections,” or consult your Web Analysis Studio administrator.

6 Click Connect, to retrieve the latest values.

You may be prompted by the Database Login dialog box, to log on to the data source. Enter
logon credentials, and click OK.

When you connect to the data source, the Database File Location text area is disabled, and
Connect is converted to Disconnect. If you are using a data source that supports POV, Personal
Variables and Alias Tables, these controls are enabled.

7 Select an alias table from Alias Table.

8 Select one of these options from the Default Logon group:

Default Logon Options Description

Use User's ID and Password Connects to the database connection using the Web Analysis Studio user ID and
password.
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Default Logon Options Description

Prompt for User ID and Password Connects to the database connection by prompting the user for a Web Analysis
Studio user ID and password.

Enter User ID and Password Connects to the database connection using a user ID and password for the
database connection, if it varies from the Web Analysis Studio Login parameters.
You must enter values in the corresponding text areas.

9 Click OK.

Whenever the specified database connection is used, the selected label mode is also used.
Subsequent label mode selections made in the Cube Navigator or the Dimension Browser
overwrite these default settings.

POV Definitions
POV database preferences insert dimensions and members that are of interest to you into the
documents of others. POV definitions are defined and activated by database connection.

When a POV is activated, the Use Point of View option in Cube Navigator and the Document
Creation wizard are enabled. All subsequently created and loaded documents use the specified
POV until it is deactivated. You can also deactivate use of POV by deselecting the Cube Navigator
Use Point of View option as needed.

POV definitions consist of axes and dimension member selections. The definition is used when
documents are created with the activated POV.

When you apply a POV definition to a document, only the dimension member selections are
applied. This prevents points of view from automatically arranging non-functioning layouts
(such as moving all dimensions to one axis).

If all POV member selections are custom filters, you may not see obvious changes to your
document. You can check to see which POV is applied on the View Pane Information Panel tab,
Point of View segment.

Using a POV definition is a three part process. First, you must create a POV definition. Next,
you must activate the POV definition. Lastly, you must set a document to use the activated POV
definition, or create a document that uses it.

Consider these four (4) benefits:

Generic and Specific Documents
Document designers in large enterprises can create a set of generic documents, knowing that
individual users can superimpose diverse and user-specific member selections into these
documents.

POV Definitions 269



Replacing Member Selection Statements
You can apply the complex calculations and analysis tool definitions of others' documents to
the dimensions and members they track, using points of view. This eliminates the need for the
user to investigate and recreate these analyses.

Default Dimension Layout and Member Selections for New
Documents
When points of view are activated, the document-creation process is simplified. Cube Navigator
is loaded with the dimension member selections designated by the current POV.

Session-based Points of View
Session-based. POV definitions are saved and recalled as part of individual database connections.
This enables them to be used on all documents using the corresponding database connection.

Reloading Documents
You must reload the document for the applied POV definition to be displayed.

POV Definitions and Personal Variables
POV definitions replace all member selections for corresponding dimensions and database
connections. Personal variables can instead augment member selections for one dimension.

You can also leverage personal variables in the creation of POV definitions.

See “Creating and Applying Points of View” on page 79.

Personal Variables
Personal variables enable you to define and name complex member selections. After being
defined, you can select personal variables when they are presented (with the corresponding
dimension and database connection).

Generic and Specific Documents
Other users can create personal variables using matching name, dimension, and database
connection that contain the dimensions members that are of interest to them.

This technique enables everyone to create hybrid documents that feature generic and user-
specific content.

270 Setting Preferences



POV Definitions and Personal Variables
POV definitions replace all member selections for corresponding dimensions and database
connections. Personal variables can instead augment member selections for one dimension.

You can also leverage personal variables in the creation of POV definitions. See “Creating and
Selecting Personal Variables” on page 78.
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Web Analysis Configuration Options
WebAnalysis.properties contains variables that control Web Analysis functionality.
Administrators must modify this file to support their implementations.

WebAnalysis.properties location when using Apache Tomcat 4.0.1 application server:

C:\Hyperion\WebAnalysis\deployments\webapps\WebAnalysis\WEB-INF\conf

WebAnalysis.properties location when using IBM WebSphere application servers:

C:\Hyperion\appserver\hosts\default_host\WebAnalysis\classes

➤ To edit WebAnalysis.properties variables:

1 Stop the application server.

2 In a text editor, open WebAnalysis.properties.

The default installation location is \\Hyperion\WebAnalysis\conf
\WebAnalysis.properties.

3 Edit variables and save changes.

4 Restart the application server.

Topics that explain Web Analysis configuration options:

● “Controlling Result Sets” on page 274

● “Configuring Java Plug-in Versions” on page 274

● “Configuring the Repository” on page 275

● “Configuring Analytic Provider Services” on page 275
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● “Considerations for Configuring Analytic Provider Services” on page 276

● “Resolving Analytic Services Subscriptions in Web Analysis” on page 277

● “Configuring a Web Analysis Mail Server” on page 277

● “Formatting Data Value Tool Tips” on page 277

● “Setting Web Analysis to Log Queries” on page 278

● “Exporting Raw Data Values to Excel” on page 278”

● “Configuring MS Office to Support Web Analysis” on page 278

● “Restricting Users from Selecting Multiple Members in Filters” on page 278

● “Configuring Default Print Behavior” on page 279

● “Limiting Web Analysis Studio Shortcut Menu Options” on page 280

● “Controlling Sizes of Web Analysis Documents that are Exported to Excel” on page 281

Controlling Result Sets
Users and system administrators can set row limits to control relational and OLAP query result
set size. This protects server and network resources from being consumed by large query result
sets.

The Relational Drill-through dialog box features a “Max rows to return” field that controls the
number of rows returned during relational drill-through.

You must set other OLAP and relational row limits in WebAnalysis.properties, the path to
which varies by application server configuration.

WebAnalysis.properties contains variables that control the query result sets in terms of
rows:

● MaxDataCellLimit—OLAP database connection query result set size; default is 50000

● MaxJdbcCellCount—Relational database connection query result set size; default is 50000

Note:

“MaxJdbcCellCount” is located in the Analytic Services Config section.

Configuring Java Plug-in Versions
Web Analysis Studio is configured to use a specific Sun Java Plug-in, which administrators can
update by editing the static versioning statement in WebAnalysis.properties. This mandates
the loading of the Sun Java plug-in specified version when clients log on to Web Analysis Studio,
but does not impact the JDK used by the server.

➤ To edit the WebAnalysis.properties static versioning statement:

1 Stop the application server.

274 Web Analysis Administration and Configuration



2 In a text editor, open WebAnalysis.properties.

The default location is \\Hyperion\WebAnalysis\conf\WebAnalysis.properties.

At the top of the file are three variables:

_JREVersion=1.4
_JREClassID=CAFEEFAC-0014-0002-0006-ABCDEFFEDCBA
_JRECodeBaseVersion=j2re-1_4_2_06-windows-i586-p.exe

3 Edit these values and remove the preceding underscore to change the Sun Java Plug-in version.

Alphabetic characters at the beginning and end of the string are set by Sun. Do not change these
characters. The first two sets of numeric digits indicate the Sun Java plug-in version. The third
set of numeric digits indicates the patch number. For example, this is the class identifier (CLSID)
value for Sun Java plug-in 1.3.1_10:

clsid:CAFEEFAC-0013-0001-0010-ABCDEFFEDCBA

4 Save your changes.

5 Restart the application server.

Configuring the Repository
The Repository Config section of WebAnalysis.properties sets a series of variables
supporting JDBC connectivity for supported repositories:

db.type=
db.subprotocol=
db.driver=
db.alias=
db.user=
db.password=
db.password-encrypted=true

Alternate values for each variable are commented out on the line after the variable. To use an
alternate value, remove the pound sign (#) and place it before the old value.

When moving, migrating, or upgrading the repository, you may need to edit these variables and
re-encrypt the password (see “Repository Password Encryption Utility” on page 282).

Configuring Analytic Provider Services
WebAnalysis.properties supports variables that enable Hyperion® System™ 9 BI+™
Analytic Provider Services™, which provides Analytic Services connection alternatives for
administrators running Web Analysis on Solaris operating systems.

Review “Repository Password Encryption Utility” on page 282 before configuring Analytic
Provider Services.

See the Hyperion System 9 BI+ Analytic Provider Services Installation Guide for complete
information on installing, configuring, and using this service.
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Variable Description

UseEES A value of true prompts ADM to use Analytic Provider Services to access Analytic
Services; a value of false enables ADM to use the default JNDI driver

EESDriverName Analytic Provider Services driver to ADM; do not modify

EESServerName Server running Analytic Provider Services

EESLocale Locale for Analytic Provider Services

EESDomain Domain for Analytic Provider Services; do not modify this variable

EESORBType ORB type for Analytic Provider Services; only TCP/IP is supported

EESPort Analytic Provider Services communication port

EESUseConnPool

EESConnPerOp

Method ADM uses for Analytic Provider Services connection pooling

A connection pool is a set of login sessions from Analytic Provider Services to an
Analytic Services server. Analytic Provider Services uses a connection pool to process
requests for Analytic Services services. There are three combinations of these
properties:

● EESUseConnPool=false EESConnPerOp is ignored—Connection pooling is not
used

● EESUseConnPool=true EESConnPerOp=false—Connection pooling is used;
connection is held from when cube view is opened until it is closed

● EESUseConnPool=true EESConnPerOp=true—Connection pooling is used;
connection is released immediately after each operation

EESUseReportOption Set to true only if using Microsoft's JVM

UseUnicodeAdmConnection Default value is false. Set to true on this configuration:

Web Analysis server: OS HP-UX 11i, LANG=ko_KR.utf8, LC_ALL=ko_KR.utf8,
ESSLAN=Korean_Korea.MS949@Binary

Analytic Services server: ESSLAN=Korean_Korea.MS949@Binary

Considerations for Configuring Analytic Provider Services
Keep in mind these items when configuring Analytic Provider Services:

● User name and password used by the ADM Analytic Provider Services driver must be valid
on the Analytic Provider Services server and the Analytic Services server.

● ChangePassword and SetPassword server actions attempt to modify Analytic Provider
Services and Analytic Services OLAP server passwords. To be successful,
olap.server.autoChangePassword must be set to true, and the administrator user ID
specified in the EDS_ES_HOME/bin directory (olap.server.admin.name=admin) must
differ from the user ID being passed by the action.

● Two archives installed with Analytic Provider Services must be defined in Web Analysis
classpath: ess_es_server.jar and ess_japi.jar.
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● Hyperion does not recommend implementing Analytic Provider Services in conjunction
with AIX platforms.

Resolving Analytic Services Subscriptions in Web Analysis
Administrators can set the WebAnalysis.properties file variable FastResolveAnalytic
ServicesSubscriptions=true to realize a Web Analysis performance improvement, as long
as they are not conducting hybrid analysis. Setting to true indicates use of Analytic Services pass-
through methods to generate dimension member lists of subscription controls. Because there is
no way for Web Analysis to detect hybrid analysis, this variable is set to false by default.

FastResolveAnalytic ServicesSubscriptions=false indicates to use standard
Analytic Services resolve member methods to generate dimension member lists for subscription
controls.

Improving Analytic Services Search Performance
The WebAnalysis.properties file variable DisableFastSearch (true/false) controls how the
Search dialog in Member Selection retrieves the list of descendants to search. The default value
is false; however, when set to true, the Analytic Services server perform the search (for training
wildcard searches only) instead of the Web Analysis server, which should improve performance
in most cases.

Configuring a Web Analysis Mail Server

➤ To configure a Web Analysis mail server:

1 Stop the application server.

2 In a text editor, open WebAnalysis.properties.

The default location is \\Hyperion\WebAnalysis\conf\WebAnalysis.properties.

3 Scroll to the end of the file.

4 For the MailServer=<localhost>, remove the pound signs (#) and enter a value for localhost.

5 Save the file.

6 Restart the application server.

Formatting Data Value Tool Tips
WebAnalysis.properties contains a variable that controls the format of data value tooltips,
which display as small boxes over data cells when the cursor triggers a float-over event.

When the variable FormatToolTips=true, tooltips displays data values in scientific notation
unformatted to up 1E7. When FormatToolTips=false, or when the variable is not specified,
tooltips display data values in a format that matches the spreadsheet grid.
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Setting Web Analysis to Log Queries
Setting the WebAnalysis.properties variable LogQueries=true redirects the ALE query
report and Analytic Services report specification created by ADM to the Web Analysis output
log. This variable is set to false by default, to minimize the amount of logged information.

Exporting Raw Data Values to Excel
Setting the WebAnalysis.properties variable ExportDataFullPrecision=true exports
data values directly from data sources to Microsoft Excel (in lieu of data values with client-based
formatting).

Configuring MS Office to Support Web Analysis
The WebAnalysis.properties file variable ExcelPath indicates where Web Analysis should
search for the Microsoft Excel executable file, used in conjunction with the Export to Excel
feature:

ExcelPath=C:\\My_Excel_Path\\Excel.exe;C:\\Your_Excel_Path\\Excel.exe

Word and PowerPoint paths can also be defined in a similar manner in the
WebAnalysis.properties file as follows:

WordPath=C:\\My_Word_Path\\WINWORD.EXE;C:\\Your_Word_Path\\WINWORD.EXE

PPTPath=C:\\My_PPT_Path\\POWERPNT.EXE;C:\\Your_PPT_Path\\POWERPNT.EXE

Note:

Paths should be reflected using short names for the folders. For example C:\\Progra~1\
\Micros~2\\OFFICE11\\POWERPNT.EXE

Configuring SQL Server Analysis Services 2000 with Web
Analysis
The WebAnalysis.properties file setting SSASImpersonate (true/false) configures the
authentication for SQL Server Analysis Services (SSAS) 2000: By default, when using SSAS 2000,
any user can login to the data source. To correct this, you must set SSASImpersonate=false, in
this case, Web Analysis use native MSAS authentication instead.

Restricting Users from Selecting Multiple Members in Filters
Setting the WebAnalysis.properties variable FilterRestrictToSingleMember=
true, restricts users from selecting multiple members in a report object filter.

If the value is set to true, all users can select one member from the filter selections. In the Dim
Browser, only one member can be selected, therefore the right click menu options are limited
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to “Find in Tree” and “Search”. Users can select one member in the left pane; additional selections
overwrite the previous selection.

Note:

If the value of the variable is initially set to “false”, multiple filter selections are made and the
Web Analysis document is saved. If the value is changed to “true”, and the Web Analysis
document is reopened, all filter selections are removed—the dimension filter does not contain
selections.

Configuring Default Print Behavior
Setting the WebAnalysis.properties variable WorkspacePrintDefault controls the
default print behavior in Workspace. The two possible settings are
WorkspacePrintDefault=PDF or WorkspacePrintDefault=HTML.

Note:

If the option is set to PDF, HTML options are not available. If it is set to HTML, PDF options
are not available.

PDF Print Behavior
If PDF is specified, these menu options are available:

● File > Print > Print Screen

● File > Print > Print Selected Object

Print PDF launches a browser instance with Adobe Reader. The output of the Web Analysis
document or report object is embedded in Adobe Reader.

The output is rendered, as it is in the Web Analysis Studio. Settings such as Portrait and
Landscape can be set. Other settings such as header and footer are saved with the Web Analysis
document, by the designer in the Web Analysis Studio.

Note:

From the Print dialog box, users cannot print multiple pages.

HTML Print Behavior
If HTML is specified, File > Print HTML is available:

Print HTML launches a browser instance that displays the selected object.

Web Analysis Configuration Options 279



Limiting Web Analysis Studio Shortcut Menu Options
Administrators can control, at the role level (for example, Viewer), the shortcut menu options
that users see. Whether menu options are hidden or displayed is determined by settings in an
XML file on the Web Analysis server.

In WebAnalysis.properties, you specify the location of the XML file and the module to
which the functionality applies (the only valid module value is WebAnalysisStudio):

WAStudioMenuControl= C:/Hyperion/Analyzer/conf/WAMenu.xml
ModuleName=WebAnalysisStudio

The XML file has these elements and attributes:

Element Element Description Attribute Attribute Description

BIPlus Top-level element used to specify
BI+ overall

  

WebAnalysisStudio SpecifiesWeb Analysis Studio as
the BI+ module that requires
menu control

  

Role Specifies the roles to which the
shortcut menu restrictions apply

Note: The highest role assigned
to a user overwrites the shortcut
menu restriction. For example, if a
user is assigned the Explorer and
Content Publisher roles, and the
Explorer role has restrictions while
the Content Publisher role does
not, the user has no restrictions.

Name Name of the BI+ role

All BI+ roles are valid except for BI
+ Administrator and BI+ Global
Administrator

ShortCutMenu Restricts menu items in shortcut
menus

Name Menu item name that is displayed
on the shortcut menu, at any level;
ending ellipses (...) are optional

Display Set as true or false; where false is
the value that hides, or restricts,
the menu item

Enables administrators to easily
make menu items available or
unavailable to users

ParentName
Specifies the parent menu item for
menu options that can be
accessed from multiple menu
items (for example, “To Microsoft
Excel” appears under the Query
Ready, Formatted, and
Unformatted menu items)

<ShortCutMenu Name="To
File"

ParentName="Formatted"
Display="false"/>
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Element Element Description Attribute Attribute Description

In such cases, if you do not specify
ParentName, the attribute is
ignored

Note:

For shortcut menu options that are labeled specific to a dimension (for example, Year Label
Mode) including definitions for multiple dimensions in the XML file can be tedious. There
should be a generic XML file definition for all instances of this shorcut menu option called
“Dimension Label Mode”.For example: <ShortCutMenu Name="Dimension Label Mode"
Display="false" />

Sample XML File
<BIPlus>
<WebAnalysisStudio>
<Role Name="Viewer">
<ShortCutMenu Name="Drill Link Options" Display="false" />
<ShortCutMenu Name="Drill to Siblings" Display="false" />
<ShortCutMenu Name="Drill to Same Level" Display="false" />
<ShortCutMenu Name="Drill to Same Generation" Display="false" />
<ShortCutMenu Name="Edit Data" Display="false" />
<ShortCutMenu Name="To File" ParentName="Formatted" Display="false" />
</Role>
</WebAnalysisStudio>
</BIPlus>

The XML file disables only menu items (attribute of display=false). You can disable all
shortcut menu options using Report Properties.

Disabling a menu option that has child menus (for example, Drill) disables the child menus
(Drill Down, Drill Up, and so on).

Restricting a menu option (for example, Drill) to a particular areas of the software such as Charts
and Spreadsheets restricts the menu option in all areas of the software. In other words, there is
no way to restrict Drill only to Charts and not to Spreadsheets.

Controlling Sizes of Web Analysis Documents that are
Exported to Excel
When exporting to Excel, using one of the three methods that populates cells of data (Query
Ready, Formatted, Unformatted), Web Analysis evaluates the number of rows and columns in
the data and if they are larger than the number of rows or columns in Excel, an error message
is displayed and the Web Analysis document is not exported.

Setting the WebAnalysis.properties variables XLExportMaxRows and
XLExportMaxColumns controls the size of a Web Analysis document that can exported to
Microsoft Excel.
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If upcoming releases of Microsoft have row and column width maximums that differ from Excel
2003, set these variables in WebAnalysis.properties:

XLExportMaxRows=

XLExportMaxColumns=

Note:

If these two entries do not exist, the current Office 2003 defaults are used (65,536 and 256)

In Custom Reports, the token Number of Rows displays the total number of rows in a Web
Analysis document, on retrieval.

Example:

<<nrows ReportDataSrc1>>

Web Analysis Utilities
Topics that explain Web Analysis utilities:

● “Repository Password Encryption Utility” on page 282

● “Web Analysis Configuration Test Servlet” on page 283

Repository Password Encryption Utility
When moving, migrating, and upgrading repositories, users may change the repository user ID
and password values listed in WebAnalysis.properties. Because these file values are viewable
over the Web using the Configuration Test Servlet, a method exists to encrypt password values.

➤ To change and encrypt repository passwords:

1 Stop the application server.

2 In a text editor, open WebAnalysis.properties.

The default location is \\WebAnalysis\conf\WebAnalysis.properties.

3 In the Repos Config section, locate these variables:

● db.user=<userID>

● db.password=<encrypted password>

● db.password-encrypted=true

4 Edit values for user ID and password.

Note that the password is not encrypted.

5 Change the db.password-encrypted value to false.

6 Save your changes.
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7 Navigate to \\WebAnalysis\conf\ and run EncryptUtil.bat or EncryptUtil.sh.

You may use alternative methods to execute this file. EncryptUtil locates the user ID,
password, and encryption variable, encrypts the password, and resets db.password-
encrypted to true.

To review the changes, open WebAnalysis.properties.

8 Restart the application server.

Web Analysis Configuration Test Servlet
Use Web Analysis Configuration Test Servlet to diagnose and resolve connectivity issues. The
servlet displays links that centrally report environmental variables and
WebAnalysis.properties parameters, and test connectivity to the class factory, the
repository, the external authentication configuration file, and the Analytic Services driver.

➤ To launch Configuration Test Servlet, open a Web browser and type this URL:

http://<hostname>/WebAnalysis/Config

Configuration Test Servlet provides links to configuration information:

● “List Environment Variables” on page 283

● “View Web Analysis Property Files” on page 283

● “Services Framework Test” on page 284

● “Test Pages for Analytic Services, Financial Management, and SAP BW ODBO” on page
284

Tip:

Use the browser’s Back button or the Available Tests link at the page bottom to return to
the Configuration Test Servlet home page.

List Environment Variables
The List Environment Variables page provides information about Java system properties and
system environment variables, such as user.name, Java.class.path, Java.home,
HYPERION_HOME, LOGONSERVER, and CLASSPATH.

View Web Analysis Property Files
The Web Analysis Property Files page provides links to and locations for
WebAnalyis.properties and CssConfig.xml.
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Services Framework Test
The Test ATF Configuration page retrieves information from the repository and tests the
repository connection. The last line on the page indicates whether the test executed successfully.
If the test failed, a stack trace is displayed to help you troubleshoot problems.

Test Pages for Analytic Services, Financial Management, and SAP BW ODBO
The test pages for Analytic Services, Financial Management, and SAP BW ODBO, provide this
configuration information:

● ADM Environment Variables

● ADM Property File Locations (click a link to view the property file)

● ADM Jar Locations

● Version Information

You use these pages to test your connectivity (using ADM) to Analytic Services, Financial
Management, and SAP BW ODBO.

Changing Web Analysis Ports
You can change Web Analysis port numbers without rerunning the Configuration Utility.

This procedure describes how to change Web Analysis port numbers for Tomcat Application
Servers. You must match port numbers in three locations to successfully change Web Analysis
port numbers.

Note:

Web Analysis must not be running during this process. At the end of the process, you must
restart applications that use the HTTP Server.

➤ To change Web Analysis port numbers:

1 Change the Web Analysis port number on Tomcat Application Servers:

a. In Windows Explorer, navigate to %BIPlus_Home%\AppServer\InstalledApps
\Tomcat\5.0.28\WebAnalysis\conf and open Server.xml file for editing.

b. Change values for shutdown and service connector ports:

(At the top) Server port =”port_number”

(At the bottom) Connector port =”port_number”

c. Save and close Server.xml.

2 Update the HTTP Server with the Web Analysis port number:

a. In Windows Explorer, navigate to %HYPERION_HOME%\common\httpServers\Apache
\2.052\conf and open HYSLWorkers.properties for editing.
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b. Change the Web Analysis port number to match the AJP port specified by the Service
Connector port parameter in Server.xml (Connector port=).

c. Save and close HYSLWorkers.properties.

3 Update the Hyperion Apache application server HTTP with the Web Analysis port number:

a. In Windows Explorer, navigate to %HYPERION_HOME%\common\httpServers\Apache
\2.052\conf and open HTTP.conf for editing.

b. Change the Listen port number to match the port specified by the Service Connector port
parameter in Server.xml (Connector port=).

c. Save and close HTTP.conf.

4 Restart Hyperion Apache HTTP Server and applications that use the HTTP Server.

Improving Web Analysis Studio Responsiveness
To improve the performance and applet load time of the Web Analysis Studio through Windows
Control Panel, increase the maximum amount of memory allocated to the plug in.

1. Open the Java plug-in console by selecting Start > Control Panel > Java Plug-In.

Note:

If multiple Java Plug-in versions are installed, select the version that the Web Analysis Studio
uses.

2. Select the Advanced tab and add these parameters to Java Runtime Parameters:

-Xms64m –Xmx256m –Xss6m

For information on parameters, please see the JRE documentation

Improving Web Analysis Studio Performance
McAfee virus scan on servers and clients decrease performance. McAfee’s Internet WebScanx,
which searches internet files for viruses, scans AnalyzerClient.jar, which resides in the
internet cache of the PC, every time Web Analysis Studio is launched.

➤ To improve Web Analysis Studio performance:

1 Run the SysInternal Filemon program and determine which file analyzers are using and excluding the relevant
folder and files.

2 Disable WebScanx.

3 Disable Allow Scanning Inside Archives.
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Importing ARU Files to Set User and Active Preferences
Web Analysis user preferences can be imported from an .ARU (XML format) file using a
command line utility.

The supporting import functionalities are discussed in these topics:

● “Creating Personal Variables” on page 287

● “Removing Personal Variables” on page 288

● “Creating POV Definitions” on page 288

● “Removing POV Definitions” on page 289

● “Adding Personal Database Connections” on page 289

● “Setting User Preferences” on page 290

● “Setting Active Preferences” on page 260

Note:

Member names that contain special characters need modification; for example, <Member
Name=”P&O” /> should be <Member Name=”P&amp ;O” />

Processing Order
The ARU file is processed in this order:

1. Add database connection.

2. Remove Personal Variables

3. Remove POV

4. Add/replace Personal Variables

5. Add/replace POV

6. Define user preferences

Importing ARU Files
To import and execute an ARU file using the command line, enter this command:

ARUUtil.bat [ServerURL] [UserID] [Password] [ImportFile] [LogFile] 

All arguments needed for the ARUUtil.bat are defined in ARUImport.properties.

Note:

ARUUtil.bat (and .sh) is located in BIPLUS_HOME/bin and ARUImport.properties is
located in BIPLUS_HOME/common/config.

Here is sample content of ARUImport.properties:
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ServerURL=http://localhost:16000/WebAnalysis/processor 
UserID=hyper1 
Password=hyper1 
ImportFile=D:\Welcome\create1user.xml 
LogFile=d:\Welcome\Import.log 

Property Description

ServerURL URL of started Web Analysis

UserID Provisioned user name

Password Provisioned user password

ImportFile File path to import

LogFile File path to log status messages

Note:

Login credentials of a user with administrators privileges must be used.

ARU Import File Format Supported Tags
● AnalyzerAdmin

● ModifyUsers

● User

● AddPersonalVariable

● Member

● AddPointOfView

● AxisSelections

● Dimension

● RemovePersonalVariable

● RemovePointOfView

● Settings

● Database

Creating Personal Variables
To create a Personal Variable, use this file format:

<?xml version="1.0" encoding="UTF-8"?>
<AnalyzerAdmin>
<ModifyUsers>
<User LoginID="hyper1">
<AddPersonalVariable Name="MarketPV" Database="epmsd030:Sample:Basic" 
Dimension="Market">
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<Member Name="Market" SelectionMode="CHILDREN"/>
<Member Name="East" SelectionMode="CHILDREN"/>
</AddPersonalVariable>
</User>
</ModifyUsers>
</AnalyzerAdmin>

User and LoginID define the user login for which the Personal Variable is added. If a database
connection exist with a specified name (see Database) for a specified user, a Personal Variable
is added. The database connection file name is formed from the Database property by replacing
«:» on «_». The connection file is searched in the Database folder of the specified user. If a
connection file does not exist, the operation aborts. If a Personal Variable exists for the database
connection, it is replaced by the new definition.

AddPersonalVariable initiates a request to create a Personal Variable. Member identifies the
members within the dimension that make up the Personal Variable, and the selection mode for
each member. Selection modes are: MEMBER, CHILDREN, DESCENDANT, PARENT,
ANCESTOR, SIBLING, DIMBOTTOM, DIMTOP, LEVEL, GENERATION, and PREVIOUS.
Default selection mode is MEMBER.

Removing Personal Variables
To remove a Personal Variable, use this file format:

<?xml version="1.0" encoding="UTF-8"?>
<AnalyzerAdmin>
<ModifyUsers>
<User LoginID="vefim">
<RemovePersonalVariable Name="MarketPV" Database="epmsd030:Sample:Basic"/>
</User>
</ModifyUsers>
</AnalyzerAdmin>

RemovePersonalVariable deletes the Personal Variable named MarketPV which is defined
against database epmsd030:Sample:Basic.

Name defines the name of the Personal Variable to delete. Database defines the database
connection file name.

Creating POV Definitions
To create a POV, use this file:

<?xml version="1.0" encoding="UTF-8"?>
<AnalyzerAdmin>
<ModifyUsers>
<User LoginID="vefim">
<AddPointOfView Name="BatchPOV" Database=" epmsd030:Sample:Basic" Active="True">
<AxisSelections Axis="Columns">
<Dimension Name="Market">
<Member Name="East"/>
<Member Name="West" SelectionMode="CHILDREN"/>
</Dimension>
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<Dimension Name="Product">
<Member Name="Product" SelectionMode="CHILDREN"/>
</Dimension>
</AxisSelections>
<AxisSelections Axis="Rows">
<Dimension Name="Year">
<Member Name="Year" SelectionMode="CHILDREN"/>
</Dimension>
</AxisSelections>
<AxisSelections Axis="Pages">
<Dimension Name="Scenario">
<Member Name="Scenario" SelectionMode="CHILDREN"/>
</Dimension>
</AxisSelections>
</AddPointOfView>
</User>
</ModifyUsers>
</AnalyzerAdmin>

AddPointOfView initiates a request to create a POV. The Name and Database name for the
POV must be provided. The user may optionally indicate whether this POV should be active.
Default Active value is False. If a POV of the same name exists for the database connection, it
is replaced by the new definition.

AxisSelections identifies the axis to which the dimension selections are to be applied. Axes
are Rows, Columns, Pages, and Filters. Default axis is Filters.

Dimension defines the dimension to be placed on the axis.

Member identifies the members within the specified dimension to be placed on the axis. Selection
modes are: MEMBER, CHILDREN, DESCENDANT, PARENT, ANCESTOR, SIBLING,
DIMBOTTOM, DIMTOP, LEVEL, GENERATION, and PREVIOUS. The default selection
mode is MEMBER.

Removing POV Definitions
To remove a POV definition, use this file format:

<?xml version="1.0" encoding="UTF-8"?>
<AnalyzerAdmin>
<ModifyUsers>
<User LoginID="vefim">
<RemovePointOfView Name="123" Database="epmsd030:Sample:Basic"/>
</User>
</ModifyUsers>
</AnalyzerAdmin>

RemovePointOfView requests to delete the POV named 123 which is defined against database
epmsd030:Sample:Basic.

Adding Personal Database Connections
To add a personal database connection, use this file format:
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<?xml version="1.0" encoding="UTF-8"?>
<AnalyzerAdmin>
<ModifyUsers>
<User LoginID="hyper1">
<Database Name=”DBName” Server=”epmsd030” Database=”Sample”  Cube=”Basic” 
AliasTable=”Long Names” Type=”1” User=”admin” Password=”password” 
LoginMode=”1”>
</User>
</ModifyUsers>
</AnalyzerAdmin>

Database requests to add a database connection. If a database connection file with the same
name exists, the operation is aborted.

Database Attributes Description Permitted values Example

Name Connection File name—File is
created in /Users/
user_name/Databases/.

user_name—User’s name,
defined in tag User. For this,
user connection is created.

  

Server Analytic Services server host
name

  

Database Application Name   

Cube Cube Name   

AliasTable Which alias to use   

Type Type of connection to create.
Only Analytic Services
connections can be created.

1  

User User’s login for connection   

Password Password for connection   

LoginMode Login mode of DB connection 1 – Use User’s ID and
Password;

2 – Prompt for User ID and
Password;

3 – Enter User ID and
Password

1 – Example, [“hyper1”,
“hyper1”]

2 – always show dialog
“Database Logon”

3 – Use specified in User,
Password properties values

Setting User Preferences

Note:

Some user preferences cannot be imported.
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Import user preferences using this syntax:

<?xml version="1.0" encoding="UTF-8"?>
<AnalyzerAdmin>
<ModifyUsers>
<User LoginID="hyper1">
<Settings  MissingZero="0" MissingText="n/a" PageComboBoxesStyle="0" 
ShowInfoPanel="0" ShowFilterPanel="1" ShowToolbar="1" ShowMenu="0" 
DrillType="0" DrillMethod="1" Wallpaper="" TileWallpaper="1" 
StretchWallpaper="0"/>
</User>
</ModifyUsers>
</AnalyzerAdmin>

Supported Preferences

● ShowInfoPanel

● ShowFilterPanel

● ShowToolbar

● ShowMenu

● PageComboBoxesStyle

● DrillType

● DrillMethod

● UseGridAPI

● ShowCurrency

● Wallpaper

● SuppressMissing

● ShowGridLines

● MissingZero

● MissingText

● HomePage

● DefaultView

● ShowInfoPanel

● ShowFilterPanel

● ShowToolbar

● ShowMenu

● PageComboBoxesStyle

● DrillType
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Setting Active Preferences
Each user'sWeb Analysis preference file is located under /Users/username/Profiles and is
invisible to all users. An administrator can copy, paste and maintain all user preference files. In
addition, the /Users/{Profiles} folder is the common profiles directory, from which users
can select any preference file to use as their active preference.

To set active preferences for a user during ARU import, the repository location of the file must
be specified.

To set active preferences for a user, use this syntax:

<?xml version="1.0" encoding="UTF-8"?>
  <AnalyzerAdmin>
    <ModifyUsers>
      <User LoginID="PersParamEditor1">
        <SetGroupPrefs Name="/Users/&lt;Profiles&gt;/GlobalAdmin2Prefs4" />
      </User>
      <User LoginID="Analyst3">
        <SetGroupPrefs Name="/Users/&lt;Profiles&gt;/GlobalAdmin2Prefs4" />
      </User>
      <User LoginID="DataEditor1">
        <SetGroupPrefs Name="/Users/&lt;Profiles&gt;/GlobalAdmin2Prefs4" />
      </User>
      <User LoginID="DataSourcePublisher1">
        <SetGroupPrefs Name="/Users/&lt;Profiles&gt;/GlobalAdmin2Prefs4" />
      </User>
    </ModifyUsers>
  </AnalyzerAdmin>
<SetGroupPrefs Name="\Users\<Profiles>\group_prefs1"/>

Notes

1. In XML files, you must use &lt; instead of < and &gt; instead of >.

2. If more than one SetGroupPrefs element is specified for a user, the last preference file
specified is established for that user.

Rename Utility
The Rename Utility is a stand-alone application designed to update objects in a Web Analysis
repository based on the data source metadata changes. For example, if a member name, and/or
dimension name changes in an Essbase® or Analytic Services cube, the utility searches the
repository and changes all objects (such as documents and database connections) to reflect the
metadata changes. The metadata change mapping must be created in a map file, as there is no
direct link to the data source to detect the changes.

Please note, the utility supports only Essbase and Analytic Services data sources.

These objects are updated:

● Documents

● Database formatting
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● Essbase and Analytic Services database connections

● Personal variable definitions

● POV definitions

These metadata changes are supported:

● Renaming references to existing dimensions (name and alias/description)

● Renaming references to existing members (name and alias/description)

● Adding references to new dimensions (default member selected)

Note:

The Rename Utility installer is not included as part of the Web Analysis installer. See “Rename
Utility Installation” on page 294.

Rename Utility Important Considerations 
● The Rename Utility modifies the content of various tables within the Web Analysis

repository. You must back up all repositories before running this utility.

● The map file must correctly reflect old and new mapping names. If errors exist, these results
may occur

❍ Errors in old names:

❏ No member is found; nothing is renamed

❏ The wrong member is found; the wrong member is renamed

❍ Errors in new names:

❏ A name does not match a member. When the document is executed, an error
message is displayed, and the member is removed from the document.

❏ (A name matches a member (the wrong member). When the document is executed,
an error message is not displayed, but the wrong member is selected..

Rename Utility Files
The Rename Utility files can be executed from the folder in which the utility resides, which is
installation_folder\renamer.

Table 2 Rename Utility Folder Structure

\renamer Contains all necessary files to execute the Rename Utility

AnalyzerResource_xx.jar

AnalyzerServer.jar

log4j-1_2_8.jar

From the current Web Analysis install (for example, the deployed WEB-INF
\lib folder)

db2java.zip JDBC drivers for all database types supported by the Rename Utility
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db2jcc.jar

mssqlserver.jar

msutil.jar

mysql-connector-java.jar

oracle.zip

xercesImpl.jar

xml-apis.jar

Provide XML support

renamer-map.xml Map file used to define all of the dimensions and members to rename; see
the “Rename Utility Map File” on page 295

Renamer.properties Provides default choices to the input fields in the Rename Utility; see
“Renamer.properties” on page 299

renamer-services.xml Defines ATF services by the Rename Utility.

renamer-map.dtd

renamer-map.xsd

Currently unused; represent an attempt to develop a DTD or an XML Schema
for map file validation

RenameUtil.bat

RenameUtil.sh

Start the utility on Windows or UNIX platforms, respectively.

\renamer\renamer

common.profile

db2.profile

hsqldb.profile

mssqldb.profile

 mssqldb7.profile

mysql.profile 

oracle.profile

Contains repository profiles used to connect to the supported database types

Rename Utility Installation

➤ To install the Rename Utility:

1 Back up all repositories before using the Rename Utility.

2 Install Web Analysis.

3 Uncompress rename_utility.zip to the Rename Utility folder (for example, C:\renamer).

4 Copy these files from the Web Analysis WEB-INF\lib folder to the Rename Utility folder:

● AnalyzerServer.jar
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● AnalyzerResource_*.jar

● log4j-1.2.8.jar

5 Verify that the JAVA_HOME environment variable exists and points to a Java 1.4 run-time home folder (for
example, C:\jdk1.4.2).

You can also edit RenameUtil.bat or RenameUtil.sh to set the JAVA_HOME environment.

6 Optional: Edit Renamer.properties to set the default choices for running the Rename Utility as
described in “Renamer.properties” on page 299.

7 Launch the start script (RenameUtil.bat or RenameUtil.sh).

Rename Utility Map File
The Rename Utility map file defines the dimensions and members to be renamed in the
repository. It is an XML file that defines the complete logical path to each dimension and
member. Here is a sample map file (with line numbers) along with a description of each section:

[01] <map name="Rename Map 01">
[02]   <server name="essbase9x"
[03]     <serverAlias>essbase9x.hyperion.comserverAlias>essbase9x.hyperion.com>
[04]     <application name="Sample">
[05]       <database name="Basic">
[06]
[07]         <dim oldName="Year" newName="NewYear" />
[08]
[09]         <dim oldName="Market" newName="NewMarket" 
[10]           oldAlias="Market" newAlias="My New Market"> 
[11]           <member oldName="South" newName="NewSouth"/>
[12]           <member oldName="East" newName="NewEast"/>
[13]           oldAlias="Eastern" newAlias="New Eastern">
[14]         </dim>
[15]
[16]         <newDim name="NewDim" alias="NewDim Alias" />
[17]
[18]         <newDim name="Attr" alias="Attribute" parentDim="product">
[19]
[20]         <newDim name="Features" alias="Prod Features">
[21]           <attrDim name="Attr1"/>
[22]           <attrDim name="Attr2"/>
[23]           <attrDim name="Attr3"/>
[24]         </newDim>
[25]
[26]       </database>
[27]     </application>
[28]   </server>
[29]
[30]   <server name="server2">
[31]     <...>
[xx]   </server>
[xy]
[xz] </map>
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map Element

The topmost element of the map file must be the <map> element shown on line [01]. It must
have a name attribute, which can be any text enclosed in quotes. There can be only one <map>
element in a map file. This element is used internally to contain the list of servers included in
this map file. It can contain only one or more <server> elements.

server Element

This element identifies an Essbase or Analytic Services server that has renamed dimensions or
members. Examples are shown on lines [02] and [30]. As shown in the example, there can be
multiple server elements in a map file. It has the single attribute name which is required. This
name must match the server name in the Essbase or Analytic Services database connection stored
in the Web Analysis repository. No DNS or hosts lookup is performed, and no IP address
translation is done. Thus, <server name=”127.0.0.1”> is not the same as <server
name=”localhost”>. The server element can contain only one or more application
elements.

serverAlias Element

This element enables the user to specify alternate names that identify the same Essbase or Analytic
Services server. For example, the server, ess9x might also be known as ess9x.hyperion.com,
172.27.31.126, or localhost. Using serverAlias elements in the map file allows the dimension
and member mappings for a server to be applied to that server, regardless of how it is referenced
in the repository. An example is shown on line [03]. This example associates all dimensions and
members for the server essbase9x with the alternate name essbase9x.hyperion.com. The
serverAlias element does not have attributes and its body specifies the server alias.

application Element

This element identifies a specific instance of an Essbase orAnalytic Services application. An
example is shown on line [04]. The application element has one attribute, name, which is
required. This name must match the application name in the Essbase or Analytic Services
database connection stored in the Web Analysis repository. The application element can
contain only one or more database elements.

database Element

This element identifies a specific instance of an Essbase or Analytic Services database. An example
is shown on line [05]. The database element has one attribute, name, which is required. This
name must match the database name in the Essbase or Analytic Services database connection
stored in the Web Analysis repository. The database element must contain one or more dim
or newDim elements.

dim Element

This element identifies a specific instance of an Essbase or Analytic Services dimension within
a unique database. Examples are shown on lines [07] and [09]. The dim element must contain
the attribute oldName to identify the dimension. There are three optional attributes for each
element:
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● newName—New name for this dimension

● oldAlias—Current alias for this dimension

● newAlias—New alias for this dimension

If there is no newName or newAlias attribute for the dim element, it is not renamed. An example
of this could be the case when a dimension name did not change, but members within that
dimension were renamed. The oldAlias attribute should be included if it is defined in the
outline, so that top level member selections using the alias can be identified. This is necessary
because in Essbase or Analytic Services, the top level member of a dimension uses the dimension
name and alias. Because members may be stored by name or alias in repository objects,
oldName and oldAlias must be included for all dim elements. This element can contain zero
or moremember elements only. This would be the case if only the dimension name or alias
changed, but no members in that dimension were renamed.

member Element

This element identifies a specific instance of an Essbase or Analytic Services member within a
unique dimension. Examples are shown on lines [11] and [12]. The member element must
contain the attribute oldName to identify the member. There are three optional attributes for
each element:

● newName—New name for this member

● oldAlias—Current alias for this member

● newAlias—New alias for this member

The oldAlias attribute should be included if it is defined in the outline, so that member
selections using the alias can be identified. Because members may be stored by name or alias in
repository objects, oldName and oldAlias must be included for all member elements. This
element may not contain other elements.

newDim Element

This element identifies a specific instance of a new Essbase or Analytic Services dimension within
a unique database. The newDim element must contain the attribute name to uniquely name the
dimension. An optional attribute alias may exist to define an alias for this dimension. An
example of this is shown on line [16].

If the dimension is an attribute dimension, the required XML attribute parentDim must be
included in the element to associate the attribute dimension with its parent dimension. An
example of this is shown above on line [18].

Finally, if the dimension has associated attribute dimensions, they must be defined in
attrDim elements. This is the only case when the newDim element may contain child elements,
and there can be multiple attrDim elements in it.

attrDim Element

This element identifies a specific instance of an Essbase or Analytic Services attribute dimension
to associate with a new dimension. Examples are shown on lines [21], [22], and [23]. The
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attrDim element must contain the attribute name to uniquely identify the attribute dimension.
This element cannot contain other elements.

Using the Rename Utility

➤ To use the Rename Utility:

1 Make a backup of the Web Analysis repository.

2 Create a map file that defines old and new values in the data source that need to be replaced in the Web
Analysis repository. See “Rename Utility Map File” on page 295.

3 Launch the start script (RenameUtil.bat or RenameUtil.sh).

4 Select the Repository Type (Microsoft SQL Server, DB2, MySQL or Oracle).

5 Enter the necessary RDBMS Repository connection fields:

● Server Name

● Database Name / Tablespace Name (Oracle)

● Port Number

● SID (Oracle only)

● Web Analysis User

● Web Analysis Password

6 Select the map file location.

7 Click Finish.

The Confirm tab is displayed with connection confirmation and map file verification.

8 Click Rename.

A confirmation message is displayed.

9 Click Yes to proceed with processing.

The process begins with all activity listed in the Confirm tab. For example:

Preparing rename mapping rules...  
Reading rename mappings from renamer-map.xml  
Building list of rename mappings.

Processing Web Analysis Reports
Report "/Groups/Everyone/Reports/_Sample Reports/Samples/Product Sales" (ID = 214) 
Report "/Groups/Everyone/Reports/_Sample Reports/Samples/Product Profitability" (ID = 
217)
Report "/Groups/Everyone/Reports/_Sample Reports/Samples/Regional Analysis" (ID = 220)
Report "/Groups/Everyone/Reports/_Sample Reports/Samples/KPI Scorecard" (ID = 223)
Report "/Groups/Everyone/Reports/_Sample Reports/Samples/Expense Analysis" (ID = 226)
Report "/Groups/Everyone/Reports/_Sample Reports/Samples/State Rankings" (ID = 229)
Report "/Groups/Everyone/Reports/_Sample Reports/Samples/High\Low States" (ID = 232)
Report "/Groups/Everyone/Reports/_Sample Reports/Samples/Margin Chart" (ID = 235)
Report "/Groups/Everyone/Reports/_Sample Reports/Samples/Product Share" (ID = 238)
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Report "/Groups/Everyone/Reports/_Sample Reports/Samples/Product Budget" (ID = 241)
Report "/Groups/Everyone/Reports/_Sample Reports/Samples/Sales Forecast" (ID = 244)
Report "/Groups/Everyone/Reports/_Sample Reports/Samples/Profit vs Sales" (ID = 247)
Report "/Groups/Everyone/Reports/_Sample Reports/Samples/KPI Details" (ID = 250)

Renamer.properties
The Renamer.properties file provides the default choices displayed by the Rename Utility in
the Hyperion Web Analysis Renamer dialog box.

Use of Renamer.properties is optional; it eliminates the need to enter information that is
repeated each time the utility is run. If properties are not included in Renamer.properties,
the corresponding input fields are left blank. Users can enter values for fields from within the
Renamer Utility. Renamer.properties provides descriptive comments and sample entries for
each property , and contains these variables:

Variable Name Description

# MapFile Map file name

# ReposServer Server name where the repository exist

# ReposType Type of repository selected

# ReposSID Repository SID

# ReposName Repository database name

# ReposUser User name

# ReposPassword User password
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Glossary

! See bang character (!).

#MISSING See missing data (#MISSING).

access permissions A set of operations that a user can

perform on a Hyperion resource.

accessor Input and output data specifications for data

mining algorithms.

account A dimension that represents an accounting

container that identifies the location and primary nature of

the data.

account type The definition of how an account's value

flows over time, and its sign behavior. Account type options

can include expense, income, asset, liability, and equity.

Expense examples: payroll expenses, salaries, office supplies,

legal expenses, and rent. Revenue examples: sales, interest

income, and other income. Asset examples: cash, accounts

receivable, fixed assets, and accumulated depreciation.

Liability examples: accounts payable, accrued expenses, and

long-term debt. Equity examples: common stock, preferred

stock, additional paid-in-capital, and retained earnings.

accountability map A visual, hierarchical representation of

the responsibility, reporting, and dependency structure of

your organization. An Accountability map depicts how each

accountability team in your organization interacts to

achieve strategic goals. An accountability team is also known

as a critical business area. For example, team, department,

or office.

accounts dimension A dimension type that makes

accounting intelligence available. Only one dimension can

be defined as Accounts.

active service A service whose Run Type is set to Start rather

than Hold.

active user A user who is entitled to access the system.

active user/user group The user or user group identified as

the current user by user preferences. Determines default

user preferences, dynamic options, access, and file

permissions. You can set the active user to your user name

or any user group to which you belong.

activity-level authorization Defines user access to

application components and the types of activities they can

perform on the application component. Activity-level

authorization controls whether a given user may perform a

certain action in an application and is independent of the

data that will be operated on by the action. Data access is

controlled by data-level authorization.

ad hoc report An online analytical query created on-the-fly

by an end user.

adaptive states Interactive Reporting level of permission.

There are six levels of permission: view only, view and

process. analyze, analyze and process, query and process,

and data model and analyze.

adjustment See journal entry (JE).

Advanced Relational Access Advanced Relational Access is

the integration of a relational database with an Analytic

Services multidimensional database. However, with

Advanced Relational Access, you can build entire

dimensions, with the exception of the Account dimension,

so that all data remains in the relational database and is

mapped to summary-level data residing in the Analytic

Services database. Advanced Relational Access uses MDX

extensively and only works with aggregate storage outlines.

Hybrid Analysis will continue to use SQL as the data access

mechanism and work with both aggregate storage and block

storage outlines.

agent An Analytic Server process that starts and stops

applications and databases, manages connections from

users, and handles user-access security. The agent is referred

to as ESSBASE.EXE.
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aggregate cell A cell comprising several cells. For example,

a data cell that uses Children(Year) expands to four cells

containing Quarter 1, Quarter 2, Quarter 3, and Quarter 4

data.

aggregate function A type of function that summarizes or

performs analysis on data. Sum, calculation of an average,

and identification of a maximum value are examples of

aggregate functions.

aggregate limit A limit placed on an aggregated request line

item or aggregated metatopic item.

aggregate storage database The database storage model

provided by Enterprise Analytics. It is designed to support

large-scale, sparsely distributed data which is categorized

into many, potentially large dimensions. Upper level

members and formulae are dynamically calculated, and

selected data values are aggregated and stored, typically with

improvements in overall aggregation time.

aggregate view An aggregation point based on the levels of

the members within each dimension. These are used by the

Enterprise Analytics kernel to quickly derive data values for

queries. For example, instead of aggregating from the

bottom of an outline, Enterprise Analytics starts at the

closest possible aggregate view and adds up from there.

aggregation The process of rolling up and storing values in

an aggregate storage database; the stored result of the

aggregation process.

aggregation script In aggregate storage databases only, a

file that defines a selection of aggregate views to be built into

an aggregation.

algorithm A method (set of instructions) that the Data

Mining Framework uses to analyze data.

alias An alternative name. For example, for a more easily

identifiable column descriptor you can display the alias

instead of the member name.

alias table A table that contains alternate names for

members.

alternate hierarchy A hierarchy of shared members. An

alternate hierarchy is based upon an existing hierarchy in a

database outline, but has alternate levels in the dimension.

An alternate hierarchy allows the same data to be seen from

different points of view.

Analytic Server The server component of Analytic Services.

Analytic Server log A record of actions performed by the

Analytic Server (agent).

Analytic Services An OLAP engine in the Hyperion

platform. An instance of Analytic Services is an Analytic

Server.

Analyze The main Web Analysis interface for analysis,

presentation and reporting.

ancestor A branch member that has members below it. For

example, in a dimension that includes years, quarters, and

months, the members Qtr2 and 2006 are ancestors of the

member April.

appender A Log4j term for destination.

applet In Java, a program that can run in a Web browser.

Small programs written in languages other than Java are

sometimes referred to as applets.

application (1) A software program designed to run a

specific task or group of tasks such as a spreadsheet program

or database management system. (2) A related set of

dimensions and dimension members that are used to meet

a specific set of analytical and/or reporting requirements.

application currency The default reporting currency for

the application.

ARBORPATH An environment variable that specifies the

Analytic Services root directory.

area A predefined set of members and values that makes up

a partition.

arithmetic data load A data load that performs operations

on values in the database, such as adding 10 to each value.

artifact An individual application or repository item; for

example, scripts, forms, rules files, Interactive Reporting

documents, financial reports and so forth. Also referred to

as an object.

asset account An account type that stores values that

represent a company's assets.

attribute Characteristics of a dimension member. For

example, an Employee Number dimension member may

have attributes of Name, Age, or Address or a product

dimension can have several attributes, such as a size and

flavor.
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attribute association A relationship in a database outline

whereby a member in an attribute dimension describes a

characteristic of a member of its base dimension. For

example, if product 100-10 has a grape flavor, the product

100-10 has the Flavor attribute association of grape. Thus,

the 100-10 member of the Product dimension is associated

with the Grape member of the Flavor attribute dimension.

Attribute Calculations dimension A system-defined

dimension that performs the following calculation

operations on groups of members: Sum, Count, Avg, Min,

and Max. This dimension is calculated dynamically and is

not visible in the database outline. For example, by using

the Avg member, you can calculate the average sales value

for Red products in New York in January.

attribute dimension A type of dimension that enables

analysis based on the attributes or qualities of dimension

members.

attribute reporting A reporting process based on the

attributes of the base dimension members. See also base

dimension.

attribute type A text, numeric, Boolean, or date type that

enables different functions for grouping, selecting, or

calculating data. For example, because the Ounces attribute

dimension has the type numeric, the number of ounces

specified as the attribute of each product can be used to

calculate the profit per ounce for that product.

attributes In data mining, a class of values used as a factor

in analysis of a set of data.

authentication Verification of identity as a security

measure. Authentication is typically based on a user name

and password. Passwords and digital signatures are forms

of authentication.

authentication service A core service that manages one

authentication system.

automated stage A stage that does not require human

intervention, for example, a data load.

auto-reversing journal A journal for entering adjustments

that you want to reverse in the next period.

axis (1) A straight line that passes through a graphic used

for measurement and categorization. (2) A report aspect

used to arrange and relate multidimensional data, such as

filters, pages, rows, and columns. For example, for a data

query in Simple Basic, an axis can define columns for values

for Qtr1, Qtr2, Qtr3, and Qtr4. Row data would be retrieved

with totals in the following hierarchy: Market, Product.

balance account An account type that stores unsigned

values that relate to a particular point in time.

balanced journal A journal in which the total debits equal

the total credits.

bang character (!) A character that terminates a series of

report commands and requests information from the

database. A report script must be terminated with a bang

character; several bang characters can be used within a

report script.

bar chart A chart that can consist of one to 50 data sets,

with any number of values assigned to each data set. Data

sets are displayed as groups of corresponding bars, stacked

bars, or individual bars in separate rows.

base currency The currency in which daily business

transactions are performed.

base dimension A standard dimension that is associated

with one or more attribute dimensions. For example,

assuming products have flavors, the Product dimension is

the base dimension for the Flavors attribute dimension.

base entity An entity at the bottom of the organization

structure that does not own other entities.

batch calculation Any calculation on a database that is

done in batch; for example, a calculation script or a full

database calculation. Dynamic calculations are not

considered to be batch calculations.

batch file An operating system file that can call multiple

ESSCMD scripts and run multiple sessions of ESSCMD. On

Windows-based systems, batch files have BAT file

extensions. On UNIX, batch files are written as a shell script.

batch POV A collection of all dimensions on the user POV

of every report and book in the batch. While scheduling the

batch, you can set the members selected on the batch POV.
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batch processing mode A method of using ESSCMD to

write a batch or script file that can be used to automate

routine server maintenance and diagnostic tasks. ESSCMD

script files can execute multiple commands and can be run

from the operating system command line or from within

operating system batch files. Batch files can be used to call

multiple ESSCMD scripts or run multiple instances of

ESSCMD.

block The primary storage unit which is a

multidimensional array representing the cells of all dense

dimensions.

block storage database The Analytics database storage

model categorizing and storing data based on the sparsity

of data values defined in sparse dimensions. Data values are

stored in blocks, which exist only for sparse dimension

members for which there are values.

book A container that holds a group of similar Financial

Reporting documents. Books may specify dimension

sections or dimension changes.

book POV The dimension members for which a book is

run.

bookmark A link to a reporting document or a Web site,

displayed on a personal page of a user. The two types of

bookmarks are My Bookmarks and image bookmarks.

bounding rectangle The required perimeter that

encapsulates the Interactive Reporting document content

when embedding Interactive Reporting document sections

in a personal page, specified in pixels for height and width

or row per page.

broadcast message A simple text message sent by an

administrator to a user who is logged on to a Planning

application. The message displays information to the user

such as system availability, notification of application

refresh, or application backups.

budget administrator A person responsible for setting up,

configuring, maintaining, and controlling an application.

Has all application privileges and data access permissions.

build method A method used to modify database outlines.

Choice of a build method is based on the format of data in

data source files.

business process A set of activities that collectively

accomplish a business objective.

business rules Logical expressions or formulas that are

created within an application to produce a desired set of

resulting values.

cache A buffer in memory that holds data temporarily.

CALC status A consolidation status that indicates that

some values or formula calculations have changed. You

must reconsolidate to get the correct values for the affected

entity.

calculated member in MaxL DML A member designed for

analytical purposes and defined in the optional WITH

section of a MaxL DML query.

calculation The process of aggregating data, or of running

a calculation script on a database.

calendar User-defined time periods and their relationship

to each other. Q1, Q2, Q3, and Q4 comprise a calendar or

fiscal year.

cascade The process of creating multiple reports for a

subset of member values.

Catalog pane A pane displaying a list of elements available

to the active section. For example, if Query is the active

section, the Catalog pane displays a list of database tables. If

Pivot is the active section, the Catalog pane displays a list of

results columns. If Dashboard is the active section, the

Catalog pane displays a list of embeddable sections, graphic

tools, and control tools.

categories Groupings by which data is organized (for

example, month).

cause and effect map A map that depicts how the elements

that form your corporate strategy are interrelated and how

they work together to meet your organization's strategic

goals. A Cause and Effect map tab is automatically created

for each of your Strategy maps.

CDF See custom-defined function (CDF).

CDM See custom-defined macro (CDM).

cell (1) The data value at the intersection of dimensions in

a multidimensional database; the intersection of a row and

a column in a worksheet. (2) A logical group of nodes

belonging to one administrative domain.

cell note A text annotation of up to 599 bytes for a cell in

an Analytic Services database. Cell notes are a type of LRO.
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CHANGED status A consolidation status that indicates

data has changed for an entity.

chart A graphical representation of spreadsheet data. The

visual nature of charts expedites analysis, color-coding, and

visual cues that aid comparisons. There are many different

chart types.

chart template A template that defines the metrics to

display in Workspace charts.

child A member with a parent above it in the database

outline.

choice list A list of members that a report designer can

specify for each dimension when defining the report's point

of view. A user who wants to change the point of view for a

dimension that uses a choice list can select only the members

specified in that defined member list or those members that

meet the criteria defined in the function for the dynamic list.

clean block A data block that where the database is fully

calculated, if a calculation script calculates all dimensions at

once, or if the SET CLEARUPDATESTATUS command is

used in a calculation script.

cluster Two or more servers or databases connected

together in such a way that they behave as a single resource

to share task loads and provide failover support. Clustering

eliminates one server or database as a single point of failure

in a system.

clustered bar charts Charts in which categories are viewed

side-by-side within a given category; useful for side-by-side

category analysis. Clustering is only done with vertical bar

charts.

code page A mapping of bit combinations to a set of text

characters. Different code pages support different sets of

characters. Each computer contains a code page setting for

the character set requirements of the language of the

computer user. In the context of this document, code pages

map characters to bit combinations for non-Unicode

encodings. See also encoding.

column A vertical display of information in a grid or table.

A column can contain data from one field, derived data from

a calculation, or textual information.

committed access An Analytic Services Kernel Isolation

Level setting that affects how Analytic Services handles

transactions. Under committed access, concurrent

transactions hold long-term write locks and yield

predictable results.

computed item A virtual column (as opposed to a column

that is physically stored in the database or cube) that can be

calculated by the database during a query, or by Interactive

Reporting Studio in the Results section. Computed items

are calculations of data based on functions, data items, and

operators provided in the dialog box and can be included in

reports or reused to calculate other data.

configuration file The security platform relies on an XML

document to be configured by the product administrator or

installer of the software. The XML document must be

modified to indicate meaningful values for properties,

specifying locations and attributes pertaining to the

corporate authentication scenario.

connection file See Interactive Reporting connection file

(.oce).

console The console is displayed on the left side of the

Enterprise Metrics workspace. The console is context

sensitive, depending on the page displayed.

consolidation The process of gathering data from

dependent entities and aggregating the data to parent

entities. For example, if the dimension Year consists of the

members Qtr1, Qtr2, Qtr3, and Qtr4, its consolidation is

Year.

consolidation rule Identifies the rule that is executed

during the consolidation of the node of the hierarchy. This

rule can contain customer specific formulas appropriate for

the correct consolidation of parent balances. Elimination

processing can be controlled within these rules.

content Information stored in the repository for any type

of file.

content area The content area is displayed on the right side

of the Workspace and provides specific information for the

page that you are using.

context variable A variable that is defined for a particular

task flow to identify the context of the taskflow instance.

contribution The value added to a parent from a child

entity. Each child has a contribution to its parent.
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conversion rate See exchange rate.

cookie A small piece of information placed on your

computer by a Web site.

correlated subqueries Subqueries that are evaluated once

for every row in the parent query. A correlated subquery is

created by joining a topic item in the subquery with one of

the topic items in the parent query.

critical business area (CBA) An individual or a group

organized into a division, region, plant, cost center, profit

center, project team, or process; also called accountability

team or business area.

critical success factor (CSF) A capability that must be

established and sustained to achieve a strategic objective. A

CSF is owned by a strategic objective or a critical process

and is a parent to one or more actions.

crosstab reporting A type of reporting that categorizes and

summarizes data in a table format. The cells within the table

contain summaries of the data that fit within the intersecting

categories. For example, a crosstab report of product sales

information could show size attributes, such as Small and

Large, as column headings and color attributes, such as Blue

and Yellow, as row headings. The cell in the table where

Large and Blue intersect could contain the total sales of all

Blue products that are sized Large.

cube A block of data that contains three or more

dimensions. An Analytic Services database is a cube.

currency conversion A process that converts currency

values in a database from one currency into another

currency. For example, to convert one U. S. dollar into the

European euro, the exchange rate (for example, 0.923702)

is multiplied with the dollar (1* 0.923702). After

conversion, the European euro amount is .92.

currency partition A dimension type that separates local

currency members from a base currency, as defined in an

application. A currency partition identifies currency types,

such as Actual, Budget, and Forecast.

custom calendar Any calendar created by an administrator.

custom dimension A dimension created and defined by

users. For example, channel, product, department, project,

or region could be custom dimensions.

custom property A property of a dimension or a dimension

member that is created by a user.

custom report A complex report from the Design Report

module, composed of any combination of components.

custom-defined function (CDF) Analytic Services

calculation functions that are developed in the Java

programming language and added to the standard Analytic

Services calculation scripting language by means of MaxL.

See also custom-defined macro (CDM).

custom-defined macro (CDM) Analytic Services macros

that are written with Analytic Services calculator functions

and special macro functions. Custom-defined macros use

an internal Analytic Services macro language that enables

the combination of calculation functions and they operate

on multiple input parameters. See also custom-defined

function (CDF).

cycle through To perform multiple passes through a

database while calculating it.

Dashboard A collection of metrics and indicators that

provide an interactive summary of your business.

Dashboards enable you to build and deploy analytic

applications.

data cache A buffer in memory that holds uncompressed

data blocks.

data cell See cell.

data file cache A buffer in memory that holds compressed

data (PAG) files.

data form A grid display that enables users to enter data

into the database from an interface such as a Web browser,

and to view and analyze data or related text. Certain

dimension member values are fixed, giving users a specific

view into the data.

data function A type of function that computes aggregate

values, including averages, maximums, counts, and other

statistics, that summarize groupings of data.

data load rules A set of criteria or rules that determines how

to load data from a text-based file, a spreadsheet, or a

relational data set into a database.

data lock A user-controlled mechanism that prevents

changes to data according to specified criteria, such as

period or scenario.
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data mining The process of searching through an Analytic

Services database for hidden relationships and patterns in a

large amount of data.

data model A representation of a subset of database tables.

data value See cell.

database connection A file that stores definitions and

properties used to connect to data sources. Database

connections enable database references to be portable and

widely used.

dense dimension In block storage databases, a dimension

likely to contain data for every combination of dimension

members. For example, a time dimension is typically a dense

dimension because it contains all combinations of all

members. Contrast with sparse dimension.

dependent entity An entity that is owned by another entity

in the organization.

descendant Any member below a parent in the database

outline. For example, in a dimension that includes years,

quarters, and months, the members Qtr2 and April are

descendants of the member Year.

Design Report An interface in Web Analysis Studio for

designing custom reports, from a library of components.

destination currency The currency to which the balances

are converted. You enter exchange rates and convert from

the source currency to the destination currency. For

example, when you convert from EUR to USD, the

destination currency is USD.

detail chart A chart that provides the detailed information

that you see in a Summary chart. Detail charts appear in the

Investigate Section in columns below the Summary charts.

For example, if the Summary chart shows a Pie chart, then

the Detail charts below represent each piece of the pie.

dimension A data category used to organize business data

for retrieval and preservation of values. Each dimension

usually contains a hierarchy of related members grouped

within it. For example, a Year dimension often includes

members for each time period, such as quarters and months.

dimension build The process of adding new dimensions

and members (without data) to an Analytic Services outline.

dimension build rules Specifications, similar to data load

rules, that Analytic Services uses to modify an outline. The

modification is based on data in an external data source file.

dimension tab In the Pivot section, the tab that enables you

to pivot data between rows and columns.

dimension table (1) A table that includes numerous

attributes about a specific business process. (2) In Enterprise

Metrics, a table in a star schema with one part primary key.

(3) In Analytic Integration Services, a container in the OLAP

model for one or more relational tables that define a

potential dimension in Analytic Services.

dimension type A dimension property that enables the use

of predefined functionality. Dimensions that are tagged as

Time have a predefined calendar functionality.

dimensionality In MaxL DML, the represented

dimensions (and the order in which they are represented)

in a set. For example, the following set consists of two tuples

of the same dimensionality because they both reflect the

dimensions (Region, Year): { (West, Feb), (East, Mar) }

direct rate A currency rate that you enter directly in the

exchange rate table. The direct rate is used for currency

conversion. For example, assume you want to convert

balances from JPY to USD. In the exchange rate table, you

enter a rate for the period/scenario where the source

currency is JPY and the destination currency is USD.

dirty block A data block containing cells that have been

changed since the last calculation. Upper level blocks are

marked as dirty if their child blocks are dirty (that is, they

have been updated).

display type One of three Web Analysis formats saved to

the repository: spreadsheet, chart, and pinboard.

dog-ear The flipped page corner in the upper right corner

of the chart header area.

domain In data mining, a variable representing a range of

navigation within data.

drill-down Navigation through the query result set using

the organization of the dimensional hierarchy. Drilling

down moves the user perspective from general aggregated

data to more detailed data. For example, drilling down can

reveal the hierarchical relationships between year and

quarters or between quarters and months.

Glossary 307



drill-through The navigation from a data value in one data

source to corresponding data in another data source.

duplicate alias name A name that occurs more than once

in an alias table and that can be associated with two or more

different members in a database outline. Duplicate alias

names can be used with duplicate member outlines only.

duplicate member name The multiple occurrence of a

member name in a database. Each occurrence of the name

represents a different member in the database. For example,

two members named “New York” exist in the same

database. One member represents New York state and the

other member represents New York city.

duplicate member outline A database outline that contains

duplicate member names.

Dynamic Calc and Store members A member in a block

storage outline that Analytic Server calculates only upon the

first retrieval of the value. Analytic Server then stores the

calculated value in the database. Subsequent retrievals of a

Dynamic Calc and Store member do not require calculating.

Dynamic Calc members A member in a block storage

outline that Analytic Server calculates only at retrieval time.

Analytic Server discards calculated values after the retrieval

request is complete.

dynamic calculation In Analytic Services, a calculation that

occurs only when you retrieve data on a member that has

been tagged as Dynamic Calc or Dynamic Calc and Store.

The member's values are calculated at retrieval time instead

of being precalculated during batch calculation.

dynamic hierarchy In aggregate storage database outlines

only. A hierarchy in which the members are calculated at

retrieval time.

dynamic member list A named member set that is a system-

created list based on predefined criteria. The dynamic

member list is automatically refreshed whenever the list is

referenced in the application. As dimension members are

added and deleted, the dynamic member list automatically

reflects the changes by reapplying the user-defined criteria.

dynamic reference A pointer in the rules file to header

records in a data source.

dynamic report A report containing current data. A report

becomes a dynamic report when you run it.

Dynamic Time Series A process that performs period-to-

date reporting

dynamic view account An account type indicating that the

account value is calculated dynamically from the data that

you are viewing.

Edit Data An interface for changing data values and

sending edits back to Essbase Analytics.

elimination The process that occurs when certain

transactions are zeroed out or “eliminated” because they

were generated between entities within the same

organization.

employee Users responsible for, or associated with, specific

business objects. Employees do not necessarily work for an

organization, such as an analyst or consultant. An employee

must be associated with a user account for authorization

purposes.

encoding A method for mapping bit combinations to text

characters for creating, storing, and displaying character

text. Each encoding has a name; for example, UTF-8. Within

a specific encoding, each character maps to a specific bit

combination; for example, in UTF-8, uppercase A maps to

HEX41. See also code page and locale.

ending period A period that enables you to adjust the date

range shown in the chart. For example, an ending period of

“month”, produces a chart that shows information through

the end of the current month.

Enterprise View An Administration Services feature that

enables viewing and managing of the Analytic Services

environment from a graphical tree view. From Enterprise

View, you can operate directly on Analytic Services objects.

entity A dimension representing organizational units.

Examples include divisions, subsidiaries, plants, regions,

products, or other financial reporting units.

essbase.cfg The name of an optional configuration file for

Analytic Services. Administrators may enter parameters and

values in this file to customize Analytic Server functionality.

Some of the configuration settings may also be used with

Analytic Services clients to override the Analytic Server

settings.
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EssCell The spreadsheet cell retrieve function into an

Analytic Services database. An EssCell function is entered

into a cell in Essbase Spreadsheet Add-in to retrieve a single

database value that represents an intersection of specific

database members.

ESSCMD A command-line interface that is used to

perform Analytic Services operations interactively or

through a batch script file.

ESSLANG The Analytic Services environment variable that

defines the encoding that Analytic Server uses to interpret

text characters. See also encoding.

essmsh See MaxL Shell.

exceptions Values that satisfy predefined conditions. You

can define formatting indicators or notify subscribing users

when an exception is generated.

exchange rate A numeric value used to convert one

currency to another. For example, to convert 1 USD into

EUR, the exchange rate of 0.8936 is multiplied with the U.S.

dollar. The European euro equivalent of $1 is 0.8936.

exchange rate type An identifier associated with an

exchange rate. Different rate types are used because there

may be multiple rates for a period and year. Users

traditionally define a rate at period end for the average rate

of the period and also a rate for the end of the period.

Additional rate types are historical rates, budget rates,

forecast rates, and so on. All these exchange rate types apply

to the same point in time.

expense account An account type that stores periodic and

year-to-date values that decrease net worth if the value is

positive.

Extensible Markup Language (XML) A language

comprised of a set of tags used to assign attributes to data

that can be interpreted between applications based on the

schema used.

external authentication Logging on to Hyperion

applications by means of user information stored outside

the application, typically in a corporate user directory such

as MSAD or NTLM.

externally triggered events Non-time-based events that are

used to schedule job runs.

Extract, Transform, and Load (ETL) Data source-specific

programs that are used to extract and migrate data to an

application.

extraction command A type of Analytic Services reporting

command that handles the selection, orientation, grouping,

and ordering of raw data extracted from a database. These

commands begin with the less than (<) character.

extrapolation A means of showing projected figures.

Extrapolation from the current date to the end of the current

period is displayed on Enterprise Metrics charts with a white

area of the bar. If a line chart shows extrapolation, the line

that is extrapolated is dotted.

fact table The central table in a star join schema,

characterized by a foreign key and elements drawn from a

dimension table. This table typically contains numeric data

that can be related to all other tables in the schema.

field A value or item in a data source file that will be loaded

into an Analytic Services database.

file delimiter One or more characters, such as commas or

tabs, that separate fields in a data source.

filter A constraint placed on data sets to restrict values to

specific criteria. For example, to exclude certain tables,

metadata, data values, or to control access.

flow account An unsigned account type that stores periodic

and year-to-date values.

folder A file that contains other files for the purpose of

ordering and structuring a hierarchy.

footer The text or images that are displayed at the bottom

of each page in a report. A footer can contain a page number,

date, company logo, document title or file name, author

name, and so on. Footers can contain dynamic functions

and static text.

format The visual characteristics of a document or a report

object.

formula A combination of operators and calculation

functions, as well as dimension names, member names, and

numeric constants, used to perform specific calculations on

members of a database.

frame An area of the desktop where information is

displayed to the user. There are two main areas on the

desktop: the navigation frame and the workspace frame.
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free-form grid A data object that presents manually entered

data and data from different types of data sources, enabling

you to integrate data in dynamic calculations.

free-form reporting A method of creating reports in which

you type members of dimensions or report script

commands in a worksheet.

function A predefined routine that returns a value, a range

of values, a Boolean value, or one or more database

members.

generation A layer in a hierarchical tree structure that

defines member relationships in a database. Generations are

ordered incrementally from the top member of the

dimension (generation 1) down to the child members.

generation name A unique name that describes a

generation.

generic jobs Jobs that are neither Production Reporting

nor Interactive Reporting jobs.

global report command A command that is executed when

it occurs in the report script file and that stays in effect until

the end of the report file or until another global command

replaces it.

grid POV A means for specifying members for a dimension

on a grid without placing the dimension on the row,

column, or page intersection. A report designer can set the

POV values at the grid level, preventing the user POV from

affecting that particular grid. If a dimension has only one

value for the entire grid, the dimension should be put into

the grid POV instead of the row, column, or page.

group A container that enables the assignment of similar

access permissions to a group of users.

GUI Graphical user interface

header record One or more records at the top of a data

source. Header records describe the contents of the data

source.

High Availability Server A server running the Analytic

High Availability Services software that manages requests

between the client and Analytic Servers, in addition to

providing various services, such as event handling and

clustering.

highlighting Depending on your configuration, you may

see highlighting applied to a chart cell value or ZoomChart

detail values. A value can be highlighted in red (indicating

the value is bad), yellow (indicating that the value is a

warning), or green (indicating the value is good).

holding company An entity that is part of a legal group of

entities, and has either a direct or indirect investment in all

the other entities within the legal group.

host A server on which applications and services are

installed.

host properties Properties pertaining to a host, or if the

host has multiple Install_Homes, to an Install_Home. The

host properties are configured from the LSC.

Hybrid Analysis The integration of a relational database

with an Analytic Services multidimensional database so that

lower-level data remains in the relational database and is

mapped to summary-level data residing in the Analytic

Services database. Hybrid Analysis enables Analytic Services

to take advantage of the mass scalability of a relational

database while maintaining a multidimensional view of the

data in a live environment.

hyperlink A link to a file, Web page, or an HTML page on

an intranet.

Hypertext Markup Language (HTML) A programming

language of tags that specify how Web browsers display data.

identity A unique identification of one valid user or group

existing on an external authentication repository.

image bookmarks Graphic links to Web personal pages or

repository items.

IMPACTED status A consolidation status indicating that

the data that rolls up to this parent entity has changed.

implied share A member with only one child, or a member

with multiple children of which only one child is

consolidated. For this reason the parent and child share the

same value.

inactive group A group that cannot access the system

because an administrator inactivated it.

inactive service A service that is on hold or excluded from

the list of services to be started.
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INACTIVE status A consolidation status indicating this

entity is not active for the current period.

inactive user A user who cannot access the system because

an administrator inactivated the user account.

income account An account type that stores periodic and

year-to-date values that increase net worth if the value is

positive.

index (1) A method that Analytic Services uses to retrieve

block storage data. The retrieval is based on the

combinations of sparse dimensions. (2) The index file.

index cache A buffer in memory that holds index pages.

index entry A pointer to an intersection of sparse

dimensions. Each index entry points to a data block on disk

and locates a particular cell within the block by means of an

offset.

index file A file that Analytic Services uses to store data

retrieval information from block storage databases. The

index file resides on disk and contains index pages.

index page A subdivision of an index file containing entries

that point to data blocks.

input block A type of data block that has at least one loaded

data value.

input data Any data that is loaded from a data source and

is not generated by calculating the database.

Install_Home A variable name for the path and directory

where Hyperion applications are installed. Refers to one

instance of a Hyperion application when multiple

applications are installed on the same computer.

integration Process that is run to move data between

Hyperion applications using Shared Services. Data

integration definitions specify the data moving between a

source application and a destination application, and enable

the data movements to be grouped, ordered, and scheduled.

intelligent calculation A calculation method that tracks

which data blocks have been updated since the last

calculation.

Interactive Reporting connection file (.oce) Files that

encapsulate database connection information. Interactive

Reporting connection files(.oce) specify the database API

(ODBC, SQL*Net, etc.), database software, the network

address of the database server, and your database user name.

Administrators create and publish Interactive Reporting

connection files(.oce).

interactive user Interactive users can review and approve

budgets, set up e-mail notification to other users, create

Web-based data forms, create worksheets using Hyperion

Smart View for Office, create reports using Hyperion

Reports, create and launch integrations using Hyperion

Application Link, create and launch business rules using

Hyperion Business Rules and/or Analytic Services, enter

and view data in Web data forms and Hyperion Smart View.

intercompany elimination See elimination.

intercompany matching The process of comparing

balances for pairs of intercompany accounts within an

application. Intercompany receivables are typically

matched or compared to intercompany payables. The

system uses these matching accounts to eliminate any

intercompany transactions from your organization's

consolidated totals.

intercompany matching report A report that compares the

balances of a group of intercompany accounts and indicates

if the accounts are in balance or out of balance for any

branch of an organization.

interdimensional irrelevance A situation in which a

specific dimension does not intersect with other

dimensions. The data is not irrelevant, but because the data

in the specific dimension cannot be accessed from the other

dimensions, those other dimensions are not relevant to the

specific dimension.

intersection A unit of data representing the intersection of

dimensions in a multidimensional database; also, a

worksheet cell.

Investigation See drill-through.

isolation level An Analytic Services Kernel setting that

determines the lock and commit behavior of database

operations. Choices are committed access and

uncommitted access.

iteration A “pass” of the budget or planning cycle in which

the same version of data is revised and promoted.
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Java Database Connectivity (JDBC) A client-server

communication protocol used by Java based clients and

relational databases. The JDBC interface provides a call-

level API for SQL-based database access.

job output Files or reports produced from running a job.

job parameters The compile time and runtime values

necessary to run a job.

job parameters Reusable, named job parameters that are

accessible only to the user who created them.

jobs A collection of documents with special properties and

that can be executed to generate output. A job can contain

Interactive Reporting documents, Production Reporting

documents, or generic documents.

join A link between two relational database tables based on

common content in a column or record or a relational

database concept indicating a link between two topics. A

join typically occurs between identical or similar items

within different topics. For example, a row record in the

Customer table is joined to a related record in the Orders

table when the Customer ID value for the record is the same

in each table.

journal entry (JE) A set of debit/credit adjustments to

account balances for a scenario and period.

JSP Java Server Pages.

latest A key word that is used to extract data values based

on the member defined as the latest period of time.

layer (1) The horizontal location of members in a

hierarchical structure, specified by generation (top down)

or level (bottom up). (2) Position of objects relative to other

objects. For example, in the Sample Basic database, Qtr1 and

Qtr4 are in the same layer. This means that Qtr1 and Qtr4

are also in the same generation. However, in a different

database with a ragged hierarchy, Qtr1 and Qtr4 might not

necessarily be in the same level simply because they are in

the same generation.

legend box An informative box containing color-keyed

labels to identify the data categories of a given dimension.

level A layer of a hierarchical tree structure that defines

database member relationships. Levels are ordered

incrementally from the bottom member of the dimension

(level 0) up through the parent members.

level 0 block A data block that is created for sparse member

combinations when all of the members of the sparse

combination are level 0 members.

level 0 member A member that has no children.

liability account An account type that stores “point in

time” balances that represent a company's liabilities.

Examples of liability accounts include accrued expenses,

accounts payable, and long term debt.

life cycle management The process of managing

application information from inception to retirement.

line chart A chart that displays one to 50 data sets, with

automatic, uniform spacing along the X-axis. Each data set

is rendered by a line. A line chart can optionally show each

line set stacked on the preceding ones, using either the

absolute value or a normalized value from 0 to 100 percent.

line item detail The lowest level of detail in an account.

link (1) Fixed references to a specific object in the

repository. Links can reference folders, files, shortcuts, and

other links using unique identifiers. (2) The point during

the execution of a taskflow instance where the activity in one

stage ends and control passes to another stage, which starts.

link condition A logical expression that is evaluated by the

taskflow engine to decide the sequence of stage execution

within a taskflow.

linked data model Documents that are linked to a master

copy in a repository

linked partition A form of shared partition that provides

the ability to use a data cell to link together two different

databases. When a user clicks a linked cell in a worksheet,

for example, Analytic Services opens a new sheet displaying

the dimensions in the second database. The user can then

drill down into the available dimensions in the second

database.

linked reporting object (LRO) A cell-based link to an

external file such as cell notes, URLs, or files that contain

text, audio, video, or pictures. Note that support of Analytic

Services LROs in Financial Reporting applies only to cell

notes at this time (by way of Cell Text functions).

local currency Input currency type. When an input

currency type is not specified, the local currency matches

the entity's base currency.
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local report object A report object that is not linked to a

Financial Reporting report object in Explorer. Contrast with

linked reporting object (LRO).

local results Results of other queries within the same data

model. These results can be dragged into the data model to

be used in local joins. Local results are displayed in the

catalog when requested.

locale A computer setting that identifies the local language

and cultural conventions such as the formatting of currency

and dates, sort order of the data, and the character set

encoding to be used on the computer. Analytic Services uses

only the encoding portion of the locale. See also encoding

and ESSLANG.

locale header record An additional text record, at the

beginning of some non-Unicode-encoded text files such as

scripts, that identifies the encoding locale.

location alias A descriptor that identifies a data source. The

location alias specifies a server, application, database, user

name, and password. Location aliases are set by DBAs at the

database level using Administration Services Console,

ESSCMD, or the API.

locked A user-invoked process that prevents the data from

being modified by any process, user, or other means.

locked data model Data models that cannot be modified by

a user.

LOCKED status A consolidation status indicating that an

entity contains data that is locked for the specified period.

Log Analyzer An Administration Services feature that

enables filtering, searching, and analysis of Analytic Services

logs.

LRO See linked reporting object (LRO).

LSC services The services that are configured with the Local

Service Configurator. They include Global Services

Manager (GSM), Local Services Manager (LSM), Session

Manager, Authentication Service, Authorization Service,

Publisher Service, and in some contexts, Data Access Service

(DAS) and Interactive Reporting Service.

managed server An application server process running in

its own Java Virtual Machine (JVM).

manual stage A stage that requires human intervention to

complete the stage.

Map Navigator A feature that displays your current

position on a Strategy, Accountability or Cause and Effect

map. Your current position is indicated by a red outline on

the Map Navigator.

master data model A data model that exists independently

and is referenced as a source by multiple queries. When you

use a master data model, the text “Locked Data Model” is

displayed in the Content pane of the Query section. This

means that the data model is linked to the master data model

displayed in the Data Model section, which may be hidden

by an administrator.

mathematical operator A symbol that defines how data is

calculated. A mathematical operator can be any of the

standard mathematical or Boolean operators; for example,

+, -, *, /, and %. Mathematical operators are used in

formulas and outlines.

MaxL The multidimensional database access language for

Analytic Services, consisting of a data definition language

(MaxL DDL) and a data manipulation language (MaxL

DML). See also MaxL DDL, MaxL DML, and MaxL Shell.

MaxL DDL Data definition language used by Analytic

Services for batch or interactive system-administration

tasks.

MaxL DML Data manipulation language used in Analytic

Services for data query and extraction.

MaxL Perl Module A Perl module (essbase.pm) that is part

of the MaxL DDL component of Analytic Services. The

essbase.pm module can be added to the Perl package to

provide access to Analytic Services databases from Perl

programs.

MaxL Script Editor A script-development environment

provided by Administration Services Console. The MaxL

Script Editor is an integrated alternative to using a text

editor and the MaxL Shell for creating, opening, editing, and

running MaxL scripts for Analytic Services system

administration.

MaxL Shell An interface for passing MaxL statements to

Analytic Server. The MaxL Shell executable file, located in

the bin directory for Analytic Services, is named essmsh

(UNIX) or essmsh.exe (Windows).
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MDX (multidimensional expression) The language used

to give instructions to OLE DB for OLAP- compliant

databases, as SQL is the language used for relational

databases. When you build the OLAPQuery section's

Outliner, Intelligence Clients translate your requests into

MDX instructions. When you process the query, MDX is

sent to the database server. The server returns a collection

of records to your desktop that answer your query. See also

SQL spreadsheet.

measures Numeric values in an OLAP database cube that

are available for analysis. Measures may be margin, cost of

goods sold, unit sales, budget amount, and so on. See also

fact table.

member A discrete component within a dimension. A

member identifies and differentiates the organization of

similar units. For example, a time dimension might include

such members as Jan, Feb, and Qtr1.

member list A named group, system- or user-defined, that

references members, functions, or other member lists

within a dimension.

member load In Analytic Integration Services, the process

of adding new dimensions and members (without data) to

an Analytic Services outline.

member selection report command A type of Report

Writer command that selects ranges of members based on

database outline relationships, such as sibling, generation,

and level.

member-specific report command A type of Report Writer

formatting command that is executed as it is encountered

in a report script. The command affects only the member

to which it is associated and executes the format command

before it processes the member.

merge A data load option that clears existing values from

the accounts specified in the data load file and then replaces

them with the values in the data load file. Unlike the Replace

option, the Merge option clears only the values from the

accounts specified in the load file.

metadata A set of data that defines and describes the

properties and attributes of the data stored in a database or

used by an application. Examples of metadata are

dimension names, member names, properties, time

periods, and security.

metadata sampling The process of retrieving a sample of

the members of a selected dimension in a drill-down

operation.

metadata security Security set at the member level to

control users from accessing certain members in an outline.

metaoutline In Analytic Integration Services, a template

containing the structure and rules for creating an Analytic

Services outline from an OLAP model.

metric A numeric measurement computed from your

business data. Metrics help you assess the performance of

your business and analyze trends in your company.

migration The process of copying an application or users

from one environment or computer to another.

MIME Type (Multipurpose Internet Mail Extension) An

attribute that describes the format of data in an item, so that

the system knows which application to launch to open the

object. A file's mime type is determined either by the file

extension or the HTTP header. Plug-ins tell browsers what

mime types they support and what file extensions

correspond to each mime type.

minireport A minireport is a component of a report, and

includes layout, content, hyperlinks, and the actual query

or queries to load the report. Each report can include one

or more minireports.

missing data (#MISSING) A marker indicating that data in

the labeled location does not exist, contains no value, or was

never entered or loaded. For example, missing data exists

when an account contains data for a previous or future

period but not for the current period.

model (1) In data mining, a collection of an algorithm's

findings about examined data. A model can be used

(applied) against a wider set of data to generate useful

information about that data. (2) A file or string of content

containing an application-specific representation of data.

Models are the basic data managed by Shared Services.

Models are of two major types: dimensional and non-

dimensional application objects. (3) In Business Modeling,

a network of boxes connected to represent and calculate the

operational and financial flow through the area being

examined.

monetary A money-related value.

314 Glossary



multidimensional database A method of organizing,

storing, and referencing data through three or more

dimensions. An individual value is the intersection point for

a set of dimensions.

named set In MaxL DML, a set with its logic defined in the

optional WITH section of a MaxL DML query. The named

set can be referenced multiple times in the query.

native authentication The process of authenticating a user

name and password from within the server or application.

nested column headings A column heading format for

report columns that displays data from more than one

dimension. For example, a column heading that contains

both Year and Scenario members is a nested column. The

nested column heading shows Q1 (from the Year

dimension) in the top line of the heading, qualified by

Actual and Budget (from the Scenario dimension) in the

bottom line of the heading.

NO DATA status A consolidation status indicating that

this entity contains no data for the specified period and

account.

non-dimensional model A type of model in Shared

Services that includes application objects such as security

files, member lists, calculation scripts, and Web forms.

non-unique member name See duplicate member name.

note Additional information associated with a box,

measure, scorecard or map element.

null value A value that is absent of data. Null values are not

equal to zero.

numeric attribute range A feature used to associate a base

dimension member that has a discrete numeric value with

an attribute that represents a range of values. For example,

to classify customers by age, an Age Group attribute

dimension can be defined that contains members for the

following age ranges: 0-20, 21-40, 41-60, and 61-80. Each

member of the Customer dimension can be associated with

a particular Age Group range. Data can then be retrieved

based on the age ranges rather than based on individual age

values.

ODBC Open Database Connectivity. A database access

method used from any application without regard to how

the database management system (DBMS) processes the

information.

OK status A consolidation status indicating that an entity

has already been consolidated, and that data has not

changed below it in the organization structure.

OLAP Online Analytical Processing.

OLAP Metadata Catalog In Analytic Integration Services,

a relational database containing metadata describing the

nature, source, location, and type of data that is pulled from

the relational data source.

OLAP model In Analytic Integration Services, a logical

model (star schema) that is created from tables and columns

in a relational database. The OLAP model is then used to

generate the structure of a multidimensional database.

online analytical processing (OLAP) A multidimensional,

multiuser, client-server computing environment for users

who analyze consolidated enterprise data in real time. OLAP

systems feature drill-down, data pivoting, complex

calculations, trend analysis, and modeling.

Open Database Connectivity (ODBC) Standardized

application programming interface (API) technology that

allows applications to access multiple third-party databases.

organization A hierarchy of entities that defines each entity

and their relationship to others in the hierarchy.

origin The intersection of two axes.

outline The database structure of a multidimensional

database, including all dimensions, members, tags, types,

consolidations, and mathematical relationships. Data is

stored in the database according to the structure defined in

the outline.

outline synchronization For partitioned databases, the

process of propagating outline changes from one database

to another database.

P&L accounts (P&L) Profit and loss accounts. Refers to a

typical grouping of expense and income accounts that

comprise a company's income statement.

page A display of information in a grid or table often

represented by the Z-axis. A page can contain data from one

field, derived data from a calculation, or text.

page file Analytic Services data file.
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page heading A type of report heading that lists members

that are represented on the current page of the report. All

data values on the page have the members in the page

heading as a common attribute.

page member A member that determines the page axis.

palette A JASC compliant file with an extension of PAL.

Each palette contains 16 colors that complement each other

and can be used to set the color elements of a dashboard.

parallel calculation An optional calculation setting.

Analytic Services divides a calculation into tasks and

calculates some of the tasks at the same time.

parallel data load In Analytic Services, the concurrent

execution of different stages of a single data load by multiple

process threads.

parallel export The ability to export Analytic Services data

to multiple files. This may be faster than exporting to a single

file, and it may resolve problems caused by a single data file

becoming too large for the operating system to handle.

parent adjustments The journal entries that are posted to

a child in relation to its parent.

parents The entities that contain one or more dependent

entities that report directly to them. Because parents are

both entities and associated with at least one node, they have

entity, node, and parent information associated with them.

partition area A subcube within a database. A partition is

composed of one or more areas. These areas are composed

of cells from a particular portion of the database. For

replicated and transparent partitions, the number of cells

within an area must be the same for both the data source

and the data target to ensure that the two partitions have the

same shape. If the data source area contains 18 cells, the data

target area must also contain 18 cells to accommodate the

number of values.

partitioning The process of defining areas of data that are

shared or linked between data models. Partitioning can

affect the performance and scalability of Analytic Services

applications.

pattern matching The ability to match a value with any or

all characters of an item that is entered as a criterion. A

missing character may be represented by a wild card value

such as a question mark (?) or an asterisk (*). For example,

“Find all instances of apple” returns apple, but “Find all

instances of apple*” returns apple, applesauce,

applecranberry, and so on.

percent consolidation The portion of a child's values that

is consolidated to its parent.

percent control Identifies the extent to which an entity is

controlled within the context of its group.

percent ownership Identifies the extent to which an entity

is owned by its parent.

performance indicator An image file used to represent

measure and scorecard performance based on a range you

specify; also called a status symbol. You can use the default

performance indicators or create an unlimited number of

your own.

periodic value method (PVA) A process of currency

conversion that applies the periodic exchange rate values

over time to derive converted results.

permission A level of access granted to users and groups

for managing data or other users and groups.

persistence The continuance or longevity of effect for any

Analytic Services operation or setting. For example, an

Analytic Services administrator may limit the persistence of

user name and password validity.

personal pages Your personal window to information in

the repository. You select what information to display and

its layout and colors.

personal recurring time events Reusable time events that

are accessible only to the user who created them.

personal variable A named selection statement of complex

member selections.

perspective A category used to group measures on a

scorecard or strategic objectives within an application. A

perspective can represent a key stakeholder (such as a

customer, employee, or shareholder/financial) or a key

competency area (such as time, cost, or quality).

pie chart A chart that shows one data set segmented in a pie

formation.
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pinboard One of the three data object display types.

Pinboards are graphics, composed of backgrounds and

interactive icons called pins. Pinboards require traffic

lighting definitions.

pins Interactive icons placed on graphic reports called

pinboards. Pins are dynamic. They can change images and

traffic lighting color based on the underlying data values and

analysis tools criteria.

pivot The ability to alter the perspective of retrieved data.

When Analytic Services first retrieves a dimension, it

expands data into rows. You can then pivot or rearrange the

data to obtain a different viewpoint.

planner Planners, who comprise the majority of users, can

input and submit data, use reports that others create,

execute business rules, use task lists, enable e-mail

notification for themselves, and use Smart View.

planning unit A slice of data at the intersection of a

scenario, version, and entity. It is the basic unit for

preparing, reviewing, annotating, and approving plan data.

plot area The area bounded by the X, Y, and Z axes; For pie

charts, the rectangular area immediately surrounding the

pie.

plug account An account in which the system stores any

out of balance differences between intercompany account

pairs during the elimination process.

POV (point of view) A feature that lets you work with

dimension members that are not assigned to a row, column,

or page axis. For example, you could assign the Currency

dimension to the POV and select the Euro member. By

selecting this POV in a data form, all the data in the form is

displayed in Euro values.

precalculation The process of calculating the database

prior to user retrieval.

precision Number of decimal places displayed in a number.

predefined drill paths Paths that enable you to drill directly

to the next level of detail, as defined in the data model.

presentation A playlist of Web Analysis documents,

enabling reports to be grouped, organized, ordered,

distributed, and reviewed. Presentations are not reports

copied into a set. A presentation is a list of pointers

referencing reports in the repository.

preserve formulas The process of keeping user-created

formulas within a worksheet while retrieving new data.

primary measure A high-priority measure that is more

important to your company and business needs than many

other measures. Primary measures are displayed in the

Contents frame and have Performance reports.

product In Shared Services, a product is an application

type, such as Planning or Performance Scorecard.

Production Reporting A specialized programming

language for data access, data manipulation, and creating

Production Reporting documents.

project An instance of Hyperion products that are grouped

together to comprise an implementation. For example, a

Planning project may consist of a Planning application, an

Analytic Services cube, and a Financial Reporting Server

instance.

promote The action to move a data unit to the next review

level, allowing a user having the appropriate access to review

the data. For example, an analyst may promote the data unit

to the next level for his supervisor's review.

promotion The process of transferring artifacts from one

environment or machine to another; for example, from a

testing environment to a production environment.

property A characteristic of an artifact, such as size, type,

or processing instructions.

provisioning The process of granting users and groups

specific access permissions to Hyperion resources.

proxy server A server that acts as an intermediary between

a workstation user and the Internet to ensure security.

public job parameters Reusable, named job parameters

created by an administrator and accessible to users who have

the requisite access privileges.

public recurring time events Reusable time events created

by an administrator and accessible through the access

control system.

PVA See periodic value method (PVA).

qualified name A member name in a qualified format that

differentiates duplicate member names in a duplicate

member outline. For example, [Market].[East].[State].

[New York] or [Market].[East].[City].[New York]
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query To request information from a data provider. For

example, queries are used to access a relational data source.

query governor An Analytic Integration Server parameter

or Analytic Server configuration setting that controls the

duration and size of the queries made to the data source.

range A set of values that includes an upper and lower limit,

and the values that fall between the limits. A range can

consist of numbers, amounts, or dates.

reconfigure URL URL used to reload servlet configuration

settings dynamically when a user is already logged on to the

Workspace.

record In a database, a group of fields that make up one

complete entry. For example, a record about a customer

might contain fields for name, address, telephone number,

and sales data.

recurring template A journal template used to make

identical adjustments in every period.

recurring time event An event that specifies a starting point

and the frequency for running a job.

redundant data Duplicate data blocks that Analytic

Services retains during transactions until Analytic Services

commits the updated blocks.

regular journal A feature used to enter one-time

adjustments for one period only. Regular journals can be

balanced, balanced by entity, or unbalanced.

relational database A type of database that stores data in

the form of related two-dimensional tables. Contrast with

multidimensional database.

replace A data load option that clears the existing values

from all accounts for the periods specified in the data load

file, and then loads the values from the data load file. If an

account is not specified in the load file, its values for the

specified periods are cleared during the load.

replicated partition A portion of a database, defined

through Partition Manager, that is used to propagate an

update to data that is mastered at one site to a copy of data

that is stored at another site. Users are able to access the data

as though it were part of their local database.

replication In Analytic High Availability Services, the

copying of data from one Analytic Services application

database to another.

Report Extractor An Analytic Services component that

retrieves report data from the Analytic Services database

when a report script is run.

report object A basic element in report designs. Report

objects have specific properties that define their behavior or

appearance. Report objects include text boxes, grids,

images, and charts.

report script A text file containing Analytic Services Report

Writer commands that generate one or more production

reports.

Report Viewer An Analytic Services component that

displays the complete report after a report script is run.

reporting currency The currency in which an enterprise

prepares its financial statements. Currency is converted

from local currencies to one or more reporting currencies.

The converted reporting currency values are stored.

resources Objects or services that the system manages.

Examples of a resource include a role, user, group, file, job,

publisher service, and so on.

restore An operation to reload data and structural

information after a database has been damaged or

destroyed. The restore operation is typically performed after

you shut down and restart the database.

restructure An operation to regenerate or rebuild the

database index and, in some cases, the data files.

result frequency The algorithm used to create a set of dates

for the collection and display of results.

review level A Process Management review status indicator

that represents the process unit level. Review levels include

the following: Not Started, First Pass, Review Level 1, Review

Level 2 ... Review Level 10, Submitted, Approved, and

Published.

role The means by which access permissions are granted to

users and groups for Hyperion resources.

roll-up See consolidation.

root member The highest member in a dimension branch.

row heading A report heading that lists members down a

report page. The members are listed under their respective

row names.
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RSC services The services that are configured with the

Remote Service Configurator. They include Repository

Service, Service Broker, Name Service, Event Service, and

Job Service.

rules User-defined formulas.

runtime prompt A system variable that allows values to be

entered during the execution of an allocation process.

Values can be members, strings, or numbers.

sampling The process of selecting a representative portion

of an entity for the purpose of determining the

characteristics of that entity. See also metadata sampling.

saved assumptions Planning assumptions, created globally

or locally, that can be named, saved and referenced in

planning methods and allocations to help drive plan and

budget values.

scale The range of values on the Y axis of a chart.

scaling Determines how currency values are displayed in a

data form or report: in whole numbers, tens, hundreds,

thousands, millions, and so on.

scenario A dimension that specifies a data classification.

Examples include Actuals, Budget, Forecast1, and

Forecast2.

schedule Specify the job that you want to run and the time

and job parameter list for running the job.

scope The area of data encompassed by any Analytic

Services operation or setting; for example, the area of data

affected by a security setting. Most commonly, scope refers

to three levels of granularity, where higher levels encompass

lower levels. From highest to lowest, these levels are as

follows: the entire system (Analytic Server), applications on

Analytic Server, or databases within Analytic Server

applications. See also persistence.

score The level at which specified targets are being

achieved. It is usually expressed as a percentage of the target

for a given time period.

scorecard Business Object used to represent the progress

of an employee, strategy element, or accountability element

toward specific goals. Scorecards ascertain this progress

based on the data collected for each measure and child

scorecard you add to the scorecard.

scorecard report A report that presents the results and

detailed information about scorecards attached to

employees, strategy elements, and accountability elements.

secondary measure A low-priority measure that is less

important to you than primary measures. Secondary

measures do not have Performance reports but can be used

on scorecards and to create dimension measure templates.

Section pane Lists all sections that are available in the

current Intelligence Client document.

security agent A Web access management solutions

provider employed by companies to protect Web resources;

also known as Web security agent. The Netegrity SiteMinder

product is an example of a security agent.

security platform A framework enabling Hyperion

applications to use external authentication and single sign-

on using the security platform driver.

serial calculation The default calculation setting. Analytic

Services divides a calculation pass into tasks and calculates

one task at a time.

services Resources that provide the ability to retrieve,

modify, add, or delete business items. Some services are

Authorization, Authentication, Global Service Manager

(GSM).

servlet A piece of compiled code executable by a Web

server.

Servlet Configurator A software utility for configuring all

of the locally installed servlets.

session The time between login and logout for a user

connected to Analytic Server.

set In MaxL DML, a required syntax convention for

referring to a collection of one or more tuples. For example,

in the following MaxL DML query, SELECT { [100-10] }

ON COLUMNS FROM Sample.Basic { [100-10] } is a set.

shared application An application in Shared Services that

enables two or more products to share their models. See also

model.

shared member A member that shares storage space with

another member of the same name. A storage property

designates members as shared. The use of shared members

prevents duplicate calculation of members that occur more

than once in an Analytic Services outline.
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Shared Services Application enabling users to share data

between supported Hyperion products by publishing data

to Shared Services and running data integrations.

sibling A child member at the same generation as another

child member and having the same immediate parent. For

example, the members Florida and New York are children

of East and siblings of each other.

single sign-on A feature that enables you to access multiple

Hyperion products after logging on just once using external

credentials.

slicer In MaxL DML, the section at the end of a query that

begins with and includes the keyword WHERE.

smart tags Predefined properties that associate available

actions with keywords in Microsoft Office applications.

Smart tags are the mechanism by which the Hyperion menu

is displayed and the end user can import content from

Hyperion System 9 BI+ or use functions to display

information from Financial Management or Analytic

Services.

SmartCut A link to an item in the repository, in the form

of a special URL.

snapshot Read-only data from a specific point in time.

source currency The currency from which the balances

originate and are converted. You enter exchange rates and

convert from the source currency to the destination

currency. For example, when you convert from EUR to

USD, the source currency is EUR.

sparse dimension In block storage databases, a dimension

unlikely to contain data for all combinations of dimension

members when compared to other dimensions. For

example, not all customers have data for all products.

SPF files Printer-independent files created by a Production

Reporting server that contains a representation of the actual

formatted report output, including fonts, spacing, headers,

footers, and so on.

Spotlighter A tool that enables color coding based on

selected conditions.

SQL spreadsheet A data object that displays the result set

of a SQL query.

stacked charts A chart where the categories are viewed on

top of one another for visual comparison. This type of chart

is useful for subcategorizing within the current category.

Stacking can be used from the Y and Z axis in all chart types

except pie and line. When stacking charts the Z axis is used

as the Fact/Values axis.

stage A description of a task that forms one logical step

within a taskflow, usually performed by a single individual.

A stage can be manual or automated.

stage action For automated stages, the action that is

invoked to execute the stage.

standard dimension A dimension that is not an attribute

dimension.

standard journal template A journal function used to post

adjustments that have common adjustment information for

each period. Instead of creating a new regular journal every

month, you can create a standard template that contains the

common account IDs, entity IDs, or amounts. You can then

use the template as the basis for many regular journals that

contain similar adjustment information.

Start in Play The quickest method for creating a Web

Analysis document. The Start in Play process requires you

to specify a database connection, then assumes the use of a

spreadsheet data object. Start in Play uses the highest

aggregate members of the time and measures dimensions to

automatically populate the rows and columns axes of the

spreadsheet.

stored hierarchy In aggregate storage databases outlines

only. A hierarchy in which the members are aggregated

according to the outline structure. Stored hierarchy

members have certain restrictions, for example, they cannot

contain formulas.

strategic objective (SO) A long-term goal defined for an

organization that is stated in concrete terms whose progress

is determined by measuring results. Each strategic objective

is associated with one perspective in your application, has

one parent, the entity, and is a parent to critical success

factors or other strategic objectives. It also has measures

associated with it.

Strategy map A detailed representations of how your

organization translates its high-level mission and vision

statements into lower-level, constituent strategic goals and

objectives.
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structure view A view that displays a topic as a list of

component items allowing users to see and quickly select

individual data items. Structure view is the default view

setting.

Structured Query Language The language used to give

instructions to relational databases. When you build the

Query section's Request, Limit, and Sort lines, Interactive

Reporting translate your requests into SQL instructions.

subscribe Register an interest in an item or folder to receive

automatic notification whenever the item or folder is

updated.

Summary chart A chart that is displayed at the top of each

chart column in the Investigate Section and plots metrics at

the summary level, meaning that it rolls up all of the Detail

charts shown below in the same column. All colors shown

in a stacked bar, pie, or lines Summary chart also appear

above each Drill button of the Detail charts and extend

across the row, acting as the key.

super service A special service used by the

startCommonServices script to start the RSC services.

supervisor A defined type of user who has full access to all

applications, databases, related files, and security

mechanisms for a server.

supporting detail Calculations and assumptions from

which the values of cells are derived. Supporting detail can

include text, values, and operators that define how data

aggregates.

suppress rows The option to exclude rows that contain

missing values and to underscore characters from

spreadsheet reports.

symmetric multiprocessing (SMP) A server architecture

that enables multiprocessing and multithreading. Analytic

Server supports multiple threads over SMP servers

automatically. Thus, performance is not significantly

degraded when a large number of users connect to an single

instance of Analytic Server simultaneously.

sync The ability to synchronize models in Shared Services

with models in the application.

synchronized The condition that exists when the latest

version of a model resides in both the application and in

Shared Services. See also model.

system extract A feature that allows you to transfer data

from an application's metadata into an ASCII file.

target The expected result for a measure for a specified

period of time, such as a day, quarter, month and so on. You

can define multiple targets for one measure.

task list A listing of tasks for a particular user along with

detailed status information for each task.

taskflow The automation of a business process in whole or

in part, during which tasks are passed from one taskflow

participant to another for actions, according to a set of

procedural rules.

taskflow definition The representation of the business

process in the taskflow management system, which enables

the process to be automated. The taskflow definition

consists of a network of stages and their relationships;

criteria to indicate the start and end of the taskflow; and

information about individual stages, such as participants,

associated applications, associated activities, and so on.

taskflow instance The representation of a single instance of

a taskflow including its state and associated data.

taskflow management system A system that defines,

creates, and manages the execution of a taskflow. It enables

the creation of taskflow definitions, interaction with

taskflow participants (users or applications), and the

launching of other applications during the execution of a

business process.

taskflow participant The resource that performs the task

associated with the taskflow stage instance. The taskflow

system requires a participant for both manual and

automated stages. For a manual stage, the task is shown on

the task list for the user to execute the task. For an automated

stage, Shared Services, along with the application, executes

the task. For automated stages, the application executes the

task on behalf of the participant.

TCP/IP See Transmission Control Protocol/Internet Protocol

(TCP/IP).

template A predefined format that is designed to retrieve

particular data on a regular basis and in a consistent format.

time dimension A dimension that defines the time period

that the data represents, such as fiscal of calendar periods.

time events Triggers for execution of jobs.
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time scale A scale that enables you to see the metrics by a

specific period in time, such as monthly or quarterly.

time series reporting A process of reporting data based on

a calendar date (for example, year, quarter, month, or

week).

token An encrypted identification of one valid user or

group on an external authentication system.

top and side labels In the Pivot section, the column and

row headings on the top and sides of the pivot. These define

categories by which the numeric values are organized.

top-level member A dimension member at the top of the

tree in a dimension outline hierarchy, or the first member

of the dimension in sort order if there is no hierarchical

relationship among dimension members. The top-level

member name is generally the same name as the dimension

name if a hierarchical relationship exists.

trace level A means of defining the level of detail captured

in the log file.

traffic lighting Color-coding of report cells, or pins based

on a comparison of two dimension members, or on fixed

limits.

transformation (1) The process of transforming an artifact

so that it functions properly in the destination environment

after application migration. (2) In data mining, a way to

modify data (bidirectionally) flowing between the cells in

the cube and the algorithm.

translation See currency conversion.

Transmission Control Protocol/Internet Protocol (TCP/

IP) A standard set of communication protocols that is

adapted by many companies and institutions around the

world and that links computers with different operating

systems and internal architectures. TCP/IP utilities are used

to exchange files, send mail, and store data to various

computers that are connected to local and wide area

networks.

transparent login A mechanism that enables users who

have been previously authenticated by external security

criteria to log in to a Hyperion application, bypassing the

login screen.

transparent partition A form of shared partition that

provides the ability to access and manipulate remote data

transparently as though it is part of a local database. The

remote data is retrieved from the data source each time a

request is made. Any updates made to the data are written

back to the data source and become immediately accessible

to both local data target users and transparent data source

users.

trend How the performance of a measure or scorecard

changed since the last reporting period or a date that you

specify.

triangulation A means of converting balances from one

currency to another via a third common currency. In

Europe, this is the euro for member countries. For example,

to convert from French franc to Italian lira, the common

currency is defined as European euro. Therefore, in order

to convert balances from French franc to Italian lira,

balances are converted from French franc to European euro

and from European euro to Italian lira.

triangulation currency A currency through which

exchange rates can be derived. For example, if you set up the

Euro/Dollar exchange rate and the Euro/Yen rate, the

Dollar/Yen rate can be derived by using Euro as the

triangulation currency.

triggers An Analytic Services feature that enables efficient

monitoring of data changes in a database. If data breaks rules

that you specified, Analytic Services alerts the user or system

administrator.

trusted password A password that enables users who have

been previously authenticated in another system to have

access to other applications without reentering their

passwords.

trusted user A user authenticated by some mechanism in

the environment.

tuple In MaxL DML, a required syntax convention for

referring to a member or a member combination from any

number of dimensions. For example, in the Sample Basic

database, (Jan) is a tuple, and so is (Jan, Sales), and so is

( [Jan], [Sales], [Cola], [Texas], [Actual] ).
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two-pass calculation An Analytic Services property that is

used to recalculate members that are dependent on the

calculated values of other members. Two-pass members are

calculated during a second pass through the database

outline.

UDA User-defined attribute, associated with members of

an outline to describe a characteristic of the members. Users

can specify UDAs within calculation scripts and reports so

that they return lists of members that have the specified

UDA associated with them. UDAs can be applied to dense

as well as sparse dimensions.

UI User interface

unary operator A group of mathematical indicators (+, -,

*, /, %) that define how roll-ups take place on the database

outline.

unbalanced journal A journal in which the total debits do

not equal the total credits.

uncommitted access An Analytic Services Kernel setting

that affects how Analytic Services handles transactions.

Under uncommitted access, concurrent transactions hold

short-term write locks and can yield unpredictable results.

Unicode-mode application An Analytic Services

application wherein character text is encoded in UTF-8,

enabling users with their computers set up for different

languages to share the application data. A Unicode-mode

application can be created only on a Unicode-mode server.

Uniform Resource Locator (URL) The address of a

resource on the Internet or an intranet.

unique member name A non-shared member name that

exists only once in a database outline. Shared instances of

the unique member name can occur in the outline, but all

instances represent the same member in the database.

unique member outline A database outline that is not

enabled for duplicate member names.

upgrade The process of replacing an earlier software release

with a current release or replacing one product with

another.

upper-level block A type of data block that is created for

sparse member combinations when at least one of the sparse

members is a parent-level member.

URL See Uniform Resource Locator (URL).

user directory A centralized, corporate store of user and

group information. May also be referred to as a repository

or provider.

user variable A variable that dynamically renders data

forms based on a user's member selection, displaying only

the specified entity. For example, the user variable named

Department enables you to display only specific

departments and employees.

user-defined attribute See UDA.

user-defined member list A named, static set of members

within a dimension defined by the user. As dimension

members are added to an application, member lists remain

constant and will not reflect any changes made to the

application outline.

validation A process of checking a rules file, report script,

or partition definition against the outline to make sure that

the object being checked is valid.

value dimension A dimension that is used to define the

input value, translated value, and consolidation detail.

variance The difference between two values (for example,

between a planned and actual value).

version A possible outcome used within the context of a

scenario of data. For example, Budget - Best Case and

Budget - Worst Case where Budget is the scenario and Best

Case and Worst Case are the versions.

view The representation of either a year-to-date or periodic

display of data.

visual cue A formatted style, such as a font or a color, that

highlights specific types of data values. Data values may be

dimension members; parent, child, or shared members;

dynamic calculations; members containing a formula; read

only data cells; read and write data cells; or linked objects.

Web server Software or hardware hosting intranet or

Internet Web pages or Web applications.
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weight A value assigned to an item on a scorecard that

indicates the relative importance of that item in the

calculation of the overall scorecard score. The weighting of

all items on a scorecard accumulates to 100%. For example,

to recognize the importance of developing new features for

a product, the measure for New Features Coded on a

developer's scorecard would be assigned a higher weighting

than a measure for Number of Minor Defect Fixes.

wild card A wild card is a character that represents any

single character (?) or any group of characters (*) in a search

string.

WITH section In MaxL DML, an optional section of the

query used for creating re-usable logic to define sets or

members. Sets or custom members can be defined once in

the WITH section, and then referenced multiple times

during a query.

workbook An entire spreadsheet file with many

worksheets.

write-back The ability for a retrieval client, such as a

spreadsheet, to update a database value.

ws.conf A configuration file for Windows platforms.

wsconf_platform A configuration file for UNIX platforms.

XML See Extensible Markup Language (XML).

Y axis scale The range of values on the Y axis of the charts

displayed in the Investigate Section. You can use a unique

Y axis scale for each chart, the same Y axis scale for all Detail

charts, or the same Y axis scale for all charts in the column.

Often, using a common Y axis improves your ability to

compare charts at a glance.

Zero Administration A software tool that identifies the

version number of the most up-to-date plug-in on the

server.

zoom A feature that sets the magnification of a report. The

report can be magnified to fit the whole page, page width or

a percentage of magnification based on 100%.

ZoomChart A feature that makes it easy to view detailed

information by enlarging a chart. Zooming in on a chart

enables you to see detailed numeric information on the

metric that is displayed in the chart.
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A
active preferences

controls, 260
setting, 260

adding
custom document components, 217
pins, 189

advanced member selection
defining subset member selections, 71, 75
Financial Management, 169
overview, 66
searching for members, 68

alias tables, 267
analysis tools

definitions
default, 116
disabling, 117
enabling, 117
ordering, 116

overview, 115
Restrict Data, 124
Retrieve Only Top/Bottom, 126
Sorting, 123
Traffic Lighting, 120

Analysis Tools Manager toolbar, 115
Analytic Services

configuring XTD Deployment Services, 277
features extended through Web Analysis Studio,
165
subscriptions, resolving, 277
substitution variables., 78

arranging dimensions in the layout, 61
asymmetrical analysis, 118
Average calculation, 130

B
background color, setting, 220

background images for pinboards, 186
background objects, 236
Browser, Dimension, 65

C
calculations

Average, 130
creating, 136
Cumulative, 130
Difference from Average, 130
Divide, 131
Linear Regression, 131
Maximum, 131
Maximum Value, 131
Minimum, 132
Minimum Value, 132
modifying, 137
Multiply, 132
overview, 130
Percent, 132
Percent Difference from Average, 133
Percent of Difference, 133
Percent of Member, 133
Percent of Total, 133
Rank Ascending, 134
Rank Descending, 134
Subtract, 134
Sum, 134
Trend, 135
Variance, 135
Variance Percent, 135

cells, formatting, 102
chart objects, filling, 110
Chart Properties panel

Axes tab, 108
Bubble tab, 111
General tab, 106
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Pie tab, 111
Series tab, 109
Titles tab, 107

chart properties, overview, 106
Chart User Preferences panel

Axes tab, 108
Bubble tab, 111
General tab, 106
Pie tab, 111
Series tab, 109
Titles tab, 107

charts
overview, 105
pie, 105
previewing, 112

Check Box object, 237
clipboard, exporting to, 143, 144
colors

background, setting, 220
hiding by color, 117
selecting, 113

columns
fitting header labels in, 102
selecting for SQL queries, 199
sizing

overview, 102
resetting default widths, 103

commands
Redo, 92
Undo, 92

components, selecting current, 217
composing a SQL query, 198
Configuration Test Servlet, 283
configuring

Analytic Services XTD Deployment Services, 277
for Excel, 277
JDBC drivers, 177
Shared Services, 273

connectivity issues, diagnosing and resolving, 283
content, retrieving from other applications, 254
coordinating selected dimensions, 224
creating

calculations, 136
personal variables, 78
relational database connections, 180
relational drill-through, 163
SQL queries, 198

SQL spreadsheets, 194, 204, 209
Cube Navigator

options, 63
overview, 61

cubes, defining, 179
Cumulative calculation, 130
custom documents

Alias Controller object, 239
components, adding, 217

D
data formatting, 101
data source metadata changes, Rename Utility and,
292
data source, linking components by, 224
data values, hiding by, 117
database connections

editing, 184
relational, creating, 180

database preferences, 267
date selections, 81
default formatting preferences, 265
defining relational cubes, 179
deleting, 190
design, 213
Design Documents Interface, 213
detail, line item, 168
Difference from Average calculation, 130
Dimension Browser

labels in, 65
overview, 65

dimension headers, sorting, 97
dimension members

editing selections, 100
selecting with Dimension Browser, 65

dimensions
arranging in the layout, 61
browsing, 65
coordinating selected, 224
moving, 87
selecting with Cube Navigator, 61
swapping, 87

Divide calculation, 131
Document Reference URLs, 148
documents

changing display types for, 103
drilling to detail, 89
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locking display types for, 103
dragging, 91
drill linking

accessing the Drill Link Options dialog box, 91
defining drill links, 91
overview, 90

Analytic Integration Services drill-through, 253
drill-through, relational, creation, 163
drilling

overview, 89
user preferences, 90
variations, 90

drilling preferences, 265
dynamic text labels, 200, 232
Dynamic Time Series

definitions, 81
substitution variables, 82

E
editing

dimension member selections, 100
pinboards, 188
pins, 190

Enter Member's Display Name dialog box, 231
Enter SQL Query dialog box, 197
environment variables, 283
Excel

configuring Web Analysis for, 277
exporting raw data values to, 278

exiting Web Analysis Studio, 23
exporting

document and document group definitions to
Shared Services, 146
to the clipboard, 143, 144

F
features

Financial Management, 168
Analytic Services, 165

files, Rename Utility, 293
Fill Properties dialog box, 110
Financial Management

advanced member selection, 169
conventions, 170
features extended through Web Analysis Studio,
168

overview, 168
folders preferences, 263
font properties, 113
formatting

cells, 102
chart properties, 106
data, 101
default, preferences, 265
measures, 162
methods, order of precedence, 94

G
general user preferences, 262
graphics, selecting, 114

H
header labels, fitting in columns, 102
hiding

by color, 117
by data value, 117
by selected members, 117

Home page
preferences, 262
specifying, 262

hotspots, 241
HTML Browser object, 236

I
Image objects, 236
image selection, 114
Information Panel, 19
installing JDBC drivers, 177
integrated applications, retrieving content from, 254
intersections, paging through, 87

J
JDBC drivers, installing and configuring, 177

L
label mode

custom Alias Controller object, 239
overview, 96
setting default, 64

layouts, arranging dimensions in, 61
line item detail, 168
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Linear Regression calculation, 131
Linked Reporting Objects. See LROs.
linking

components by data source, 224
selected dimensions, 225

List Environment Variables page, 283
Look and Feel preferences, 264
LROs

accessing, 258
overview, 258

M
map file, for Rename Utility, 295
Maximum calculation, 131
Maximum Value calculation, 131
measures formatting, 162
member selection

advanced, 66
defining previous, 82
editing, 100
for pinboards, 186

members, renaming text labels for, 231
Minimum calculation, 132
Minimum Value calculation, 132
modifying calculations, 137
Multi-level Combo Box Subscription object, 238
Multiply calculation, 132

N
navigation methods, 86

O
objects

Check Box, 237
HTML Browser, 236
Image, 236
Multi-level Combo Box Subscription, 238
Split Panel, 235
SQL Grid, 242
SQL Spreadsheet, 242
SQL Subscription, 242
Tab Group Subscription, 237
Text, 236

OLAP query builder. See Cube Navigator.
OLAP server preferences, 266

P
paging through intersections, 87
Percent calculation, 132
Percent Difference from Average calculation, 133
Percent of Difference calculation, 133
Percent of Member calculation, 133
Percent of Total calculation, 133
personal variables, creating, 78
Pinboard Designer, 186
pinboards

background selection, 186
editing, 188
tips for creating, 191

pins, 190
adding, 189
deleting, 190
editing, 190
options for, 188
selecting, 189
tips for creating, 191

points of view
creating, 80
definitions, 269
overview, 79

POV. See points of view.
preference files

creating, 261
editing shared, 261
managing shared, 261

preferences
database, 267
default formatting, 265
drilling, 265
folders, 263
Home page, 262
Look and Feel, 264
OLAP server , 266

previewing
charts, 112
print jobs, 155

Print dialog box
Headers/Footers tab, 151
Page tab, 150

Q
queries

building OLAP queries with Cube Navigator, 61

A B C D E F G H I J L M N O P Q R S T U V W

328 Index



creating SQL, 198
defining with Cube Navigator, 61
Dynamic Time Series definitions for, 81

query result set, setting maximum size in
WebAnalysis.properties, 274

R
Rank Ascending calculation, 134
Rank Descending calculation, 134
Redo command, 92
related content, 254

accessing, 254
cell text, 168
definitions, 116

accessing, 254
applying to cells, 256
creating, 256

Related Content dialog box, 255
Related Content dialog box, 254
relational cubes, defining, 179
relational data

access, 176
retrieving tables, 178

relational database connections, creating, 180
relational drill-through

creating, 163
overview, 162

Rename Utility
files, 293
folder structure, 293
important considerations, 293
installing, 293, 294
map file, 295
metadata changes supported, 293
objects updated by, 292
overview, 292
properties file, 299
using, 298

Renamer.properties file, 299
Restrict Data analysis tool, 124
Restrict Data definitions, restriction columns, 125
Restriction Columns dialog box, 125
result set size, setting maximum size in
WebAnalysis.properties, 273
Retrieve Only Top/Bottom analysis tool, 126
retrieving relational tables, 178

S
SAP BW, advanced member selection, 172
Select Column Advanced dialog box, 199
Select Graphic dialog box, 114
selected members, hiding by, 117
selecting

colors, 113
current component, 217
dimension members, 65
graphics, 114
pins, 189

selecting dimension members, 65
setting, background color, 220
shared preference files

creating, 261
editing, 261
enabling, 261
selecting, 260

Shared Services
configuring, 273
exporting document and document group
definitions to, 146

Show/Hide Only analysis tool
creating definitions, 119
editing definitions, 117
overview, 117

Show/Hide Only dialog box, 118
sizing columns, 102
Sorting analysis tool, 123
sorting dimension headers, 97
Split Panel object, 235
splitter bars, creating, 224
SQL

queries
column selection for, 199
composing, 198
creating, 198
defining, 197

spreadsheets, creating, 194, 204, 209
SQL Grid object, 242
SQL Query Builder wizard, 198
SQL Spreadsheet objects, 242
SQL Subscription objects, 242
startup procedure, 17
subscription controls, creating, 226
substitution variables

Dynamic Time Series, 82
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syntax, 78
using, 78

Subtract calculation, 134
Sum calculation, 134

T
Tab Group Subscription object, 237
text labels

dynamic, 200, 232
members, renaming, 231
renaming member text labels, 231

Text objects, 236
time selections, 81
tool tips, data value, formatting, 277
traffic lighting

analysis too loverview, 120
opacity, 123
Traffic Lighting dialog box, 120
transparency, 123

Trend calculation, 135

U
Undo command, 92
unlinking coordinated components, 224

V
Variance calculation, 135
Variance Percent calculation, 135

W
WebAnalysis.properties file

editing, 273
ExportDataFullPrecision, 278
maximum query result set size settings, 274
overview, 273
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